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PREFACE 

The National Curriculum Framework, 2005, recommends that children’s life at 

school must be linked to their life outside the school. This principle makes a 

departure from the legacy of bookish learning which continues to shape our 

system and causes a gap between the school, home, community and the 

workplace. 

The student workbook Volume 1 on “Functional English (Advanced)” is a part of 

the qualification package developed for the implementation of National 

Vocational Education Qualification Framework (NVEQF), an initiative of Ministry 

of Human Resource Development (MHRD), Government of India to set common 

principles and guidelines for a nationally recognized qualification system 

covering Schools, Vocational Education and Training Institutions, Technical 

Education Institutions, Colleges and Universities. It is envisaged that the NVEQF 

will promote transparency of qualifications, cross-sectoral learning, student-

centered learning and facilitate learner’s mobility between different 

qualifications, thus encouraging lifelong learning. 

This student workbook, which forms a part of vocational qualification package 

for students who have passed Class X or equivalent examination, was created 

by a group of experts. The IT-ITeS Skill Development Council approved by the 

National Skill Development Corporation (NSDC) for the IT/ITES Industry 

developed the National Occupation Standards (NOS). The National Occupation 

Standards are a set of competency standards and guidelines endorsed by the 

representatives of IT Industry for recognizing and assessing skills and knowledge 

needed to perform effectively in the workplace. 

The Pandit Sunderlal Sharma Central Institute of Vocational Education 

(PSSCIVE), a constituent of National Council of Educational Research and 

Training (NCERT) in association with Wadhwani Foundation has developed 

modular curricula and learning materials (Units) for the vocational qualification 

package in IT/ITES sector for NVEQ levels 1 to 4; level 1 is equivalent to Class 

IX. Based on NOS, occupation related core competencies (knowledge, skills, and 

abilities) were identified for development of curricula and learning modules 

(Units). 

This student workbook attempts to discourage rote learning and to bring about 

necessary flexibility in offering of courses, necessary for breaking the sharp 

boundaries between different subject areas. The workbook attempts to 

enhance these endeavors by giving higher priority and space to opportunities 

for contemplation and wondering, discussion in small groups and activities 

requiring hands-on-experience. We hope these measures will take 

ussignificantly further in the direction of a child-centered system of education 
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outlined in the National Policy of Education (1986). The success of this effort 

depends on the steps that school Principals and Teachers will take to encourage 

children to reflect their own learning and to pursue imaginative and on-the-job 

activities and questions. 

Participation of learners in skill development exercises and inculcation of 

values and creativity is possible if we involve children as participants in 

learning, and not as receiver of information. These aims imply considerable 

change in school routines and mode of functioning. Flexibility in the daily time-

table would be a necessity to maintain the rigor in implementing the activities 

and the required number of teaching days will have to be increased for 

teaching and training. 
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FUNCTIONAL ENGLISH (ADVANCED) 

SESSION 1: CUSTOMER SERVICE REPRESENTATIVES 

RELEVANT KNOWLEDGE 

Who is acustomer service representative? 

A customer service representative forms a link between businesses and 

customers, providing customer service support, answering general questions, 

offering technical support over the phone or via internet-chat. 

• Customer service representatives are more popularly known as “CSRs”. 

• CSRs may be direct representatives (store executives) or calling agents 

(call center) of their businesses. 

• They communicate with customers to provide information in response to 

inquiries about products and services, and to handle and solve customer 

complaints. They form a very important link between businesses and the 

customers; they are often a company's main source of constant customer 

contact. 

• CSRs, as call center agents, may also provide customer service support 

by offering technical and non-technical support over the phone or via 

internet-chat or answer general questions. 

• They might handle bank or credit card account inquiries, customer 

requests, customer complaints, technical or non-technical support 

issues, customer suggestions and feedback. 

Now, in your own words, describe the job profile of a customer service 

representative. Write your answer in your notebooks. 

For any job profile, specific skills are required. What skills do you think 

customer service representative needs? 

1. _______________________________________________________ 

2. _______________________________________________________ 

3. _______________________________________________________ 

4. _______________________________________________________ 

5. _______________________________________________________ 

6. _______________________________________________________ 

7. _______________________________________________________ 

Some of the skills required to be a good customer service representative are: 

• Communication:Customer service representatives often handle client 

concerns by phone, so it's important they be skilled talkers. They must 

also be good listeners, and should be able to write brief and clear emails 

and letters. 
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• Problem Solving: Often, customer service representatives must identify 

problems, handle complaints or answer complicated questions. This 

makes it very important for them to be skilled in quick, logical problem 

solving. 

• Computer Skills: The majority of customer service representatives use 

computers use computers on a daily basis, to recover client or company 

information. Therefore, they must be comfortable using computers and 

be able to learn and use different types of software and the Internet. 

• People Skills: Customers are often upset when they contact customer 

service. This makes it very important that the customer service 

representatives are able to remain calm, polite and respectful at all 

times. 

• Grammar and Spelling:Customer service representatives should speak 

proper English and be able to avoid slang. When writing emails or 

letters, they must practice good grammar and spelling. 

EXERCISE 1 : Customer Service Representatives 

Follow the instructions of your facilitator. In this exercise, you should be able 

to fill in the blanks to correctly describe and understand the job of a customer 

service representative, in a call center scenario and a face-to-face interaction. 

1. A: Hi! How did your interview go? 

B: Good. They said I had the skills of a good CSR. 

A: CSR? What’s that? 

B: It’s the shorter version of a ____________________________. 

A: Oh, that’s good to know. So, what is the job of a CSR? 

B: Well, as they deal with customers on a daily basis, they form a very 

important __________________ between the businesses and the 

customers. And because they handle complaints and sometimes answer 

complicated questions, they also need to be skilled in quick, logical 

__________________. 

A: Sounds interesting. I hope you get the job. 

B: Me too. 

A: Good luck! 

B: Thanks! 

2. A: Hey, Do you think I too could apply for a job as a CSR? 

B: Sure! In fact, you would be perfect for the job. 

A: What makes you think so? 

B: Because you have the all the skills required for the job. 

A: What are the skills needed? 

B: The first skill needed is _________________, as you will have to either 

talk or email chat with customers the whole day. The next skill needed is 
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___________________, as it’s very important to be calm, polite and 

respectful at all times when dealing with customers. The other skills 

required are two things you are excellent at! 

A: What? 

B: Computers and ___________. Computers, as CSRs use computers on a 

daily basis, to take down and recover client or company information, and 

they are required to speak and write/type letters/mails in clear and 

understandable English. 

A: Great! I think I will apply for the job first thing tomorrow morning. 

Wish me luck. 

B: Best of luck! 

3. A: Did you check out the new website “This is IT.com” for IT/ITES jobs? 

B: No. Is it any good? 

A: Yes, it is. My friend just got a job through the site. 

B: So, do you know of any job offers that I could apply for? 

A: Yes. There is an opening for a customer service representative in a 

BPO. You should apply. 

B: What would my job as a customer service representative be like? 

A: I think you might have to provide customer service support by offering 

_________________ and ____________ support over the phone or via 

internet-chat or answer general questions. And you also may have to 

handle _______________ or _____________ card account inquiries, 

customer requests, customer _____________. 

B: Wow! That seems like a lot to do. Do you really think I should apply? 

A: Yes. I do. 

B: Alright. I will go online and apply for the job right away! 

A: All the best! 

B: Thanks! 

EXERCISE2 : Present Perfect Tense 

Identify the sentences in the present perfect tense. 

1. More stores have realized the importance of good customer service. X 

2. APPLE has introduced the iPad-4 recently. √ 

3. Compworldhas a new computer gaming section. X 

4. Customers have decided to shop only at Compworld because of the wide 

range of computers they sell.√ 

5. They have reduced the prices of their laptops to half. √ 

6. More customers are coming to the shop after the sale was announced. X 

Try and make simple sentences using this grammar concept. 
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Go through the assessment. If time permits, you can try to attempt it in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 

ASSESSMENT 

•Read this: 

1. I ______ (buy) a modem. 

I havebought a modem. 

2. I ______ not ______ (buy) a CD. 

I have not bought a CD. 

Fill in the blanks with present perfect form of the verbs given in the brackets. 

1. By mistake I ____________ (keep) these old DVDs. 

2. I just bought the laptop for 50,000 rupees and yet you____________ not 

____________(give) me any discount. 

3. We are in loss because he ____________ (sell) the laptop at a price 

lower than the cost price. 

4. Trust me ma’am, I ____________ (offer) you the best price. No other 

shop will offer you this price. 

5. Someone____________ (forget) their wallet here. 

6. He ____________ (sell) very few computers because the customers find 

the prices very high. 

7. I ____________ (spend) less money for this computer than I thought I 

would because the shopkeeper gave me a good discount. 

8. How many calls ____________ you ____________ (make) to the 

customers? 

9. You ____________ not ____________ (tell) me the cost of the Tablet PC. 

10.You ____________ already ____________ (serve) the customer well. 
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RELEVANT KNOWLEDGE 

In the last session, you discussed the job profile of a customer service 

representative. In this session, you will learn how to give a simple job 

description. 

Imagine that you have the job that you always wanted and your family is eager 

to know all the details. Now, answer the following questions. 

1. What do you do? 

2. Where do you work? 

3. Where is your office located? 

4. How long have you been working there? 

5. What are your work timings? 

Write your answers in your notebooks. The answers that you have just written 

constitute(i.e. form) a simple description of your job. 

EXERCISE 1: Describing Your Job 

Read the passage given below. It discusses Manish’s job. Now, imagine that you 

are Manish (stand in Manish’s boots) and answer the questions in the 

conversation that follows. Post that, you will form pairs and role play the 

conversation between A and B, and present the role play before the class. 

Sahil works for a call center called “Contact-One”. He is a customer service 

representative. His job requires him to answer all in-coming calls from 

customers and help them solve their issues. The office he works at is located in 

Gurgaon. He works from 14.30hrs (2:30pm) in the afternoon to 23.30hrs 

(11:30pm) in the night. He has been working on the same job for a little more 

than 2 years. 

Sahil had worked as a customer service executive at a lifestyle-store before, 

but he likes this job better. That is because Contact-One is a huge organization 

and working there has helped him develop and expand his skills. He is also 

happy with the salary and benefits he receives. Sahil gets a salary of Rs 12,000 

per month, and medical insurance covering him and his parents. He also 

receives an additional bonus of Rs 500 every week, if he solves more than 90% 

of his customers’ issues, which he does! The only problem that he has with his 

job is the long distance from his home to the office, and the time it takes to 

travel back and forth. 

A: So, where are you working at? 

B: _________________________________________________________________. 

A: Where is it located? 

B: _________________________________________________________________. 
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A: Whatare the working hours? 

B: _________________________________________________________________. 

A: How long have you been working on this job? 

B: _________________________________________________________________. 

A: Tell us a little about your work. 

B: I am working as a _______________________________. The job requires 

____________________________________________________________________. 

A: Have you worked as a sales representative before? 

B: _________________________________________________________________. 

A: How is this job different from your previous job? 

B: _________________________________________________________________. 

A: How much does your job pay you? 

B: _________________________________________________________________. 

A: What else is there? 

B: _________________________________________________________________. 

A: So, is there anything that you do not like about your job? 

B: __________________________________________________________________ 

________________________________________________. 

EXERCISE 2: Connectors and Conjunctions 

Choose the appropriate conjunction / connector. 

1. My main job is that of a Team Leader, _____ I also answer calls 

sometimes. (but, yet, so) 

2. I chose to take up the job in Delhi _____ it is a bigger organization. (so, 

as, and) 

3. My working hours are from 9am to 7pm; _____ you could say that I work 

10 hours. (but, so, because) 

4. I am doing an MBA ___________ I want to grow in my career. (and, 

though, because) 

5. In the near future, I want to become a Call Center Manager. 

____________ I have not worked in a managerial role before, I am sure I 

will pick up the skills. (Though, For, But) 

6. First, I used to be a call center agent. ______ I became a Team Leader. 

(However, Then, In brief) 

7. I like my new job. _____________ I love talking on the phone! 

(Nevertheless, Moreover, Therefore) 

Try and make simple sentences using this grammar concept. 

Go through the assessment. If time permits, you can try to attempt it in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 
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ASSESSMENT 

•Read this: 

1. I told her I didn’t know how to make an omelette, so she offered to show me 

how. (conjunction) 

2. I told her I didn’t know how to make an omelette. Then she offered to show 

me how. (connector) 

3. She offered to show me how to make omeletteas I didn’t know how. 

(conjunction) 

4. I didn’t know how to make an omelette. Therefore she offered to teach me. 

(connector) 

•Instruction: Fill in the blanks with connectors/conjunctions given in the box 

below. Some of the connectors/conjunctions can be used more than once. 

though however and but as 

then because so next thus 

My name is Isha _______ I am a call center agent at WKS, a BPO at Tech-City in 

Gurgaon. I have been working there for more than a year. _______ I enjoy my 

work so much that time seems to have passed very quickly. 

_______, a lot of people feel that a call center agent’s job is easy, it’s not. It is 

a job that requires a lot of energy _______ patience. Every morning, I have to 

reach the office by 9:00am sharp. _______ I have to mark my attendance, 

_____ make sure I check all my emails for any incomplete work that has to be 

completed. _______, I have to attend and solve all the customers’ calls. 

I start attending to calls at around 9:30am, _____, break for lunch only at 

12:30pm. We have an hour to finish eating, and _____ its back to work. 

_______ our organization is very large ____ internationally well known, it 

attracts a lot of customers from across the world. 

14 
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In this session, you will learn about how to apply for leave in a formal working 

environment. You will learn about different formats used to create leave 

applications. 

What is a leave application? 

An application for leave is a common employment email / letter written / 

typed in all organizations. Some points in common about all leave applications 

are: 

• An employee should make it a point to draft a leave application before 

going on long leave. This helps the management in handing-over 

responsibilities to another employee, for the specified duration. 

• The application emails / letters help in maintaining the leave record of 

the employee. 

• The application is written to inform the superior about the employee’s 

non-availability in the organization for a specific period. 

• The letter is written in formal language and format specified by the 

organization. 

• The reason of leave and period of absence is clearly specified in the 

letter. 

• The application email / letter is short and precise. 

• Only relevant information features in the letter / mail. 

• The application should convey an assurance to the employer that all the 

pending work will be completed once the employee returns from leave. 

The two samples below are for employees who choose to write an application in 

hard copy. Note the format and the language.Notice how the employee is 

applying a leave for a period of five days for a genuine personal reason. 

A Sample Employee Leave Application letter – 1 

Name:RaashiDingra 

Employee Code: CSD - 1248 

Date: 05/24/2013 

To, 

Avinash Bagaadi 

Manager, Human Resources 

Subject: Leave Application for 10 days for exams 

Dear Sir, 

I wish to apply for 10 working days leave from the 15th of next month till the 

end of month (16 - 27 Apr. 2012). 
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The reason for this is my master's course examinations of the final term. The 

examinations consist of the 10 papers that I need to appear for, and the 

additional five days are for preparing for the examinations. 

I shall report back to work on the 30thof May 2012 and put in extra hours to 

complete any work that has arisen during the period of my absence. 

I request you to kindly approve my leave. 

Thanking you. 

Regards, 

Ankita Pandey 

A Sample Employee Leave Application letter - 2 

Dated: 21st July, 2009 

To, 

The Manager, 

Computer Services Department. 

Subject: Request for leave 

Dear Sir/Ma’am, 

I would like to request a leave for 5 days, from the 25th to the 29thof July, as I 

have to attend my brother’s wedding in Jamshedpur. I assure you that the 

31st reports expected on of July will be delivered on time. 

I would be extremely happy if my leave is sanctioned. 

Thanking you, 

Regards, 

Arun Anand - (Employee-Id No. 0123) 

Computer Services Department 

Note the format of the applications. Did you notice the details below? 

o The date is written on the top left corner. 

o The date is followed by the designation of the addressee. This is written 

on the left. 

o The designation of the addressee is followed by the subject. 

o The subject is followed by the salutation. 

o The salutation is followed by the body of the later. 

o The body of the letter is followed by the leave-taking. 

Sample-3: Application of leavevia e-mail. 

Note the format and the language. 
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3 . A Sample Employee Leave Application E-mail -

Dear Sir, 

This application mail is to request you to grant me a leave of absence for three 

weeks starting from November 10, 2012. 

My wife has had an accident resulting in a dislocated knee joint that needs to 

be surgically operated and I am the prime care taker. I need to be with her 

during the surgery and the recovery period. The doctors have advised her three 

weeks of complete bed rest. 

Therefore, I would really appreciate your approval of leave, as I will have to 

take care of my wife, children and home. I will return to work on December 2, 

2012. 

All my work has been completed up-to-date; however, if there are any 

concerns, I can be contacted via phone / internet. 

Yours sincerely 

Jagjit Anand 

Customer Service Representative 

Employee – id 78910 

Do you notice the difference in the format of a leave application via e-mail? 

In an e-mail, the format all sections within the letter are aligned to the left. 

The paragraphs too should start from the left. All sentences too, should start 

from the margin of the letter or mail. 

For example: 

To: (recipient's address) 

CC: (the reporting manager’s personnel's e-mail addresses) 

Subject: Leave application for ____ days for ____. 

In this section, you may or may not mention the reason of the leave in the 

subject line itself. For instance, if it is for personal reasons, it is better not to 

write it in the subject line. In case it is for some general reason, such as an 

examination, then you may. 

Body of the e-mail: 

o Start with the addressee's name, designation, department, etc. In the 

first line, i.e. the introduction of the e-mail, one is supposed to write 

that he or she wishes to apply for leaves. 

o Next, follows the date and number of working days. 

o In the second paragraph, one can cite the reason for applying for leaves. 

Then request them to accept and approve the leave. 
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o The content of this letter should not exceed more than 300 words in 

general. 

o End the letter by thanking the recipient and saying that you will await 

the reply. 

Signature: Your name, designation, employee id, department 

EXERCISE 1: Writing a Leave Application 

Listen carefully to the instructions given by your facilitator. You need to form 

pairs and prepare a presentation as directed in the exercise. Each pair has to 

enact the completed conversation in the form of a role-play where one student 

plays the role of the A and B. 

Fill in the blanks with the options given below: 

o your reasons for taking the leave 

o The letter should start 

o you can write down the salutation 

o Thanks a lot 

o the top left corner 

o you can write the body of your leave application 

o write the subject after that 

o designation of the person 

A: I don’t know how to write a leave application. 

B: I do. Would you like me to teach you? 

A: Yes, that will be great! 

B: Okay. _____________________with the date. Write down the date on 

_________________. 

A: Okay. What should I write after date? 

B: The ______________________________________you are writing the leave 

application to. 

A: Right! And I suppose we have to _______________________________. 

B: Correct! After that, ________________________________________. 

A: And the salutation is usually followed by the subject, isn’t it? 

B: Yes. Then, ______________________________________________________. 

A: What should I write in that? 

B: You can state how many days’ leave you want to request as well 

as___________________ _______________________. 

A: Okay. And what comes after the body? 

B: After the body of the letter, you can give the leave-taking. And that’s how 

you write a leave application. 

A: ________________________________! 
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EXERCISE 2: Vocabulary 

Choose the option which define the words in bold or share meaning with them. 

1. A leave letter is one where you request leave. 

(a) ask for 

(b) demand 

(c) refuse 

2. It should have a subject. 

(a) a statement which shortens the letter 

(b) a statement which states the topic of the letter 

(c) a statement which is an example of the letter 

3. It is easy to write a leave application. 

(a) difficult 

(b) a tough job 

(c) not difficult 

4. I would be extremely happy if my leave is sanctioned. 

(a) refused 

(b) allowed 

(c) not allowed 

5. I have to attend my brother’s meeting in Jamshedpur. 

(a) to be present at 

(b) to be absent at 

(c) to not go to 

Go through the assessment. If time permits, you can try to attempt it in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 

ASSESSMENT 

•Instruction: Select the right word from the options given. 

1. I would like to request/beg you for a grant of motherhood/maternity 

leave. 

2. I have been working with this organization for the past six years and my 

leave record is very good/perfect. 

3. Apart from last year when I exhausted/finished all my available leaves, 

every other year has at least 5 or 6 days of un-availed leaves. 

4. I understand/know that the company does not provide maternity 

leave/off. 

5. However/Though, I hope that my case can be considered as an 

exception/omission to the rule. 

6. I hope this record helps you to view my case favorably/happily. 

7. I would be extremely grateful if my leave is sanctioned/passed. 
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SESSION 4: BEING A GOOD TEAM PLAYER 

RELEVANT KNOWLEDGE 

 

 

       

  

                  

              

            

             

              

               

  

                 

               

               

           

         

              

            

  

           

    

     

               

 

              

             

           

              

      

        

                 

            

             

        

 

    

            

 

 

       

              

     

All of us have worked in teams. A family too, is a team where each one of us 

cooperates with the others to make the journey smooth. The same holds true in 

organizations too. Now, look at the following situations and note down which 

characterizes the quality of being a good team player and which does not. 

1. Your colleague asks you to look after his department for a while because 

he has to attend an urgent call. You refuse him by saying that you are 

too busy. 

2. Your junior asks you to explain what to do as he is new. You describe the 

job in detail and tell him to come to you if he needs any help. 

3. Your boss tells you to complete the call reports for the last two weeks 

with the help of two other customer service representatives; you tell 

your boss that you like to do things alone. 

4. Your colleague asks you to help her with her calculations for the report. 

You willingly calculate her numbers and offer to complete the report for 

her. 

Listen carefully to the instructions given by your facilitator and participate 

in the class discussion. 

EXERCISE 1: Team Player 1 

What would you do in order to be a good team player in the following 

situations?. 

1. A colleague of yours wants your help in completing a project. You say: 

(a) I am busy; however, I suppose I could help you a little. 

(b) I am busy and I can’t help you at all. 

2. A colleague of yours wants your help in getting the information for the 

weekly call report. You say: 

(a) I am busy so I can’t help. 

(b) I really wish I could help you; however, I have a lot of work to finish. 

3. You and your colleagues are given the same task. You say: 

(a) I think we can work together on the task as a team. 

(b) You do the work your own way. 

EXERCISE2: Team Player 2 

Rearrange the following in order to complete the conversation between A and 

B. 

o Maybe we could do it together. 

o We will need the call reports, follow-up documents, as well as, all the on-

site service reports we have. 
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o Oh! Even I have been given the same assignment. 

o Okay. Shall I get the call reports? 

o Yes, we could. Let’s make a list of the things we might need. 

A: Hello, I have been asked to categorize all the customer files according to the 

issues. 

B: __________________________________________________________________ 

A: __________________________________________________________________ 

B: __________________________________________________________________ 

A: __________________________________________________________________ 

B: __________________________________________________________________ 

A: Yes. I will go and get the follow-up documents, and the on-site service 

reports. 

Listen carefully to your facilitator follow the instructions to complete the 

exercise. 

EXERCISE3: Pronouns 

Choose the appropriate pronoun for the following: 

1. He told me to do the job ______________. (mine, myself, me) 

2. I needed __________ help. (your, yours, you) 

3. If we do the work together, it will take ________ less time to complete 

it. (we, our, us) 

4. I told them we can’t do it without ____________ co-operation. (theirs, 

their, them) 

5. Working as a team helps ___________ do our work faster and better. 

(we, us, ourselves) 

6. Would you like __________ to help you? (me, I, myself) 

7. He can do the work ___________ but if we help him, it will be done 

faster. (him, himself, his) 

Go through the assessment. If time permits, you can try to attempt it in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review 

ASSESSMENT 

•Read this: 

1. We need to fight for our rights. 

2. They should do the work themselves. 

3. I have to learn it on my own. 

4. This is my struggle and mine alone. 

•Instruction: Fill in the blanks with the correct pronouns. 
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1. My boss is a very intelligent and friendly person. _________ (His / He) 

guidance and support help _______________ (ourselves / us) do our work 

efficiently. 

2. When I joined the electronic department I didn’t know how to service a DVD 

player. But Kaushik, who is very kind and helpful in nature, explained all 

_________ (it / its) know-how to me. 

3. Shalini seemed unfriendly at first, but once I become a friend of _________ 

(hers / her), she helped _________ (I / me) a lot and made me feel 

comfortable in the new office. 

4. Naman and ________ (I / me) have never been that close, yet when I asked 

_________ (him / he)to help with categorizing the products according to 

their Brands, he readily agreed. 

5. Anshuman had to leave for home early as his sister was not well. My boss not 

only gave _________ (him / his) permission to leave early, but also asked 

_________ (he / his) driver to drop Anshuman home. 

6. Vandana has exchanged _________ (hers / her) day shift with Nisha’s night 

shift because Nisha had to go to her son’s school on Monday morning. 
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Objective: To evaluate your knowledge and understanding of Sessions 1, 2, 3 

and 4 of Level-4. 

Methodology: The review evaluations will be Question and Answer based. 

Answers will be assessed on content, context, grammar, sentence structure and 

vocabulary based on the sessions that have been imparted. 

Process: The review evaluations will be divided into four parts. One for each 

session: 

1. Customer Service Representatives. 

2. Describing your job. 

3. Applying for Leave. 

4. Being a Good Team Player. 

ASSESSMENT 

Review of Session 1: Customer Service Representatives 

Questions 

Answer each question in this sectionas completely as possible, in your own 

words. “Parroted” answers are not expected. (i.e. do not repeat the exact 

same words that were taught in the sessions). 

1. What are customer service representatives popularly known as? 

2. What kind of a “link” do customer service representatives form between 

businesses and their customers, and why? 

3. What is the job description of a customer service representative? 

4. What the most important skills of a good customer service 

representative? 

Grammar 

Fill in the blanks of the given sentences with present perfect form of the verbs 

given in the brackets. 

1. By mistake I ____________ (keep) these old DVDs. 

2. I just bought the laptop for 50,000 rupees and yet you____________ not 

____________(give) me any discount. 

3. Trust me ma’am, I ____________ (offer) you the best price. No other 

store will offer you this price. 

4. Someone____________ (forget) their wallet here. 
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5. He ____________ (sell) very few computers because the customers find 

the prices very high. 

6. You ____________ not ____________ (tell) me the cost of the Tablet PC. 

7. You ____________ already ____________ (serve) the customer well. 

*********************************************************************** 

Review of Session 2: Describing Your Job 

Questions 

The details given below are of Tanuja Shah’s job description. Rearrange the 

sentences of her job description, so it makes sense and has a sequential flow, 

and then answer the questions given below. 

Sentences: 

She works from 9.30am in the morning to 6:30pm in the evening. Her job 

requires her to attend to and serve all the customers’ needs and queries, and 

assist them in the best way possible. She is a customer service representative 

at one of their stores. Tanuja works for a computer manufacturing giant called 

“Gadgetronics”. 

She has been working on the same job for a little more than 2 years. The office 

she works at is located in Gurgaon. 

That is because Gadgetronics is a huge organization and working there has 

helped her develop and expand her skills. Tanuja gets a salary of Rs 9,500 per 

month, and medical insurance for her and her parents. Tanuja had worked as a 

customer service executive at a lifestyle-store before, but she likes this job 

better. She is also happy with the salary and benefits she receives. The only 

problem that she has with her job is the long distance from her home to the 

office, and the time it takes to travel back and forth. She also receives an 

additional bonus of Rs 750 every week, if she provides excellent service to 

more than 90% of her customers and receives good feedback, which Tanuja 

does! 

Questions: 

A: So, where are you working at? 

B: ___________________________________. 

A: Where is it located? 

B: ______________________________. 

A: How are the working hours? 

B: _____________________________________________________. 
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A: How long have you been working on this job? 

B: _____________________________________________________________. 

A: Tell us a little about your work. 

B: I am working as a _______________________________. The job requires 

_______________________________________________________________. 

A: Have you worked as a sales representative before? 

B: _____________________________________________________________. 

A: How is this job different from your previous job? 

B: _____________________________________________. 

A: How much does your job pay you? 

B: _________________________________________________________________. 

A: What else is there? 

B: _________________________________________________________________. 

A: So, is there anything that you do not like about your job? 

B:___.______________________________________________________________. 

Sentences 

Fill in the blanks with connectors/conjunctions given in the box above the 

given sentences. Some of the connectors / conjunctions can be used more 

than once. 

Connectors & Conjunctions: 

though however and but as 

then because so next thus 

My name is Isha _______I work as a customer service representative at 

Gadgetronics at Tech-City in Chennai. I have been working there for more than 

a year now. _______I enjoy my work so much, I haven’t noticed the months roll 

by. 

_______,a lot of people feel that a customer service representatives job is 

easy, it’s not. It is a job that requires a lot of energy _______patience. Every 

morning, I have to reach the office by 9:00am sharp. _______I have to mark my 
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attendance, _____make sure I check all my emails for any incomplete work that 

has to be completed. _______, I have to attend to all the customers’ needs. 

I start attending to customers at around 9:30am, _____,break for lunch only at 

12:30pm. We have an hour to finish eating, and _____ it’s back to work. 

_______our organization is very large ____ internationally well known, it 

attracts a lot of customers from across the world. 

*********************************************************************** 

Review of Session 3: Applying For Leave 

Questions 

Answer each question in this section as completely as possible, in your own 

words. 

1) What do application emails/letters help maintain? 

2) What kind of language and format must you use in an application 

email/letter? 

3) What should be specified in the application email/letter? 

4) Why is the application email/letter for leave written, and to whom? 

5) “A leave application email/letter should consist of all kinds of 

information.” - True/False? State why. 

6) “The leave application email/letter should not be lengthy and 

imprecise.” – True/False? State why. 

7) “An employee shouldn’t draft a leave application before going on long 

leave.” – True/False? State why. 

8) What do you need to always assure your employer of when applying for 

leave? 

9) What is the format of a leave application letter? Explain step-by-step. 

Letter Format 

Rearrange the given points, to form a logical and coherent leave application 

letter based on the format taught in the session. 

Leave Application Letter: 

o Dear 

o Computer Services Department 

o The Manager, 

o Thanking you, 

o Dated: 21st July, 2009 

o Sir/Ma’am, 

o Regards, 
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o Computer Services Department 

o Subject: Request for leave 

o MitaaliSinghania - (Employee-Id No. 7890) 

o I would be extremely happy if my leave is sanctioned. from the 25th to the 

29th of July, as I have to attend my brother’s wedding in Jamshedpur. I 

would like to request a leave for 5 days. 

Sentences 

Select the right word from the options given in bold in the givensentences. 

1. I would like to request / beg you for a grant of unwell/sick leave. 

2. I have been working with this organization for the past six years and 

my leave record is very good/perfect. 

3. Apart from last year when I exhausted / finished all my available 

leaves, every other year has at least 5 or 6 days of un-availed leaves. 

4. I understand / know that the company does not provide any paid 

leave / off. 

5. However / Though, I hope that my case can be considered as an 

exception / omission to the rule. 

6. I hope this record helps you to view my case favorably / happily. 

7. I would be extremely grateful if my leave is sanctioned / passed. 

*********************************************************************** 

Review of Session 4: Being a Good Team Player 

Questions 

Answer each question in the “Questions” section as completely as possible, in 

your own words. 

• Which of the following characterizes the quality of being a good team 

player, and which do not? 

1. Your colleague asks you to help her prepare the report chart. You 

willingly help her and offer to complete preparing the chart for 

her. 

2. Your colleague asks you to help him with his report because he has 

to submit it today. You refuse him by saying that you are too busy. 

3. A new member of your team asks you to explain to him what the 

job involves. You describe the job in detail and tell him to come 

to you if he needs any help. 

4. Your boss tells you to complete the customer service reports for 

the last two weeks with the help of two other customer service 

representatives.; you tell your boss that you can’t work with 

them, as you don’t like them. 
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Role Play 

Rearrange the following dialogues, in order to complete the conversation 

between A and B. 

Good Team Player 

o Maybe we could do it together. 

o We will need the customer service reports, follow-up documents, as well as, 

all the on-site service reports we have. 

o Oh! Even I have been given the same assignment. 

o Okay. Shall I get the customer service reports? 

o Yes, we could. Let’s make a list of the things we might need. 

A: Hello, I have been asked to categorize all the customer files according to the 

issues. 

B: __________________________________________________________________ 

A: __________________________________________________________________ 

B: __________________________________________________________________ 

A: __________________________________________________________________ 

B: __________________________________________________________________ 

A: Yes. I will go and get the follow-up documents, and the on-site service 

reports. 

Sentences 

Fill in the blanks of the given sentences with the correct pronouns. 

1. My boss is a very intelligent and friendly person. _________ (His / He) 

guidance and support help _____________ (ourselves / us) do our 

work efficiently. 

2. When I joined the electronic department I didn’t know how to service 

a DVD player. But Kaushik, who is very kind and helpful in nature, 

explained all _________ (it / its) know-how to me. 

3. Shalini seemed unfriendly at first, but once I become a friend of 

_________ (hers / her), she helped _________ (I / me) a lot and 

made me feel comfortable in the new office. 

4. Naman and ________ (I / me) have never been that close, yet when I 

asked _________ (him / he)to help with categorizing the products 

according to their Brands, he readily agreed. 

5. Anshuman had to leave for home early as his sister was not well. My 

boss not only gave _________ (him / his) permission to leave early, 

but also asked _________ (he / his) driver to drop Anshuman home. 
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6. Vandana has exchanged _________ (hers / her) day shift with Nisha’s 

night shift because Nisha had to go to her son’s school on Monday 

morning. 

*********************************************************************** 
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SESSION 5: TALKING ABOUT ONE S COMPANY 

RELEVANT KNOWLEDGE 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

At the end of this session, you should be able confidently describe your place of 

work. Read the following sentences given below about a company Safe-Keep. 

Safe-Keep 

• One of largest Software Companies in India. 

• Provideshigh-end anti-virus and anti-hacking software. 

• USP (Unique Selling Point)– software that keeps all individual personal 

data; bank accounts, personal information, all online details and 

passwords, etc. safe from theft; being hacked, and viruses. 

Imagine that you work in this company and have to describe the company based 

on the points given above. 

EXERCISE:1: Talking About One s Company 1 

Use the given points given below to form a paragraph. Start with the line “I 

work at Nokia.” 

Nokia 

• World’s largest manufacturer of mobile devices 

• Offers internet services which enable users to access music, games, 

media, messaging, and maps 

• One of the most valuable global brands 

• Mobile devices named according to series 

• Series ranging from 1000 to 9000 

• Special function series include Nokia Eseries (Enterprise series), Nokia 

Nseries (Multimedia Computer series), and Nokia N-Gage (Mobile gaming 

devices) 

EXERCISE 2: Talking About One s Company 2 

In this exercise you need to rearrange the sentences to form a conversation 

between a Customer and a Salesperson. Then you will form pairs and enact the 

conversation in a role play before the class. 
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• APPLE is the largest technology company in the worldthat designs, 

manufactures and sells consumer electronics, computer software, and 

personal computers. 

• Of course! Our company invented the iPod! 

• Thank you so much Ma’am. Please do visit us again. 

• Ma’am, some of our best-known products are the Macintosh line of 

computers, the iPod, the iPhone and the iPad. 

• No. That will be all. 

• Ok. Does your company have any product that plays music only? 

• Could you tell me a little about your company? 

• Oh! That’s great. What are your best known products? 

• Really? I didn’t know that. 

• Alright, you’ve convinced me. APPLE it is! I’ll buy the APPLE Laptop. 

• Can you tell me what some of them are? 

• Ma’am, would you like to purchase any software too? 

• Do you make software too? 

• Thank you. After all that you’ve told me about your company, I’m really 

happy I’ve bought an APPLE product. 

• No. Not at this time. Right now, I only want to buy a good laptop for my 

son’s birthday. He is studying animation. 

• Then I think an APPLE Laptop would be perfect for your son Ma’am, as 

our products are mainly for professionals in the creative media and 

design fields. 

• Our company produces some excellent software such as, iTunes, iLife, 

iWork, and many more. 

• Very good! Is there anything else I can help you with Ma’am? 

• Alright Ma’am, I’ll make your bill right away. 

The conversation should start with: 

Customer: Could you tell me a little about your company? 

EXERCISE 3: Pronouns 

Read out the sentences below and choose the correct pronouns. 

1. _____ was asked to talk about ____ company. (she-her, her-she) 

2. I will let the company’s success speak for ________. (myself, itself) 

3. ______ Company lets _____, the employees, take initiatives. (our-we, 

our-us) 

4. _____ Company employs fewer workers than _______. (my-yours, yours-

mine) 

5. _______ Company employs more workers than _______ does. (yours-my, 

your-mine) 
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6. At _________ company, _________ do not have to bring ___________ 

own food. (our-we-our, our-us-our, our-we-ours) 

7. Cooks are employed to prepare lunch for __________. (ours, us, 

ourselves) 

8. But those who do not like the food prepared by ___________, can bring 

food from home. (them, they, their) 

Try and make simple sentences using pronouns.Go through the assessment. If 

time permits, you can attempt the exercise in class. Otherwise, you can 

attempt it at home and bring to the class the next day for review. 

ASSESSMENT 

•Read this: 

This, these, that, and those – These pronouns distinguish particular objects and 

people. 

Anyone, anybody, somebody, someone, everyone, each, either, neither, 

everything, everyone, something, nothing, nobody, both, few, fewer, many, 

others, several, all, any, more, most, none, some, and such – These pronouns 

refer to one or more unspecified things or people. 

•Instruction: Fill in the blanks by choosing the correct pronoun. 

I work at SellWell, _______ (who, which) is a huge supermarket. It is situated in 

Anand Vihar. Myjob there is that of a sales representative. __________(Our, 

Ours) company is the largest supermarket chain in India. It has been around for 

more than five years. The items that wesell in __________ (this, these) huge 

supermarket are many. __________ (They, Their)include food, clothing, 

accessories, utilities, kitchen items, stationery, books – the list goes on. In fact, 

our slogan is “A shop for_____________.” (everyone, each) 

Although we do great business every day, the one time when we get over a 

thousand customers a day is during the “Sale Season”. For_____(me, mine), it 

is also the time to earn a lot of incentive. Customers pour in by hundreds and 

we have to help ________ (them, they)with _________ (their, theirs)shopping. 

Each customer gives the sales representative helping them a token; the more 

tokens you get, the higher __________ (your, yours)incentive. The person who 

gets the highest incentive is awarded the “Best Sales Rep” title. It was given to 

__________ (me, myself) last year. 
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Have you thought - What does the term IT mean? 

“The full form of IT is Information technology. It is a branch of engineering 

dealing with the use of computers and telecommunications equipment to 

store, recover, transmit and control data.” 

Information technology is information that is processed, communicated, 

displayed and recovered in a fast, error-free and proper-way. Today's world is 

the world of information and telecommunication. All this has been possible 

through information technology like telephone, fax, telex, computers, internet, 

e-mail, photocopier, printer, scanner, cellular phones, pagers, videophone, 

televisions, digital camera, multimedia, etc. We can find IT everywhere around 

us. In fact the modern world will be incomplete without Information 

Technology and its various uses. It’s almost impossible to even imagine the 

modern facilities without the use of IT. Every day new technology and 

inventions are being made in the area of information, processing and travelling, 

agriculture, health, education, etc. 

In the field of agriculture, farmers use IT to start harvesting with the help of a 

“digital moisture meter” that records the wetness in the soil. For people 

suffering from hearing loss, “digits technology” helps process sounds that 

reduce noise, improves clarity of speech and controls unwanted loudness. In 

supermarkets IT helps for faster processing of bills. 

Things that were once done manually or by hand have now become easier and 

faster due to the arrival of a computing technology. Our world today has 

changed a great deal with the help of IT which has entered almost every part of 

our daily lives, from homes to businesses. IT has become a part and parcel of 

our daily lives through the use of PC's, Internet, cell phones, faxes, etc. It is 

transforming lifestyles and habits of people all over the world. Any information 

can be exchanged by people in few seconds and that, too, in a proper and 

effective way without any loss of data while it is being processed. 

The wonders of satellite phones, internet phones, text messages and e-mails, 

have opened up many opportunities for direct communication. Due to this, the 

whole world has become a smaller place today. The breakdown of geographical 

boundaries has made the world a 'global village'. 

The use of IT has increased by leaps and bounds worldwide. Internet and 

multimedia have now become playthings for children. Our surroundings are 

proof enough to see how Information Technology has entered itself into our 
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everyday lives. Shopping, banking, travelling, education, entertainment, public 

sector, private sector, almost everywhere IT is playing its various roles very 

smoothly. 

One of the biggest advantages of IT has been the creation of a whole new field 

of opportunities for skilled people leading to new and interesting jobs such as 

hardware and software developers, computer programmers, web designers, 

system analysts, etc. 

The Indian Institutes of Information Technology are being set up at various 

places in the country. The government of India is very keen to achieve a great 

deal in the field of Information Technology. Now we can hope that India will 

become an IT superpower in the near future. There are many next generation 

modern and developing fields of Information Technology. Let us hope that 

these newer developments can provide benefits to our future generations, just 

as it has greatly benefited ours. 

“Without Information Technology, Modern life will be the same as a car 

without fuel.” 

Read the above section and write down the main points in your notebooks. 

EXERCISE 1: Information Technology 

Complete the conversation between A and B with the help of inputs from the 

comprehension section of this session. 

A: What is the book you’re reading? 

B: It’s on Information technology. It’s called “This is IT!” Have you read it? 

A: Yes. It was very informative. Before reading the book, I never knew that IT is 

a branch of ____________ dealing with the use of computers and 

telecommunications equipment to __________, __________, ___________ and 

_______________ data. 

B: Exactly! IT’s so interesting to find out that Information technology is just 

information that is processed, _____________, displayed and __________ in 

a fast, error-free and proper-way. 

A: Today, we can find IT everywhere around us. In fact the ___________ world 

willbe incomplete without Information Technology and its various uses. 

B: It’s almost impossible to even imagine the modern facilities without the use 

of IT. 

A: I agree. Every day new __________ and __________ are being made in the 

area of information, __________ and _________, agriculture, health, 

________, etc. 

B: Very true. In the field of agriculture, IT tells the farmers start harvesting 
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with the help of a “digital moisture meter” that _________ the wetness in 

thesoil. 

A: Yes, and for people, who are suffering from hearing loss, “digits technology” 

is of great help. It processes sounds that _______ noise, _______ clarity of 

speech and _______ unwanted loudness. 

B: And in super_____ it helps for ______ processing of bills. 

A: It is amazing how things that were once done manually by hand, have now 

become so much easier and faster due to the arrival of __________ _ 

______________. 

B: IT has entered almost every part of our daily lives, from _______ to 

____________. 

A: Our surroundings are proof enough to see how Information Technology has 

entered itself into our everyday lives. 

B: _____ping, _______, travelling, education, entertainment, public business 

sector, private business sector, almost everywhere IT is playing its various 

roles very smoothly. 

A: Yes, it is transforming ________ and ______ of people all over the world. 

B: Due to the wonders of satellite _______, _______ phones, text messages and 

e-mails, have opened up many opportunities for direct communication. 

A: And because of that, the whole world has become a smaller place today. 

B: Absolutely! The breakdown of geographical ___________ has made the world 

a 'global ____________'. 

A: Let us just hope that the new developments in the fields of IT can provide 

benefits to our future ____________, just as it has greatly benefited ours. 

Listen carefully to the instructions of your facilitator and after you have 

completed the exercise, form pairs to present a role play where you enact the 

role of A and B each. 

EXERCISE 2: Prepositions 

Read aloud the sentences and choose the correct preposition: 

1. Stack those CDs ________ the third shelf. (in, on, at) 

2. The shelf where the cables are kept is next ___________ the shelf where 

the disks are stacked. (to, from, beside) 

3. Put those CPUs on the shelf _________ the one where you just placed 

the monitors. (below, under, underneath) 

4. Keep the yellow folders separate _________ the blue ones. (with, 

against, from) 

5. Then arrange the keyboards on the shelf __________ the one where the 

speakers are placed. (above, over, inside) 

6. Place the manual ___________ the table. (above, over, on) 

7. Make sure the monitor screen is facing forward when you put it _____ 

display. (at, for, on) 
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8. Make sure the customers ___________ are served too. (out, outside, 

over) 

9. Make sure all products are placed _______ the right shelves. (on, in, at) 

10. You can stack these parts are fixed _______ the help of the technology 

specialist. (by, with, from) 

11. Our ever day lives have been made easier ________ Information 

Technology. (by, with, from) 

12. The manual will tell you where _____ put each cable. (to, at, with) 

Try to make simple sentences using prepositions. Go through the assessment. If 

time permits, you can try to attempt it in class. Otherwise, you can attempt it 

at home and bring to the class the next day for review. 

ASSESSMENT 

•Read this: 

1. Are you going to the office? 

2. Are you going to the office with Ashish? 

3. Are you going to the office with Ashish in his car? 

4. Are you going at 5 or before that? 

•Instruction: Fill in the blanks with appropriate prepositions. 

1. Do not place heavy items ______________ (between / on) the laptop. It 

is not strong enough to bear the weight. 

2. The software designer lives ______________ (at / in) the end of the 

street. 

3. Remove the deleted items ______________ (in / from) the recycle bin. 

4. Always make sure that the logos of the computers are visible so that it’s 

easy for the customers’ _____________ (to / for) recognize the brand 

names. 

5. Do not place too many items _____________ (above / on) the desktop. It 

slows down the computer. 

6. Make sure that there is enough lighting ___________ (in / on) the office. 

Put extra lights _____________ (over / upon) the items that you want to 

draw attention to. 

7. Customers’ details should be filed and kept _____________ (into / 

inside) a folder. 

8. Be extra careful _____________ (while / during) opening certain emails. 

9. The game may be stored _____________ (under / in) a folder. 

10.Make sure there is enough space _____________ (among / between) the 

two shelves for customers to walk around. 
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What does the term ITES mean? 

ITES stands for Information Technology-Enabled Services. 

• This means services delivered over telecom networks (phone) or the 

Internet (e-mail or chat) to millions of customers of different companies 

across the world. 

• In simple terms, IT-Enabled Services are functions performed in a 

country (example: India / China) different from the one where the final-

service is delivered (United States of America or England); that is, 

delivered over telecommunication (phone or e-mail). 

• ITES is supported by Information Technology (IT) in different fields like 

Banking, Insurance, Telecommunication, etc. 

• ITES – Information Technology Enabled Services includes the Call center, 

BPO, KPO and RPO.” 

In the above bullets you have come across the terms “Call center”, “BPO”, 

“KPO” and “RPO”. What are they? 

Call Center: is a service center with good telecom facilities, trained 

consultants, access to the Internet and other online information and is set-up 

to provide information and support to a customer. 

They are offices used for the purpose of receiving and transmitting a large 

volume of customer focused telephone calls that are handled by trained 

customer service representatives. The telephone calls may be “inbound” 

(customers call-in for getting information about a product) or “outbound” 

(customer service representatives call customers to sell some product or to 

provide information about some service). 

A typical call center functions as follows: 

• A customer uses a toll-free number (there is no cost when this number is 

dialed) that is connected to a customer support center. 

• When a call reaches the call center, the customer is answered by a 

trained customer service representative, who has access to a wide 

database of information, and is trained on the product/service being 

offered. 

• The technology created by the IT experts, to support the Call center, 

makes sure that the customer service representatives have the latest 

information available, thereby ensuring that the highest standards of 

customer service are delivered. 

• With the increase in world-wide connectivity, it does not matter if the 

call center is located in the local city of the customer or anywhere else 

in the world. 
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BPO: is business process outsourcing when an organization outsources a part of 

its business (customer service; attending customer calls or sales calls) to 

another organization that is an expert in handling that kind of business. The 

two organizations can be in two entirely different parts of the world. 

For example; Company-A in the USA, may sign an outsourcing customer-service 

contract with Company-B in India. The contract means that Company-B will be 

responsible for Company-A’s Customers by 

• Attending and communicating with all of Company-A’s customers 

• Handling all Company-A’s customers’ questions and complaints 

• Making sure all of Company-A’s customers are happy and satisfied 

with the services provided by Company-A and Company-B. 

• Making certain that all of Company-A’s customers stay loyal to 

Company-A’s Brand. 

Company-B will be responsible for Company-A’s customer-service only till the 

time that is mentioned in the contract. 

KPO: is Knowledge Process Outsourcing. It describes the outsourcing of core 

business activities, that are important and forms a primary part of a company's 

chain of activities. KPO services include all kinds of research and information 

gathering, e.g. intellectual property research for patent applications; equity 

research, business and market research, legal and medical services; training, 

consultancy, as well as, research and development in fields such as; 

pharmaceuticals and biotechnology, and animation and design. 

RPO: Recruitment Process Outsourcing is a form of business process outsourcing 

(BPO) where an employer outsources or transfers all or part of its employment 

and staffing activities to an external service provider. The employment and 

staffing activities that are normally stated in the contract are; screening of 

candidates who have applied for jobs and the hiring of new employees. If 

mentioned in the contract, it may also include one, some or all of the 

following: 

1. Deciding the position and salaries to be offered to new 

employees 

2. Setting company guidelines, and 

3. Ensuring all employees and department heads follow 

company guidelines. 

Now, read aloud the following story: 

Twenty-two-year-old Hrithik gets ready in haste, and rushes into the company 
cab to go to the I-Tech city. He works at AG - Gurgaon, a Call center for the 
American company Assurance Giant Inc. 

A typical day for Hrithik begins at 7 p.m. (8 a.m. US time), as he begins calling 
the AG credit-card holders in faraway places like New York and Washington to 
remind them to pay their bills. "Hi. My name is Greg (his name is changed to 
Greg) and I’m calling from AG," he says in his friendliest voice. People 
answering Greg 's calls have no way of knowing that he is sitting in Gurgaon, or 
that his real name is Hrithik, and that he picked up the American accent by 
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____________________________________________________________________ 

____________________________________________________________________ 

attending a training class at AG, Gurgaon. AG, Gurgaon, is filled with such 
talented customer service representatives who make outgoing calls to the 
United States of America, and take incoming calls, bounced by satellite to 
India. 

Most have never set foot in the United States, but they spend a large part of 
every day (or every night) answering customer enquiries, calling credit-card 
nonpayers, calculating medical claims, providing customer service, and doing 
such other activities. There are many international companies such as… 
computer giants; DELL, Microsoft, automobile manufacturer; Ford, and leading 
airline; British Airways, who are benefiting from the IT-enabled services being 
provided in India 

Think - Why India? Why do so many American organizations choose to outsource 

their businesses to India? Write your answers here: 

Some of the reasons are that our country offers many advantages as an IT-

enabled services destination for major global companies: 

• A 12 hour time difference with the USA 

• Talented work force who can speak English fluently 

• The cost of qualified employees is amongst the lowest in the world 

• The support that the Government of India lends to all IT based 

industries 

EXERCISE 1: The ITES Industry 

Based on what you have understood about the ITES Industry, complete the 

conversation between Aman and Simrit, given below: 

Aman: Simrit, I heard you’ve decided to join the ITES industry, is it true? 

Simrit: Yes. It’s a good offer from a very big company, and the job is very 

interesting too. 

Aman: Well, good for you! Can you tell me what does ITES stand for? 

Simrit: ITES stands for _____________ ________________ _________ 

___________. 

Aman: Thanks for telling me. So, are you going to work for the ITES itself? 

Simrit: No, silly! ITES means services delivered over _________ networks or the 

__________ to millions of customers of different companies across the 

world. 

39 



 

 

       

            

            

          

      

           

          

              

              

          

              

  

            

   

            

  

              

          

         

  

     

           

          

           

  

                

      

              

           

          

         

            

              

  

            

       

         

           

            

       

             

   

           

          

Aman: I’m still a little confused. 

Simrit: Okay, let me explain it in simpler terms, ITES are __________ 

performed in a country (example: India / China) different from the one 

where the final-service is _________ (United States of America or 

England); that is, delivered over tele______________. 

Aman: So do the computer experts also work for the ITES? 

Simrit: Well, the ITES is supported by _________________ ______________ (IT). 

Aman: So, what are the different businesses that are a part of the ITES? 

Simrit: There are mainly four business units that are part of the ITES. 

Aman: I think I know one, the ____ ________. Correct? 

Simrit: Yes. You’re right! The remaining three are the ___, the ___ and the 

____. 

Aman: What’s the difference between all of them? Aren’t they all business 

pro_____ _____________ing units? 

Simrit: Well, they are similar, and yet have very different functions. 

Aman: How? 

Simrit: Well, let’s start with the ____ __________. They are offices used for the 

purpose of ____ing and transmitting a large volume of __________ 

focused __________ calls that are handled by trained __________ 

service _________________. 

Aman: What kind of calls? 

Simrit: The calls may be “_________”, meaning customers call-in for getting 

information about a product, or “_________”, meaning calls are made 

outto customers to sell some product or to provide information about 

some service. 

Aman: Is it true that the ___ ________ can be located in a different city or 

country from where the customer lives? 

Simrit: Yes. The customer may be in a completely different part of the world! 

Aman: Cool! So what about the ____? What are its functions? 

Simrit: ____ is ________ pro______ __________ing. That is, when an 

organization _____________ a part of its business to another 

organization that is an ________ in handling that kind of business. 

Aman: And can the two organizations be in two entirely different parts of the 

world? 

Simrit: Yes. A company in the USA may sign an __________ing customer-service 

_________ with a company in India. 

Aman: What does the Indian company have to do? 

Simrit: The Indian company will be _____________ for the American company’s 

customer-service that is, taking care of all their customers, only till the 

time that is mentioned in the contract. 

Aman: Sounds interesting. So what about the ____? How is that different from 

the above two? 

Simrit: The ____ is known as _______ledge Pro____ _________ing. It describes 

the _______ing of core _________ activities, that are important and 
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forms a primary part of a company's chain of activities. 

Aman: What kind of services do they provide? 

Simrit: ____ services include all kinds of __________ and ____________ 

gathering. 

Aman: So it’s all knowledge based? 

Simrit: Yes. 

Aman: Super! So, what about the ____? I’ve never heard about it before. 

Simrit: ____ is Rec________ Pro_____ Out_______ is when an employer 

___sources or transfers all or part of its employment and staffing 

activities to an external service provider. 

Aman: What are the employment and staffing activities? 

Simrit: The employment and staffing activities that are normally stated in the 

contract are the ________ing of candidates who have _______ for jobs 

and the ______ of new employees. 

Aman: Wow! Everything sounds very interesting. Thanks Simrit, for explaining 

it all to me. 

Simrit: You’re welcome! Aman, now it’s your turn to explain something to me. 

Aman: What? 

Simrit: Can you tell me why do American organizations choose to outsource 

their businesses to India? 

Aman: I suppose because of a ___ hour time difference with the USA, and we 

have talented _____ force who can speak _______ fluently. Also 

because, the cost of _________ employees is amongst the _______ in 

the world, and the support that the _____________ of India lends to all 

IT based industries. 

Simrit: So true! 

After completing the exercise, form pairs and enact the role of Aman and 

Simrit each. 

EXERCISE 2: Shades of Meaning 

Read aloud the following sentences and choose the correct option: 

1. ___________ you were deciding on which book to read, I bought a music 

Cd. (While, Meanwhile) 

2. If you ___________ to do your MBA, you will __________ a degree first. 

(want-require, require-want) 

3. Put those computer ____________ (packets, packs) in the “Electronics” 

section. 

4. All phones should be checked before the customers __________ (start, 

commence) calling. 

5. All Cds should be __________ (deposited, stored) in their covers. 

6. Product _____________ (arrangement, display) is a tricky task. 
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7. _______________ (Show, Demonstrate), the customers around the store 

and _____________ (assist, support) them in finding what they need. 

Go through the assessment. If time permits, you can try to attempt it in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 

ASSESSMENT 

•Instruction: Fill in the blanks with the correct options. 

1. You need to _______________ (follow / go after) the guidelines of the 

company. 

2. Make sure that the team works well _____________ (jointly / together). 

3. The pictures in the manuals need to be easy for the customers to 

understand, so that they can easily _____________ (identify / detect) 

the parts of the computer. 

4. _____________ (Extra / Further) work should be appreciated. 

5. Do not touch the computer monitor with _____________ (polluted / 

dirty) hands. 

6. Do not put more than the required number of items needed on your 

desk, or else it will look _____________ (messy / jumbled). 

7. Keep the floppy disks away from extreme heat, or else they will get 

________ (spoilt / destroyed). 

8. _____________ (Current / Fresh) recruits should be informed of the 

company’s guidelines. 

9. I have always wanted to join the BPO ____________ (sector / portion). 

10.The new micro-computer is very ____________ (small / little). 
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The purpose of this session is to evaluate your knowledge and understanding of 

Sessions 5, 6 and 7. 

Methodology: The review evaluations will be Question ‘n’ Answer /Role play 

based. Answers will be assessed on content, context, grammar, sentence 

structure and vocabulary based on the sessions that were imparted. 

Process: The review evaluations will be divided into three parts, one for each 

session: 

• Talking about One’s Company.’ 

• Information Technology. 

• The ITeS Industry. 

ASSESSMENT 

Review of Session 5: Talking about one’s Company 

Listen carefully to your facilitator and complete the following details as per 

directions given.Rearrange the sentences to form a conversation between a 

Customer and a Customer Service Representative. 

Role-Play: 

o APPLE is the largest technology company in the world that designs, 

manufactures and sells consumer electronics, computer software, and 

personal computers. 

o Of course! Our company invented the iPod! 

o Thank you so much Ma’am. Please do visit us again. 

o Ma’am, some of our best-known products are the Macintosh line of 

computers, the iPod, the iPhone and the iPad. 

o No. That will be all. 

o Ok. Does your company have any product that plays music only? 

o Could you tell me a little about your company? 

o Oh! That’s great. What are your best known products? 

o Really? I didn’t know that. 

o Alright, you’ve convinced me. APPLE it is! I’ll buy the APPLE Laptop. 

o Can you tell me what some of them are? 

o Ma’am, would you like to purchase any software too? 

o Do you make software too? 

o Thank you. After all that you’ve told me about your company, I’m really 

happy I’ve bought an APPLE product. 
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o No. Not at this time. Right now, I only want to buy a good laptop for my 

son’s birthday. He is studying animation. 

o Then I think an APPLE Laptop would be perfect for your son Ma’am, as our 

products are mainly for professionals in the creative media and design fields. 

o Our company produces some excellent software such as, iTunes, iLife, iWork, 

and many more. 

o Very good! Is there anything else I can help you with Ma’am? 

o Alright Ma’am, I’ll make your bill right away. 

Questions: 

Answer each question in the “Questions” sectionas completely as possible, in 

your own words. 

Scenario – I: Gadgetronics 

1. In Scenario-I, you work for Gadgetronics. Describe your company based on 

the points given below. 

o One of largest Computer and Software Manufacturing Companies in India 

o Manufacture all types of Computers and high-end anti-virus softwares 

o USP – “Something for Everyone” their tag line. Costs that suits every 

budget and softwares that keeps all online data and passwords, safe 

from viruses. 

Scenario – II: Nokia 

2. In Scenario-II, you work for Nokia. Describe your company based on the 

points given below. 

o World’s largest manufacturer of mobile devices 

o Offers internet services which enable users to access music, games, 

media, messaging, and maps 

o One of the most valuable global brands 

o Mobile devices named according to series 

o Series ranging from 1000 to 9000 

o Special function series include Nokia E-series (Enterprise series), Nokia 

N-series (Multimedia Computer series), and Nokia N-Gage (Mobile gaming 

devices) 

Sentences: 

In the sentences given below, fill in the blanks by choosing the correct 

pronoun. 

1) I work at Gadgetronics, _______ (who, which) is a computer 

manufacturing giant. It is situated in Gurgaon. My job there is that of a 

customer service representative. 
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2) ______ (Our, Ours) company is the largest computer manufacturer in 

India. It has been around for more than five years. 

3) The computers that we sell in ______ (our, we) stores are many. _______ 

(They, Their) include desktops, laptops, tablets, notebooks, etc. 

4) In fact, our slogan is “Something for________.” (Everyone, Each) 

5) Although we do great business every day, the one time when we get over 

a thousand customers a day is during the “Sale Season”. 

6) For_____ (me, mine), it is also the time to earn a lot of incentive. 

Customers pour in by hundreds and we have to help ______ (them, they) 

with ______ (their, theirs) shopping. 

7) Each customer gives the customer service representative helping them a 

token; the more tokens you get, the higher _______ (your, yours) 

incentive. 

8) And the person who gets the highest incentive is awarded the “Best 

Service Rep” title. It was given to ______ (me, I) last year. 

*********************************************************************** 

Review of Session 6 :Information Technology 

Listen carefully to your facilitator and complete the following details as per 

directions given. 

Question: 

Answer each question in the “Questions” sectionas completely as possible, in 

your own words. 

1) What is Information Technology? 

2) Where can we find Information Technology? Explain. 

3) How has computer technology made things easier? Give an example. 

4) Fill in the blanks with the correct option given: Every day new 

_______________ (technicians/technology) and ________________ 

(things / inventions) are being made in the area of information, 

processing and travelling, agriculture, health, education, etc. 

5) How has our world today changed with the help of Information 

Technology? 

6) How has Information Technology become a part of our daily lives? 

7) What is one of the biggest advantages of Information Technology, in 

relation to jobs? 

8) The government of India is not showing much interest in the field of 

information technology. True or False? Explain. 

9) The Indian Institutes of Information Technology are being set up at 

various places in the country. True or False? 
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10)Today, Information takes a long time to be exchanged by people and 

that too, in an improper and ineffective way where loss of data may 

occur while it is being processed. True or False? State your reason. 

Sentences: 

In the sentences given below, fill in the blanks with appropriate prepositions. 

1) Do not place the CDs ______________ (between / on) top of the modem. 

2) The Gadgetronics office is ______________ (at / in) Gurgaon. 

3) Do not place too many items _____________ (above / on) the desktop. It 

slows down the computer. 

4) Customers’ details should be filed and kept _____________ (into / 

inside) a folder. 

5) Make sure that there is enough lighting ___________ (in / on) the office. 

Put extra lights _____________ (over / upon) the items that you want to 

draw attention to. 

6) Delete all the infected files ______________ (in / from) the computer. 

7) Be very careful _____________ (while / during) opening certain emails. 

8) Companies usually make sure their logos are visible so that they’re easy 

for customers’ _____________ (to / for) recognize their brand names. 

9) Place the customer contact details _____________ (under / in) the 

“customer info” label. 

10)Computer technology is very popular _____________ (among / between) 

the youth. 

*********************************************************************** 

Review of Session 7: The ITES Industry 

Listen carefully to your facilitator and complete the following details as per 

directions given. 

Question: 

Answer each question in the “Questions” sectionas completely as possible, in 

your own words. 

1) What does ITES stand for? 

2) When we say IT-Enabled “Services”, what kind of services are we 

referring to? 

3) What is ITES supported by? 

4) Does the ITES Company and the customer need to be in the same 

country? If no, explain why. 

5) What does ITES comprise of? 

6) What is a Call center and its’ functions? Explain in simple terms. 
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7) What does BPO stand for, and what is its main function? Give example of 

the kind of business. 

Sentences: 

In the sentences given below, fill in the blanks with the correct options. 

1) The files that have been infected by the virus have all been ________ 

(gone bad/ destroyed). 

2) We should _______________ (follow / go after) what we want. 

3) They need to do this project _____________ (jointly / together). 

4) Our logo has to be easy for the customers to _____________ (identify / 

detect) our brand. 

5) _____________ (Extra / Further) progress should be made. 

6) Science has _____________ (proved / improved) over the years. 

7) Do not put more than the required number of folders needed on your 

desktop, or else it will look _____________ (messy / jumbled). 

8) _____________ (Current / Fresh) recruits should be informed of the 

company’s guidelines. 

9) I have always wanted to join the ITES ____________ (sector / portion). 

10)The new microchip from Intel is really very ____________ (small / tiny). 

*********************************************************************** 
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SESSION 8: COMMUNICATING EFFECTIVELY 

RELEVANT KNOWLEDGE 

 

 

    

  

            

        

     

            

          

            

    

             

              

    

            

                

          

   

      

               

               

          

               

   

 

 

    

       

              

           

               

                 

             

   

 

          

              

____________________________________________________________________ 

____________________________________________________________________ 

We have been communicating with other ever since we can remember. But 

then what do we mean by effective communication? 

Read the passage below, aloud: 

Whether you're speaking with a customer over the phone, via email or face-to-

face, effective communication skills, proper grammar and active listening / 

reading skills, can make all the difference between satisfying a need and 

escalating a problem. 

In fact, the same is true when communicating with anyone in a professional 

environment, whether you're applying for a job or talking to your boss about a 

promotion you want. 

So though basic and simple, these skills are critical to achieving your 

professional goals, both today and in the future. Best of all, it's all right here at 

your fingertips. Just practice your pronunciation, enhance your listening and 

improve your grammar. 

Now look at the following situation: 

Your boss demands that you work an extra hour. But you always come to work 

on time and leave after you complete your shift. Plus, your house is quite far 

from your office and you have to take a bus. 

How would you explain to the boss that you can’t work the extra hour? Write 

your answer below. 

EXERCISE 1: Communicating Effectively 

Choose the response appropriate for each situation: 

1. Your customer asks you to process his/her request while on the call. But 

you, as a CSR, have your own work to do. 

(a) I am not going to process anything for you now. I am busy. 

(b) I am sorry, Sir/Ma’am. I really wish I could do that right now, however, as a 

customer service rep, I have to process orders according to the call number 

of the customers. 

2. Your boss gives you only ten minutes’ lunch-break. 

(a) Sir/Ma’am, could we have a longer lunch-break? Ten minutes is too short for 
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having lunch. 

(b) No one can eat lunch in ten minutes. 

(c) Could you give us a longer lunch-break? 

3. Your customer does not want the cell-phone that has been delivered to her. 

She says it’s not working properly. 

(a) I am not going to replace the cell-phone. You bought it, so you have to keep 

it. 

(b) I’m sorry Ma’am/Sir; however, as we have no return policy, I will be unable 

to replace the cell-phone. What I can do is, have one of our tech-experts 

take a look at it and replace any parts that may not be working properly. 

Will that be okay with you? 

4. Your boss never sanctions your request for leave. You have an important 

family event to attend. 

(a) I would like you to consider my request, Sir/Ma’am. I have an important 

family event to attend. 

(b) I am asking because I have an important family event to attend. Now, are 

you allowing me to go or not? 

5. Your colleague asks you to help him/her prepare the monthly service call 

report. 

(a) I wish I could, however, I am sorry; I will not be able to assist you with the 

monthly report, as I have to complete all my assigned work by the same 

date. 

(b) I am not going to help you. I have enough to do. 

EXERCISE 2: Past Continuous Tense 

Read aloud the following sentences and identify those that are in the past 

continuous tense. 

1. I was talking to my boss. 

2. He is a demanding person. 

3. He was asking me if I could work this Saturday. 

4. I refused him by saying that I have some urgent work. 

5. Everyone has been complaining about him. 

6. My colleagues were also telling me about their experiences. 

7. We were thinking about writing a formal complaint. 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the class 

the next day for review. 
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ASSESSMENT 

•Read this: 

1. She was playing with her dog. 

2. The mob of people was shouting. 

3. Zara, and not Meher, was painting the wall. 

•Instruction: Change the verbs in bold to past continuous tenseand rewrite 

the sentences. 

1. My boss is looking for me. 

2. He is going to complain about my performance again. 

3. He plans to talk about why the store is getting less and less customers 

each day. 

4. Fewer customers come because of lack of fresh stock. 

5. But our boss blames us for this. 

6. We have thought of having a talk with him. 

7. We are going to tell him that we need to remove the old stocks and get 

fresh ones. Who wants to buy rotten potatoes, after all?! 

8. We think that a meeting would be a better approach than talking 

individually. 

9. We forced him to listen to our opinions on the subject. 

10.He listened to his worker’s suggestions for the first time in his life; our 

plan worked! 
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SESSION 9:OPENING AND CLOSING A CUSTOMER SERVICE CALL 

RELEVANT KNOWLEDGE 

 

 

        

  

             

                

               

 

         

            

  

             

               

                

          

      

    

              

 

              

              

  

     

    

        

   

    

           

 

        

   

     

              

 

   

        

           

              

              

  

            

          

   

Listen carefully to the instructions given by the facilitator and enact the role 

play as directed. At the end of this role play, you should be able to appreciate 

how to open and close a customer service call. Some of things good to know 

are: 

When dealing with customers over the telephone, customer service 

representatives need to remember that, the call is a substitute for face-to-face 

conversations. 

Over the phone, no one can see the other person (facial expression, their 

manners, reactions, or what the other person is doing), but a lot can be judged 

from the tone of the voice! The rules for dealing with a customer over a phone 

professionally are simple but they need to be continually practiced. 

Read aloud the passages given below: 

Opening the conversation: 

There are the two basic ways of opening a call. These should always be 

employed. 

1. Smile when you answer. This helps to make the customer feel welcome 

2. Use friendly phrases as part of your greeting; “Thanks for calling”, “May I 

help you?” 

Some polite opening statement examples: 

• Greet the customer 

o State the name of your organization 

o Introduce yourself 

o Offer your help 

“Good morning, Airway Travels, Harpreet Kaur speaking. How may I help?” 

• Thank the customer for calling your organization 

o Introduce yourself 

o Offer your help 

“Thank you for calling Airway Travels, this is Harpreet Kaur. How may I help?” 

Closing the conversation: 

When customer service representatives finish their telephone conversation 

there are some polite statements that should always be made. 

1. Ask the customer if their issue has been solved to their satisfaction. 

2. Ask the customer if there is anything else they need any assistance or 

help with. 

3. Thank the customer, once again, for calling your organization. This lets 

the customer know that their business has been appreciated 

4. Re-introduce yourself. 

51 



 

 

           

      

  

            

              

               

    

 

           

 

           

     

          

 

            

          

              

        

   

               

             

               

    

             

     

      

          

   

  

            

    

           

      

 

 

 

           

       

               

               

         

              

              

             

5. Tell the customer it was a pleasure serving them. 

6. Say good-bye and close call 

For Example: 

“Has your question been answered satisfactorily? Is there anything else I can 

help you with? Thank you for calling Airway Travels. This was Harpreet Kaur. If 

you have any additional questions please feel free to call us anytime. It was a 

pleasure serving you. Goodbye.” 

EXERCISE 1: How to Open and Close a Customer Service Call 

Read aloud the details below. (Here CST stands for Customer Service 

Representative and Cust indicates Customer) 

CSR: __________ for calling Airsell. This is Jaspreet. How ____________ 

you? 

CSR: May I please have your full name and phone number? 

Cust: Ranjeev Singh. My phone number is 919922 2299. 

CSR: If I understand you correctly, what you are saying is you would like 

a ‘post-paid connection’, am I correct? 

Cust: Yes. 

CSR: Very good Sir. I’d be very happy to tell you all about the different 

plans we have. May I have two minutes of your time now? 

Cust: No, I don’t have the time right now, but could you please mail me 

your different post-paid plans? 

CSR: Sure. Would you please provide me with your email-id and I’ll send 

you the details right away! 

Cust: Great! My email-id is ranjeev.singh@email.com. 

CSR: May I please confirm your email-id. It is ranjeev.singh@email.com, 

am I correct? 

Cust: Yes. 

CSR: Thank you Sir. Is _______________ I can assist you with? 

Cust: No. That’s it. 

CSR: ____________ so much for _______ Airsell. This was Jaspreet. It’s 

been a pleasure serving you. Goodbye!_______________________. 

############################################################### 

CSR: Hello! Thank you for ________ Holiday Travels. ____ is Mandira 

________. How may I help you? 

Cust: My family and I want to go for a summer holiday, and we would 

like to know the best place to go to. Can you please tell me which 

place is best at this time of the year? 

CSR: I can surely help you Ma’am. As there are many wonderful places to 

choose from, I can send you a mail with all the different choices and 

you can take your time and select what best suits your family. 
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Cust: Great! 

CSR: May I please have your email-id Ma’am? So I can mail you the details 

right away! 

Cust: It is seema.kapoor@yahoo.com. 

CSR: Thank you Ma’am. Is there anything else I can help you with? 

Cust: No. 

CSR: Thank you for calling Holiday Travels. We really appreciate you 

calling us. This was Mandira. It’s was a _________ assisting you. 

_______________________________________! 

Form pairs and do the exercise in your student handbooks. Fill in the blanks. 

After you have filled out the blanks, come forward by turns and enact the role 

of the CSR and the customer. 

EXERCISE 2: Adjectives and Adverbs 

Read aloud the following sentences and identify whether the words in bold are 

adjectives or adverbs. 

1. Good Morning! 

2. The customer service representative must always be polite. 

3. A customer must be greeted cheerfully. 

4. A satisfied customer will speak highly of the company. 

5. Smile warmly while greeting customers. 

6. Wish customers a good day when you end a call. 

7. Never forget to thank customers for calling. 

Try to make simple sentences using adjectives and adverbs. Go through the 

assessment. If time permits, you can try to attempt the exercise in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 

ASSESSMENT 

•Read this: 

1. This issue should be solved quickly. (adverb) 

2. You need to be quick while handling such issues. (adjective) 

3. I am sure that the work will be completed. (adjective) 

4. Surely,the work will be completed. (adverb) 

•Instruction: Fill in the blanks with the correct adjective/adverb. 

Delivering good customer service – sounds like an ________ (easy, easily)task. 

However, how you talk to your customers plays an important role. 
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A ________________ (professional, professionally) __________ (friend, 

friendly)conversation will makes them feel welcome. Here are some examples 

of how you can talk to a customer _______ (warm, warmly): 

1. Good morning! Thank you for calling ‘book-your-ticket.com’, 

2. This is Karan Singh speaking. 

3. How may I help? Or 

4. Is there anything in __________ (particular, particularly) that I can help 

you with? 

5. Has your question been answered satisfactorily? 

6. Is there anything else I can help you with? 

7. Thank you for calling ‘book-your-ticket.com’. 

8. This was Karan Singhania. 

9. If you have any additional questions please feel free to call us anytime. 

10.It was a pleasure serving you. 

11.Goodbye. 

________(Simple, Simply) sentences like these not just show manners; they 

___________ (actual, actually) let your customers know that help is available. 

However, just saying the words is not enough. Your voice plays an __________ 

(equal, equally)important role. Politeness and a friendly smile __________ 

(real, really) helps the customers feel comfortable. You also show them that 

your services are _________ (ready, readily)available,and you will do all that 

you can to make sure their experience is _____________ (successful, 

successfully). 
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____________________________________________________________________ 

____________________________________________________________________ 

What is paraphrasing? Write down your understanding of the term here: 

The Merriam-Webster online dictionary defines the word “paraphrase” as a 

restatement of a text, passage, or work giving the meaning in another form.” 

In simple terms, “Paraphrasing is actually restating in your own words what 

someone else said.” 

• Paraphrasing sends a signal to the speaker that you “got” what the 

speaker is saying. 

• Paraphrasing also shows that you are interested in making sure that what 

you heard is what the speaker meant to say. 

For example, if your customer says, “I really like the Apple Macintosh PC, 

the Apple Laptop, the Apple iPad and the Apple iPod.” You could paraphrase 

and reply, “Wow! you really like Apple products!” 

What is paraphrasing really about? It is all about: 

• Understanding what the customer is trying to convey; message / issue 

• Internalizing the customers’ message / issue 

• Restating the important points in your own voice 

Why is paraphrasing necessary? Paraphrasing is needed to: 

• Clarify what your customer is saying. 

• Demonstrate to your customer that you are interested in what he/she 

has to say. 

• Confirm to your customer that you understand what he/she said. 

• Ensure that you fully understand the situation before moving ahead with 

the conversation. 

When on a call,there are some phrases on how an agent/customer service 

representative should start to paraphrase. Some of these are: 

• “If I heard you correctly, you were asking if…” 

• “Your question is/was……Is that right?” 

• “As I understand it, you want to know if…. Am I correct?” 

• “So your issue is …” 

• “As I understand, you’re facing an issue with…. Would that be correct? 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

If the customer confirms that the paraphrased question is correct, then the 

agent/ customer service representative should start answering. 

The agent’s / customer service representative’s response should be what the 

customer wants to hear and know. 

Learning how to paraphrase requires practice. When you are talking with 

someone, practice listening to what he or she is saying and then clarifying it in 

your own words. As you practice paraphrasing, you will find yourself gaining a 

better understanding of your customer and others in your life. 

The key to paraphrasing is listening carefully to what the other person says, 

and then translating what you heard into your own words. 

EXERCISE 1: Learning to Paraphrase I 

Note: Paraphrasing can be done with individual sentences or entire paragraphs. 

The first sentence in this exercise has been paraphrased as an example. 

• Original: The women, whose lives Sakshi had saved, were very thankful 

to her. 

• Paraphrase: The women were very thankful to Sakshi for saving their 

lives. 

Paraphrase the sentences given below: 

Original: Giraffes like eating leaves and hay, and they can consume 35 kilos of 

it a day 

Paraphrase:__________________________________________________________ 

Original: Any trip to Delhi should include a visit to Agra to see the Taj. 

Paraphrase:__________________________________________________________ 

Original:The use of recycled resources could stop the destruction of the 

rainforests. 

Paraphrase:__________________________________________________________ 

Original: From the thousands of motorcycle accidents each year, three-fourths 

were caused by head injuries. Half of those killed were school-age children. 

One study reported that wearing a bike helmet can reduce the risk of head 

injury by 85%. During an accident, a bike helmet absorbs the shock, cushions 

the head and can save a life 

Paraphrase:__________________________________________________________ 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

EXERCISE 2: Learning to Paraphrase II 

Form pairs and use the starting following phrases to fill in the responses of the 

agents. 

• “If I heard you correctly, you were asking if…” 

• “Your question is/was……Is that right?” 

• “As I understand it, you would like to / want to know if…. Am I correct?” 

• “So your issue is …Is that correct?” 

• “As I understand, you’re facing / you have an issue with…. Would that be 

correct? 

Customer: Could you tell me when will I get my laptop? 

Agent: ______________________________________________________________ 

Customer: I don’t think my desktop is functioning properly. 

Agent: ______________________________________________________________ 

Customer: This is not what I had booked. Please send me the one I chose. 

Agent: ______________________________________________________________ 

Customer: My new iPad is completely broken…Am I entitled to another one for 

free? 

Agent: ______________________________________________________________ 

Customer: I need the service-order information sent to me right now! 

Agent: ______________________________________________________________ 
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EXERCISE 3: Active and Passive Voice 

The following sentences are in the passive voice. Convert them to active voice. 

1. The products have been sorted by us. 

2. The products have been packed. 

3. The products had to be sorted so that we could pack them. 

The following sentences are in the active voice. Convert them to passive voice. 

1. We put the iPads and laptops into the Electronics category. 

2. We have counted the number of iPads and laptops. 

3. We had packed the iPads and laptops. 

Try making simple sentences in the active and passive voice. Go through the 

assessment If time permits, you can try to attempt the exercise in class. 

Otherwise, you can attempt it at home and bring to the class the next day for 

review. 

ASSESSMENT 

•Read this: 

Active Voice: She is arranging her bedroom. 

Passive Voice: Her bedroom is being arranged. 

Active Voice: She has arranged her bedroom. 

Passive Voice: Her bedroom has been arranged. 

Active Voice: She will arrange her bedroom. 

Passive Voice: Her bedroom will be arranged. 

•Instruction: Convert the following sentences into passive voice. 

1. I have categorized the items that can be packed together. 

2. She has made a list of items packed in each carton. 

3. Pooja is making a list of items to be packed separately. 

4. You should not pack vegetarian and non-vegetarian food items together. 

5. You have to bubble wrap all the glass and porcelain items. 

6. This list specifies the order in which the items have to be packed. 

7. I will remove the security tags before packing the clothes and glassware. 

8. I will fold the garments before they are packed. 

9. You must label all the cartons carefully. 

10.I have counted the number of cartons to be loaded in the truck. 
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RELEVANT KNOWLEDGE 

The purpose of this session is to evaluate your knowledge and understanding of 

Sessions 8, 9 and 10. 

Methodology: The review evaluations will be Question ‘n’ Answer /Role play 

based. Answers will be assessed on content, context, grammar, sentence 

structure and vocabulary based on the sessions that were imparted. 

Process: Therewill be one review evaluationfor each session: 

• Communicating Effectively 

• Opening and Closing a Customer Call 

• Paraphrasing 

ASSESSMENT 

Review of Session 8: Communicating Effectively 

1) Answer each question in the “Questions” sectionas completely as 

possible, in your own words. 

Questions: 

1. When speaking to a customer, over the phone, via e-mail or face-to-

face, what skill can either please the customer or escalate the issue? 

2. How important are communication skills when communicating in a 

professional environment? 

3. How does a person improve his/her communication skills? 

2) Change the verbs marked in bold to Past Continuous Tense and rewrite 

the given sentences. 

Sentences: 

1. A customer is looking for a Smartphone. 

2. He is going to applaud my performance again. 

3. We have thought of having a talk with him. 

4. I am planning to find out why our customers are going to our 

competitors’ store. 

5. Customers have come in thousands to see the launch of the new 

iPhone. 

6. Our boss praised my team for the success of the project. 

7. I ate, while Jaspreet Studied. 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 
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____________________________________________________________________ 

8. We think that a meeting would be a better approach than talking 

individually. 

9. We forced him to listen to our opinions on the subject. 

10.He listened to his worker’s suggestions for the first time in his life; 

our plan worked! 

3) Apply effective communication skills to explain your decision to your 

Manager. 

Role Play 

Your Manager asks you to work for an extra hour every day for the entire week, 

and help your team mate, Akaash, finish his reports. 

You’ve completed all your pending work, and live two hours away from the 

office. 

Before you make your decision, you must think of all the pros and cons of the 

situation. 

o If leave an hour late by bike, you’ll end up reaching your home only by 11pm 

every day, therefore, you will have to request your Manager for a car to 

pick-up and drop you for the week. 

o Your acceptance will showcase your positive attitude towards your team, as 

well as, make your Manager happy. 

o If you decline, then it may showcase your attitude towards your team in poor 

light, and you might end up upsetting your Manager. 

What will you do? Explain your decision to your Manager, using effective 

communication skills. 

*********************************************************************** 

Review of Session 9 :Greeting a Customer 

1) Answer each question in the “Questions” sectionas completely as 

possible, in your own words. 

Questions: 

1) You work for Gadgetronics, a manufacturing giant that makes 

computers and smartphones. You are at your store, when customers 

start walking in. What are the five different ways you can greet a 

customer? 
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------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------

2) Fill in the blanks in order to complete the dialogues so as to form a 

conversation between customer and customer sales/service 

representative. 

Scenario-1 

A: _____________________________________ 

B: Good Morning! 

A: ____________________ particular _________? 

B: Yes, I would like to have a look at some laptops with a printer. 

A: _________________ brand _____________? 

B: Which do you have? 

A: We have Apple, Dell, Sony, HCL and HP. 

B: That’s great. I’d like to have a look at them. 

A: Sure, Ma’am/Sir. Please come this way. 

Scenario-2 

A: _____________________________________ 

B: Hello. 

A: _____________________________________ 

B: I would like to buy a computer. Could you show me one that is not too 

expensive? 

A: Sure, Ma’am/Sir. What type of computer do you have? 

B: I’m not too sure. Something I can carry around. 

A: I think you’ll find our range of laptops very satisfactory. Would you like to 

have a look at some of them? 

B: Yes. 

A: Very good, Ma’am/Sir. Please come this way. 

Scenario-3 

A: _____________________________________ 

B: Morning! 

A: _____________________________________ 

B: I I haven’t decided yet. I’m just looking around. 

A: Okay, Ma’am. Please _____________________________________. 

B: I’ll do that. Thank you. 

Sentences: 

1) Fill in the blanks with the correct adjectives/adverbs. 

Delivering good customer service – sounds like an ________ (easy, 

easily)task; however, it’s how you talk to your customers that, plays an 

important role. 

A ________________ (professional, professionally) __________ (friend, 

friendly)conversation will makes them feel welcome. Here are some 
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examples of how you can talk to a customer __________ (warm, 

warmly): 

1. Good morning! Welcome to Gadgetronics. 

2. My name is Krish, how may I assist you? Or 

3. Is there anything in _______________ (particular, particularly) 

that I can help you with? 

4. Has your question been answered satisfactorily? Or 

5. Have you found what you’ve been looking for? 

6. Is there anything else I can help you with? 

7. If you have any additional questions please feel free to ask me. 

8. Thank you for being a Gadgetronics customer. 

9. We aim to serve you better. Or 

10.It was a pleasure serving you. 

A ________(Simple, Simply) and pleasant conversation such as this show 

the customers that they are ___________ (real, really) appreciated, and 

that let help is available. 

However, just saying the words is not enough. You need to sound like 

you __________ (actual, actually)mean it. Politeness and a friendly smile 

__________ (real, really) helps the customers feel comfortable. You also 

need to assure them that your services are _________ (ready, 

readily)available,and you will do all that you can to make sure their 

experience is very _____________ (pleasant, pleasantly). 

*********************************************************************** 

Review of Session 10:Paraphrasing 

1) Answer each question in the “Questions” section as completely as 

possible, in your own words. 

Questions: 

1) What is Paraphrasing? Explain in simple terms. 

2) What are the three steps involved when paraphrasing? 

3) What does “paraphrasing” convey to a person / customer? 

4) Why is it necessary to paraphrase? 

5) Describe a minimum of three starting phrases used when 

paraphrasing? 

Sentences: 

1) Paraphrase the original sentences given. Once completed, read out the 

sentences. 
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_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

1) Original: The computer, that Sahil had repaired, was working very well. 

2) Original:Mansi’s new laptop has been completely damaged in an 

accident…Will the company she bought it from, give her another one for 

free? 

3) Original: When you go to buy that new computer you were telling me 

about, make sure you buy it from the Gadgetronics store. They offer the 

best discounts. 

4) Original: I think the use of recycled resources in technology would be 

fantastic! 

5) Original: From the thousands of computer crashes each year, half are 

caused by virus attacks. The other half are caused by badly 

manufactured computers. 

2) Convert the following sentences into passive voice. 

1. I have categorized the computers that need to be packed together. 

2. She has made a list of computers packed in each carton. 

3. Priyal is helping a customer find a laptop. 

4. Ansh mailed the letter. 

5. You have to paraphrase all the customers’ issues. 

6. This list specifies the customer’s name for which the Tablet PC has to 

be packed. 

7. The driver delivered the desktop at the correct address. 

8. The salespeople always clean the computers before they are put on 

sale. 

9. You must file all the customers’ names alphabetically. 

10.Many of our customers inquired about our newly launched laptop 

today. 

*********************************************************************** 
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SESSION 11: VERIFICATION OF INFORMATION 

RELEVANT KNOWLEDGE 

 

 

     

   

         

 

 

 

 

 

 

 

 

   

             

            

         

         

       

      

           

                 

         

            

              

            

             

            

          

              

            

           

             

          

           

              

             

             

        

          

            

               

     

____________________________________________________________________ 

___________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

What do you think the term “Verifying Information” means? 

Verifying Information includes: 

• All information gathered, can be verified, with the help of the internet. 

• The verification process that companies follow is very important as it 

safe guards the customers’ information (bank account details, insurance 

policy details, product and service order numbers, credit-card numbers, 

etc.) from being misused or stolen. 

Read the following paragraph, aloud: 

“Verify names:check customers’ first name and last name (For example: Rahul 

Seth), as it is important to make sure if the person calling is an existing or new 

customer. Confirm land-line and cell phone numbers: Check customers’ land-

line number / Cell phone number. Check the postal code: Companies provide 

their agents the use of many directory services to verify customer details (if it 

an existing customer) that the entered post code matches the already stored 

information about the customer. If the customer is new, then the details will 

be recorded and kept for future confirmation. Confirm the email address: Order 

confirmations and product information are sent to the customers’ email 

addresses. If the email is returned without being delivered, this can be a sign 

that something is wrong; that the information provided by the customer was 

not correct. Very few customers provide wrong email addresses, because they 

want to be notified of their order’s status or receive information about their 

old / new products. Verify service order number: Check customers’ 

confirmation number, service order number (the number given to the customer 

at the time when customer submits the service order), and order date. End the 

call: When customers do not provide correct information and do not verify their 

details to the satisfaction of the agent, or when agents suspect something is 

wrong, they are required to close the call.” 

Now, break down the paragraph into simple instructions, for example: 

• Verify name: Check customers’ first name and last name (For example: 

Rahul Seth), as it is important to make sure if the person calling is an 

existing or new customer. 
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When you have completed the activity, follow the instructions of your 

facilitator to enact a role-play. 

Read the two sections below carefully. Verification Process-1 is an example of 

when a customer provides the correct information. Verification Process-2 is an 

example of what happens when a customer does not provide correct 

information. 

Verification Process -1: 

Agent: Sure, I can assist you with that; however, before we continue I need to 

verify your account information. Is that okay with you? 

Customer: Yes. 

Agent: May I have your First name and Last name? 

Customer: Sure, that would be Kunal Seth. 

Agent: May I please have your landline phone number and your mobile phone 

number? 

Customer: Sure. My landline number is 011 – 123 45678, and my mobile number 

is 77410 56987. 

Agent:Thank you.Would you please tell me if a customer-account number was 

provided to you when you bought the product? 

Customer: Yes, I was given a customer-account number. 

Agent: Thank you. May I please have your customer-account number, along 

with your product’s model/serial number? 

Customer: The service-order number is XYZ1234. The model number is ABC4567 

Agent: Thank you. Just to confirm I have the right account I see that email 

address on the account is Kunal.Seth@email.com, is that correct? 

Customer: Yes, that’s right. 

Agent:Thank you for verifying your information. I can now assist your issue. 

Verification Process -2: 

Agent: Sure, I can assist you with that; however, I will need to verify your 

information before we continue. May I have your First and Last name? 

Customer: Sure, that would be Abhaas Kapoor. 

Agent: Thank you. May I please have your landline phone number and your 

mobile phone number? 

Customer: Sure. My landline number is 011 – 4567 19834, and my mobile 

number is 79139 69087. 

Agent: May I have your customer-account number please, along with your 

service-order number? 

Customer: My customer-account number is XYZ1234, and my service-order 

number MKR6789 

Agent: Thank you. May I please have your bill number? 

Customer: Umm… I don’t know where I’ve put the bill. Will that be a problem? 

Agent: No problem Sir. Do you have the date you bought the product? 

Customer: Yes, I do. I bought it on the 12th of August this year. 
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EXERCISE 1: Verifying Information 

Agent: Thank you. I am going to take just a few moments to check the account 

here. 

Customer: Sure. 

Agent: Sir, I am unable to find any record of that customer-account number 

and the service-order number in my systems. Could you please provide your 

email address and billing address so I may search for your account and order 

details? 

Customer: Sure, my email address is AbhaasK@email.com and my billing 

address is No 15, 16th Street, Sector 17, Chandigarh – 18. 

Agent: Sir, I have tried to search with the details you’ve provided; however, 

I’m unable to find any related account or service-order. Is it possible that you 

may have registered with a different address or email address? 

Customer: I may have. I don’t remember. My documents are not with me. 

Agent: In that case sir, I would like to suggest you find the bill or customer-

account form and call us with the correct details. We will surely assist you 

with your issue if you are able to verify your details with us. 

Customer: Alright, I will do that. Thank you. 

Agent: Thank you for calling “Online Clothes”. This is Dalinder. Have a nice 

day. 

Customer: Thank you. 

1. Verification of Information -1 

Agent: Sure, I can assist you with that; however, before we continue I need 

_______________________________________. ______________________? 

Customer: Yes. Go ahead. 

Agent: _______________________________? 

Customer: Sure, that would be MaahiGor. 

Agent: __________________________________________________________? 

Customer: Sure. My ______________________ is xxx – xxxxxxxxx, and my 

___________________ is xxxxxxxxxx. 

Agent:___________.____________________________________________? 

Customer: Yes. My exam roll-number is CBT345 6780. 

Agent: _____________. _____________________________________? 

Customer: It is myname@email.com 

Agent:_______________________________________. I can now assist your 

issue. 

2. Verification Process -2 

Agent: Sure, I can assist you with that; 

____________________________________before we continue. 

________________________________? 

Customer: Sure. 
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Agent: _________________________________? 

Customer: It’s Viren Mehra. 

Agent:__________. 

___________________________________________________________? 

Customer: Sure. My ______________________ is xxx – xxxxxxxxx, and my 

_____________________ is xxxxxxxxxx. 

Agent: _____________________________________, along with 

_______________________? 

Customer: My _____________-__________ number is XYZ1234, and my 

________ is IMeMyself___themail_____. 

Agent: Thank you. Sir, _____ unable to find 

______________________________________ in _______________. 

Customer: How can that be? Please check again. I am sure it’s there. 

Agent: I am Sir. Could you please ______________________________? 

Customer: Sure, I live at: No. xx, xxth Street, Sector xx, Faridabad – xx. 

Agent: Sir, I have tried ____________________________; however, I’m unable 

to ____________________________________________. 

Customer: I don’t know what to say. 

Agent: Sir, I would like to suggest ______________________________________ 

____________________________________________. We will surely assist you 

with your issue, ____________________________________________. 

Customer: Alright, I will do that. Thank you. 

Agent: _________for calling. Have a nice day. 

Customer: Thank you. 

3. Verification of Information -3 

Agent: Sure, I can assist you with that; however, before we continue I need to 

_____________________________________________. 

________________________? 

Customer: Yes. What do you need? 

Agent: ___________________________________________? 

Customer: Sure, that would be Jagpreet Anand. 

Agent: __________________________________________________________? 

Customer: Sure. My ______________________ is xxx – xxxxxxxxx, and my 

___________________ is xxxxxxxxxx. 

Agent:___________.____________________________________________? 

Customer: Yes, I have a customer-account number. 

Agent: Thank you. 

____________________________________________________? 

Customer: My ___________________________ is xxx xxxx. 

Agent: __________________________________? 

Customer: I got it on the 5th of Sept’2012. 

Agent: _____________. _____________________________________? 
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Customer: My email-id is, Myself@email.com 

Agent:_______________________________________. I can now assist your 

issue. 

Form pairs. Frame the verification questions for the agent, and fill in the 

correct responses for the customer. You can use inputs from the previous 

section. 

EXERCISE 2: Making Meaningful Sentences 

Rearrange the italicized words so that the sentences make complete sense. 

1. When do we verifying start information the? 

2. We have him for bought phone a. 

3. Clean computers longer attractive and last look. 

4. Phones should be weeks in cleaned two once. 

5. Even if you wipe won’t if properly, you neat don’t them the roomthe 

furniture, look arrange. 

6. When in doubt, the instructions follow always. 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the class 

the next day for review. 

ASSESSMENT 

•Instruction: Rearrange the words in the following sentences to make 

meaningful sentences. 

For Example: 

the laptop. am carrying I 

Ans: I am carrying the laptop. 

1. from the shop. damaged the good returned The customer he bought 

2. name of opening has address and Before be customer the account, a 

verified. bank to 

3. customers their organizations always Big to keep try happy. 

4. mobile a from bought store. I online phone an 

5. airline internet. booked they my on I ticket 

6. everyday have important part Computers of life. an become 

7. favorite is of sports. one my Football 

8. industry. lots Today, the there joining of our youngsters IT 

9. software homework. wish was there my that I computer all do could 

10.most The love science. that computer I subject is 

68 

mailto:Myself@email.com


SESSION 12: DIRECTING A CUSTOMER OVER THE PHONE 

RELEVANT KNOWLEDGE 

 

 

        

   

              

               

           

 

    

 

  

You must be familiar with the figure given below. An explanation of each item 

is given in Fig 2 and 3. Listen carefully to the instructions given by your 

facilitator to role play a customer service representative (CSR) / customer. 

Fig 1 - DESKTOP 

Fig 2 
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_____________________ 

Fig 3 

Role Play 1: 

Customer asks to be shownn the desktop on the CSR’s computer. The CSR 

complies by verbally speakingg and pointing out. 

Role Play 2: 

Customer asks to be shown wwhere the taskbar is. The CSR complies byy verbally 

speaking and pointing out. 

Role Play 3: 

Customer asks to be shown how to close a document. The CSR commplies by 

verbally speaking and pointinng out. 

Role Play 4: 

Customer asks to be shown where the Start button is. The CSR commplies by 

verbally speaking and pointinng out. 

EXERCISE 1: Directing a Cust tomer 

Fill in appropriate responses aand instructions with using Fig-4 & Fig-5. 

ISSUE 

“Phone is frozen on the mennu screen.” 

Customer: My phone is frozzen on the menu screen. I can 

navigate around. I’ve tried to make a call, but there is a 

message saying that there issn't any service. It didn’t switch 

off for a long time either! Cann you please help me? 

CSR: 

Customer: What kind of inforrmation do you need? 

CSR: I will need the and of your ______ ________ _________ 

phone please. 

Customer: I have a Trac cFone, but I don't have the 

paperwork, so I'm not sure of f the model. 

CSR: 

Customer: I think it’s a LG22 20. 

CSR: Okay, Thank you! Could you please tell me 

swit tched off? 

Customer: Yes. Do you know what the matter is with it? 

CSR: From what you’ve descrribed, the phone it seems needs to restart,, so let’s 

try and force a wrestart, shall we? 

Customer: Okay. Is it a big prroblem? 
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CSR: Not really. This is usually just a tiny issue that can be cleared up quickly. 

Please try this and let me know the results. 

• Remove the battery and wait a few seconds then reinsert the battery. 

• Then hold the power button for 30 seconds 

• Allow the phone to restart and it should be ready for use again. 

Customer: I've never taken the back off, and I don't want to ruin the phone, so 

can you help me with that? 

CSR: No issues! I will guide you through a set of ______________ to remove the 

battery. Will that be okay? 

Customer: Yes, absolutely! 

CSR: Okay. Kindly perform the following steps, as I call out the instructions: 

FIG-4 

• Please _________________________________________________ (1) on 

the back of your phone, _________________________________ (2). 

• Lift _______________ (1) and away (2) from ________________. 

FIG-5 

To replace the battery: 

• To reinstall the battery, arrange the battery contacts (1) with those in 

the battery compartment. Press the _______________ until it clicks into place 

(2). 
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• With the battery in position in the phone, ____________________ on the 

back of your phone so that it fits. 

Customer: Mission Accomplished! Thank you! 

CSR: I hope everything is working well with your phone now. Please let me 

know if there is anything else, I can be of any assistance with. I will be glad to 

answer any follow up questions you may have. 

Customer: No. Everything’s working just fine. Thank you, once again! 

CSR:_________________________________ 

EXERCISE 2: Modals 

• Select the right modals and fill in the blanks: 

1. ___________ you like me to show you the way? (Could, Should, 

Would) 

2. I _______ check and let you know if we have this shirt in size XL. 

(will, shall, can) 

3. _________ I help you? (Can, May, Might) 

4. I ___________ take you there if you like. (will, could, should) 

5. You _________ try our new arrivals here. (could, would, will) 

6. Turn left and walk straight down – you ________ be able to find the 

Customer Care desk there. (could, can, should) 

• Make a sentence with one of the following modals: might, could, should, 

shall, can, will, would, may 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Read this: 

Has/Have to - Used to express something that is certain or necessary. 

The singer has to be Smriti from our class. 

We have to get there by seven. 

Ought to - Used to express an obligation or something that is probable. 

The Indian team ought to win the match. 

We ought to let them know when we are arriving. 

Had better - Used to express warning, recommendation, or hope. 

You had better complete your essay before Monday. 

You had better take your raincoat today. 

You had better be right about the car coming to get us. 

•Instruction: The following is a conversation between a salesman and a 

customer . Fill in the blanks with appropriate modals. 
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Salesman: Hello ma’am! How _____________ (may / will) I help you? 

Customer: Well, I wanted to buy a gift for my daughter. 

_____________(Should / Could) you direct me to the kid’s section? 

Salesman: Sure, ma’am! Please follow me. It’s right here. Are you looking for 

something specific? 

Customer: I’m not sure! _____________ (Would / Can) you help me find a 

good gift for her? She is just six years old. 

Salesman: In that case, you _____________ (should / will) take a look at our 

gifts section here…this section is especially for girls. You _____________ 

(must / can) choose from a variety of gifts here. How about this pair of 

earrings here? 

Customer: Well, I was thinking of educational gifts…you know…the ones that 

help children learn even as they play. 

Salesman: Such gifts are very popular these days. They are on that shelf near 

the counter. These wooden blocks are specially recommended by 

teachers…You _____________ (will / must) buy these. 

Customer: Well, this is exactly what I was looking for. 

Salesman: _____________ (Should / Would) you like this gift to be gift-

wrapped ma’am. 

Customer: Yes, please. And I _____________ (must / would) like to take a 

look at the Women’s section also. Is it on the same floor? 

Salesman: No, ma’am it’s on the second floor. You _____________ (will/ 

could) take the elevator to go there. 

Customer: Oh! I _____________ (have to / would) buy some stuff for the 

birthday party also. Where is the grocery section? 

Salesman: It’s on the ground floor. 

Customer: Thanks! 

Salesman: Is there anything else I _____________ (will / can) help you with? 

Customer: No, thanks! You have been a great help! 
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SESSION 13: HANDLING AN ANGRYCUSTOMER 

RELEVANT KNOWLEDGE 

 

 

     

   

       

      

 

            

           

           

             

             

              

          

                

             

     

 

               

         

          

   

           

    

        

 

             

   

 

 

 

 

             

          

           

             

          

           

          

         

 

           

             

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

_________________________________________________________________ 

ANGRY: annoyed, irate, enraged, furious and irritated. 

Read aloud the situation given below: 

“A customer purchased a new mobile phone from a reputable cell phone 

provider. Three months later, the phone started to malfunction and the 

customer sent the phone back to the company for service. 

The company stated that they would not replace the phone because it showed 

signs of rust on the battery. The customer informed the company that the 

phone had not been exposed to water; however, all of the customers’ calls to 

the company’s customer service department, were met with the ridiculous 

excuse that the rust was due to the phone’s normal exposure to air – so the 

company was not responsible, and therefore they would not replace it or fix 

the problem free of charge!” 

1. How would you feel, if you were the customer, in the above situation? 

Would you feel “nice”, “upset”, “pleasant”, “irritated”, “unconcerned”, 

“cheated”, “happy” or “angry” OR would you feel “angry”, “cheated”, 

“upset”, “irritated”, etc. 

2. How would you speak to the company’s customer service representative 

in such a situation? 

Would you speak “nicely”, “pleasantly”, “indifferently”, “happily” or 

“angrily”? 

3. What should be the lesson the company should learn from this situation? 

Write your answer. 

In a career as a customer service representative, one does come across angry 

customers. Such customers leave zero ground for conversation or negotiation. 

There’s nothing much that thecustomer service representative can do when the 

customer is angry. The cause of the anger may be valid or otherwise. 

When customers are concerned, upset or irritated, a customer service 

representatives need to act quickly to regain their trust and confidence. 

Customer service representatives use the following techniques to develop skills 

that will help them deal effectively with angry customers. 

Remain calm: When answering an angry customers’ call, always be patient. 

Realize that any anger that the customer is displaying is not directed towards 
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you personally. Therefore, do not respond with emotion. An angry customer 

will just get even angrier if you respond with any aggression. Takes quiet deep 

breaths and wait patiently for your turn to speak. Be warm and friendly and 

remain calm at all times. 

Listen: Calmly listen to what the customer has to say, without any 

interruption. Listening to an upset customer is half of the process helping to 

reduce a customer’s emotions, making the person easier to deal with. The 

other half is doing something to ease the tension. 

Apologize: Express sincere personal regret for the bad experience if 

appropriate; apologize on behalf of the organization. 

For example: 

o “I apologize that (specify the issue) happened” 

o “I am sorry you ran into that issue” 

o “You are right; it is our error; and I apologize” 

o "I'm sorry your expectations weren't met. Let's focus on finding a solution 

that will make you happy." 

Paraphrase: Re-phrase the customer's complaint to ensure that you correctly 

understand the issue. The customer is more to likely calm down if he/she 

realizes you understand the situation. 

Be empathetic; to identify with and understand someone else’s situation: It 

is important to show empathy when dealing with an angry customer. 

Remember, customers want to be heard. The ideal way to let your customer 

know you hear and understand their anger is to acknowledge it. You're letting 

the customer know you understand without necessarily agreeing. For example: 

o "You're right, it can be frustrating to read and fill out all of this 

paperwork" 

o "I understand how frustrating writing this down must be." 

No matter how one feels inside, a customer service representative must always 

speak very courteously, confidently and politely to the customer. This tells the 

customer that you, the customer service representative, are in-control of the 

situation, are experienced in handling angry customers and can perhaps even 

find a solution to their issue! 

Act to improve the situation: 

• Fix it!– 

• Provide a solution that will make your customer happy. 

• Correct the issue for the specific customer and also look for long 

term corrective measures. 
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• It may be appropriate to reassure the customer that you will be 

available to assist in the event that another different problem 

should occur again. 

• Explain what happened– 

• Recap the issue and solution. 

• Restate the issue and every change you've made to correct the 

issue so that the angry customer knows exactly what was done. 

Follow up:Leave a positive impression. By displaying compassion and 

attentiveness after an issue has been solved send a powerful message to the 

customer that you really care about each individual customer. This follow-up 

after the anger has subsided and the solution has been proven to be effective 

may be enough to retain loyal customers and earn a few new ones. 

Thank the customer: Thank the customer for taking the time to call and let 

you know about the issue. Tell the customer that he/she has done your 

company a favor by notifying your company about an issue other customers may 

also be experiencing. 

End the call on a high-note: Close all such calls by thanking customers, and 

telling them that you appreciate and value them and their feedback. And, that 

you look forward to serving them in the best possible way. 

Now, study the scenario given below. If you were the customer,what would you 

want to hear from thecustomer service representative? 

If you were thecustomer service representative, how would you handle the 

situation? 

You can use the above given points to write your answer in your notebooks. 

“A customer purchased a new Laptop from a well-known computer 

manufacturer. A few months later, the laptop malfunctions and the customer 

wants the company to replace the laptop or provide service that’s free of 

charge. 

The company responds that it is not responsible and that it would not replace 

the Laptop as the laptop showed signs of some parts being short circuited 

because of water. The customer informs the company that water has never 

been spilt on the Laptop; however, all of the customers’ calls to the company’s 

customer service department were met with one negative excuse after 

another. 

As a result of this, the customer has become very angry.” 
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EXERCISE 1: Handling an Angry Customer 

Fill in the blanks with the options given below so as to complete the 

conversation between a customer service representative and a customer. 

• As I understand, the music system installed in your laptop is not 

functioning properly. Am I correct? 

• I am so sorry for your inconvenience, Ma’am. May I please have a 

moment to check your records? 

• Thank you for your patience, Ma’am. 

• I understand you’d like your laptop replaced, would that be correct? 

• I really wish I could Ma’am; however, company policy wouldn’t allow me 

to do that. What I can do, however, is replace your laptop’s music 

system with a brand new one! Would that be okay with you? 

• How can I help you, Ma’am? 

• So I can better serve you, and get started on solving the issue, 

• Could you please tell me what is the issue you’re facing Ma’am? 

• Ma’am, please let me assure you that I am here to assist you in finding a 

solution to the issue you’re facing right away. Will that be okay with 

you? 

• Thank you Ma’am. Would you please tell me when you bought the 

laptop? 

• Thank you, Ma’am. We really appreciate you bringing the issue to our 

notice. It was a pleasure serving you. 

CSR: _______________________________________________________________? 

Customer: I want a replacement for this laptop, and I want it now! 

CSR: _______________________________________________________________? 

Customer: Yes. 

CSR: _______________________________________________________________? 

Customer: The stereo is not working! 

CSR: _______________________________________________________________? 

Customer: Yes! 

CSR: ________________________________________________________________ 

____________________________________________________________________? 

Customer: Yes, I guess so. 

CSR: _______________________________________________________________? 

Customer: I bought it eight months ago, and it’s been giving me an issue for 

the past four months! This is the fifth time I’m calling you people! 

CSR: _______________________________________________________________? 

Customer: Why? 

CSR: _______________________________________________________________. 

Customer: Ok, fine! 
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CSR: ________________________________________________________________ 

Customer: So, will you be replacing my laptop with a new one, for free? 

CSR: ________________________________________________________________ 

____________________________________________________________________. 

Customer: Oh, absolutely! That will be great! Thank you so much! 

CSR: ________________________________________________________________ 

EXERCISE 2: Present Perfect Tense 

Choose the correct option: 

1. I am afraid we can’t do that. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

2. I had bought it eight months before. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

3. We have to follow our company’s policy. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

4. I have brought the bill with me. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

5. We had replaced your mobile phone’s battery. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

6. We have fixed your laptop’s stereo. 

(a) Present Perfect Tense (b) Past Perfect Tense(c) Neither 

7. The warranty period has got over. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

8. I had already complained before. 

(a) Present Perfect Tense (b) Past Perfect Tense (c) Neither 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Read this: 

Present Perfect Tense 

1. I have had enough of those chocolate cakes. 

2. She has marked the chapter. 

3. You have done nothing to make her happy. 
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Past Perfect Tense 

1. I had had enough of those chocolate cakes. 

2. She had marked the chapter. 

3. You had done nothing to make her happy. 

•Instruction: Fill in the blanks with the correct present and past perfect forms 

of the verbs in brackets. 

1. One of the most difficult customers I_____________ (face) is Mrs. Anju 

Mukherjee. 

2. Neither I nor Tara were able to handle this lady’s complaints about the 

mobile phone she ______________ (buy) last week. 

3. Naresh ________________ (check) her mobile phone and found out the 

problem. 

4. His friendly nature, along with his sound technical knowledge, 

______________ (prove) proved useful in handling this difficult customer. 

5. The problem that none of us were able to solve for so long, _____________ 

(solve) in only a few minutes by him! 

6. I _______________ (come) across many difficult customers in my life, but 

none has been as bad as Mr. Gupta. 

7. He _____________ (order) for a toaster, and after I ____________ (make) 

the bill, he called and cancelled it. 

8. I had to politely remind him, as I ____________ (remind) him twice before, 

that he could not cancel his order after the bill was made. 
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The purpose of this session is to evaluate your knowledge and understanding of 

Sessions 11, 12 and 13. 

Methodology: The review evaluations will be Question ‘n’ Answer and Role 

play based. Answers will be assessed on Content, Context, Grammar, Sentence 

structure and Vocabulary based on the sessions that were imparted. 

Process: There will be one review evaluation for each session: 

• Verification of information. 

• Directing a customer. 

• Handling an angrycustomer. 

ASSESSMENT 

Review of Session 11:Verification of Information 

Question: 

1) Answer the question in the “Questions” sectionas completely as 

possible, in your own words. 

1. How much information can be verified, and with the help of what? 

2. What is the process of verifying information that most companies 

follow? 

3. How would a company know if the information provided by the 

customer is incorrect? 

4. Why is the verification process that companies follow important? 

Role Play: 

2) Complete the Verification Process. After completing the dialogues, you 

need to present the conversation before the class. 

Role-Play - 1:Verification Process -1: 

Customer service representative: Sure, I can help you with sourcing your order 

number; however, before we continue __________________ 

____________________. Is that _____________? 

Customer: Yes. 

Customer service representative: May _________________________________? 

Customer: Sure, that would be Karan Thakur. 
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Customer service representative: May I please 

_______________________________and your __________________________? 

Customer: Sure. My _____________________ is 012 – 45678910, and my 

__________________ is 98456 78910. 

Customer service representative:Thank you.Would you please tell me if a 

__________________ number was provided to you when you bought the product? 

Customer: Yes, I was given a _____________________. 

Customer service representative: Thank you. May I please have the date you 

placed the order, along with your product’s model/serial number? 

Customer: The date is the 17th of June. The Desktop’s model number is DTP3456 

Customer service representative: Thank you. Just to confirm I have the right details, 

I see that __________________in our files is Karan.Thankur@email.com, is that 

correct? 

Customer: Yes, that’s right. 

Customer service representative:Thank you ___________________________. I 

can now assist you with your issue. 

Sentences: 

3) Rearrange the words in the sentencesbelowto make meaningful sentences. 

a) the I day. laptop to every work carry 

b) Gadgetronics. another customer Notebook The from bought 

c) software all work. wish do was there our that I computer could 

d) name delivering has of address and When the be customer the a 

verified. package, and to 

e) customers their organizations always Big to keep try happy. 

f) most The love science. that computer I subject is 

g) PC a from new store. I website Tablet a bought 

h) sold bought his and a Macintosh new laptop. on Armaan the APPLE 

internet, brand old computer 

i) everyday have important part Computers of life. an become 

j) industry. lots Today, the there joining of our youngsters IT 

*********************************************************************** 

Review of Session 12:Directing a Customer 

Role Play: 
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1) Rearrange the given phrases, and fill in the blanks in order to complete the 

dialogues and form a coherent conversation between a customer service 

representative and a customer. 

1: “Direct the Customer” 

a. Once the folder is open, right-click on a blank space inside the folder and, 

once again, you will see the drop-down menu appear. 

b. Please make sure the files you want copied, is closed. 

c. Please select "Copy" from the menu that appears. 

d. Now, please select the option "Paste." 

e. The file is copied to the folder. Depending on the size of the file, this may 

happen immediately or take some time. 

f. Next, please right-click on the file that you want to copy. 

g. Now, please double-click on the folder to which you want to paste the file. 

h. You will see a drop-down menu. 

i. To close the file, please click the red "X" in the top-right corner of the 

window. 

Customer service representative: ____________________________________. 

Customer: I’m sorry, but you’ll have to tell me how. 

Customer service representative:_____________________________________. 

Customer: Oh, ok. Done! What next? 

Customer service representative:_____________________________________. 

Customer: Ok. 

Customer service representative: You will see a drop-down menu. 

Customer: Yes, I do. 

Customer service representative:_____________________________________. 

Customer: Uhm… Okay, selected. 

Customer service representative:____________________________________. 

Customer: Ok, double clicked. 

Customer service representative: ____________________________________ 

__________________________________________________________________. 

Customer: I have and I do. What do I select now? 

Customer service representative: ____________________________________ 
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_________________________________________________________________ 

_________________________________________________________________ 

____________________________________________________________________ 

_________________________________________________________________ 

____________________________________________________________________ 

_________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

__________________________________________________________________. 

Customer: Okay, Done. 

Customer service representative:____________________________________ 

__________________________________________________________________. 

Customer: Yes, it has. Thank you so much! 

2: “Direct the Customer Again!” 

a) Now, please choose one of the options that appear in the menu. You can 

either select switch off the computer entirely, or you can choose to log off. 

b) You should be able to see the “Shut-Down” / “Log Off” button in the Start 

Menu. Please confirm once you do. 

c) Please click on the "Start" button at the bottom right corner of the taskbar. 

d) A drop-down menu should appear next to the “Shut-Down” / “Log Off” 

button. 

e) Thank you. Please click on the “Shut-Down” / “Log Off” button. 

Sentences: 

Customer service representative: ____________________________________ 

Customer: Okay. 

Customer service representative: ___________________________________ 

Customer: Yes, I do. 

Customer service representative: ___________________________________ 

Customer: Okay, I have. 

Customer service representative: ___________________________________ 

_________________________________________________________________. 

Customer: Yes, it has. 

Customer service representative: ___________________________________ 

_________________________________________________________________. 

Customer: Okay, done. Thank you. 
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Sentences: 

2) Fill in the blanks with appropriate modals, to complete a conversation 

between the customer sales representative and acustomer . 

Customer service representative: Hello ma’am! How ________ (may / 

will) I help you? 

Customer: Well, I wanted to buy a Desktop for my daughter. ________ 

(Should / Could) you direct me to the computers’ section? 

Customer service representative: Sure, ma’am! Please follow me. Its 

right here…Are you interested in any particular brand? 

Customer: I’m not sure! ________ (Would / Can) you help me find a 

good brand for her? She is just 10 years old. 

Customer service representative: In that case, you ________ (should / 

will) take a look at our range of kids’ computers by Gadgetronicshere 

they are. They’ve been made especially for children below 13. You 

________ (must / can) choose from a variety of models and colors 

here…How about this one in pink and white here? 

Customer: Well, I was thinking of something in blue, that’s her favorite 

color. 

Customer service representative: Good choice. Blue is very popular 

these days. They are on that shelf near the counter. 

Customer: Well, this is exactly what I was looking for. 

Customer service representative: While you’re looking at those, 

________ (will/may) I show you some of these educational software 

that are specially recommended for school going children… they are 

subject guides that will help your daughter do her homework, as well 

as, guide her when she studies for her exams. You _____________ 

(will / must) buy one of these for her. 

Customer: Excellent! 

Customer service representative: _____________ (Should / Would) 

you like me to gift wrap the computer Ma’am? 

Customer: Yes, please. 

Customer Service representative: Is there anything else I 

_____________ (will / can) help you with, Ma’am? 

Customer: No, thanks! You have been a great help! 
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*********************************************************************** 

Review of Session 13:Handling an Angry Customer 

Questions: 

1) Answer the question in the “Questions” section as completely as 

possible, in your own words. 

a. When facing an issue with a dis-satisfied customer, what must a 

company do to ensure customer satisfaction? 

b. What must a company do if it is responsible for an issue? 

c. What must a company do, if it is not responsible for the issue? 

d. What must customer service representatives do when faced with 

customers who are customers are concerned, upset or irritated? 

e. What do customer service representatives use to help them deal 

with angry customers? 

f. What are the 9 steps that a good customer service representative 

uses to effectively handle an angry customer? 

Role Play 

2) Fill in the blanks with the options given given, so as to complete the 

conversation between a customer service representative, and an angry 

customer. 

a) Thank you, Ma’am. We really appreciate you bringing the issue to our 

notice. It was a pleasure serving you. 

b) I am so sorry for your inconvenience, Ma’am. May I please have a 

moment to check your records? 

c) Thank you for your patience, Ma’am. 

d) I understand you’d like your laptop replaced, would that be correct? 

e) I really wish I could Ma’am; however, company policy wouldn’t allow me 

to do that. What I can do, however, is replace your laptop’s music 

system with a brand new one! Would that be okay with you? 

f) How can I help you, Ma’am? 

g) As I understand, the music system installed in your laptop is not 

functioning properly. Am I correct? 

h) So I can better serve you, and get started on solving the issue, 

i) Could you please tell me what is the issue you’re facing Ma’am? 

j) Ma’am, please let me assure you that I am here to assist you in finding a 

solution to the issue you’re facing right away. Will that be okay with 

you? 

k) Thank you Ma’am. Would you please tell me when you bought the 

laptop? 
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Customer service representative: ____________________________________? 

___________________________________________________________________. 

Customer: I want a replacement for this laptop, and I want it now! 

Customer service representative: _________________________________ 

__________________________________________________________________? 

Customer: Yes. 

Customer service representative: _________________________________ 

__________________________________________________________________? 

Customer: The stereo is not working! 

Customer service representative: ____________________________________ 

_____________? ____________________________________________________. 

Customer: Yes! 

Customer service representative: _________________________________ 

__________________________________________________________________? 

Customer: Yes, I guess so. 

Customer service representative: _________________________________ 

__________________________________________________________________? 

Customer: I bought it eight months ago, and it’s been giving me an issue for 

the past four months! This is the fifth time I’m calling you people! 

Customer service representative: _________________________________ 

__________________________________________________________________? 

Customer: Why? 

Customer service representative: _________________________________ 

__________________________________________________________________. 

Customer: Ok, fine! 

Customer service representative: _________________________________ 

__________________________________________________________________. 

Customer: So, will you be replacing my laptop with a new one, for free? 

Customer service representative: _________________________________ 

__________________________________________________________________. 

Customer: Oh, absolutely! That will be great! Thank you so much! 

Customer service representative: _________________________________ 

__________________________________________________________________. 

Sentences: 

3) Fill in the blanks with the correct Present and Past Perfect forms of the 

verbs in brackets. 

a) One of the most difficult customers I_____________ (face) is Mr. 

Anand Singh. 

b) Neither Tara nor I were able to handle this lady’s complaints about 

the Smartphone she ______________ (buy) last week. 

c) I had to politely remind him, as I ____________ (remind) him twice 

before, that he could not cancel his order after the bill was made. 
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d) Mira ________________ (update) her computer. 

e) His friendly nature, along with his sound technical knowledge, 

______________ (prove) proved useful in handling this difficult 

customer. 

f) The problem that none of us were able to solve for so long, 

_____________ (solve) in only a few minutes by him! 

g) Gurmeet _______________ (handle) many difficult customers in his 

career as a customer sales representative. 

h) He _____________ (order) for a laptop, but later he ____________ 

(change) his mind, and ordered a desktop. 

*********************************************************************** 
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SESSION 14: HANDLING CUSTOMER QUERIES 

 

 

     

   

              

            

        

       

          

         

     

        

              

 

             

               

  

            

            

             

           

    

      

           

          

    

          

          

          

           

         

              

       

         

      

         

          

  

           

          

           

             

RELEVANT KNOWLEDGE 

If you work as a customer service or sales representative, you will have to 

answer a lot of queries, i.e. questions, asked by their customers. 

Some common statements you would use frequently are:. 

1. “How can I help you, Ma’am/Sir?” 

2. “Is there anything else I can help you with?” 

3. “Of course, I can help you with that.” 

4. “It’s my pleasure, Ma’am/Sir.” 

5. “It was a pleasure serving you Ma’am/Sir.” 

6. “I’m glad I could help. Is there anything else you’d like to know 

Ma’am/Sir?” 

When a customer service or sales representative is approached or called by a 

customer, he or she should greet the customer with a polite “How can I help 

you, Ma’am/Sir? 

The customer service or sales representative may also ask the customer if 

he/she can be of further assistance. When the customer service or sales 

representative is thanked by the customer, he/she should say either “It was a 

pleasure serving you Ma’am/Sir.” Or “It’s my pleasure, Ma’am/Sir” instead of 

“You are welcome, Ma’am/Sir.” 

Some important things to remember are: 

• Listen actively. Accurately listening to customers is as important as 

talking to them. Efficient listening is focussing on everything the 

customer has to say. 

• Paraphrase.To ensure that you're capturing the right information, a 

customer sales representative must repeat in their own words i.e. 

paraphrase what they’ve heard. This shows customers that you are 

paying attention to them and their needs. This also aassures the 

customers that the customer sales representative is attempting to 

process and understand what is being asked or said; it helps to avoid any 

communication errors. Customer sales representatives need to 

paraphrase customer queries, as well as, any other important 

information that the customers may provide. 

• Provide practical details. Customer sales representative should provide 

customers with information that helps them understand the products and 

services satisfactorily. 

• Smile. Customers can hear the smile in the customer sales 

representative’s voice when they answer the phone. No matter what 

type of day the customer sales representative may be experiencing, all 

of that is not important when they're assisting a customer. It is important 
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___________________________________________________________________ 

___________________________________________________________________ 

___________________________________________________________________ 

___________________________________________________________________ 

___________________________________________________________________ 

___________________________________________________________________ 

___________________________________________________________________ 

to provide customers the most pleasant, memorable experience possible 

when they call. 

EXERCISE 1: Handling Customer Queries 

Rearrange the jumbled words in order to complete the conversation between 

Sales Rep and Customer. The jumbled words have been italicized. 

Sales Rep: Yes, Ma’am/Sir. How can I help you? 

Customer: I just wanted to ask you if this I exchange cell could phone. 

Sales Rep: Could me tell it wrong what’s you with? 

Customer: The phone keeps switching off by itself although I keep the battery 

well charged. 

Sales Rep: I see. When it buy you did? 

Customer: I bought it two months ago. 

Sales Rep: Okay, Ma’am. Since not is over warranty the yet period, we will 

replace the item. 

Customer: Thank you. 

Sales Rep: It’s my pleasure, Ma’am/Sir. 

Sales Rep: How can I help you, Sir/Ma’am? 

Customer: I to discount about inquire wanted scheme your. 

Sales Rep: We have different schemes for different products. Which you know 

like would to about product? 

Customer: Adidas. 

Sales Rep: For Adidas, you will get a 15% discount for a purchase of 2000 

Rupees, 25% discount for a purchase of 4000 Rupees and 50% discount for a 

purchase of 7000 Rupees. 

Customer: Great! Thanks. 

Sales Rep: Is there anything else I can help you with? 

Customer: No, be that all will. Thanks again. 

Sales Rep: No problem, Ma’am/Sir. 

EXERCISE 2: Reported Speech 

Choose the option that is in the corresponding direct speech. 

1. The customer asked the salesperson if that TV was on sale. 

(a) “Is this TV on sale?” 
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(b) “Is that TV on sale? 

(c) “Was that TV on sale?” 

2. The salesperson told that customer that the TV was not on sale. 

(a) “The TV is not on sale.” 

(b) “Is the TV not on sale?” 

(c) “The TV was not on sale.” 

3. The customer asked the salesperson how much the TV cost. 

(a) “How much the TV cost?” 

(b) “How much does the TV cost?” 

(c) “How much does the TV costs?” 

4. The salesperson told the customer that the TV cost 7500 Rupees. 

(a) “The TV cost 7500 Rupees.” 

(b) “The TV costs 7500 Rupees.” 

(c) “Does the TV cost 7500 Rupees?” 

5. The salesperson told the customer that the price was fixed. 

(a) “The price was fixed.” 

(b) “That the price is fixed.” 

(c) “The price is fixed. 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Read this: 

Direct speech: Anuskha: “Shall I give the presentation?” 

Reported speech: Anushka asked if she should give the presentation. 

Direct speech: Manager: “Yes, Anuskha. You should give the 

presentation.” 

Reported speech: The manager told Anushka that she should give the 

presentation. 

•Instruction: Change the following sentences into reported speech. 

1. Customer: “I got this gift coupon yesterday. Can I redeem it here?” 

_________________________________________________________________. 

Salesperson: “Yes Sir, you can.” 

_________________________________________________________________. 

2. Customer: “Do you follow an exchange and refund policy?” 

_________________________________________________________________. 

3. Salesperson: “We have a strict “no refund” policy.” 

_________________________________________________________________. 
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_________________________________________________________________ 

Salesperson: “You can exchange the item within a week of purchase, but 

only if the price tag is still in place.” 

_________________________________________________________________. 

4. Customer: “Excuse me, could you tell me how much VAT you charge?” 

_________________________________________________________________. 

Salesman: “We charge only 12% VAT, Sir.” 

_________________________________________________________________. 

5. Salesman: “Can I help you, Ma’am?” 

_________________________________________________________________. 

Customer: “Yes, I lost the invoice. Could you make me another one?” 

_________________________________________________________________. 

Salesman: “Sure, Ma’am. Just give me a minute.” 

_________________________________________________________________. 
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SESSION 15: CLARIFYING 

RELEVANT KNOWLEDGE 

 

 

   

   

          

                

              

    

      

          

         

         

          

              

         

               

         

              

    

               

  

   

           

         

    

         

      

    

            

     

             

          

           

 

             

 

   

   

              

  

     

Whencustomers call, the customer service representative needs to ask the 

customers a few questions to clarify what it is they want or what the issue is. 

The following are some of the common phrases which are often used by call 

center customer service representatives: 

1. Which _______ would you like? 

2. What kind of a ____________ are you interested in? 

3. Do you have any __________ ______ in mind? 

4. Would you like it in any particular _______? 

5. Would you like to subscribe to our _________? 

6. Could you be a little more __________ about when you first noticed the 

issue? Was a week back or a little longer? 

7. So what you’re saying is that the mobile ___________ to you, is not the 

same one you had ________, would that be correct? 

8. Am I correct in understanding that you would like to ____________ in the 

next survey we conduct? 

Think and fill in the blanks with the correct answers and write the sentences in 

your notebook. 

EXERCISE 1: Clarifying 

Rearrange the following sets of sentences in order to form conversations 

between a Customer Service Representative (CSR) and a Customer. 

Scenario – I 

a) CSR: For which standard are you interested in? 

b) Customer: 250 to 500 Rupees. 

c) Customer: Sure. 

d) CSR: Very good. What the price range you are looking at? 

e) Customer: Standard XI (eleven). 

f) CSR: Thank you. Could you please provide me with your postal address, 

in order for us to mail you the DVD? 

g) Customer: Hi! Does your company sell any “School Self-Help Guide” 

DVDs? 

h) CSR: Yes, we do. Which subject would you like; Science, English or 

Computers? 

i) Customer: Computers. 

Scenario – II 

a) CSR: Now, could you please open a new word document, and type your 

name? 

b) Customer: Okay, done. 
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c) CSR: Could you please check and let me know if the cable that runs from 

the keyboard to the central processing unit (CPU) tower, is fit in the 

socket properly? 

d) Customer: Yes, exactly! 

e) CSR: Can you tell me what the issue you’re facing is? 

f) Customer: Great! I can see my name. Thank you! 

g) CSR: As I understand, whenever you type on the keyboard, the action 

does not translate itself on to the document, thus leaving the open page 

blank. Would that be correct? 

h) Customer: Four days ago. 

i) CSR: So your keyboard is not functioning properly. Am I correct? 

j) Customer: It’s a little loose. 

k) CSR: Could you push it in the socket firmly? 

l) Customer: When I type anything no words appear on the document. It 

remains empty. 

m) CSR: Thank you. Could you tell me when did you first notice the issue? 

n) Customer: Okay. 

o) CSR: Could you please let me know what happens? 

p) Customer: My keyboard is not working. I need one of your computer 

technicians to come and repair it? 

q) CSR: Thank you. 

r) Customer: Yes. 

EXERCISE 2: Framing Questions 

Choose the options which could be the appropriate question for the given 

statements. 

1. The train to Mumbai leaves at 5:45 p.m. 

(a) When does the train to Mumbai leave? 

(b) Which train leaves at 5: 45 p.m.? 

(c) Where does the train leave? 

2. Tara is going to the mall with Smita. 

(a) Who is going to the mall with Smita? 

(b) Who is Tara going to the mall with? 

(c) Where do Tara and Smita want to go? 

3. He wants to buy a book. 

(a) What does he want to buy? 

(b) Which book does he want to buy? 

(c) What does he want to do? 

4. She should meet him at school. 

(a) Where should she meet him? 

(b) Why should she meet him? 

(c) Who should meet her? 
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5. The lunch will arrive at 12:30 sharp. 

(a) When will the lunch arrive? 

(b) Who sends the lunch? 

(c) Where is the lunch? 

6. It is Tina’s birthday tomorrow. 

(a) Whose birthday is it tomorrow? 

(b) Who is Tina? 

(c) What day is tomorrow? 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Instruction: Choose the question that should follow what the customer says. 

For Example: Customer: I would like a cold drink, please. 

Your question: 

a. When cold drink would you like, ma’am? 

b. Which cold drink would you like, ma’am? 

1. Customer: I’m looking for formal shirts. 

Your question: 

i. Do you have any particular brand in mind? 

ii. Are you looking for a shirt, ma’am? 

2. Customer: I would like an ice-cream. 

Your question: 

i. When flavor would you like? 

ii. Which flavor would you like? 

3. Customer: Could you show me a pair of jeans please? 

Your question: 

i. Sure ma’am! Are you looking for a particular color or brand? 

ii. Sure ma’am! Can you look for a particular color or brand? 

4. Customer: I need five packets of Ching’s Secret noodles. 

Your question: 

i. Shall you want egg noodles or vegetarian noodles? 

ii. Do you want egg noodles or vegetarian noodles? 

5. Customer: I need to exchange this sweater. This is too small for me. 

Your question: 

i. You can try out the medium size? 

ii. Would you like to try out the medium size? 
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6. Customer: I like the phone but I don’t like the color. 

Your question: 

i. This phone comes in five different colors, Sir. Would you 

like to take a look at them? 

ii. This phone comes in five different colors, Sir. What you 

would like to take a look at? 

7. Customer: I am looking for ChetanBhagat’s books. 

Your question: 

i. We have all of them, ma’am. What one do you want? 

ii. We have all of them ma’am. Which one do you want? 

8. Customer: I saw a beautiful vase here last week – can you please find that 

for me? 

Your question: 

i. Where was the color of the vase? 

ii. What was the color of the vase? 

9. Customer: Can you show us a cot? 

Your question: 

i. Should I show you a double bed or a single bed, Sir? 

ii. How I show you a double bed or a single bed, Sir? 

10.Customer: I need to buy a gift for my niece. Could you help me out? 

Your question: 

i. Why are you looking for something in particular? 

ii. Are you looking for something in particular? 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

What do you think is the meaning of the term “call flow”? Write your answer 

here. 

Do you know- The telephone is one of the best brand-building devices. Over the 

telephone agents get 5-to-30 minutes of a customer’s full attention; depending 

on the issue. If the agent gets the interaction right, he/she can create a 

memorable experience for the customer, generate positive word-of-mouth 

advertising, and build customer loyalty.This leads to a better brand image and 

increased profits. Getting the interaction “right” usually requires a call flow of 

some kind. 

The following 11-point call plan (See “Call-Flow Chart”) focuses on creating a 

warm customer-focused experience and building a better brand image. 

1. Standard opening (Smile. State own name and Company’s name, and ask for 

Issue) 

• “Good morning” or “Good afternoon. Customer Care. This is Preetha.” 

• “Thank you for calling Customer Care. This is Preetha. How may I help 

you?” 

2. Paraphrase issue and check for confirmation (Paraphrase: to retell 

something in your own words) 

• “So, what you’re saying is you want to / you have a ....... would that be 

correct?” 

• “From what I understand, you would like to / your ………. would that be 

correct?” 

3. Ask for verification of details 

• “May I please have your first name and last name? 

May I have your phone number, postal address and email-id please? 

May I please have the account / bill / model number of the product? (If 

applicable)” 

(The call will only proceed if the customer has verified / confirmed all his 

details.) 
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4. Bridge to questioning 

• “In order to find out what happened, I will need to ask you some 

questions.” 

• “Do you mind if I ask you some questions so we can find out what has 

happened?” 

• “For me to assist you better, may I ask you a few questions?” 

5. Question customer about details of the issue (Use please and thank you) 

• “Can you tell me when you first noticed the problem with …………?” 

• “For how long has it been …….?” 

• “When did you buy the product…?” 

• “Have you checked the…..?” 

• “Thanks. I have one final question.” 

6. Assure customer 

• “This is just a small issue. Please be sure I will find a solution.” 

• “There’s nothing to worry. I will guide you through the instructions.” 

• “I will get that information for you.” 

7. Seek customer’s agreement for following troubleshooting steps 

(troubleshooting steps: a set of instructions). 

• “We’ll have to perform a few troubleshooting steps / instructions. Is it 

okay with you?” 

8. Direct customer 

• “Please place the ……………………over the ………… and click on ……………..on 

the mouse and then click on……………………...” 

• “Please click on the …………..at the bottom ……………..of your 

…………………… you will see a ………………………… on the ………………..of 

the……………..” 

9. Inform customer of solution, and ask customer for permission to document 

result. 

• “I would like to inform you that the issue you called us 

for………………………… has been solved. I’d like your permission to record 

this interaction as resolved.” 

10.Clarify “Is there anything else?” 

• “May I help you with anything else?” 

• “Do you have any additional questions, Sir/Ma’am?” 

• “Is there anything else I can help you with today, Sir/Ma’am?” 

11.Standard closing (Include thanks, own name and company name) 

• “Thank you for calling…………………... This was ………………Good-bye.” 
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• “Thank you for calling……………………… You were speaking 

to/with……………… Goodbye.” 

 

The Call Flow Chart 

Read the details of a role-play given below and make a note of the important 

points in your notebook.   

 

Mock-Role-Play: 

 

Situation: A customer is calling for assistance because he is unable to open the 

internet on his computer at home. 

Solution: Helps customer to successfully move a file from his desktop to the 

documents folder. 

Agent: Thank you for calling “Customer-Tech-Support”. This is Jasmeet. How 

may I assist you? 

Customer: Hi this is Sahil. I am one of C-T-S customers, and I’d like some help 

with this issue I am having. I have a file on the Desktop on my PC that I want to 

transfer it to the “documents” folder. 

Agent:You want to move a file from your desktop to your documents folder? 

Sure, I can assist you with that. However, I will need to verify your account 
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information before we continue. May I have your first name and last name 

please? 

Customer: Sure, it isSahil Shah. 

Agent: Thank you. May I have your C-T-S account number please? 

Customer: That is XYZ1234. 

Agent: Thank you. Just to confirm that I have the right account, I see that the 

e-mail address on the account is Sahil.Shah@email.com, is that correct? 

Customer: Yes, that’s right. 

Agent: Thank you for verifying your account Sir. I can now assist you with 

transferring your file to the “documents” folder on your PC. Are you in front of 

your PC now? 

Customer: Yes I am. 

Agent: Which operating system are you running on your PC, sir? 

Customer: It is windows 7. 

Agent: Alright, do you see the file on your desktop sir? 

Customer: Yes, I do. 

Agent: Please place the mouse cursor / pointer over the icon and click on the 

right button of the mouse. Do you see a menu poping up? 

Customer: Yes. 

Agent: Now click on the option Cut with the left mouse button. 

Customer: Okay, I have done that. 

Agent: Now click on the Start button, at the bottom right corner of your 

Desktop screen, and once the start menu opens, you will see a menu option 

“Documents” on the right side of the menu. 

Customer: Yes, do I click on it? 

Agent: Yes, Please. That should bring up the window for the documents folder. 

Customer: Yes it did. 

Agent: Position the cursor / pointer on the empty part of the window and click 

on the right button on the mouse and click on the option Paste. 

Customer: Okay…yes. I see the file in this folder now. Thank you! 

Agent: You are welcome sir. Before we end this call, I’d like to confirm that 

the issue you called us for, moving a file from the desktop to the documents 

folder is resolved. 

Customer: Yes, that’s right. 

Agent: Thank you. I’d like your permission to record this interaction as 

resolved. 

Customer: Sure, please go ahead. 

Agent: Thank for choosing “Customer-Tech-Support”, sir. Have a nice day. 

Customer: Thank you. You have a nice day as well. 
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EXERCISE 1: Following a Call Flow 

In your own words, fill in the responses for the agent in the role-plays below. 

You may take inputs from the previous section and the above given call flow 

chart but use your own language – DO NOT COPY / PASTE!! 

Role-Play -1 

Situation: A customer is calling to find out his bank account balance. 

Agent Name: Tanish. 

Company Name: Bank of Wealth 

Solution: Agent informs customer how much money there is in the account 

Agent: 

Customer: I would like to know how much money I have in my account. 

Agent: 

Customer: Sure, it's HarshaRandwa. My account number is 012-345-9876-543 

Agent: 

Customer: The last three numbers of my password is ***. 

Agent: 

Customer: Oh, I thought I had one lakh, but fifteen thousand less is not bad 

either. 

Agent: 

Customer: That will be all. Thank you. 

Agent: 

Customer: Yes, that’s right. 

Agent: 

Customer: Sure, please go ahead. 

Agent: 

Role-Play -2 

Situation: A customer is calling in to order a Pizza. 

Agent Name: Kushi. 

Company Name: Tasty Kebabs 

Solution: Place the order and offer the customer to upgrade their orders. 

Agent: 

Customer: I want to order kebabs for dinner, for the entire family. We are 12 

of us, and we’re all non-vegetarians. So, what would you suggest? 

Agent: 

Customer: Great! That sounds perfect. I’d like to order 4 sheekh kebabs, 4 

murghhariyali kebabs, and 4 tandoori chicken kebabs! 

Agent: 

Customer: Yes. Please have it delivered to H – 1/23, Sector – 456, Faridabad 

(Haryana). 

100 



 

 

  

              

          

  

     

 

        

  

 

     

              

  

             

   

               

 

         

          

             

             

  

               

     

 

             

              

      

   

  

        

          

        

 

             

  

              

         

           

    

             

     

Agent: 

Customer: Sure! 5 rupees per roti is very reasonable. Send 2 rotis per person. 

I'll just pay the bill in cash once it's delivered. 

Agent: 

Customer: 30 minutes? Very good! 

Agent: 

Customer: No. No. That’s all! Thank you. 

Agent: 

EXERCISE 2: Present Continuous Tense 

Read aloud the following and pick out the sentences which are in the Present 

Continuous Tense. 

1. Nokia is a very large company that specializes in the production of 

mobile devices. 

2. You are looking at a new model by Sony which has an external memory 

slot. 

3. This phone is becoming popular day by day. 

4. The iPhone is also great for using the internet. 

5. APPLE is offering a 10% discount on all their products this Christmas. 

6. Buying this product will also make you a member of our Premium 

Customer Group. 

7. By becoming a member of this group, you are securing for yourself a 15% 

discount on all further purchases. 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Read this: 

1. Meetika and I are solving the riddles. 

2. One of my colleagues is coming to dinner tonight. 

3. Is anyone coming to the dance show? 

•Instruction: Fill in the blanks with the present continuous form of the words 

in brackets. 

1. Keeping in mind the special brand name and image of our company, I 

____________ (prepare) a new advertisement for our products. 

2. Ma’am, we _______________ (launch) a new mobile phone, which will 

make dialing calls easier. 

3. Sir, I ______________ (offer) you the best price for this product because 

you are a valued customer. 
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4. This computer has a nice design; it ___________ (go) to look great in 

your study-room. 

5. If you ____________ (look) for a computer that most artists use, then 

this is the one. 

6. I have sold at least 50 such phones since morning. We_________ (run) 

out of stock now. These are the last three we have. So, if you like the 

design, you should buy one now. 

7. A lot of stores charge far more money than we have offered. But we 

___________ (charge) less because you are a regular customer. 

8. If you ___________ (will) to buy them now, then we can offer you a 25% 

discount. 

9. We ______________ (search) for a new place to shift the office. 

10.This is such a fantastic computer! You ___________ (do) the right thing 

by buying it. 
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________________________________________________________ 

The review evaluations will be Question and Answer and Role-Play based. 

Answers will be assessed on content, context, grammar, sentence structure and 

vocabulary based on the sessions 14, 15 and 16. 

The review evaluation is divided into three parts. One for each session: 

• Handling Customer Queries . 

• Clarifying . 

• The Call Flow. 

ASSESSMENT 

Review of Session-14: Handling Customer Queries 

Questions: 

1) Answer the question in the “Questions” section as completely as 

possible, in your own words. 

a. What should a customer service/sales representative (CSR) do 

when he/she is approached or called by a customer? 

b. What are the different ways a customer service/sales 

representative (CSR) may ask the customer if he/she can be of 

further assistance? 

c. What must a customer service/sales representative (CSR) do when 

a customer thanks them? 

d. What are the four important skills ‘customer service/sales 

representatives’ use when handling customers’ queries? Explain in 

detail. 

e. Complete the dialogues in Role-Play (by filling in the blanks) to 

form a conversation between a Customer (A) and a Customer 

Sales/Service Representative (B). 

Sentences: 

1. Customer: “I bought a computer yesterday. Can I exchange it?” 

_________________________________________________________________. 

CSR: “Yes Sir, you can, as it’s only one day since you bought it.” 

________________________________________________________________. 

2. Customer: “Do you follow an exchange and refund 

policy?”_________________________________________________________. 

CSR: “We have a strict “no refund” policy.” 

CSR: “You can exchange the item within a week of purchase, but only if the 

price tag is still in place 
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_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

_______________________________________________________________ 

3. Customer: “Excuse me, could you tell me how long will you take to deliver 

my computer set to my house?” 

CSR: “We will deliver it within two days, Sir.” 

4. CSR: “Can I help you, Ma’am?” 

Customer: “Yes, I lost my service-delivery number. Could you please give 

me the number again?” 

CSR: “Sure, Ma’am. Just give me a minute.” 

*********************************************************************** 

Review of Session-15: Clarifying 

Questions: 

1) Answer the question in the “Questions” section as completely as 

possible, in your own words. 

a) What are some of the common questions customer service 

representatives ask customers, to clarify what the customer 

wants or what the issue is? 

Role Play 

2) Rearrange the sentences to form a conversation between a customer 

service representative and a customer. 

Role-Play 1: 

CSR: Excellent choice, Ma’am/Sir! Could you please provide me with your 

phone number and postal address, in order for us to make a note of your 

details in our customer database? 

Customer: Hi! Does your company sell Smartphones? 

CSR: Very good. What is the price range you are looking at? 

Customer: What’s the difference between the Apple and Samsung? 

CSR: Yes, we do. Which brand would you like to see? 
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Customer: Sure. 

Customer: I think the best benefit of the Samsung Smartphone is that it fits 

right into my budget! I’ve decided to buy the Samsung Smartphone. Could 

you please make my bill? 

CSR: Not much, except for the cost. The Smartphone by Samsung costs only 

Rs 27,000, whereas, the basic Apple Smartphone costs more than Rs 40,000! 

In fact, the Smartphone by Samsung has got as many features, advantages 

and benefits as the one by Apple. 

CSR: Thank you. May I suggest the Samsung Smartphone? 

Customer: In Apple, the 4-S and in Samsung, I’m not too sure. 

CSR: We have the complete range of Apple and Samsung products. Is there 

any particular model you’re interested in? 

Customer: Rs 20,000 to a maximum of Rs 35,000. Not more. 

Customer: Apple or Samsung. 

CSR: Thank you. 

Role-Play 2: 

CSR: Now, could you please open a new word document, and type your name? 

Customer: Okay, done. 

CSR: Could you please check and let me know if the cable that runs from the 

keyboard to the central processing unit (CPU) tower, is fit in the socket 

properly? 

Customer: Yes, exactly! 

CSR: Can you tell me what the issue you’re facing is? 

Customer: Great! I can see my name. Thank you! 

CSR: As I understand, whenever you type on the keyboard, the action does not 

translate itself on to the document, thus leaving the open page blank. Would 

that be correct? 

Customer: Four days ago. 

CSR: So your keyboard is not functioning properly. Am I correct? 

Customer: It’s a little loose. 
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CSR: Could you push it in the socket firmly? 

Customer: When I type anything no words appear on the document. It remains 

empty. 

CSR: Thank you. Could you tell me when did you first notice the issue? 

Customer: Okay. 

CSR: Could you please let me know what happens? 

Customer: My keyboard is not working. I need one of your computer 

technicians to come and repair it? 

CSR: Thank you. 

Customer: Yes. 

Sentences: 

3) Choose the correct question that should follow what the customer says. 

1. Customer: I would like a sell my laptop for 7,500 rupees. 

Your question: 

o When would you like to sell it? 

o How old is the laptop? 

2. Customer: I would like to buy a mobile phone. 

Your question: 

o What kind of phone would you like to buy? 

o Is there any particular brand of phone that you would like to see? 

3. Customer: Could you show me a pair of speakers please? 

Your question: 

o Sure! Are you looking for a specific brand or model? 

o Sure! Can you look for me any particular brand or model? 

4. Customer: I need some educational CDs on Science and Math. 

Your question: 

o Shall you want CDs for five sciences only? 

o Would you like one Cd for each subject? 

5. Customer: I need to exchange this phone. It hasn’t been working from 

the day I bought it! 

Your question: 
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o Oh, that’s too bad! Do you want to buy another phone in exchange? 

o I’m so sorry for the inconvenience caused. Could you please 

provide me with the Bill you had received when you had bought the 

phone? 

6. Customer: I like the phone but I don’t like the color. 

Your question: 

o This phone comes in five different colors. Would you like to take a 

look at them? 

o This phone comes in five different colors. What you would like to 

take a look at? 

7. Customer: I am looking for the Apple iPhone. 

Your question: 

o We have all of them. What one do you want? 

o We have all of Apples’ iPhones. Which one would you like to see? 

8. Customer: I saw a pair of speakers here last week – can you please 

find that for me? 

Your question: 

o Where was the brand or model of the speakers? 

o What was the brand or model of the speakers? 

9. Customer: Can you show us a computer? 

Your question: 

o Should I show you a desktop or a laptop? 

o How I show you a desktop or a laptop? 

10. Customer: I want to buy a computer for my niece. Could you help 

me out? 

Your question: 

o Why are you looking for something in particular? 

o Are you looking for a particular type of computer? 

*********************************************************************** 

Review of Session-16: The Call Flow 

Questions: 

1) Answer the question in the “Questions” section as completely as 

possible, in your own words. 

a. What does the 11-point Call Flow Plan Focus on? 

b. What are the 11 steps of the 11-point Call Flow Plan? 

c. Explain each step of the Call Flow Plan. Give an example for each 

step. 
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d. Which step decides whether the call will proceed or not? 

Sentences: 

2) Fill in the blanks with the Present Continuous form of the words in 

brackets. 

a. Keeping in mind the special brand name and image of our 

company, I ____________ (made) new user manuals for all our 

computers. 

b. This is such a fantastic computer! You ___________ (do) the right 

thing by buying it. 

c. We _______________ (launch) a new Smartphone, which will make 

storing data easier. 

d. A lot of companies ___________ (charge) far more money for a 

computer than we do. 

e. We ______________ (offer) a 40% discount for the newly launched 

Smartphone to our first 100 customers. 

f. This computer has a nice design; it ___________ (go) to sell like 

hot-cakes! 

g. If you ____________ (look) for a store that sells computers at the 

best prices, then you’ve come to the right place! 

h. We have sold at least 120 laptops today. We_________ (run) out 

of stock now. These are the last three we have. 

i. If you ___________ (will) to buy them now, then we can offer you 

a 30% discount. 

j. I ______________ (search) for the customer service report. 

*********************************************************************** 
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SESSION 17: GIVING AND RECEIVING FEEDBACK 

 

 

      

   

     

      

       

      

     

     

      

        

        

              

 

          

  

  

  

  

  

            

   

    

            

             

              

        

          

  

           

             

     

             

 

            

            

           

    

           

              

          

RELEVANT KNOWLEDGE 

Read aloud the following sentences: 

1. You did a good job! 

2. You need to improve your performance. 

3. You have improved a lot. 

4. You have done well. 

5. You should try harder. 

Such comments are issued when you: 

(a) Are happy with someone’s performance at work. 

(b) Feel that someone needs to work harder. 

Decide for each point, whether the feedback belongs to option (a) or to option 

(b). 

For each feedback, how would you respond? Write your answers. 

1. ___________________________________________________________. 

2. ___________________________________________________________. 

3. ___________________________________________________________. 

4. ___________________________________________________________. 

5. ___________________________________________________________. 

There are some basic guidelines that are followed while giving or receiving 

feedback. These are: 

Guidelines for giving feedback: 

• Express your feedback in positive terms. For example, 'It would have 

been helpful if you had emailed the location and starting time for the 

meeting to everybody” rather than “How do you expect us to meet if you 

don't tell us the time and location”. 

Being positive gives an opportunity for agreement, being negative is 

more confrontational. 

• Be descriptive rather than evaluative. For example, “You didn't bring 

the notes to the meeting, which you agreed you would” rather than “You 

are lazy and unreliable”. 

Describing what you see and hear reduces the need for others to react 

emotionally. 

• Reveal your own position or feelings. For example, “I felt unsettled 

when you argued your point” rather than “You were very rude”. 

Describing your reaction gives the person an opportunity to think and 

respond to the feedback. 

• Be specific rather than general. For example, “When you spent forty 

minutes trying to find my account details in your records, I lost some of 

my confidence” rather than “You and your company are disorganised”. 
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• Feedback is usually more effective when requested than when given 

voluntarily. 

• Generally, feedback is most useful at the earliest opportunity after 

the given behaviour. 

• Check that you have communicated your feedback clearly. Ask the 

person to rephrase your feedback to see if it corresponds closely to what 

you intended. 

Guidelines for receiving feedback: 

• Listen to the feedback. Try to understand the other person's perspective. 

• There is nothing called “negative” feedback. All feedback is always 

positive; only the attitude of the person can be negative. 

• Focus on “only” what you need to learn from the feedback. 

• Don’t reject feedback immediately. Give the feedback serious 

consideration and weigh up the consequences of changing or not 

changing. Don't reject it immediately. 

• Express your thoughts and feelings about the feedback and possible 

changes. 

• Tell the person whether you intend to try and change, and in what ways. 

• Tell the person what they could do to help you make changes. 

• Express appreciation for their concern and interest. 'Thank you for the 

feedback' or 'Thank you for the ideas'. 

EXERCISE 1: Giving and Receiving Feedback 

Fill in the blanks with appropriate feedback and responses: 

o I will work harder. 

o Thank you for the feedback, Sir/Ma’am. 

o You have to learn how to work in a team. 

1. A: I have reviewed your performance. 

B: How did I do, Sir/Ma’am? 

A: You do well alone but not when you are working in a team. 

__________________________________________________. 

B: Thank you for the feedback, Sir/Ma’am. I will work on it. 

2. A: How do you find work at our office? 

B: I like working here, Sir/Ma’am. 

A: I would like to give you a feedback. You have done very well till now. 

B: _______________________________. 

3. A: I would like to give you a feedback. 

B: Okay, Sir. 

A: As a sales representative, you need to be more attentive to the customers. 
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B: Thank you for the feedback, Sir/Ma’am._______________________________. 

EXERCISE 2: Reported Speech 

The following sentences are in the Direct Speech. Choose the option which is in 

the corresponding reported speech. 

1. The supervisor to Reena: “You are doing well.” 

(a) The supervisor told Reena she was doing well. 

(b) The supervisor told Reena you are doing well. 

(c) The supervisor told Reena she were doing well. 

2. Reena to the supervisor: “Thank you, Ma’am.” 

(a) Reena told the supervisor thank you. 

(b) Reena said thank you Ma’am. 

(c) Reena thanked the supervisor. 

3. The supervisor to Reena: “You need to improve.” 

(a) The supervisor told Reena she needs to improve. 

(b) The supervisor told Reena she needed to improve. 

(c) The supervisor told Reena you need to improve. 

4. Reena to the supervisor: “I will work harder.” 

(a) Reena told the supervisor she would work harder. 

(b) Reena told the supervisor she will work harder. 

(c) Reena told the supervisor I will work harder. 

5. The supervisor to Reena: “You will get a feedback.” 

(a) The supervisor told Reena you will get a feedback. 

(b) The supervisor told Reena she would get a feedback. 

(c) The supervisor told Reena she will get a feedback. 

Go through the assessment. If time permits, you can try to attempt the 

exercise in class. Otherwise, you can attempt it at home and bring to the 

class the next day for review. 

ASSESSMENT 

•Read this: 

Examples: 

Direct speech: Linda: “Ayesha, you are looking great.” 

Reported speech: Linda told Ayesha that she was looking great. 

Direct speech: Ayesha: “Thanks for the compliment, Linda.” 

Reported speech: Ayesha thanked Linda for the compliment. 

•Instruction:Change the parts in bold to reported speech. 

1. Manager: “Saroj, you have done well!” 

_________________________________________________________________. 

Saroj: “Thank you, Sir!” 
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_________________________________________________________________ 

2. Manager: “You need to be more attentive to your customers.” 

_________________________________________________________________. 

Saroj: “Yes, Sir. I will try harder.” 

_________________________________________________________________. 

3. Manager: “You have to learn how to work in a team.” 

_________________________________________________________________. 

Saroj: “Yes, Sir. Actually this is the first time I am working as a part of a 

team.” 

_________________________________________________________________. 

Saroj: “However, I will give it my level best.” 

_________________________________________________________________. 

4. Manager: “Saroj, I am happy to see that you are improving.” 

_________________________________________________________________. 

Saroj: “Thank you, Sir.” 

Manager: “How do you like working in this office?” 

_________________________________________________________________. 

Saroj: “Sir, I like the office very much as it provides opportunities for 

moving ahead.” 

_________________________________________________________________. 
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_______________________________________________________ 

The review evaluations will be Question and Answer and Role-Play based. 

Answers will be assessed on content, context, grammar, sentence structure and 

vocabulary based on the session 17. 

The review evaluation consists of one session: Giving & Receiving Feedback 

ASSESSMENT 

Review of Session-17: Giving and Receiving Feedback 

Questions: 

1) Answer the question in the “Questions” section as completely as 

possible, in your own words. 

a) What kind of feedback do you give when you are happy with 

someone’s performance at work? State examples. 

b) What kind of feedback do you give when you feel that someone needs 

to work harder? State examples. 

c) How should someone respond to following feedback? Fill in the blanks 

with the appropriate responses. 

o “You did a good job!”- _________________________. 

o “You need to improve your performance.” 

__________________. 

o “You have improved a lot.” 

_________________. 

o “You have done well.” 

______________________________________. 

o “You should try harder.” 

_______________________________________. 

d) What are the different guidelines for giving feedback? Give examples 

that describe each guideline. 

e) When is feedback more effective? 

f) When is feedback most useful? 

g) How will you know if your feedback has been understood clearly? 

h) What are the guidelines for receiving feedback? 

Role Play 

1) Fill in the blanks with the appropriate feedback and responses, in order 

to form a coherent conversation between “A” & “B”. 

a) I will work harder. 
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____________________________________________________________ 

_________________________________________________________ 

b) Thank you for the feedback, Sir/Ma’am. 

c) I could see the amount of effort you’d put into your work, and 

I really think you will be very successful if you keep up the 

good work. 

d) You have to learn how to work in a team. 

e) Thank you so much for your feedback. I assure you, I will 

continue to do well. 

1. A: I have reviewed your performance 

B: How did I do, Sir/Ma’am? 

A: You do well alone but not when you are working in a team. 

____________________________________________________________. 

B: Thank you for the feedback, Sir/Ma’am. I will work on it. 

2. A: How do you find work at our office? 

B: I like working here, Sir/Ma’am. 

A: I would like to give you a feedback. You have done very well till 

now. 

B:__________________________________________________________ 

____________________________________________________________. 

A: I went through your report this morning. 

B: Was it okay. I’d collected all the data I could get. 

A: I’d like to give you some feedback that may help you. 

B: What is it? 

A: __________________________________________________________ 

____________________________________________________________. 

B:__________________________________________________________ 

____________________________________________________________. 

3. A: I would like to give you a feedback. 

B: Okay, Sir. 

A: As a customer service representative, you need to be more 

attentive to the customers. 

B: Thank you for the feedback, Sir/Ma’am.________________________ 

____________________________________________________________. 

Sentences: 

2) Convert the direct speech of the given sentences to reported speech by 

filling in the blanks.. 

• Manager: “Sahil, your presentation was very good!” 

Sahil: “Thank you, Sir!” 
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• Team Leader: “Trisha, you need to be more focused on your 

work.” 

________________________________________________________. 

Trisha: “Yes, Sir. I will try harder.” 

________________________________________________________. 

• Manager: “You have to learn how to work in a team.” 

_________________________________________________________. 

Sahil: “Yes, Ma’am. Actually this is the first time I am working 

as a part of a team.” 

_________________________________________________________. 

• Manager: “How do you like working in this office?” 

_________________________________________________________. 

Sahil: “Sir, I like the office very much as it provides 

opportunities for moving ahead.” 

_________________________________________________________. 

• Team Leader: “Trisha, I am happy to see that you are 

improving.” 

_________________________________________________________. 

Sahil: “Thank you, Sir.” 

*********************************************************************** 

115 



 

 

  

      

         

     

    

   

   

   
                 

             
            

        
 

   

   

          

            

           

             

          

 

       

    

    

    

     

     

    

         

 

             

              

            

           

            

    

          

          

         

   

COMMUNICATION SKILLS 

SESSSION 17: IMPORTANCE OF COMMUNICATION SKILLS 

This section on communication skills has the following topics: 

• Importance of communication skills. 

• Effective listening skills. 

• Non-verbal communication. 

• Workplace communication. 

• Interview skills 
This section focuses on a few of the soft skills that you need as you move from 
school to the workplace. Hence, you will find that the exercises and activities 
are different from the previous section on English. Listen carefully to your 
facilitator to make the most of this section. 

RELEVANT KNOWLEDGE 

What Is Communication? 

Communication is more than just talking; it requires understanding the 

information that has been exchanged. If you cannot understand what has been 

expressed, then the communication has not been not successful. For example, 

you can explain to someone how to multiply a complicated equation, but if 

they don’t understand your explanation, then your communication was not 

successful. 

Many actions are involved with communication: 

• speaking clearly, 

• listening effectively, 

• asking questions, 

• understanding body language, 

• using a common language, 

• organizing information, 

• understanding (this is the most important aspect). 

We want the students to not only improve their language skills, but also 

improve the way they speak with other people to ensure that the thoughts are 

conveyed and understood correctly. This will be important when they move into 

the working environment, and interact with and are exposed to different 

people. They might meet people who don’t listen well or cannot communicate 

effectively, causing misunderstandings. 

Misunderstandings can create many problems. Hence it is important for 

students to improve their communication skills in order to avoid 

misunderstandings and improve the likelihood of positive outcomes with 

everything they do. 
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Our understanding of communication is incomplete till we understand the flow: 

Sender -> Message ->Receiver ->Feedback-> Sender 

Communication is an ongoing process and does not end with receiver receiving 

the message. Feedback is a very important component of this process. 

Message is not just what a person says, but also the meaning of that message. 

Meaning takes more than one form. That is, it can be the meaning(s) as 

intended by the sender and the meaning(s) as interpreted by the receiver. 

Sometimes, the sender may have more than one meaning and/or the receiver 

may understand more than one meaning. 

Feedback is the way the receiver lets the sender know she or he got a message 

and the way the sender finds out if the receiver correctly understood the 

message. 

WORKSHEET - EFFECTIVE COMMUNICATION 

Answer the following questions in your own words based on your experiences 

and learning from today’s session. 

1. What do you think about the communication model? 

2. Have you ever had difficulty sending a message? What happened? Why is 

it sometimes difficult to say what we really mean? 

3. Have you ever tried to communicate and been misunderstood? What 

happened? What could you have done differently? 
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4. What happens when communication breaks down between you and your 

friends? 

Case Study- Communication is the savior 

The following is a true story that took place on a small fishing island off the 

coast of Sri Lanka at the time of the Tsunami. The son of one of the fishermen 

was in Singapore, watching news about the earthquake that had just occurred 

off the coast of Indonesia. Worried about the potential impact on his family of 

giant waves that were reported to be spreading across the Indian Ocean, he 

telephoned his sister in Nallavadu, who told him that water was already 

beginning to seep into her home. He told her to leave immediately, and to urge 

others to do so. The villagers broke into the telecommunications centre. Using 

the public alert system set up for weather forecasts, they told the 500 families 

in the village that they had to leave immediately. The result of the warning was 

that although 150 houses and 200 boats were destroyed, not one of more than 

3,500 villagers lost their lives. 

What does this story tell us? Discuss with your class fellows. 
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RELEVANT KNOWLEDGE 

What are Effective Listening Skills? 

Expressing our wants, feelings, thoughts and opinions clearly and effectively is 

only half of the communication process needed for interpersonal effectiveness. 

The other half is listening and understanding what the other person is 

communicating to us. Effective communication exists between two people 

when the receiver comprehends, interprets and understands the sender’s 

message in the same way as the sender intended it. It has many advantages. 

By listening effectively, you will: 

• Get more information from the people 

• Increase others trust in you 

• Reduce conflict 

• Better understand how to motivate others 

• Inspire a higher level of commitment in the people you manage 

Effective listening is actively absorbing the information given to you by the 

speaker, showing that you are listening and are interested in what he/she is 

saying, and giving feedback to the speaker so that he/she knows that the 

message was received. It makes the speaker feel special and paid attention to. 

Active Listening 

Active listening is an intent to "listen for meaning", in which the listener checks 

with the speaker to see that a statement has been correctly heard and 

understood. The goal of active listening is to improve mutual understanding. 

When interacting, people often do not listen attentively to one another. They 

may be distracted, thinking about other things, or thinking about what they are 

going to say next. (The latter case is particularly true in conflict situations or 

disagreements). 

Active listening is a structured way of listening and responding to others. It 

focuses attention on the speaker. Suspending one’s own frame of reference and 

suspending judgment are important in order to fully attend to the speaker. 

Techniques: 

• Focus on the speaker. 

• Watch for non-verbal cues. These may be more important than what 

is said. 

• Listen to how something is said. Inflection, intonation and strength of 

the speaker’s voice may communicate more than words alone. 
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____________________________________________ 

• Eliminate distractions. 

• Give encouraging non-verbal cues. Nodding and leaning toward the 

speaker show interest. 

• Encourage the speaker by using words such as, “Yes,” “I see,” and 

“go on”. 

• Ask questions to clarify what is said. 

• Check your understanding by repeating or paraphrasing what you 

think you heard. 

• Respond when appropriate. 

• Control emotional responses. 

• Listen to the entire point without interrupting. 

• Give the speaker time to think as well as talk. 

• Summarize what was said. 

Your facilitator will guide you through the session. Listen to him/her carefully 

and follow all instructions. 

EXERCISE: CHECK YOUR LISTENING SKILLS 

Name: __________________________________________________ 

Directions: Start in the United States and follow the directions to see where 

you end up. 

1. Write down: THE UNITED STATES OF AMERICA 

2. Take out all of the E’s. 

3. Take out every fifth letter. 

4. Change the F to an A. 

5. Move the S’s to the front of the word. 

6. Take out all of the T’s. 

7. Take out the first vowel (A, E, I, O, U) and the last consonant (alphabets 

other than the vowels). 

8. Move the fourth and fifth letter to the end of the word. 

9. Replace the S’s with L’s. 

10.Remove the sixth, seventh, and eighth letters. 

11.Move the double L’s to be the third and fourth letters. 

12.Where did you end up? 
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RELEVANT KNOWLEDGE 

What is Non Verbal Communication? 

Our Communication comes from three sources. These are listed below: 

Words 7% 

Tone 38% 

Gestures, Body Language 55% 

Nonverbal communication is behavior, other than spoken or written 

communication, that creates or represents a meaning. In other words, it 

includes facial expressions, body movements, and gestures. Nonverbal 

communication is talking without speaking a word. It is very effective, maybe 

even more so than speech. 

Remember the saying, “Actions speak louder than words”. 

You may be surprised to know that it is not only humans who 

respond to this form of communication. If you have a pet, 

especially a dog, it may follow directions and respond to hand 

and body movements more than your words. Dogs will even get 

confused if you say “sit” but give the hand motion that you 

usually use for “stay”. 

Next, we will focus on different kinds of nonverbal communication and its 

usage. One form of nonverbal communication is called the “universal 

gesture”. See if you can guess what it is by the time you finish this page! 

There are two main types of nonverbal communication: Body Language and 

Gestures. 

Body language: Body language is body movements that depend on a person’s 

attitude or feelings. Body language includes the way people walk, how they 

stand, and their facial features. In other words, any kind of meaning that is 

shown by a person's body attitude or movements. For example, when a boy is 

sad he may drop his head and walk slowly. Or, if a girl is happy, she might run 

and jump or stand up straight and put her hands in the air. People don't have to 

say anything to show how they feel about things. The color of people's skin may 

even show how they feel. For example, if people with light colored skin get 

embarrassed, their skin may turn red, or if they are worried, they might get 

pale. Body language can be voluntary (on purpose) or involuntary (a person 

can’t help it). An interesting fact is that blind children will smile when happy 

even though they have never seen a smile. 
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Gestures: Gestures are commmunications like facial expressions, handd signals, 

eye gazing, and body posturres. Examples include smiles, handshakes,, waving, 

and raising certain fingers to say something. For instance, if you see a friend at 

a noisy carnival, you might smmile and wave at your friend. You might aalso point 

at theFerris wheel if you wannted to meet your friend there. You could do all of 

these things without saying a word. Another great example is in criicket the 

umpire has different hand siggnals for showing if the batsman is out or if he has 

hit four or six runs. 

There are three main uses of nonverbal communication. People 

often use aall of them every day. 

The first use is for greeetings. Greetings include waves, 

handshakes, hugs and salutees. For example, when you see your 

friends in the morning on thhe way to school, you may wave to 

them. A more formal greetinng would be shaking hands with your boss at work. 

The salute is used in the armeed forces when you see a person with a rannk higher 

than yours. 

The next use is for specificc communication. For example, workers may use 

signals at their jobs. One impportant use is in construction when a workeer signals 

to a crane operator to keep everyone safe. These signals are very speecific and 

tell the operator to move lefft, right, or raise and lower the hook. Anotther very 

important use is sign languagge. This form of communication is used foor people 

who have hearing problems.. They use hand signals and lip reaading to 

communicate very specific thhings. 

The third use iis involuntary nonverbal communicationn. These 

are movementss and attitudes that show how people feeel. Most 

times, people ddon't even know they're communicating whhen they 

make these acttions, because these actions are automaatic. For 

example, a slummped posture may mean that the person is sad. A 

stern look may show that thhe person is in a serious mood. When peeople rub 

their eyes, it can show they are tired. All of these examples show howw people 

feel. 

Note: Expressions and gestuures are not the same around the 

world. Some gestures, like thhe “thumbs up,” which is a positive 

gesture in the United States,, may mean something very different 

in other cultures. In Nigeriaa, the thumbs up gesture is a rude 

insult! In Australia it is an obsscene insult. Another funny example 

is spinning your finger arouund your ear. This is known as the 

“you’re crazy” sign in Americca and in some other nations. But in 

Argentina, it means “you havve a phone call!” 
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Another gesture that can be taken completely differently depending upon 

where you live is nodding the head. In most parts of the world, it is a positive 

or “yes” gesture. In Bulgaria, and parts of Greece and the Middle East, it means 

no. 

Other examples of involuntary communication are rubbing hands together to 

show anticipation, tapping or drumming fingers when impatient, biting nails if 

nervous, and putting a hand or finger to one's cheek if thinking deeply. 

Non verbal communication includes, Proxemics- how we use our personal 

space, eye contact or gaze, facial expression, gesture, especially use of hands 

and arms, dress, posture, paralanguage – sounds that we make e.g., uff, 

hmmm, etc. Carefully study the handouts on nonverbal cues given in this 

session. 
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NON VERBAL CUES 

¨ Facial expressions 

¨ Body language 

¨ Eye contact 

¨ Dress and physical appearance 

¨ Gestures 

NO 

When our words send one 

message and our nonverbal cues 

send another message, people 

Most People Express and Can Recognize 

Six Basic Emotions 

Sadness Anger 

Happiness Surprise 

Disgust 
Fear 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

WORKSHEET NON VERBAL CUES AT WORKPLACE 

Answer the questions based on the scenario given: 

#1 

Damanjit was complaining about the work he had to do on the job. His 

supervisor, Mr. Ritesh, looked at him crossed his arms and frowned. 

1. What is the inappropriate behavior? 

2. What are the non-verbal cues? 

3. How should Damanjit correct the behavior 

#2 

Julie is very friendly with Koel on the job. She always jokes with Koel and helps 

Koel do her work. She doesn't really talk to anyone else. She never helps other 

workers. When she does talk to other workers, like Suraj they often turn away 

and ignore her. 

1. What is the inappropriate behavior? 

2. What are the cues? 

3. How could he correct the behavior? 

#3 

Jay is a great worker at Coffee Day. He's young and has an unhappy family life, 

but he does a good job for you. He always has a frown on his face though. When 

customers ask him for an extra napkin or coffee, he always gets it for them, but 

he scowls and shrugs while he's doing it. So, the customers are left feeling like 

they have been an inconvenience to him. He also walks around looking at the 

floor with his shoulders slouched down. You would think he didn't like himself 

very well. 

1. What is the inappropriate behavior? 
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____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

____________________________________________________________________ 

2. What are the cues? 

3. How could he correct the behavior? 

#4 

Sohini works at a cyber cafe. She knocks into things and uses quick, jerky 

motions. She often touches people while she talks to them and puts her hands 

on their shoulders. 

What is the inappropriate behavior? 

What are the cues? 

How could she correct the behavior? 
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RELEVANT KNOWLEDGE 

What is workplace communication? 

In the workplace, the learners will meet a variety of communication styles. 

They may need to understand how language can mean different things to 

different people. They need to know how to communicate directly and to 

clarify expectations. 

Workplace Communication Skills 

There are two types of communication; formal and informal. Informal 

communication is between family and friends, but when it comes to formal 

communication, there are some etiquette and rules that need to be followed. 

Here are some tips for effective communication in the workplace with your 

subordinates, colleagues, as well as seniors. 

• Be Clear and Transparent: You need to be very clear and transparent in 

the way you communicate, especially at work. Avoid statements that 

may be dubious or with a double meaning. Whatever you communicate, 

be it any changes in the rules, regulations or policies, everything should 

be explained properly and clearly with examples. 

• Be Well Prepared: Remember this is professional communication, so you 

should always have a proper documentation of all the points to be 

covered while communicating with your employees or colleagues. 

Include everything that you want to communicate, as missing out on 

even a single important point might create a hassle later on. 

• Be Precise: You are here to communicate about organizational matters, 

and so you need to honor the time of everyone involved directly or 

indirectly. For this, you have to be precise. So do not drag the discussion 

unnecessarily and come to the point directly. 

• Be Generic: Communicating on a professional level needs discussion on a 

generic level. Pointing at anyone's mistakes or errors is undesirable, as 

this might result in a conflict. Use the word 'We' for success as well as 

failures, and try not to use the word 'You' unless there is a need for 

mentioning something specifically. 

• Be Assertive: Communicate in an assertive manner. It should be such 

that you, as well as the person in front of you should be benefited. Be 

open and honest about what you say, while respecting the feelings of 

others. 
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• Do Not Assume: Never work with any assumptions, at least as far as 

communication is concerned. For example, if there is a set of tasks that 

need to be performed, make sure you specify all of them along with the 

end result, and do not assume that everyone involved will know most of 

the things needed to be done anyway. 

• Encourage Two-Way Communication: Always give the other party a 

chance to speak. Ask questions and take the other person's opinion too, 

once you have finished speaking. Such a two-way conversation forms the 

basis of a healthy communication, and you also come to know about 

people's thoughts about certain issues. Moreover, you never know who 

might come up with a great idea and that too when least expected. 

Effective non-verbal communication 

A Mullah Nasruddin Story: 

A renowned foreign scholar and his team members were passing through the 

town where Mullah Nasruddin lived. The scholar was honored by the ministers 

of that town. During this ceremony the foreign scholar said he wanted to have 

an intellectual discussion with the knowledgeable person in the city. 

The ministers wanted to have some fun, so they immediately summoned their 

Town Jester – the “wise fool” – Mullah Nasruddin. As the news spread, a large 

crowd gathered to witness the “battle of wits”. 

The foreign scholar did not speak the local language and the rustic Nasruddin 

could not understand or converse in the foreign scholar’s language. So, the two 

wise men tried to communicate with each other non-verbally in sign-language, 

while the audience looked on with fascination. The foreigner, using a stick, 

drew a large circle on the sand. Mullah Nasruddin took the stick and divided the 

circle into two. Then the foreigner drew a line perpendicular to the one 

Nasruddin had drawn and the circle was now split into four quarters. 

He motioned to indicate first the three quarters of the circle and then pointed 

to the remaining quarter. In response to this Mullah Nasruddin made a swirling 

motion with the stick on the four quarters. Then the foreigner made a bowl 

shape with his two hands side by side, palms up, and wiggled his fingers. 

Nasruddin responded by cupping his hands palms down and wiggling his fingers. 

The foreign scholar then bowed his head in deference before Mullah Nasruddin. 

Mullah Nasruddin smiled at the foreign scholar and then he walked away. 

Later the renowned foreign scholar explained the intellectual encounter to the 

city council. “Mullah Nasruddin is truly a very learned man,” the foreign scholar 

said, “I told him that the earth was round and he told me that there was the 

equator in the middle of the earth. I told him that the three quarters of the 
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earth was water and one quarter of it was land and he said that there were 

undercurrents and winds. I told him that the waters warm up, vaporize and 

move towards the sky, and in reply to that, he said that they cool off and come 

down as rain.” 

Later, when he reached home, his wife was curious, so Mullah Nasruddin 

explained his version of intellectual encounter: “This stranger has real good 

taste. He said that he wished there was a large round tray of halwa (milk cake). 

I said that he could only have half of it. He said that the syrup should be made 

with three parts sugar and one part honey. 

I agreed and said that they all had to mix well and blend properly. Next he 

suggested that we should cook it on blazing fire. To this I suggested that we 

should pour crushed nuts on top of the halwa.” “It was a very rewarding 

discussion,” said Nasruddin with a glow of self satisfaction, “and I am so proud 

that I taught the foreign scholar the best recipe for halwa for which he will be 

grateful to me forever.” 

SATURDAY SHIFT- DIALOGUES 

Mr. Ramakrishna- It looks like we are going to have to keep the production 
line running on Saturday. 
Mr. Banerjee – I see 
Mr. Ramakrishna – Can you come in on Saturday? 
Mr. Banerjee - I think so. 
Mr. Ramakrishna –That will be a great help. 
Mr. Banerjee – Yes, Saturday is a great day for me, did you know that. 
Mr. Ramakrishna - How do you mean? 
Mr. Banerjee – It is my son’s birthday. 
Mr. Ramakrishna – How nice. I hope you all enjoy it. 
Mr. Banerjee - Thank you very much for your understanding. 

WORKPLACE SCENARIOS 

Read the scenarios given below and discuss the questions that follow with your 

class: 

1. Chetna works as a customer relation officer at a famous beauty clinic. She's 

rude and doesn't look at people when she talks to them. When she seats 

them, she tosses the menus on the table and walks off as though she is in a 

hurry and angry. She does not make the people feel welcome. 

a). What is the inappropriate behavior? 

b). What are the cues? 
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c). How could the behavior be corrected? 

2. Chetan works as IT support officer in a college. He usually slumps and holds 

his head down. He often shrugs and frowns when someone speaks to him. 

a). What is the inappropriate behavior? 

b). What are the cues? 

c). How could he correct the behavior? 
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What are Interview Skills? 

Prepare for your interview. 

When you get selected for an interview you need to ask yourself - what was 

there in your CV or application form which interested the employer? Those 

being interviewed probably have similar skills and achievements, so you need to 

show that you are the right and the best match. To prepare yourself, check the 

company website, read the company literature (if any) and find out as much as 

you can about the organization. 

Remind yourself about the contents of your application form/CV. 

A valuable tool you need to prepare is a statement about yourself so you can 

answer the key question which is often asked – ‘Why are you applying for this 

job?’ So practice talking about your own self by preparing a ‘Career 

Statement’. Can you list two or three things you are good at? Can you list two 

or three skills and combine them all into a sentence or two? 

Make sure you know exactly where the interview is taking place. The building 

may have several floors so you need to allow time to get to the right floor. Plan 

your route – how long will it take to get there? You need to allow time for 

problems with transport, parking, bad weather etc. 

Do you know who will be interviewing you? This is not essential but it may give 

you some idea about their focus. 

Dress for success 

You also need to prepare in advance, what you are going to wear. What you 

wear does not have to be new, but it does have to be clean and neat. Dress 

smartly in an outfit which is comfortable to wear and fits well. It is probably 

preferable to wear a suit of a dark, plain color and men could wear a tie. 

Women can wear a skirt or smart trousers with a coordinating jacket or a 

traditional saree/salwarkameez. Your shoes should be comfortable and clean. 

Your hair should be neat and remember to keep jewellery to a minimum. Your 

visual appearance is very important and you want to make the right impression. 

Looking good will also boost your confidence. 

Typical interview questions 

Prepare yourself for answering some questions that are typically asked in every 

interview. You could use some concepts you have learnt in your Level 1 text 
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book while preparing your answers. Most importantly, remember to be natural 

while giving your answers.  

• Tell me about yourself 

•  Why have you applied for this job and applied to this company? 

• What evidence can you offer that demonstrates you have the skills we 

are seeking? 

•  Can you give me an example of a problem you have solved? 

•  Why did you choose your particular degree? 

•  What are your strengths and weaknesses? 

•  Where do you see yourself in five years’ time? 

•  What do you do in your leisure time? 

INFO SHEET (1)- Interview Techniques 

“This could be the most important 20 minutes of your life” 

 

 

 Interviews give you the 
chance to tell someone 

 about yourself – your 
strengths, 

 yourachievements and 
your personal qualities  

 

 

 

 

 

 
This lesson provides an 
opportunity to do that. 
You will get the chance 

 to be in the role of an 
interviewer and be able 

 to observe someone 
else as well as being the 

 interviewee 

 

  

Most people are 
nervous about selection 
interviews for jobs and 
courses. One way to 
reduce anxiety and 
perform better at 
interviews is to get 
some practice. 

This should help you to 
do better next time 
when it may really be 
“the most important 20 
minutes of your life!!”. 
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INFO SHEET (2) – Interview Techniques 

 

JOB SPECIFICATION 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The company requires an enthusiastic youth who can 

work as a Customer Care Executive with a leading Gym 

in Delhi. 

The person must be able to work as part of a team, be 

a good communicator, and be prepared to work flexible 

hours, be smart in appearance, have a keen interest in 

physical fitness and be committed to our training 

program. 

Qualification- Passed Class 12 (desirable but not 

compulsory) 

 

*INTERVIEWER is the manager of the gym 
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INFO SHEET (3) – INTERVIEW TECHNIQUES 

 

 
Interviewee’s 

Checklist 
 

 

 

 

 

PREPARATION  
• Decide what to wear, be clean and tidy. 

 
• Plan the journey including how long the journey will take. 

• Find out about the company.  
• Prepare some questions. 

 • Prepare some answers 

 

 

 

 
THE INTERVIEW 

 
• Arrive 10 minutes early.         

• Be friendly and cheerful to the secretary or receptionist who  
greets you. 

 
• Look neat and clean. 

• Be prepared to shake hands.  
• Don’t sit until you are offered a chair. 

 • Try to relax and listen to the questions carefully. 

• Look at the person asking the question.             
 

• Think before you answer. 

 • Speak clearly and in a strong voice. 

• Show interest and enthusiasm. 
 

• Be honest. 
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INFO SHEET (4) – INTERVIEW TECHNIQUES 

 
Interviewee’s 

Checklist  
Continued 

 

 

 

 
QUESTIONS YOU MAY BE ASKED 

 • Tell me about yourself.      

• Why do you want the job? 
 

• What makes you think you would be good at the job?      

• What do you do in your spare time?  
• What qualities do you think you have to offer? 

 • How did you like school? 

• What are your strengths and weaknesses? 
 

 

 

 QUESTIONS WHICH YOU MAY ASK 

• During the interview the details of the job will probably be explained to 
 

you, but there may be gaps and you may wish to ask your own questions. 

 Wait until the end of the interview to ask questions and don’t ask too 

many. 
 

• What are the normal hours of work?                    

• What training will I get? 
 

• Are there any opportunities for promotion? 

• Who will I be working with?        
• Who will I be directly responsible to?         

 

 

 

WHAT WILL THE EMPLOYER NEED TO KNOW? 
 

• What qualifications you have to offer. 

 • What experience you have including work experience. 

• The standard of your health. 
 

• Whether you are keen, interested and willing to work. 

• Whether you have the skills, abilities and personal qualities for the job. 
  

• Whether you have found out about the company beforehand. 
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INFO SHEET (5) – INTERVIEW TECHNIQUES 

 

Interviewer’s 
 Checklist 

 

 

 

 

WHAT ARE THE CRITERIA THE INTERVIEWER WOULD USE IN THE SELECTION 
 

PROCESS? 

 • Qualifications.             

• Work experience.                              
 

• Health.        

 • Home circumstances (e.g. distance from home to work). 

• Skills/abilities.             
 

• Personality.                     

• Interest and willingness to work.                 
• Knowledge of the company. 

 
• Questions the candidate asks.     

 

 

 

WHAT WOULD YOU TELL THE INTERVIEWEE? 
 

• What they would be expected to do, who they would be responsible 

 to. 

• Wages, hours, holidays, lunch arrangements.         
 

• Training offered. 

 • Future prospects.   

• Values of the organization 
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ACTIVITY SHEET (1) – Interview Technique 

Interviewee Good points Bad points 

How is the interviewee sitting? 

What impression does this give? 

Is the interviewee prepared? 

Is the interviewee looking at 
the interviewer? 

Are the answers clear? 

What impression does the 
interviewee give? Confident, 
Nervous 

Does the interviewee show 
interest and enthusiasm? 

Are the questions 
easy/difficult? 

Were they relevant? 

Did the interviewee ask 
questions? 

Other comments: 
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ACTIVITY SHEET (2) – Interview Techniques 

1 
Having taken part as an observer, interviewer and interviewee in today’s session, 

list the skills, personal qualities or previous experiences you have which would be 

of value to a potential employer. 

List any concerns you may have about your management of any interview situation. 

2 

3 
Having watched or taken part in mock interviews, list the common weaknesses in an 

interviewee’s performance 

4 

How could these be overcome? 

5 
1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 

List 8 key factors important to an employer in interviewing a potential employee. 
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PREFACE 

The National Curriculum Framework, 2005, recommends that children’s life at 

school must be linked to their life outside the school. This principle makes a 

departure from the legacy of bookish learning which continues to shape our 

system and causes a gap between the school, home, community and the 

workplace. 

The student workbook Volume 2 on “Productivity Tools” (Word processor, 

Presentation, Spreadsheet and E-mail) is a part of the qualification package 

developed for the implementation of National Vocational Education 

Qualification Framework (NVEQF), an initiative of Ministry of Human Resource 

Development (MHRD), Government of India to set common principles and 

guidelines for a nationally recognized qualification system covering Schools, 

Vocational Education and Training Institutions, Technical Education Institutions, 

Colleges and Universities. It is envisaged that the NVEQF will promote 

transparency of qualifications, cross-sectoral learning, student-centered 

learning and facilitate learner’s mobility between different qualifications, thus 

encouraging lifelong learning. 

This student workbook, which forms a part of vocational qualification package 

for students who have passed Class X or equivalent examination, was created 

by a group of experts. The IT-ITeS Skill Development Council approved by the 

National Skill Development Corporation (NSDC) for the IT/ITES Industry 

developed the National Occupation Standards (NOS). The National Occupation 

Standards are a set of competency standards and guidelines endorsed by the 

representatives of IT Industry for recognizing and assessing skills and knowledge 

needed to perform effectively in the workplace. 

The Pandit Sunderlal Sharma Central Institute of Vocational Education 

(PSSCIVE), a constituent of National Council of Educational Research and 

Training (NCERT) in association with Wadhwani Foundation has developed 

modular curricula and learning materials (Units) for the vocational qualification 

package in IT/ITES sector for NVEQ levels 1 to 4; level 1 is equivalent to Class 

IX. Based on NOS, occupation related core competencies (knowledge, skills, and 

abilities) were identified for development of curricula and learning modules 

(Units). 

This student workbook attempts to discourage rote learning and to bring about 

necessary flexibility in offering of courses, necessary for breaking the sharp 

boundaries between different subject areas. The workbook attempts to 

enhance these endeavors by giving higher priority and space to opportunities 

for contemplation and wondering, discussion in small groups and activities 

requiring hands-on-experience. We hope these measures will take us 
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significantly further in the direction of a child-centered system of education 

outlined in the National Policy of Education (1986). The success of this effort 

depends on the steps that school Principals and Teachers will take to encourage 

children to reflect their own learning and to pursue imaginative and on-the-job 

activities and questions. 

Participation of learners in skill development exercises and inculcation of 

values and creativity is possible if we involve children as participants in 

learning, and not as receiver of information. These aims imply considerable 

change in school routines and mode of functioning. Flexibility in the daily time-

table would be a necessity to maintain the rigor in implementing the activities 

and the required number of teaching days will have to be increased for 

teaching and training. 
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WORD PROCESSING 

SESSION 1: CREATING TEMPLATES 

Learning Objectives: 

You have already learnt to create complex documents. You have also learnt to 

use fonts, styles, borders, images, clipart, font work etc to enhance the look 

and feel of the created document. You have also learnt to download and use 

templates. Now, in this book, you will learn about some advanced features of 

word processing software. 

At the end of this session, you will be able to: 

• Create your own document templates and use them. 

RELEVANT KNOWLEDGE 

Though you can download templates, sometimes you need to create a 

document (which you intend to use numerous times), with some specific 

personalized details, such as your company/school logo etc. Word processing 

software helps you to create custom templates to suit your needs. 

Create a template 

To create a template, the first step is to create a document that will be used 

as the template. For example to create a template with customized font for 

different headings and body text, do the following: 

1. Go to File > New > Text Document. 

2. Select Format > Styles and Formatting 

F11. The Styles and Formatting dialog 

box appears as shown adjacent. 

3. Create the following styles: 

a. Heading 1 

i. Font: Century Gothic 

ii. Size: 18pt 

iii. Color: Green 

b. Heading 2 

i. Font: Century Gothic 

ii. Size: 14pt 

iii. Color: Grey 60% 

c. Text Body 

i. Font: Arial 

ii. Size: 12pt 

4. Select Insert > Page…. Select Page tab 

and set the following layout: 

a. Top: 1.5” 
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b. Bottom: .5” 

c. Left: .75” 

d. Right: .75” 

5. To save this document as a template, select File > Templates > Save. A 

Templates dialog box 

appears as shown 

adjacent. 

6. Type a name in New 

template text box, 

for example 

MyTemplate01. 

7. Click OK. 

Alternate method to save templates 

1. Select File > Save 

As…. A Save As 

dialog box appears. 

2. Select ODF Text 

Document 

Template (.ott) from the Save as type: dropdown menu and type a 

filename, for example MyTemplate. Select Save. 

3. Close the document. 

Note: 

a. Templates have the file extension .ott. 

b. Templates are stored in the folders C:\Documents and 

Settings\USERNAME\Application Data\OpenOffice.org\3\user\template. 

Using a template 

To use this template, do the following: 

1. Select File > New > 

Templates and 

Documents. A 

Templates and 

Documents dialog box 

appears. 

2. Notice the template 

listed. Select the 

template and click 

Open. 

3. A document based on 

this template will be 
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created. Type some content, set headings and observe the results. 

Alternatively, to create a document based on the template, do the following: 

1. Go to the location where the template is 

saved. Notice the icon representing a 

template (figure adjacent). 

2. Double-click on the template to create a document based on it. Insert 

content and apply heading styles. Notice the displayed results. 

3. To save this document, select File > Save and give an appropriate file 

name. 

Editing templates 

To further modify an existing template, do either of the following: 

1. Select File > New > Templates and Documents. The Templates and 

Documents dialog box appears. 

2. Select the template and click the Edit button. 

Or 

1. Go to the location where the template (for example, MyTemplate.ott) is 

located. 

2. Right-click the 

template, 

select Open. 

Then, 

3. Customize the template by: 

a. Including page number in the footer area. 

b. Including your school name in the header area. 

4. Save the template (CTRL+S). 

5. Create a document based on this template and observe the changes. 

Creating templates from other templates or documents 

The need to create a template from other templates or documents arises when 

you already have a document structure ready for use or you want to customize 

a downloaded template and use it as a base for other documents you create. To 

create a template from another template, do the following: 

1. Go to templates.openoffice.org. 

2. Download a template for example, Service Invoice. 

3. Open the template with word processing software. A document based on 

the template will be created. 
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4. Modify the document to include Company Name, Address, Contact 

number, logo, etc. 

5. Select File > Templates > Save…. Give a file name to this template. The 

template is ready for use whenever required. 

Tip: You may also download and use templates created using Microsoft Word, 

since OpenOffice.org Writer supports the .DOC format. If you use templates 

created using for a recent version of Microsoft Word 2007/10/13 (.DOCX), you 

can download and open them using Microsoft Word 2007/10/13, save them in a 

.DOC format and then use with OpenOffice.org Writer. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a template for the following: 

a. Computer repair invoice. 

b. House sale flyer. 

c. Service apartment marketing flyer. 

d. Birthday party invitation. 

e. Daily and weekly plan. 

f. Receipt template. 

Use the following resources to download templates: 

a. http://templates.openoffice.org 

b. http://sourceforge.net/projects/aoo-templates/ 

ASSESSMENT 

Answer the following 

1. Explain the procedure to create a template. 

2. Explain the procedure to edit a template. 

Fill in the blanks 

1. File extension for word processing templates ______ . 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Create and print envelopes. 

RELEVANT KNOWLEDGE 

You can create customized envelopes and print them along with the letters that 

you send to customers or friends. Word processing software has a feature of 

creating Envelopes that helps when you want to include a standard text on the 

envelope for example, a return address. 

To include a return address to be printed on an envelope, do the following: 

1. Open a new document 

and select Insert > 

Envelope…. An Envelope 

dialog box appears (figure 

adjacent). 

2. Type the return address 

in the Sender: text box 

(sample below). 

a. If you want the 

word processing 

software to print 

the envelope when 

you print the 

document, click 

the Insert button. 

The software 

automatically 

includes an 

additional page for 

the envelope 

(figure below left). 

This is suitable 

when you print a 

single address 

along with the document. However, remember first to insert an 

envelope in the printer (prior to printing the document). 

b. If you want to insert the return address and print later, click New 

Doc. Selecting this option creates a new document along with the 

address that should be printed only on an envelope (figure below 

right). 
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3. Save the documents. 

4. Complete the letter and use the Print option to print both envelope and 

letter content separately. 

Modifying Envelope Size 

Word processing software uses a pre-defined envelope size which you can 

customize. You may use this feature if the envelope you have has a different 

size from the one that is pre-defined. To modify the envelope size, do the 

following: 

1. Select Insert > Envelope…. The Envelope dialog box appears. 

2. Select the Format tab. Notice 

the size of the envelope and 

position of the sender’s address 

(figure adjacent). 

a. Adjust the position of 

sender and recipient 

address by changing the 

values under Position in 

the Addressee and 

Sender sections. 

b. Select either a pre-

defined size from the 

Format dropdown or use 

a custom size by 

specifying values in Width 

and Height numeric value 

boxes. 

c. Select the Edit dropdown 

in Envelope dialog box to 

modify the format. 

3. Depending on your requirement, 

select either Insert or New Doc. 

Printing on Envelopes 
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You need to set up the printer in order to print envelopes. You can specify 

envelope orientation (physical placement of envelopes in the printer) by, doing 

the following: 

1. Select Insert > Envelope…. The Envelope dialog box appears. 

2. Select the Printer tab. Notice the settings specified here. 

3. Select the orientation from options under Envelope Orientation as 

required. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create an envelope template for greeting cards using the following 

guidelines: 

a. Insert pictures and make it colorful. 

b. Use different font, font size and colors. 

c. Use your home address as the return address. 

2. Create envelope templates for the following: 

a. Birthday invitation. 

b. Paycheck envelope. 

c. Receipts envelope. 

Use the following resources to download samples: 

a. http://templates.openoffice.org 

b. http://sourceforge.net/projects/aoo-templates/ 

c. http://designerstoolbox.com/designresources/envelopes 

d. http://www.zazzle.com/envelopes 

ASSESSMENT 

Answer the following 

1. Explain the procedure to include a return address to be used on an 

envelope. 

Fill in the blanks 

1. Envelopes option is available in _____ dropdown menu. 

2. Envelope size can be modified using ______ tab of Envelope dialog box. 

14 
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Learning Objectives: 

At the end of this session, you will be able to 

• Create and print labels. 

RELEVANT KNOWLEDGE 

You can print labels using the word processing software. You use labels to 

create Identification Cards (I Cards), business (visiting) cards, shopping tags, 

etc. Usually, labels are printed in identical sets. For example, there may be 10 

or 20 identical labels printed on an A4 sheet. 

You can either print a single label or a page full of labels. The latter is more 

commonly used, for example, when you want to print labels with repetitive 

information such as a store’s address (to be pasted on all products sold from a 

store). 

If you want to print 30 labels in a single sheet containing a store’s address, you 

will do the following: 

1. Select File > New > 

Labels. A Labels dialog 

box appears (figure 

adjacent). 

a. Type the store 

address in Label 

Text textbox, 

for example 

Star Office 

Supplies. 

b. Select the 

option Sheet in 

the Format 

section. 

c. Labels are of varying sizes usually identified by specific Brand and 

a particular type. So, select Avery Letter Size from Brand and 

5260 Address from Type dropdown lists. 

d. Select the Options tab. Check Synchronize contents option. 

Doing so ensures that when you format a single label, it is 

automatically synchronized with rest of the labels within the 

sheet. 
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2. Select Format tab. 

Enter the number of 

labels to be printed 

by specifying values 

in Columns and 

Rows numeric text 

boxes. For example 

to print 30 labels, 

enter 3 in Columns 

and 10 in Rows 

(figure adjacent). 

3. Click New 

Document. Notice a 

sheet full of labels is 

created (figure adjacent). 

4. You may now save this 

document and print on label 

sheets as required. 

If you want to modify the font or 

content, do the following: 

1. Place the cursor on the first 

label (Note: You can edit 

only the label in first row 

and first column). 

2. Select the text you wish to modify. For example select Star Office 

Supplies, change the font to Trebuchet MS, size 10 and align it to the 

center of this label. 

3. Click Synchronize Labels. Notice the formatting replicated to all the 

other labels. You can modify the content in the first label and replicate 

to all other labels. 

If you want to modify the size of labels, select the Format tab and specify the 

size as required. This may be helpful in situations when you want to print on 

labels that do not have standard sizes. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a label template to print 40 labels in a single A4 sheet based 

on the following guidelines: 

a. Include school’s address with contact number. 
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b. Use Verdana, size 10. 

c. Include school logo (Insert > Picture and resize). 

d. Include school’s email address. 

2. Create label templates for the following: 

a. CD / DVD jewel case labels. 

b. File / folder labels. 

c. Labels for items sold in a supermarket. 

Use the following resources to download samples: 

a. http://templates.openoffice.org 

b. http://sourceforge.net/projects/aoo-templates/ 

ASSESSMENT 

Answer the following 

1. Explain the procedure to print 30 labels in a single sheet. 
2. Explain the procedure to create a label with custom size. 

Fill in the blanks 

1. To create Labels, you should select File > New > ______ option. 

17 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Understand the purpose of mail merge feature. 

• Use mail merge feature. 

RELEVANT KNOWLEDGE 

Mail merge is a software feature used widely to create personalized cover 

letters or emails. This feature is very useful when you want to send a letter to 

multiple recipients and at the same time want to give each letter a 

personalized touch (i.e. making it appear as if the letter was specifically 

addressed to them). For example, if you want to send an Annual day 

celebration invitation to several people, you can use the mail merge feature. 

Mail merge is a widely used for a variety of purposes like: 

• Communicating promotional offers or clearance sales to customers. 

• Inviting a large group for a public presentation or awareness campaign. 

• Sending invitations to a selective group for a contest. 

Mail merge has two components: 

a. A contact list from which the contact name, address, etc. is derived. 

b. A letter or email to which the contact name, address, etc. is attached. 

Note: Mail merge supports several data sources such as a SQL database, 

spreadsheets, text files, web pages, etc. We will use a simple spreadsheet for 

our example. 

Before you work with mail merge, you should have a list of contacts with postal 

or email addresses ready. If you already have the list ready in a source such as 

a spreadsheet, you can use that as the source of data. For example, create the 

following list in a spreadsheet: 

Important: Fields in a database should have appropriate headers such as Title, 

Name, Email, etc. If you use a spreadsheet or a database without proper 

header names, mail merge will result in errors, missing data or will not work at 

all. 
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Save this spreadsheet, for example Address.ods. This will be used as our data 

source. 

Using Mail merge 

1. Select File > New Text Document. 

2. This is the second step where you create the letter or mail that will 

contain the content to be distributed. Create a document with the 

following content: 

To, 

We are glad to announce our 10th Annual Day Celebration and we 
cordially invite you to be a part of it. 

Warm regards, 

School Leader. 

3. Save this document. Select Tools > Mail Merge Wizard….A Mail Merge 

Wizard dialog box (Step 1) appears. 

4. Select Use the current document, click Next. Select a document type 

(Step 2) appears. 
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5. Select Letter and click Next. Insert address block (Step 3) appears. 

6. Click Select Different Address list…. A Select Address List dialog box 

appears (shown below). 

7. Click Add…. Browse and select the spreadsheet created earlier 

(Address.ods) and click Open. Click OK. 

8. Since we need to add address to this letter, check This document shall 

contain an address block. 
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Mail merge uses a default address block that requires certain fields such as 

Title, First name, Last name, etc. To create your own address block, do the 

following: 

a. Click More… button. 

Select Address Block 

dialog box appears as 

shown adjacent. 

b. Notice different styles 

of address block here. 

Click New… to add your 

own address block. New 

Address Block dialog 

box appears. 

c. Select Title from 

Address 

elements 

list and 

click . 

Repeat 

the 

procedur 

e to add 

First 

Name, 

Address Line 1, City and Zip from Address elements list. 

d. Notice the fields address under Drag address elements here section 

(figure above). 
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Fields added 

here may not 

be properly 

aligned to your 

requirements. 

Use spacebar, 

delete and 

enter keys on 

your keyboard 

to align field 

here (Sample 

below). 

e. Click OK twice. You return to Step 3 of the wizard. 

Mail merge feature attempts to scan the data source for matching field names 

and use them automatically. If it is unable to match, you will notice a message 

in the Check if the address data matches correctly textbox. (Notice the 

message <not yet matched>). 

In such cases you need to either rename the fields in the source (spreadsheet in 

this case) or you can 

manually map them now. 

9. To map manually, 

click Match Fields…. 

Match Fields dialog 

box appears as shown 

adjacent. 

a. Notice the 

field Title and 

City are 

automatically 

mapped as the 

spreadsheet 

had matching 

the 

Name>, 

from 

titles. You 

need to match rest 

of the fields. Now 

select 

dropdown list next 

to <First 

select Name 

this list. 
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b. Select the 

dropdown list 

next to 

<Address Line 

1>, select 

Address from 

this list. 

c. Select the 

dropdown list 

next to <Zip>, 

select Postal 

Code from this 

list. 

10.Click OK. You should 

see a window similar 

to the one below 

mapped properly. 

11.Notice the results 

under Check if the 

address data 

matches correctly 

section. Click Next. 

Create a salutation 

(Step 4) appears. 

12.Uncheck This 

document should 

contain a salutation 

and click Next. 

Adjust layout of 

address block and 

salutation (Step 5) 

appears. 

13.Adjust the position 

where you need the 

address block to 

appear in the 

document and click 

Next. Preview and 

edit the document 

(Step 6) appears. 
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14.Click Next twice. 

Save, print or send 

the document 

(Step 8). 

15.Select Save merged 

document. Notice 

the options (figure 

below). 

a. To save 

individual 

records as 

separate 

documents, 

select Save 

as 

individual 

documents. 

b. To save all 

the records 

in a single 

document, 

select Save 

as single 

document. 

For 

example, 

select Save 

as single document and click Save Documents button. Type a 

filename for example, Mail_merge_output.odt. 

16.Click Finish. Open the document created in the previous step. Notice the 

address blocks displayed in each page of the document (figure below). 

17.You may now move the address block, format & align text and print as 

required. 
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Mail Merge, Envelopes & Labels 

Imagine a situation where you need to print hundreds of letters and manually 

write the addresses of each contact on envelopes. Also it is possible that you 

may forget to include some contacts. To help avoid such a situation, you can 

use the envelope printing facility in word processing software and print 

envelopes along with letters. You can use mail merge feature to print 

personalized envelopes or labels. 

Creating labels from a database 

To create labels using the 

previously created spreadsheet, do 

the following: 

1. Select File > New > Labels. 

A Labels dialog box appears. 

2. Notice the list of data 

sources listed under 

Database dropdown list. 

a. Select the address 

source from Database 

dropdown list. 
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b. Select Sheet1 from Table 

dropdown list. 

c. Select Title from Database 

field dropdown and click 

button. Repeat to add 

Name, Address, City and 

Postal Code (figure 

adjacent). 

3. Click New Document. Notice the 

label list created in a new 

document (figure below). 

4. Select File > Print…. A confirmation popup appears to confirm if you 

want to print a form letter. 

5. Click Yes. A Mail 

merge dialog box 

appears as shown 

adjacent. 

You may create labels for 

all or selective records 

from a database; 

a. To create labels 

for selective 

records, select 

the records one 

by one from the 

record list (use 
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CTRL + Click to select more than one record). 

b. To create labels for all the records, select All (default option). 

c. To create labels for a specific range, type the range in From: and To: 

numeric text 

box (for 

example to print 

first ten records, 

type 1 to 10). 

6. Click OK. Print 

dialog box appears 

as shown adjacent. 

7. Place the label 

sheets in the 

printer and click 

Print. Notice the 

records printed as individual labels in the sheet. 

Create envelopes from a database 

To create envelopes, do the following: 

1. Select File > New > Text 

Document. 

2. Select Insert > Envelope…. An 

Envelope dialog box appears 

(figure below). 

a. Select the data source 

from Database dropdown 

list (use the list created 

earlier). 

a. Select Sheet1 from 

Table dropdown list. 

b. Select Title from 

Database field 

dropdown and click 

button. Repeat 

to add Name, 

Address, City and 

Postal Code. 

Click New Doc. button. A 

new document will be 

created similar to the one adjacent. 

Notice the address in the recipient’s text box area; records will be 

populated when you print. 
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3. Select File > Print…. A confirmation popup appears to confirm if you 

want to print a form letter. 

4. Click Yes. The Print dialog box appears. 

5. Click Print and observe the results. 

Mail Merge using E-mail 

To send bulk emails using mail merge, do the following: 

1. Create a new document with the following content. 

Dear Customer, 
We are pleased to announce 50% discount as you are a privileged customer. 
Please bring a copy of this email or call +91 9999912345 to claim this discount. 
Regards, 
John, 
Manager, Customer Service. 

2. Select Tools > Mail Merge Wizard…. Mail Merge Wizard dialog box 

appears, click Next. 

3. Select a document type section appears. Select E-mail Message and 

click Next. 

4. Insert Address Block section appears, click Select Address List…. Select 

Address List 

dialog box 

appears, select 

the data 

source used 

earlier. Click 

OK and Click 

Next. 

5. Create a 

Salutation 

section 

appears; click 

Next. 

6. Preview and 

edit the document section appears, click Next. 

7. Personalize the mail merge documents section appears, click Next. 

8. Save, print or send the document section appears. Select Send merged 

document as E-mail (figure above). 
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9. You now need to map the email address field to enable mail merge send 

this letter to requisite email addresses. 

a. Select the down arrow next to To and select the field Email from 

the list. 

b. Type the subject, for example “Special Discount”. 

c. You can send this announcement as a HTML message, Adobe 

Acrobat document (PDF), etc. Select HTML message from Send as 

dropdown list. 

Note: You can send this in a variety of formats such as Adobe Acrobat 

Document (PDF), Microsoft 

Word Document, HTML 

Message or Plain Text. Use 

the dropdown menu next to 

Send as option to select the 

format. Selecting any other format other an HTML Message or Plain Text will 

result in sending the content as an attachment. 

10.Click Send documents button. A popup appears similar to the one 

below. 

11.You need to 

specify the 

email 

account 

details from 

which these 

mails are 

sent. Click 

Yes. A Mail 

Merge E-mail 

dialog box 

appears as 

shown 

adjacent. 

a. Type 

your 

name in the Your name text box. 

b. Type your email address in E-mail Address text box. 

c. Type the SMTP address in Server name (for example, 

smtp.gmail.com) and specify the port number in Port numeric 

text box. Refer to ISP’s website for exact details. 

d. Click Test Settings… button to check if the settings are configured 

properly. 
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Note: Since Word processing software attempts to send this email directly 

(instead of using a email client software), all you need to specify is only the 

SMTP settings (POP3 settings are not required). 

12.Click OK. Word processing software will now attempt to send this letter 

to the emails available in the data source list. Click Finish. 

Personalizing Letters 

Instead of sending generic emails, you may further customize the letters or 

emails by including name of the customer. This is possible by including relevant 

field from the database within the document. 

1. Create the following content in a new document. 

Dear , 
We are happy to announce the opening of our new store in your location. As our 
privileged customer, we offer you 75% discount on purchases made above 
Rs.1000.00 from our new store. 
Please call +91 9123412345 to know more details. 
Regards, 
John, 
Manager, Customer Service. 

2. Now place the cursor next to Dear. Press F4 on your keyboard. Notice 

the data source used earlier is displayed (figure below). 
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3. Click on Namee, 

drag and drop iit 

after the texxt 

Dear. Notice thee 

field Name addedd 

adjacent appears. 

5. Click Yes. A Mail MMerge dialog box appears. 

6. Click OK. The Printt dialog box appears. 

Print this document and oobserve the field Name replaced with actuaal names 

from the data source makking it appear personalized. 

to this document 

(figure adjacent). 

4. Select File > 

Print…. A popup 

similar to the one 

EXERCISE 

Perform the following actiivities till you are confident: 

S.No. Activities 

1. Create a docume ent inviting your classmates for: 

a. Special we eekend lab classes for computer networ rks & web 

design. 

b. Weekend cclasses for engineering entrance exam prep paration. 

Collect email aaddresses of your classmates and save e it in a 

spreadsheet. Perf form a mail merge and send the invitation to all your 

classmates as: 

• HTML Messaage 

• Microsoft WWord Document (Attachment) 

• Adobe Acro obat Document, PDF (Attachment) 

2. Create newsletter rs for the following: 

a. Price list of Tablets & Smart Phones including technical 

specificatio ons & features. 

b. Price list ffor stationary items from at least three e different 

stores. 

Send this to your friends and classmates as an HTML messag ge. 

Use the following resources to download samples: 

a. http p://templates.openoffice.org 

b. http p://sourceforge.net/projects/aoo-template es/ 
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ASSESSMENT 

Answer the following 

1. Explain the purpose of mail merge. 
2. Explain the procedure to perform a mail merge for printing letters. 
3. Explain the procedure to perform a mail merge for sending an invitation 

as a PDF attachment. 

4. Explain the procedure to create envelopes using Mail merge. 

5. Explain the procedure to create labels using Mail merge. 

Fill in the blanks 

1. Mail merge Wizard option is available in ______ dropdown menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Create and use macros to automate tasks. 

RELEVANT KNOWLEDGE 

You have learnt to create macros in spreadsheet software. As in a spreadsheet, 

you can create macros in word processors too. As you know, a macro is created 

to combine a series of frequently repeated tasks into a single step. Macros help 

save time, increase efficiency, and improve productivity when a significant 

amount of work is repeatedly performed. The macro is created by "recording" a 

series of actions and assigning them to a single keystroke. The term "record" 

refers to the process of creating the macro and the term "run" refers to a macro 

execution. 

To understand macros, do the 

following: 

1. Open a new blank 

document. Select Tools > 

Macros. 

2. Click Record Macro. A 

Record Macro popup appears. 

3. Now do the following: 

a. Set the font to Verdana, Size 10. 

b. Insert a 5 x 5 table. 

4. Click Stop Recording. OpenOffice.org. Basic Macros dialog box appears. 

5. Type a name for 

this Macro, for 

example 

MyMacro01. 

Click Save. 

Now the macro is ready 

for use. Close the 

document. 

To use this Macro, do 

the following: 

1. Select File > New > Text Document. 

2. Select Tools > Macros. 

3. Click Run Macro…. A Macro Selector dialog box appears as shown below. 
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4. Expand My Macros > Standard > Module1. Notice the macro under Macro 

name (figure above, right). 

5. Select MyMacro01, click Run. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a macro for including a signature in a document using the 

following guidelines: 

4. Type your name in the first line. 

5. Include your contact number and email address in the second 

line. 

6. Format the signature to use verdana font, size 10. 

Save and apply this macro to a new document. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to create a macro with an example. 

Fill in the blanks 

1. Macros are available in _________ dropdown menu. 
2. You should select _____________ option in Macros submenu to record 

macros. 
3. You should select ___________ option in Macros submenu to execute a 

macro. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Link word documents to data stored in spreadsheets. 

RELEVANT KNOWLEDGE 

You can link worksheets from spreadsheet software to documents. You may 

come across a situation where you want to represent data (already existing) 

from a spreadsheet in the document you are preparing. You may also want that 

any change in the spreadsheet, should be reflected on your document too. 

Word processors have a feature that helps you to link data from external 

sources such as spreadsheets. 

This feature is useful when you want spreadsheet data to be available as a 

table in text documents and at the same time, you want to maintain a link 

between the two. To 

understand this, look at the 

following example: To learn 

how to link a spreadsheet to 

a document, do the 

following: 

1. Create a spreadsheet with the adjacent details. 

2. Save the spreadsheet, as scorecard.ods. 

3. Now create a new document similar to the one below. 

4. Switch to spreadsheet software. Copy the range from A1:D1 to A4:D4. 

5. Switch to the document and place the cursor where you want to paste 

this data (below the text Class 12th). 

6. Select Edit > Paste Special…. Paste Special dialog box appears (figure 

below). 
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Note: You can also use the shhortcut CTRL+SHIFT+V to launch the Pastee Special 

dialog box. 

7. Select DDE link from tthe Selection section and click OK. Notice  the cells 

are pasted as a table ((figure below). 

 

8. Save this documeent, for example 

Marksheet.odt. Close the document.  

9. Now change the valuees in the spreadsheet 

(replace names or marrks).  

10.Now open the word document; a popup 

appears similar to the one adjacent. 

11.Click Yes. Notice the vvalues are automatically updated. 

EXERCISE   

Perform the following activitiies till you are confident: 

S.No. Activities 

1. Create a spreadsheeet similar to the one in this session. Repplace the 

names in the spreaadsheet with names of your classmates. Populate 

the table with termm 1, 2 & 3 scores for a particular subject. 

Create a score carrd in word processing software using the ffollowing 

guidelines:  
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a. Create a structure similar to the one above. 

b. Include a logo at the right top and school address at the footer 

area. 

c. Replace “Subject Name” with a subject of your choice (match 

it the subject name in the spreadsheet). 

d. Link the data from spreadsheet to this document. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to link a range of cells from a spreadsheet to a 

document. 

Fill in the blanks 

1. Paste Special is available in ______ dropdown menu. 

2. Shortcut to launch the Paste Special dialog box _____________. 
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SESSION 7: SAVE A DOCUMENT OUTLINE AS A PRESENTATION 

 

 

          

  

           

        

  

               

              

                

            

            

             

              

            

      

              

             

         

            

          

             

  

       

          

        

     

    

    

    

   

   

   

  

    

       

     

  

            

      

Learning Objectives: 

At the end of this session, you will be able to: 

• Send a document outline to a presentation. 

RELEVANT KNOWLEDGE 

You can create an outline from a document and save it as a presentation. Being 

able to create outlines away from the presentation tool allows you to focus on 

content. You can style it up later in the presentation tool. It’s also a great help 

when you are working from someone else’s document, because you can markup 

an existing document and then quickly produce a presentation from it. 

An outline is a document that briefly summarizes the information that will be 

included in a paper, book, speech, or similar document. It shows the order in 

which the information will be presented and indicates the relationship of the 

pieces of information to each other. 

Outlines allow you to map your thoughts in a coherent and logical manner. They 

also help you identify if you have left out important information or added 

superfluous/unnecessary ideas. This is very important for creating great 

presentations too! Using a word processor you can write outlines by adding, 

deleting, reorganizing, or even completely revamping information as much and 

as often as needed. When satisfied, you can transfer the created outline to 

presentation software. 

To create an outline, do the following: 

1. Open a new blank document in word processing software. 

2. Create a document using headings (sample below): 

a. ETS Certifications (Heading 1) 

i. SAT (Heading 2) 

ii. TOEFL (Heading 2) 

iii. TOEIC (Heading 2) 

b. Cambridge ESOL 

Certifications (Heading 1) 

i. Business English 

(Heading 2) 

ii. IELTS (Heading 2) 

3. To send this document outline to 

a presentation, File > Send 

(figure adjacent). 

4. Click Outline to Presentation. Notice a presentation is created based on 

the document outline (figure below). 
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Note that only specific styles such as headings are imported to a presentation 

and normal text content are ignored. Also note pictures, objects, shapes, etc. 

cannot be sent to presentation software. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a document on the following topics: 

a. CAT 

b. GMAT 

c. TOFEL 

d. TOEIC 

Summarize the key points using heading levels 1 – 3; provide detailed 

information on the above mentioned topics. Create an outline in a 

presentation using the procedure dealt in this session. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to create a presentation from a document. 

Fill in the blanks 

1. _____________________ option from Send submenu should be used to 

send a document outline to a presentation. 
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SESSION 8: SAVE AND SHARE A DOCUMENT FOR REVIEW 

 

 

         

  

           

      

  

              

            

               

            

              

           

        

              

           

           

            

            

              

         

         

            
            

   

           

             

      

      

 

     

       

       

            

         

  

Learning Objectives: 

At the end of this session, you will be able to: 

• Prepare a document for review. 

RELEVANT KNOWLEDGE 

What does reviewing a document mean? A review is the task where a document 

is strategically analyzed to determine how well it fulfills its stated purpose, 

how effectively it conveys meaning, and how well it will serve the needs of the 

target audience. The person who reviews the document is called the reviewer. 

A reviewer indicates what is wrong in a document and points to solutions. The 

review process establishes a dialog between the reviewer and the author. 

Reviews occur when a document is under development. 

Now imagine if you were asked to review a printed document. You would use 

highlighters, color markers etc to highlight corrections and changes along with 

comments. Similarly, you can use the tracking and reviewing feature within 

word processing software to review, change and also track changes in a 

document. This feature comes in handy when you review /want someone to 

review a document and correct / point out mistakes before the final print. 

Note to Instructor: Combine this session with next session. 

For example, create a document with the following content: 

You can send a document for review using Windows Live Skydrive, Sharepoint 
Workspace, Google Docs, as an attachment through email, uploading to an ftp 
server, etc. 

Before sending this document for review, you should indicate that this 

document is to be tracked for changes. Tracking changes helps you to identify 

the proposed changes made to a 

document. To enable tracking, do the 

following: 

1. Select Edit > Changes. 

2. Click Record. Save this document. 

3. You can share this document for 

review through a variety of ways. For example, you can share this 

document through email to someone in your class. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Send the document to your classmates created in previous session for 

review. Enable tracking before sending the document. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of tracking and the procedure to track changes in a 

document. 

Fill in the blanks 

1. To enable tracking, you should select ______ option from Changes. 
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ISESSION 9: UNDERSTANDI NG TRACK CHANGES AND COMMENTS 

Learning Objectives: 

At the end of this session, youu will be able to: 

• Track changes, review changes and include comments in a documment. 

RELEVANT KNOWLEDGE 

In the previous session yoou learnt to enable tracking. To underrstanding 

tracking, you need to make cchanges to the document. 

Now as a reviewer, make thee following changes to the document: 

1. Change “Skydrive” to ““SkyDrive” 

2. Change “Sharepoint” tto “Share Point” 

3. Replace “ftp” with “FTTP” 

Notice the replaced text dissplayed with strikeouts (Sample below). SSince the 

tracking is enabled, word pprocessing software automatically adds addditional 

text formatting that is easy too visually track changes in a document. 

Inserting Comments 

You can also insert commennts in a document. This feature helps esttablish a 

dialog between the reviewerr and the author. Also, this is a means tto justify 

correction or provide additioonal guidelines. For example to insert a coomment, 

do the following: 

1. Place the cursor wheree you need to insert the comment or selecct a block 

of text. 

2. Select Insert > Commment. Include a comment, for example seelect the 

text “SkyDrive” and incclude the comment “d” should be capitalizzed. 

3. Now save this documment and send this back to the creatorr of this 

document. 

42 



 

 

  

            

            

             

      

    

  

  

 

  

 

  

   

 

 

              

       

           

           

            

             

   

       

        

 

      

    

       

     

  

    

             

             

             

     

Reviewing Changes 

Once the author receives the document, he/she can review the changes made 

to this document and easily identify through the highlighted areas in this 

document. You can accept or reject the changes made by a reviewer. To 

review each change, do the following: 

1. Select Edit > 

Changes > 

Accept or 

Reject….An 

Accept or 

Reject 

Changes dialog 

box appears as 

shown 

adjacent. 

2. Notice the list of items tracked; select an item under Action to notice 

the change made to the document. 

a. If you want to reject a change, click Reject. 

b. If you want to accept a change, click Accept. 

c. Select Accept All to accept all the changes in the document. 

d. Select Reject All if you don’t want to accept all the changes. 

Delete a comment 

To delete a comment, right-click on the 

comment. A popup appears similar to the one 

adjacent. 

a. To delete a single comment, 

click Delete Comment. 

b. To delete all the comments in 

this document, click Delete All 

Comments. 

Configuring the author name 

If you have noticed, the author name is displayed as “Unknown Author”. You 

need to configure the name of the author for word processing software to 

record the name along with other changes in the document. To specify an 

author name, do the following: 
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1. Select Tools > 

Options. An 

Options – 

OpenOffice.or 

g – User Data 

dialog box 

appears (figure 

adjacent). 

2. Type the name 

in First/Last 

name/Initials section (right pane) under User Data. 

3. Click OK. Now word processing software will display the name instead of 

“Unknown Author”. 

Using Filters 

Once you have set names, you can use the filter tab to display changes made a 

particular person, changes made on a particular date, etc. 

2. Select Edit > Changes > Accept or Reject….An Accept or Reject 

Changes dialog box appears. 

3. Select Filter tab. 

a. To filter based 

on a specific 

date, check 

Date and 

dropdown arrow 

next to Date 

(figure 

adjacent). 

b. Select 

appropriate 

value from this 

dropdown and 

select date & 

time. Observe 

the results. 

c. To filter changes 

made by a 

particular 

person, check Author. 

d. Select the name of the person from this dropdown list. Observe 

the results displayed. 

44 

https://Reject�.An
https://OpenOffice.or


 

 

   

          

            

             

    

           

 

   

 

   

  

    

   

 

  

  

  

   

            

 

   

        

  

              

  

 

 

   

            

  

           

    

            

  

             

       

  

Modifying Markup appearance 

Markup texts are comments, ink annotations, insertions and deletions, and 

formatting changes that you make during the review process. You can modify 

the color or style used to differentiate changes made to a document. To 

modify, do the following: 

1. Select Tools > Options. The Options – OpenOffice.org dialog box 

appears. 

2. Expand the 

OpenOffice.org 

Writer tree and 

select Changes. 

3. Modify the color 

and attribute by 

selecting 

different values 

listed under 

Attributes and 

Color dropdown. 

4. Click OK. Make changes to the document and observe the changes. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Review the changes made in the document sent to you in the previous 

session. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to accept and rejecting changes made to a 

document. 

2. Explain the procedure to modify markup appearance with an example. 

Fill in the blanks 

1. Accept or Reject option is available under _______ submenu of ____ 

dropdown menu. 

2. To accept all changes in a document, you should select ______ from 

Accept or Reject Changes dialog box. 
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SESSION 10: MERGING DOCUMENT CHANGES 

 

 

     

  

           

   

  

             

           

               

                

                

     

            

            

             

            

            

  

            

            

 

             

    

    

    

    

     

 

   

     

 

 

    

 

  

    

  

     

Learning Objectives: 

At the end of this session, you will be able to: 

• Merge documents. 

RELEVANT KNOWLEDGE 

The review processes learnt till now are effective when you have one reviewer 

at a time working on a document. Sometimes, however, multiple reviewers 

return edited versions of a document at the same time. In this case, to save 

time, you may want to review all the changes in one go, rather than work on 

one review at a time. To do so, you can use the word processor feature that 

helps you merge multiple documents. 

Consider another scenario: you may be working with multiple versions of a 

document and may need to compare different versions with the original to 

finalize the document. Here too, you can use the word processing software to 

compare each version of the document and merge different versions as one 

single final document! So much more simpler than a manual task! 

Comparing documents 

To understand how to compare documents, do the following step by step: 

1. Create a new document, type some content and save this as 

“document1.odt”. 

2. To enable tracking before you send this for review, select Edit > 

Changes > Record. 

3. Modify the document 

by adding content and 

then select File > 

Save As…. Save this as 

“document1v2.odt”. 

Close the document. 

4. Now open the first 

document 

document1.odt. 

5. Select Edit > 

Compare 

Document….An Insert 

dialog box appears as 

shown adjacent. 

6. Browse and select the 
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second document ddocument1v2.odt and click Insert. Observee the results 

displayed along wwith Accept or Reject Changes dialog box (figure 

below). 

 

7. Notice the documment displaying contents by comparingg both the 

documents as a ressult which you may find some text stroked--out. Review 

each change and cllick Accept or Reject button.  

Merging documents 

To understand merging doocuments, do the following: 

1. Create a new text ddocument. 

2. Type some content and save this as “article.odt”. 

3. You need to enablee tracking before sending this document tto others for 

adding content, sellect Edit > Changes > Record. 

4. Save the documentt.  

5. Now send this docuument to your classmate to add more conttent and ask 

him/her to send thee document back for review. 

Once you receive the doccument save the file with a different filee name (for 

example Articlev2.odt) to avoid confusion and do the following: 

6. Open the original ddocument (article.odt). 

7. Select Edit > Chaanges > Merge Document…. Browse andd select the 

second document (AArticlev2.odt) and click Open. 

8. Observe the resultts displayed along with Accept or Rejeect Changes 

dialog box (figure bbelow). 
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9. Observe 

the results 

displayed, 

review 

each item 

and select 

either 

Accept or 

Reject. 

 

 

 

EXERCISE   

Perform the following activitiies till you are confident: 

S.No. Activities  

1. Create an article onn the following topics: 

a. Starting an oonline gift shop, stationary shop & groceery store 

(online shoppping). 

b. Small Scale Inndustries 

• Provide an ovverview on selected topic and send the doocument 

to your classsmate and ask him/her to prepare addditional 

content. 

• Merge the doocuments once you receive the documentss; review 

and accept thhe changes only if they are correct.  

 

 

ASSESSMENT 

Answer the following 

1. Explain the procedure  to merge documents. 

Fill in the blanks 

1. Compare Document opption is available under _______ dropdown menu. 
2. Merge Document optiions is available under _____ submenu  of ____ 

dropdown menu. 
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SPREADSHEET 

SESSION 1: ADDING HYPERLINKS 

Learning Objectives: 

You have learnt to open, create and populate spreadsheets. You have also 

learnt about the different data types, how to format cells, manipulate data 

using formulae, and create charts to graphically represent the data. 

Now, in this module you will learn to use hyperlinks, pivot tables and pivot 

charts, compare, merge and protect spreadsheets. You will also learn to use 

digital signatures to protect spreadsheets. 

RELEVANT KNOWLEDGE 

As you already know, a hyperlink is a reference to a document, a location or an 

action that you can directly follow by selecting the link. You have learnt to 

insert and send hyperlinks in an e-mail message. You can use hyperlinks in 

spreadsheets too for the following: 

• Providing hyperlinks to websites 

• Listing e-mail addresses 

• Providing a link to a specific worksheet or a document. 

Create a hyperlink to a website 

You can create list of hyperlinks in spreadsheets. This may be useful when you 

want collect and keep list of valuable resources such as websites for additional 

references, important email addresses, etc. 

To create a hyperlink to a website, do the following: 

1. Open a new worksheet in spreadsheet software. 

2. Place the cursor where you want the 

hyperlink to be displayed, for example 

cell A1. 

3. Type the URL, for example 

www.google.com and press Enter. 

4. Notice the hyperlink automatically created and displayed (figure above). 

5. To modify the hyperlink text, 

select the cell where the link is 

located. For example, A1. 

Notice the URL displayed in the formula bar. 
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6. To modify the 

hyperlink, 

select the cell 

A1. Select 

Insert > 

Hyperlink. 

Hyperlink 

dialog box 

appears as 

shown 

adjacent. 

7. Replace www.google.com in Text textbox 

with Google. 

8. Click Apply and then Close. Notice the 

text replaced in the cell A1. 

Creating a hyperlink to an existing document 

You can create hyperlinks to documents available on your computer or another 

computer in your network. To create a hyperlink to a document on your 

computer, do the 

following: 

1. Open a new 

blank 

worksheet. 

2. Place the 

cursor where 

you want the 

hyperlink to 

be displayed, 

for example cell A1. 

3. Select Insert > 

Hyperlink. A 

Hyperlink 

dialog box 

appears 

(figure 

adjacent). 

4. Select 

Document (in 

the left pane). 

5. Click the 

folder icon , browse and select a file and click Open. 
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6. Click Apply and then Close. Notice the hyperlink to the document (figure 

below). Click on the link to open the document associated with 

corresponding application. 

Note: To provide links to documents on a network, use the UNC path (example: 

\\COMPUTERNAME\SHARENAME\FOLDER\FILENAME). 

Creating a hyperlink to a new document 

You can also create documents while creating the hyperlink. This is useful when 

you want to create the document after creating the hyperlink. 

1. Open a new 

blank 

worksheet. 

Place the cursor 

where you want 

the hyperlink to 

be displayed, 

for example cell 

A1. 

2. Select Insert > 

Hyperlink. The 

Hyperlink dialog box appears. Select New Document from left pane 

(figure above). 

3. To create a presentation and also embed a link to the presentation, do 

the following: 

a. To work with the presentation after this step, select the option 

Edit now. 

Note: If you want to edit the presentation at a later point in time, click Edit 

Later. 

4. Note: To work with the presentation at a later point in time, select Edit 

later. 

a. Type a file name for this presentation in File textbox, for example 

sales. 

b. Select Presentation from File type list. 

c. Type some title in Text textbox, for example: Beverage 

Campaign. 

51 



 

 

             

            

        

              

     

               

     

         

          

           

 

      

           

          

   

       

        

             

      

             

   

   

     

            

      

             

     

         

5. Click Apply and then Close. Notice the link created and displayed (figure 

below, left). Also notice the presentation created and launched in a new 

window for further editing (figure below, right). 

Editing documents after linking 

You can edit the document after linking (or if you have used the Edit Later 

option), by doing the following: 

1. Select the cell that has the hyperlink. 

2. Click on the hyperlink to edit the document. 

3. Close the external document once complete to return to this 

spreadsheet. 

Creating a custom hyperlink using HYPERLINK() 

Spreadsheet software includes a HYPERLINK function that is used for inserting 

hyperlinks in worksheets. The syntax of the HYPERLINK function is: 

HYPERLINK("URL", "Friendly Name") 

• Specify the location by replacing “URL” 

• Type a name by replacing “Friendly name”. 

To include hyperlink to a document on a web server, do the following: 

1. Open a new blank worksheet. 

2. Place the cursor where you want the hyperlink to be displayed, for 

example cell A1. 

3. Type =HYPERLINK("http://docs.google.com/annual_report.xls"; 

"Annual Report"). Press Enter. 

To include hyperlink to another sheet within a workbook, do the following: 

1. Open a new blank workbook. 

2. Place the cursor where you want the hyperlink to be displayed, for 

example cell A1, Sheet 1. 

3. Select Insert>Hyperlink. A Hyperlink dialog box appears. 
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4. Select Document from the left pane. 

5. Select Target in 

document icon. A 

Target in Document 

popup appears (figure 

below left). 

6. Expand Sheets (figure 

below right). 

7. Select the sheet 

name, for example 

Sheet 3. 

8. Click Apply and then Close. 

9. Type Income in the Text 

textbox. Click Apply and then 

Close. Notice the link created 

and displayed in Sheet 1 

(figure adjacent). 

Linking data from another workbook 

You can link data from different workbooks. This could be useful in situations 

when you want to consolidate data from other workbooks. For example if you 

have separate sales report for each region, you can summarize consolidated 

data in a separate workbook. Now, to understand how to link spreadsheets, you 

will create three workbooks. Two of them contain data (new and existing 

clients) of specific regions, while the third consolidates all together. 

1. Create a workbook similar to the one below: 
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2. Save this workbook, for example: Sales_region_delhi.ods. 

3. Create another workbook similar to the one below: 

4. Save this workbook with a different name, for example: 

Sales_region_mumbai.ods. 

5. Now to consolidate into a single worksheet, create a new spreadsheet 

similar to the one below (save this workbook as 

Sales_consolidated.ods): 

a. Open Sales_region_delhi.ods. 

b. Switch to sales_consolidated.ods workbook. Place the cursor in 

cell B3. 

c. Type =, switch to the first spreadsheet (Sales_region_delhi.ods) 

and select Cell B2. Press Enter. Notice the value displayed (notice 

the reference in the formula bar) from the first spreadsheet to 

this consolidated sheet (figure below). 
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d. Repeat the procedure for rest of the cells (B4 to B7& D3 to D7). 

e. Open Sales_region_mumbai.ods. 

f. Switch to sales_consolidated.ods workbook; place the cursor in 

cell C3. 

g. Type =, switch to the first spreadsheet and select Cell B2. Press 

Enter. Notice the value displayed from the first spreadsheet to 

this consolidated sheet. 

h. Repeat the procedure for rest of the cells (C3 to C7 and E3 to 

E7). 

i. You should see a result similar to the one below. 

j. Save the consolidated workbook. 

Now if you make changes to the first and second 

spreadsheets, data will be automatically updated in 

the consolidated worksheet. If you close and open the 

consolidated worksheet, you may receive a message 

similar to the one adjacent. 

Click Yes to update the data from both Sales_region_delhi.ods & 

Sales_region_mumbai.ods workbooks. 

Note: Since the consolidated workbook depends on the other two workbooks, 

both the workbooks must be present in the same location and file names must 

not be altered (If file names are changed, you will need to update the 

consolidated sheet manually). 

Alternate method to link 

1. Open the first spreadsheet (i.e. 

Sales_region_delhi.ods). 

2. Select the cells that you want to link, for 

example select B2 to B6. Select Edit >Copy 

(or CTRL+C). 

3. Switch to the consolidated workbook. Place 

the cursor where you want this data to be 

available, for example select Cell B3. 

4. Select Edit > Paste Special…. 
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5. Paste Special dialog box appears. Check Link (figure below). 

6. Click OK. Notice the content in cells B3 to B7 is pasted as a link. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a spreadsheet similar to the one below: 

Rename Subject 1, 2 & 3 to actual subject names. 

a. Populate this sheet with roll numbers, names and scores of your 

friends. 

b. Calculate the average. 

2. Create another spreadsheet in the same workbook similar to the one 

below and name the sheet as “Consolidated Average Score”. 

a. Display the average value in this sheet as hyperlinks. 

3. Create a spreadsheet similar to the one below: 
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Add additional fields such as Location, Mobile Number and timing to 

the right. 

a. Populate the website and email address fields as hyperlinks 

using Hyperlink function. 

 

 

           

   

          

   

 

 

   

           

  

 

    

            
 

      

  

ASSESSMENT 

Answer the following 

1. Explain the procedure to include hyperlinks in spreadsheets with different 

examples. 

Fill in the blanks 

1. To modify a hyperlink, you should select ________ from context menu 
(right-click). 

2. Hyperlink function syntax: _____________________ . 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Analyze data using pivot tables and pivot charts. 

RELEVANT KNOWLEDGE 

One of the most important and widely used features of spreadsheet software is 

Pivot tables and charts. Pivot tables and charts help in analysing large sets of 

data to make business decisions. 

For example, if a company has a large amount of data such as details of 

products sold across different locations, a pivot table can be used to analyse 

products that are sold the most at a particular location. This may help the 

company to understand the reason for high sales and replicate the same 

strategy in other locations. 

Pivot Table 

Pivot tables are summaries of data from a database such as a spreadsheet. 

Using Pivot tables, you can sort, count or view average of data stored in a 

spreadsheet or a different spreadsheet. Pivot tables help you quickly build 

reports because you can easily sort and visualize large amount of data. Pivot 

tables also allow you to change how your data is summarized with the least 

amount of effort (no complicated formulae changes in several places!). 

To understand how to use a Pivot table, do the following: 

1. Create a spreadsheet similar to the one below: 

2. Place the cursor in cell A1. Select Data dropdown menu (figure below 

left). 

3. Select Pivot Table, click Create…. Select Source dialog box appears as 

shown below (right). 
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4. Notice the range A1 to F10 is selected in the background. Since we need 

to use the entire range, click OK. A Pivot Table dialog box appears 

(figure below). You need to define what you need to analyse based on 

the data available here. Some of the common questions could be: 

a. How many of the total students are male (or female)? 

b. How many 

of them are 

from 

Bangalore? 

c. How many 

of them 

have their 

major as 

commerce? 

d. Which is the 

most preferred color? 

5. For example to view the total count of Gender, do the following: 

a. Drag and drop Gender (button) in Row Fields. Doing so will create 

a list box that can be used for filtering items from the list box. 

b. Drag and drop 

Gender (button) 

in Data Fields. 

c. Click Options… 

button. A Data 

Field dialog box 

appears as 

shown adjacent. 
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d. Select Count and click OK twice. 

Notice the Pivot table added to the 

worksheet (figure adjacent). 

Notice both male and female are displayed as 

categories along with individual count. Imagine the 

effort needed to filter and calculate the total count manually from a 

spreadsheet that had thousands of records! Using pivot tables, you can quickly 

get a summary of details from exhaustive data in no time! For example, an 

organization promoting a product for a particular gender could quickly come to 

a decision based on the summary. 

Now to display the count of students location-wise, do the following: 

1. Place the cursor in cell A1. Select Data>Pivot Table> Create…. 

2. Select Source dialog box appears, click OK. Pivot Table dialog box 

appears. 

a. Drag and drop City (button) in Row Fields 

b. Drag and drop City (button) in Data 

Fields 

c. Click Options… button. Data Field 

dialog box appears. 

d. Select Count and click OK twice. 

3. Notice the results displayed in the pivot table 

(figure adjacent). If you observe, the total 

count of students are displayed with city-wise 

breakup. 

This form of analysis enables making quick decisions. For example, the count 

helps you to conclude that the maximum number of students is from Bangalore. 

This helps you select the first location (ensuring maximum coverage) for a 

marketing campaign targeting students. 

Creating a chart from a pivot table 

A chart provides a visual representation of data. To create a chart from a pivot 

table, do the following: 

1. Select the range, 

for example 

A15:B19. 

2. Select Insert > 

Chart…. 

3. A Chart Wizard 

dialog box appears 

(figure adjacent). 
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4. Click Finish. Notice a chart created 

(figure adjacent) based on the data in 

the pivot table. 

Applying Filters 

You can apply filters to display selective data. 

For example if you want to display data only for selected cities, do the 

following: 

1. Click Filter Button 

located above the 

Pivot Table. Filter 

dialog box appears 

as shown adjacent. 

2. To display data 

only for Bangalore & Gurgaon, do the following: 

a. Select the dropdown arrow under Field name, select City. 

b. Select the 

dropdown arrow under Field name, select 

f. Select the dropdown arrow under Value, 

the filtered results 

dropdown arrow 

under Value, 

notice the values 

in this list. 

c. Select Bangalore. 

d. Select the 

dropdown arrow 

under Operator 

and select OR. 

e. Select the 

City. 

select Gurgaon. 

g. Click OK. Notice 

displayed (figure adjacent). 

You can also filter to find out the total number of male students from a 

particular city. For example, to filter and list the number of male students 

from Bangalore, do the following: 

1. Click Filter Button located above the Pivot 

Table. Filter dialog box appears. 

2. Select the dropdown arrow under Operator, 

select AND. 

3. Select the dropdown arrow under Field name, 
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select Gender. 

4. Select the dropdown arrow under Value, select Male. 

5. Click OK. Notice the results displayed (figure above). 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Create a spreadsheet with the data given below. 

Create a Pivot Table for the following: 

Sales 
Month/Year Item Person 

Jan/13 Washing Machine – Semi Auto Asha 

Jan/13 Washing Machine – Full Auto Kumar 

Jan/13 Dishwasher David 

Jan/13 Microwave Kumar 

Jan/13 Refrigerator – Standard Kumar 

Feb/13 Refrigerator – Double Door Kumar 

Feb/13 LED 27” TV David 

Air Conditioner – Window 1.5 
Feb/13 Ton Asha 

Feb/13 Air Conditioner – Split 1.5 Ton Asha 

Feb/13 Washing Machine – Semi Auto David 

Feb/13 Washing Machine – Full Auto Asha 

Feb/13 Dishwasher Kumar 

Mar/13 Microwave Asha 

Mar/13 Refrigerator – Standard David 

Mar/13 Refrigerator – Double Door Kumar 

Mar/13 LED 27” TV Asha 

Air Conditioner – Window 1.5 
Mar/13 Ton Asha 

Mar/13 Air Conditioner – Split 1.5 Ton Kumar 

Air Conditioner – Window 1.5 
Apr/13 Ton Asha 

Apr/13 Air Conditioner – Split 1.5 Ton Asha 

Apr/13 Washing Machine – Semi Auto David 

Apr/13 Washing Machine – Full Auto Asha 

Apr/13 Dishwasher Kumar 

May/13 Microwave Asha 

May/13 Refrigerator – Standard David 

May/13 Refrigerator – Double Door Kumar 

May/13 LED 27” TV Asha 

Air Conditioner – Window 1.5 
May/13 Ton Asha 

May/13 Air Conditioner – Split 1.5 Ton Kumar 

a. Display the count of Items sold by quantity. 

Qty. 

12 

15 

5 

30 

15 

17 

9 

8 

22 

10 

32 

10 

34 

23 

34 

10 

7 

12 

3 

12 

4 

34 

23 

12 

43 

7 

52 

18 

23 

Unit 
Cost 

7000 

18000 

33000 

4500 

5500 

12300 

55000 

17000 

28000 

7000 

18000 

33000 

4500 

5500 

12300 

55000 

17000 

28000 

17000 

28000 

7000 

18000 

33000 

4500 

5500 

12300 

55000 

17000 

28000 

Sales 

84000 

270000 

165000 

135000 

82500 

209100 

495000 

136000 

616000 

70000 

576000 

330000 

153000 

126500 

418200 

550000 

119000 

336000 

51000 

336000 

28000 

612000 

759000 

54000 

236500 

86100 

2860000 

306000 

644000 
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b. Display the quantity of items sold by each sales person. 

c. Display the Item / Quantity sold. 

d. Calculate the total Sales by Asha, Kumar and David. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of Pivot Table. 

2. Explain the procedure to create pivot table from a sample data. 

Fill in the blanks 

1. Widely used features of spreadsheet software are ________ and 
_________. 

2. ___________ are summaries of data from a database such as a 
spreadsheet. 

3. Pivot Table is available in _____ dropdown menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Create and use pivot charts. 

RELEVANT KNOWLEDGE 

Pivot Charts 

You can create pivot charts in addition to pivot tables using Microsoft Excel. As 

you know, charts help you visualize and understand complex data, easily. 

However, pivot charts are more useful than ordinary charts, because they are 

more easily manipulated to show different information as summaries. 

Moreover, a pivot chart can be moved / placed anywhere within a workbook or 

a different workbook , as per your requirement. In this session, you will learn 

about Pivot charts. 

To create a pivot chart, do the following: 

1. Create a new 

spreadsheet with 

the adjacent data: 

2. Select the data 

range, A1:F10. 

3. Select the Insert > 

PivotTable 

dropdown arrow 

(figure below left ). 

4. Select the option 

PivotChart. A Create PivotTable with PivotChart dialog box appears (-

figure below right). 
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5. Click OK. A new worksheet is created and displayed (figure below). 

6. Drag and drop Gender from Choose Fields to add to report: to Axis 

Fields Categories and Values. Notice a chart is created (figure below). 

7. You can also include other fields to this PivotChart. For example, if you 

want to visualize the breakup of Gender City-wise, select City from 
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Choose Fields to Add to report: and add that to Axis Fields Categories 

and Values. Notice the updated chart displayed (figure below). 

If you observe, data is 

now displayed 

graphically separated 

by city showing a clear 

break-up of Gender, 

city-wise. PivotChart 

can help in visualizing 

data quickly as 

compared to 

PivotTable. 

Though you have learnt the 

basics of PivotChart, it is recommended that you refer the help file or tutorials 

on the Internet. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a spreadsheet using the following data in Excel 2010: 

Month/Year Item 
Sales 

Person Qty. 
Unit 
Cost Sales 

Jan/13 Washing Machine – Semi Auto Asha 12 7000 84000 

Jan/13 Washing Machine – Full Auto Kumar 15 18000 270000 

Jan/13 Dishwasher David 5 33000 165000 

Jan/13 Microwave Kumar 30 4500 135000 

Jan/13 Refrigerator – Standard Kumar 15 5500 82500 

Feb/13 Refrigerator – Double Door Kumar 17 12300 209100 

Feb/13 LED 27” TV David 9 55000 495000 

Feb/13 Air Conditioner – Window 1.5 Ton Asha 8 17000 136000 

Feb/13 Air Conditioner – Split 1.5 Ton Asha 22 28000 616000 

Feb/13 Washing Machine – Semi Auto David 10 7000 70000 

Feb/13 Washing Machine – Full Auto Asha 32 18000 576000 

Feb/13 Dishwasher Kumar 10 33000 330000 

Mar/13 Microwave Asha 34 4500 153000 

Mar/13 Refrigerator – Standard David 23 5500 126500 

Mar/13 Refrigerator – Double Door Kumar 34 12300 418200 

Mar/13 LED 27” TV Asha 10 55000 550000 

Mar/13 Air Conditioner – Window 1.5 Ton Asha 7 17000 119000 

Mar/13 Air Conditioner – Split 1.5 Ton Kumar 12 28000 336000 

Apr/13 Air Conditioner – Window 1.5 Ton Asha 3 17000 51000 

Apr/13 Air Conditioner – Split 1.5 Ton Asha 12 28000 336000 

Apr/13 Washing Machine – Semi Auto David 4 7000 28000 
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Apr/13 Washing Machine – Full Auto Asha 34 18000 612000 

Apr/13 Dishwasher Kumar 23 33000 759000 

May/13 Microwave Asha 12 4500 54000 

May/13 Refrigerator – Standard David 43 5500 236500 

May/13 Refrigerator – Double Door Kumar 7 12300 86100 

May/13 LED 27” TV Asha 52 55000 2860000 

May/13 Air Conditioner – Window 1.5 Ton Asha 18 17000 306000 

May/13 Air Conditioner – Split 1.5 Ton Kumar 23 28000 644000 

Create PivotChart for displaying the following: 

a. Sales made by sales persons. 

b. Items sold in quantity. 

c. Items & total sales. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of Pivot Chart. 

2. Explain the procedure to create a pivot chart from a sample data. 

Fill in the blanks 

1. _____________ provides a visual representation of data. 
2. PivotTable is available in _______ group of _____ tab. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Use slicers to analyze data. 

RELEVANT KNOWLEDGE 

Slicers are one-click controls introduced in Microsoft Excel 2010 that can 

display data interactively when using pivot tables. Slicers can be used to 

display data interactively data i.e. when you apply a filter, data changes 

dynamically. 

A slicer is like an extension of a pivot table making filtering of data even more 

easy in the following ways: 

• Instead of using the drop down lists in the pivot table headings, you can 

click on a Slicer, to quickly filter the pivot table. 

• You can place a slicer anywhere you want on the spreadsheet and 

without moving the pivot table. 

Create a pivot table 

The first step to using a Slicer is to create a 

pivot table. Open the spreadsheet created in 

the previous session. Then do the following: 

1. Select the data range, A1:A10 to 

F1:F10. 

2. Select Insert tab > PivotTable > 

PivotTable. A Create PivotTable dialog 

box appears (figure adjacent). 

3. Click OK. A new worksheet is created 

(figure below). 

68 



     

  

  

   

   

   

  

  

 

 

  

    

    

   

   

  

   

  

   

   

    

 

    

    

    

   

    

     

   

   

     

 

  

       

      

     

       

         

 

 
4. To view count of gender, city-wise, do 

the following: 

a. Select Gendeer from Choose Fields 

to add to reeport:, drag and drop 

it to Row Labbels and Values. 

b. Select City ffrom Choose Fields to 

add to repoort:, drag and drop it 

to Row LLabels and Values. 

Observe thhe results (figure 

adjacent) 

Applying Slicer 

Now you can apply Slicerr to analyse data. To 

apply slicer, do the followwing 

1. Select Options tab.. 

2. Select Insert Sliceer dropdown arrow under Sort & Filter 

group 

3. Select Insert Sliceer from Insert Slicer dropdown menu. 

Insert Slicers dialogg box appears (figure adjacent). 

4. Insert Slicers dialoog box displays all the headers available; 

Check Group from this list and click OK. A popup appears 

similar to the one bbelow. 
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5. Now to quickly filter by a group, click on the group name in this list. For 

example, click Commerce. Notice the PivotTable displaying Gender and 

City count only for Commerce group (figure below). 

6. Now to know the 

gender-wise and city-

wise count for both 

Commerce AND 

Computer Science, 

select both Commerce 

AND Computer Science 

from group (to select 

multiple items, use 

CTRL + Click). Observe 

the results displayed (figure adjacent). 

You can also include slicers for multiple headers; this could be useful in 

situations when you large amount of data with multiple headers and need to 

quickly view filtered data. 

To use multiple headers, do the following: 

1. Delete the slicer (for example, select Group popup and delete). 
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2. Select Options > Insert Slicer > Insert Slicer. An Insert Slicers dialog 

box appears (figure below, left). 

3. Check Class and Favorite Color (figure above, right). Click OK. Observe 

the results displayed (figure below). 

4. Now you can filter just by a single click. For example, if you want to 

know the count of the Gender (of each city) that are from class 10th who 

prefer Orange color, select 10 from Class and Orange from Favorite 

color. Observe the results displayed (figure below). 
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Observe how quickly you can visualize data; imagine if you have hundreds or 

thousands of records that need to be analyzed. In such cases, both PivotTable 

and PivotChart can be of great help in analyzing data quickly. Now select other 

values from Class and Favorite color and observe the results. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Use the spreadsheet created in the previous session and do the 

following: 

a. Create PivotTable to include Items sold by Qty. 

b. Include the following items as filter slicers: 

i. Sales Person 

ii. Month/Year 

ASSESSMENT 

Answer the following 

1. Explain the purpose of Filter Slicers. 

2. Explain the procedure to apply slicers to a sample data. 

Fill in the blanks 

1. Slicer is a feature introduced in Microsoft Excel _____. 
2. Insert Slicer option is available in ______________ group under 

_________ tab. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Track and review spreadsheets. 

RELEVANT KNOWLEDGE 

In a work place, a workbook may be edited by multiple users, with each one 

making several changes in different places. In such a situation, it may be 

difficult to follow or track which entries were made by whom and when. As a 

solution, you can use the tracking feature of a spreadsheet to track all changes 

made. 

For example if you are collecting donation as a team, you may create a single 

spreadsheet and use the same spreadsheet to track progress. To understand 

tracking, do the following: 

1. Create a 

spreadsheet 

similar to the 

one adjacent. 

2. To enable 

tracking, 

Select Edit > 

Changes > Record. 

3. You also need to protect this 

spreadsheet so that the editor 

or reviewer need not remember 

to turn on the revision marks. . 

Select Edit > Changes >Protect 

Records…. Protect Records 

dialog box appears. 

4. Type a password in Password 

and Confirm textboxes. Click OK. 

5. Save this spreadsheet. 

Now you may send this spreadsheet for others to populate data. Once you 

receive the spreadsheet, do the following: 

1. Open the spreadsheet. 

Notice the changes are 

highlighted with a border; 

also comments are displayed 

when you move the mouse 
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over highlighted cells. 

2. You can also view changes by person, specific date or range of cells. For 

example to view 

changes made by a 

specific person, do 

the following: 

a. Select Edit > 

Changes > 

Show…. Show 

Changes dialog 

box appears as 

shown 

adjacent. 

b. Check Author and 

select the dropdown 

arrow. 

c. Select the name from this list and click OK. Observe the results 

displayed; notice the cells modified by the selected user is 

displayed. 

Accepting or Rejecting changes 

You have learnt to enable tracking in the previous session. If you are the 

administrative owner of the workbook, you may choose to accept or reject 

changes made by other users who updated this workbook. To accept or reject, 

do the following: 

1. Open the updated spreadsheet. 

2. You need to unprotect the spreadsheet 

to accept or reject changes. To 

unprotect, select Edit > Changes > 

Protect Records…. Unprotect Records 

dialog box appears as shown adjacent. 

3. Enter the 

password 

provided earlier 

and click OK. 

4. Select Edit > 

Changes > Accept 

or Reject…. 

Accept or Reject 

Changes dialog 

box appears 

(figure adjacent). 
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Now review each entry and click Accept (to accept the entry) or Reject (to 

reject the change) buttons. 

You may include additional information through notes or comments when 

working with spreadsheets; this could be useful to reviewer to know more 

details when required. 

To insert a comment, do the following: 

1. Place the cursor in a cell where you 

want to include a comment. 

2. Select Edit > Changes > 

Comments…. A window appears 

similar to the one adjacent. 

3. Type in the comment and click OK. 

View or Modify names 

You may have noticed different names in the popup and the author dropdown 

menus earlier. Spreadsheet software utilizes the names provided during 

installation by default and saves this information along with spreadsheets; 

however this can lead to confusion if a single name was used during 

installation. In such cases you can modify the user name by following the 

procedure below: 

1. Select Tools > Options. Options – OpenOffice.org – User Data dialog box 

appears (figure below). 

2. Notice the name of the user displayed in First/Last name/Initials text 

box (figure above). Type your name and click OK. 
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3. Repeat the procedure on all computers where you will open the 

spreadsheet from. Remember to keep unique names to avoid confusion. 

4. Now open the shared spreadsheet, make changes and observe the 

changes. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a spreadsheet similar to the one below: 

• Populate this sheet with roll number and name. 

• Enable tracking and protect this spreadsheet. 

Send this spreadsheet to your classmate and collect details of 

donation amount & status. 

2. Review each entry once you receive this spreadsheet; validate and 

accept only if it is correct. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to enable tracking in a spreadsheet. 

2. Explain the procedure to include your name when creating spreadsheets. 

3. Explain the procedure to review a spreadsheet and to accept or reject 

changes during a review. 

Fill in the blanks 

1. Show changes option is available under _______ submenu of _____ menu. 

2. Accept or Reject option is available under _______ submenu of _____ 

menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Protect spreadsheets. 

• Add comments to cells. 

RELEVANT KNOWLEDGE 

Spreadsheets may contain sensitive data that needs to be protected. It is 

recommended that you protect the spreadsheet from unauthorized users 

gaining access to it. You can also protect portions of a spreadsheet to avoid any 

accidental changes. 

As you are aware, a workbook contains a minimum of three sheets by default. If 

you want to restrict users to add or more sheets, do the following: 

1. Open a new blank workbook. 

2. Select Tools dropdown menu and select 

Protect Document. 

3. Select Document…. A Protect 

Document dialog box appears. 

4. Type a password in Password and 

Confirm textboxes. Click OK. 

5. Now try inserting additional 

worksheets. Notice you are unable to 

insert or delete any worksheets! 

To unprotect, do the following: 

1. Select Tools > Protect Document > 

Document…. 

2. An Unprotect Document dialog box 

appears. 

3. Enter the password provided earlier and 

click OK. Now you can insert or delete worksheets. 

Protecting Cells 

You can also protect specific cells of a worksheet. This is helpful when you 

want other to fill in information only in specific areas of the spreadsheet, 

without tampering the rest of the worksheet. For example, you can create a 

sales report sheet to be filled by team members but allow them to fill values 

only in certain cells of a worksheet. 
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1. Open a new spreadsheet and create the 

adjacent structure. 

2. Right-click cell C2, click Format > 

Cells….A Format Cells dialog 

box appears. Select the Cell 

Protection tab. 

3. Notice the default value set as 

“Protected”. Uncheck 

Protected, and click OK. 

4. Repeat this procedure for cells 

C3 and C4. 

5. Now select Tools > Protect 

Document > Sheet…. A 

Protect Sheet dialog box 

appears as shown below. 

6. Type a password in Password 

and Confirm textboxes. Click OK. 

7. Now try entering text in any other cell 

other than C2, C3 & C4. Notice that you 

are unable to enter any text as they are 

protected and a popup appears similar to 

the one below: 

8. Click OK. Now enter values in cells C2, C3 & C4; 

notice that only these three cells are editable as 

they are unprotected. 

Inserting Comments 

You can also include comments to specific cells. This could be useful in 

situations when you want to include instructions for users when they fill values 

in a field. To insert a comment, do the 

following: 

1. Place the cursor in the cell where 

you want to insert a comment, for 

example cell C2. 

2. Select Insert > 

Comment. 

3. Notice an empty 

yellow text box 

pointing to cell C2 is inserted. 

Note: To insert a comment, you may also use CTRL+ALT+C shortcut keys. 

4. Type the comment within the yellow text box . 
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5. Comments are automatically saved and 

displayed when you move the mouse 

pointer over the cell that has comments 

(comments are indicated by a tiny red 

square). 

Unprotect Cells 

To unprotect, do the following: 

1. Select Tools > Protect Document 

> Sheet…. 

2. An Unprotect Sheet dialog box appears. 

3. Enter the password provided earlier and click OK. Now you can edit any 

cell they the sheet is left unprotected. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a workbook for compiling list of under graduate courses . 

a. Replace Course 1, 2 & 3 with respective course names. 

b. Include more courses as required. 

c. Protect the cells that do not require editing (ideally everything 

except fields for typing College name and courses). 

d. Send this workbook to your classmates through email. 

e. Assign the task to each of your classmate to fill the details; ask 

them to include information about the source of details 

through comments. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to password protect a document. 

2. Explain the procedure to protect specific cells in a spreadsheet. 

Fill in the blanks 

1. To protect a workbook, you should use ______ option from 
_______________ submenu of _____ menu. 

79 



SESSION 7: MERGE WORKBOOKS 

 

 

     

  

           

   

  

             

            

              

             

               

            

              

    

       

     

       

 

            

          

             

      

       

            

 

        

              

   

        

        

                

  

             

     

      

 

       

      

Learning Objectives: 

At the end of this session, you will be able to 

• Merge workbooks. 

RELEVANT KNOWLEDGE 

You have learnt to merge documents using a word processor. Using the same 

concept, you can merge copies of shared workbooks into one final workbook. 

This is very useful when multiple users work on different copies of the same 

workbook and you need to consolidate all of them into a single workbook. 

For example, you may have created a spreadsheet and sent it to two of your 

classmates for populating data; when you receive the copies, you can merge 

and review both the copies at the same time. To understand how to merge 

workbooks, do the following: 

1. Create a spreadsheet in Sheet 1 

similar to the one adjacent. 

2. Create the same structure in Sheet 

2. 

3. You need to enable tracking as a pre-requisite for merging workbooks. 

So, select Edit > Changes > Record to enable tracking. 

4. Also a spreadsheet needs to be protected prior to merging. Hence, select 

Edit > Changes > Protect Record…. 

a. A Protect Records dialog box appears. 

b. Type in a password in both Password and Confirm textboxes, click 

OK. 

5. Save this spreadsheet (for example, Real Estate.ods). 

6. Now create two copies of this spreadsheet (File > Save As…) and name 

them as 

a. Real Estate Pricing -John.ods (fill sheet 1) 

b. Real Estate Pricing -Joe.ods (fill sheet 2). 

Now send this spreadsheet to two of your classmates and ask them to fill in the 

details. 

Once you receive the spreadsheets, store them in a single folder for easier 

access and do the following: 

1. Open the main spreadsheet (Real 

Estate.ods). 

2. Select Edit > Changes >Protect Records…. 

An Unprotect Records dialog box appears. 
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3. Type the password entered earlier and click OK. 

4. Now to merge the first spreadsheet (sent from John, Real Estate Pricing -

John.ods). 

a. Select Edit > Changes > Merge Document….An Insert dialog box 

appears. 

b. Browse and select the first spreadsheet (sent by John). Click 

Insert. Notice the contents from the first spreadsheet merged into 

this spreadsheet. Also notice the Accept or Reject Changes dialog 

box (figure below) appears for reviewing changes. 

c. Now review each change and click Accept. 

d. Close Accept or Reject Changes dialog box. 

5. Now to merge the second spreadsheet (Send from Joe, Real Estate 

Pricing -Joe.ods). 

a. Select Edit > Changes > Merge Document…. Insert dialog box 

appears. 

b. Browse and select the second spreadsheet (Sent from Joe), click 

Insert. Notice the contents from the second spreadsheet merged into 

this spreadsheet; also notice the Accept or Reject Changes dialog 

box (figure below) appears for reviewing changes. 

c. Now review each change and click Accept. 
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d. Close Accept or Reject Changes dialog box. 

In this example, you used two different worksheets in a workbook for better 

understanding. However, take extra caution when merging multiple 

worksheets; particularly, observe changes that happen during merging to avoid 

any confusion. Practice until you get a thorough understanding of this feature. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a spreadsheet similar to the one below: 

a. Create the same structure in sheet 2 and sheet 3. 

b. Rename the sheets to identify the location of the survey. 

c. Enable tracking and protect the workbook. 

Provide copies of this sheet to couple of your classmates; ask them to 

create at least 20 entries. 

2. Collect the spreadsheets from your classmates. Merge the 

spreadsheets based on the guidelines provided in this session. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to merge workbooks. 

Fill in the blanks 

1. To merge spreadsheets, you should select _________________ option 

from ________ submenu from _____ menu. 
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Learning Objectives: 

At the end of this session, you will be able to 

• Use digital signatures. 

RELEVANT KNOWLEDGE 

You can use digital signatures to assure authenticity of a spreadsheet. Digitally 

signing a document assures recipients that it was created by a known sender 

and not altered during transit. For example, manufacturing companies on 

sending out product and pricing details to distributors or dealers digitally sign 

the spreadsheet to assure authenticity. 

Digital certificate is an electronic document by itself that is used for encrypting 

other documents such as spreadsheets, audio or video files, etc. Digital 

certificates are acquired from a trusted third party digital certificate provider 

or internal IT department of an organization. 

Additional Information: http://en.wikipedia.org/wiki/Digital_signature. 

Note: You need to sign-up and install a digital certificate before you proceed; 

you may acquire a personal digital certificate (for free) from the following 

websites: 

• www.comodo.com 

• www.startssl.com 

• www.cacert.org 

Refer to the websites for detailed instructions on instructions and terms & 

conditions; Use Google to find out more websites that may offer digital 

certificates for free. 

Once you have the certificate 

installed, do the following: 

1. Create a spreadsheet 

similar to the one 

adjacent. 

2. Select File > Digital Signatures…. A Digital Signatures dialog box 

appears as shown below. 
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3. Click Sign Document…. A Select Certificate dialog box appears (figure 

below). 

Note: If you have more than 

one digital certificate, then you 

will find a list of certificate to 

choose from. Select the one 

that is most appropriate. 

4. Select the certificate from 

this list, click OK. Notice 

the results displayed (figure 

adjacent). 

5. Click Close. Notice the 

digital signature icon at the 

bottom of the spreadsheet software (figure below) indicating that the 

spreadsheet is digitally signed. Same signature details will be visible 
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when recipients view the spreadsheet and recipients can be assured that 

this document is not tampered and it is authentic as it is digitally signed. 

Digital Signature Icons 

You may have noticed the digital signature icon displayed at the bottom of the 

spreadsheet software ( ); Spreadsheet software includes the following icons 

to describe the state of the digital signature: 

a. Stylised red seal indicates document is OK and not altered 

since the time it was signed. 

b. Stylised red seal along with small yellow triangle indicates 

that the certificate is not validates; however the document is OK 

and not altered since the time it was signed. 

c. Yellow triangle indicates the digital signature is invalid. 

d. Yellow triangle with black exclamation indicates the document 

signature is broken; meaning the document is tampered and 

should not be trusted anymore. 

View Digital Certificate 

To view the digital certificate, do the following: 

1. Open the spreadsheet that is digitally signed. 

2. Select File > Digital 

Signatures….Digital 

Signatures dialog box appears 

(figure adjacent). 

3. Click View Certificate…. View 

Certificate dialog box appears 

(figure below). 

4. Notice the certificate details 

in General, Details and 

Certification Path tabs. 
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Important: Once a spreadsheet is digitally signed no alternation must be made 

as it is considered a final copy. If you alter the spreadsheet, you need to 

digitally sign the spreadsheet again. It is always recommended that you 

digitally sign only after the spreadsheet is finalized. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Apply digital signature to the workbooks created in the previous 

sessions. 

ASSESSMENT 

Answer the following 

1. Explain the concept of digital signature. 

2. Explain the procedure to digitally sign a document. 

Fill in the blanks 

1. _________ signing a document assures recipients that it was created by a 
known sender and not altered during transit when transferred 
electronically. 

2. _________________ is an electronic document by itself that is used for 

encrypting other documents such as spreadsheets, audio or video files, 

etc. 

3. To digitally sign a spreadsheet, you should select _______________ 

option from _____ menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Restrict access to a spreadsheet. 

RELEVANT KNOWLEDGE 

Imagine you have spent hours to create a sensitive spreadsheet and when that 

is sent to a group, someone prints or copies and circulates details without your 

consent. To avoid this, you can use a spreadsheet feature to protect the 

spreadsheet. However, you need to save the spreadsheet by converting to a 

PDF document. 

1. Create a new spreadsheet similar to the one below: 

2. Select File > Export as PDF…. A PDF Options dialog box appears (figure 

below - left). 

3. Select Security tab. 
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4. Click Set passwords… button. Set passwords dialog box appears as 

above – right. 

5. To set permissions, you need to provide a password first. Type in a 

password in Password and Confirm textboxes under Set permission 

password section. Click OK. 

a. If you do not want this PDF to be printed by others (including 

you), select Not Permitted under Printing section. 

b. If you do not want this PDF content to be copied by others 

(including you), Uncheck Enable copying of content under 

Changes section. 

6. Click Export. An Export dialog box appears as shown above (right). 

7. Type a name for this PDF file in File Name: and click Save. 

Now open this PDF file using Adobe Acrobat Reader; notice the copying 

(CTRL+C) and printing (File > 

Print) functions are disabled 

thus protecting this document 

being printed or copied. 

1. Open this file in Adobe 

Acrobat Reader. 

Notice the title bar 

with file name and 

encryption status as 

“Secured” (figure 
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adjacent). 

2. Select File > 

Properties. Document 

Properties dialog box 

appears; select 

Security tab (figure 

adjacent). 

3. Notice the values 

under Printing: and 

Content Copying:. 

4. Also exported PDF 

files are encrypted; to 

view details about 

encryption, click Show 

Details…. Document 

Security dialog box 

appears as shown 

below. Notice the 

value under 

Encryption Level:. 

Using IRM (Information Rights Management), Microsoft Excel 2007 

When you send spreadsheets to recipients, it may be accidentally printed, 

copied or forwarded to unauthorized people. Imagine if you have sent a 

confidential spreadsheet through email that should be viewed only by the head 

of finance department; this document may be viewed by others as you have no 

control! 
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To avoid such a mishap, you can restrict access by making use of Information 

Rights Management (IRM) which gives you the following advantages: 

• Restrict spreadsheet being copied, printed or forwarded 

• Set expiration so that it cannot be viewed after a specific duration 

• Restrict users from using Print Screen feature to capture the screen! 

Note: You need to have an active internet connection and a Microsoft 

Account for this exercise. 

To understand restricting 

document access using IRM, 

do the following: 

1. Open an existing 

spreadsheet. 

2. Select File > 

Prepare. 

3. Select Restricted Access. A 

Service Sign-Up popup appears 

(figure adjacent). 

4. To use this service, you need to 

have a Microsoft Account (Live, 

Hotmail or Outlook.com). To 

signup, select Yes, I want to sign 

up for this free trial service 

from Microsoft. Click Next. You 

will see a window similar to the 

one below. 

1. Select Yes, I have a Microsoft account. Click Next. 
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2. Enter the email address 

and password, Click 

Sign In. You will see a 

window similar to the 

one adjacent. 

a. If you are using 

your own 

computer, select 

This is a private 

computer. 

b. If you are using a 

shared computer 

(browsing centre, 

computer lab, 

etc.), select This 

is a public or 

computer. 

c. Click I Accept. 

Note that this process will take some 

time. You may notice 

certificate dialog box, click Yes if you 

receive such notifications. 

3. Click Finish 

Now you can configure permissions by 

following the procedure below: 

shared 

security 

1. Ensure Restrict Permissions to this workbook is checked (figure below). 

2. Click More Options….A Permission dialog box appears (figure below). 
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Permissions: 

a. Read: Users can only read but cannot copy, print or edit. 

b. Change: Users can read, edit and save changes but cannot print. 

c. Full Control: Users can do anything with the spreadsheet. 

3. Click OK. 

4. Now you can send this spreadsheet to intended recipients. 

Note: 

• Anyone who attempts to open this file must have a Microsoft Account 

and use the correct email address as specified for permissions. 

• Permissions will automatically apply when they attempt to open the file. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Apply content and printing protection to the spreadsheets created in 

the previous sessions (Save as PDF) using OpenOffice.org Calc. 

2. Restrict a document by making use of IRM using Microsoft Excel. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to protect a spreadsheet from being copied when 

exporting as a PDF document. 

2. Explain the procedure to protect a spreadsheet from being printed when 

exporting as a PDF document. 

92 



 

 

    

             
      

              
           

 
     

          

     

  

Fill in the blanks 

1. To allow others not to print, you should select __________ under Printing 
section in PDF Options dialog box. 

2. To allow others to print but not copy the content, you should ______ 
Enable copying of content under Changes section in PDF Options dialog 
box. 

3. Acronym for IRM: _______________________. 

4. ______ can protect documents from being accidentally printed, copied 

or forwarded to unauthorized people. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Share a workbook. 

RELEVANT KNOWLEDGE 

When you work with spreadsheets only one person can edit at a time by 

default; all other users will be able to open only a read-only copy of the 

spreadsheet. 

You can share a workbook in spreadsheet software. This could be useful in 

situations when you need to have multiple users working a single workbook. For 

example if you have a workbook for updating customer records by multiple 

users, you can share the workbook allowing others to have read-write access. 

First step is to provide access to other users on a network. You should save the 

workbook in a folder that is accessible by other users on a network. To share 

the folder that has the spreadsheet, do the following: 

1. Right-click the Folder, select Properties. 

2. Select Sharing tab, provide Full Control to Everyone group. 

3. Access this shared folder and confirm if you are able to access this folder 

over the network. 

4. Create a spreadsheet and save that in this shared folder. 

5. Keep this spreadsheet open on your computer and try accessing this 

spreadsheet from other 

computers on this 

network. This 

spreadsheet is opened 

in Read-only mode on 

other computers 

(Notice the message at 

the top above menu bar): 

6. Now close the spreadsheet on other computers. 

To share a workbook, do the 

following: 

1. Open a new spreadsheet and 

create the adjacent structure. 

2. Save this spreadsheet in the 

shared folder with a file name, 

for example Latest Price.ods. 
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3. Select Tools > Share Document…. 

Share Document dialog box appears 

as shown adjacent. 

4. Check Share this spreadsheet with 

other users and click OK. A popup 

appears similar to the one below: 

5. Click Yes. Now this spreadsheet is 

shared (figure adjacent). 

6. Go ahead and populate A3 to A7 

with list of items and their price in 

B3 to B7. 

7. Save the spreadsheet; close this spreadsheet open on your computer. 

Accessing shared spreadsheet 

1. Open this 

spreadsheet 

from another 

computer. A 

popup appears 

similar to the 

one adjacent. 

2. Click OK. 

3. Go ahead and update C3 to C7. 

4. Save the spreadsheet. 

Now open the spreadsheet on your computer; notice the updated entries 

(Sample below). 

If there are conflicts, you may see a red border around the cells (move your 

mouse over to view changes) as shown below. 
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Important note: 

Following list of items is disabled in a shared spreadsheet (not limited to): 

• Edit > Compare Document 

• Insert > Names 

• Insert > Object 

• Insert > Comment 

• Format > Print Ranges, etc. 

For complete list of disabled items, refer to the following URL: 

http://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Calc_Gui 

de/Sharing_documents_among_reviewers 

It is highly recommended that you share only after finalizing the structure of 

the workbook. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a spreadsheet similar to the one in this session (figure below). 

a. Populate with list of computer accessories under Items. 

b. Share this workbook and assign the task of collecting pricing 

details from your classmate (one shop per classmate). 

c. Consolidate the data from your classmates and share with rest 

of the class. 
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ASSESSMENT 

Answer the following 

1. Explain the procedure to share a workbook. 

Fill in the blanks 

1. You need to _____ a workbook if you want multiple users to edit at the 
same time. 

2. Share Document option is available in ______ dropdown menu. 
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PRESENTATION SOFTWARE 

SESSION 1: INSERTING AND MODIFYING SMARTART GRAPHICS 

Learning Objectives: 

In previous sessions, you learnt to create presentations, include tables, charts, 

audio and video clippings. You also learnt to animate objects, review content, 

print a presentation, design presentation templates, create handouts and 

notes, etc. In this module, you will learn to work with SmartArt graphics, 

customize animation & slide shows, annotate presentations and create 

presenter-independent slide shows. 

At the end of this session, you will be able to: 

• Use SmartArt graphics in presentation software. 

RELEVANT KNOWLEDGE 

You have already learnt about SmartArt graphics and have learnt to use it in 

Word processing & Spreadsheet software. In this session you will learnt to use 

SmartArt graphics in presentation software. As you know, SmartArt graphics is a 

feature of Microsoft PowerPoint that has pre-defined styles for use in 

presentations. 

You can create diagrams using SmartArt graphics. For example, when you 

create a presentation for presenting a company’s profile, you can use SmartArt 

graphics to include an organizational chart representing a company’s structure. 

To create an organizational chart representing a company’s structure, open a 

new blank presentation and do the following: 

1. Select Insert tab and 

click SmartArt from 

the Illustrations 

group. 

2. A Choose a SmartArt 

Graphic dialog box 

appears as shown 

adjacent. 

3. Select Hierarchy, and 

select Organization Chart (middle pane). Click OK. Notice the 

Organizational chart inserted in the presentation (figure below). 
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4. Now you need to aadd text to illustrate the organizational sttructure. To 

modify the defaultt text, enter the following under Type youur text here 

section: 

a. First Level: CCEO 

b. Second Levell: General Manager 

c. Third Level: Human Resources, Finance, Operations 

5. The organizzational 

structure (illuustrated 

adjacent), is now 

displayed as a hieerarchy 

which is easieer to 

understand. 

Modify a SmartArt 

You can use the Design tab to 

enhance the visual appeaarance of the SmartArt. Here you can cuustomize the 

color, style and layoutts of a 

SmartArt. To apply a stylee, do the 

following: 

1. Select Design tab. 

2. Select White Outline 

available in SSmartArt 

Styles group andd apply. 

Notice the visuaal effect 

changed (figure adjjacent). 

Use the list given below to select the appropriate illustration for a workflow 

process: 

• Use List, to illustraate a list that does not follow a step-by-stepp process. 

• Use Process, to illuustrate a one way process. 

• Use Cycle, to illustrrate a continuous process. 

• Use Hierarchy, too illustrate tree structure such as an orrganizational 

chart. 

• Use Relationship, tto illustrate connections between sets. 
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• Use Matrix, to illustrate how parts relate to a whole. 

• Use Pyramid, to illustrate a top to bottom proportional relationship. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Create presentation on the following titles: 

a. Rain Water harvesting 

b. Water Treatment process for drinking water 

c. Solar Energy Process 

Use appropriate SmartArt Graphics for illustrating the step-by-step 

process. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of SmartArt graphics in Presentation Software. 

Fill in the blanks 

1. SmartArt option is available in _____________ group of _______ tab. 
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Learning Objectives: 

At the end of this session, you will be able to 

• Use multimedia elements in a presentation. 

RELEVANT KNOWLEDGE 

You have already learnt to use clip arts and shapes in previous sessions. In this 

session you will learn to use audio & video elements in a presentation. You can 

enhance a presentation by audio & video content. Presentation software 

contains built-in movie clips that you can use in a presentation. To use a built-

in movie clip, do the following: 

1. Open a new blank 

presentation. 

2. Select Insert > 

Movie and Sound. 

An Insert Movie and 

Sound dialog box 

appears (figure 

adjacent). 

3. Browse and select 

the clip you want to 

use and click Open. 

Notice the clip 

inserted into the 

presentation. 

4. Notice the Media Playback 

controls available above the drawing 

toolbox (figure below). You may use 

this to play or check the movie clip 

that you inserted earlier. 

5. Play the presentation to view 

the clip (Press F5). Notice the movie 

clip played automatically. 
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Tip: You can add music or voice tracks to presentations. You can use this 

feature to narrate a presentation or play a mild music during presentation. 

Similarly, you can add audio clips either from Clipart or from your own 

collection. Go ahead and try inserting different audio clips and observe the 

results. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Download relevant movie clips for topic selected in the previous session 

from youtube.com (use clips in public domain) and include them in the 

presentation. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to include multimedia elements in a presentation. 

Fill in the blanks 

1. You should select ___________ option from Insert dropdown menu. 
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Learning Objectives: 

At the end of this session, you will be able to : 

• Customize slide components using animations. 

RELEVANT KNOWLEDGE 

You can animate the text and objects in a presentation to make your 

presentation more interesting. You could also use this feature to emphasise a 

particular text, paragraph or an object by attracting the attention of the 

audience. 

To use animations in a presentation, do the following: 

1. Create a new presentation. Include text, 

shapes, etc. when creating content (refer 

adjacent figure). 

2. Select an object (for example, the title), 

right-click. A popup appears similar to the 

one below. 

3. Click the option 

Custom Animation…. A 

Custom Animation sub-

section appears in the Tasks 

pane (figure below left). 

4. Under Modify Effect, 

click Add…. A Custom 

Animation dialog box 

appears (figure below right). 

a. Entrance tab: Apply effects when introducing objects on to the 

screen. 

b. Emphasis tab: Apply effects such as changing Font color, size, 

etc. when introducing text objects. 

c. Exit tab: Apply effects when you want objects to “disappear”. 

d. Motion Paths tab: Apply moving effects to Objects. 

e. Misc Effects tab: Apply special effects to multimedia objects. 
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5. Select an effect, for example Dissolve In effect in Entrance tab and set 

the speed to Very slow from Speed dropdown 

list. 

Note: A preview is shown when an effect is 

selected; experiment to choose an effect and 

adjust the speed if required. 

6. Click OK. 

Each animation has the following three choices: 

a. On Click, the animation starts after a mouse 

click. 

b. With Previous, the animation runs at the 

same time as the previous animation. 

c. After Previous, the animation runs after the 

previous animation ends. 

7. Repeat the procedure for other objects; use 

different effects. 

8. Play the presentation (Press F5) and observe the 

effects applied. 

Advanced Animation Options 

You can also customize the animation further by, doing the following: 
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1. Click Effects Option button ( ) next to property (figure below, left). 

Effect Options dialog box appears (figure below, right). 

 

            

         

  

               

  

           

            

            

 

            

 

      

   

        

  

 
           

 

 

   

            

 

    

          

     

  

2. To add a sound clip, click the dropdown arrow next to Sound and select 

a clip. 

Note: Click on the Play icon to preview the audio clip. 

3. To adjust animation timings, select Timing tab and adjust values. 

4. To animate text, select Text Animation tab and select from different 

options. 

5. Click OK. Play the presentation (Press F5) and observe the effects 

applied. 

Now try using different animation effects. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Animate the movie clip inserted in the previous session; use different 

effects. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to animate text and objects in a presentation. 

Fill in the blanks 

1. List any five effects available in Entrance tab: ___________, 

____________, ______________, __________ & ______________. 
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SESSION 4: CUSTOMIZING A SLIDE SHOW 

 

 

      

  

            

    

  

             

              

             

                

     

            

           

  

         

         

 

 

Learning Objectives: 

At the end of this session, you will be able to: 

• Customize slide shows. 

RELEVANT KNOWLEDGE 

Imagine a scenario where you make a presentation for the school principal with 

results of classes from Nursery to Class XII. When the principal has a meeting 

with the primary, middle or senior school teachers, only the slides relevant to 

them need to be displayed. In such a case you need to customize the slide show 

to play selected slides. 

In the example here, you will create a single presentation about different 

departments of an organization but present selective slides using a customized 

slide show. 

To understand customizing a slide show, do the following: 

1. Create a presentation with 5-6 slides (sample below). 
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2. Select Slide Show menu (figure adjacent). 

3. Click Custom Slide Show…. A Custom Slide Shows 

dialog box appears (figure below). 

4. To create a new custom slide show, click New…. A Define Custom Slide 

Show dialog box appears (figure below). 

5. Type a name in Name:, for example Show1. Select slides 1, 3 and 5 and 

click . Notice the slides under Selected slides (figure below). 
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6. Click OK. Notice the custom slide show is listed (figure below). 

7. Click Start to play this custom slide show. Notice only Slide 1,3 & 5 are 

displayed. 

Keyboard Shortcuts 

Shortcut Description 

F5 or F9 Start a slide show 

Esc, Backspace End a slide show 

Right Arrow or Spacebar Next slide 

Left Arrow Previous slide 

Home First slide 

End Last slide 

B Black screen during presentation 

W White screen during presentation 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Create a custom show to include selective slides of the presentations 

created earlier. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to create a custom slide show. 

Fill in the blanks 

1. Define Custom Slide Show option is available in _______________ dialog 
box. 

2. Custom Slide Show option is available in __________ dropdown menu. 
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SESSION 5: ANNOTATE A PPRESENTATION 

Learning Objectives: 

At the end of this session, youu will be able to  

• Annotate presentationss. 

RELEVANT KNOWLEDGE 

Annotations refer to specificc key points in a presentation. When you ddeliver a 

presentation, you may want to highlight certain key points for the auddience to 

pay special attention or to reemember those key points. Imagine if youu want to 

deliver a present a school quuarterly score report to an audience, you mmay need 

to highlight the toppers in yoour presentation. 

To understand how to use annnotation, do the following: 

1. Create a new presentaation. 

2. Select Insert > Chart.  

3. Use the following daata to 

populate for the chart:: 

4. To annotate, do  the 

following: 

a. Insert a callout and type 

the text “Class 

Topper”.  

b. Drag the calloout point 

to the person haaving the 

highest score  (figure 

adjacent). 

Annotating during presentattion 

You can annotate while makking a presentation; this is possible by higghlighting 

specific text or object (tto 

emphasize a point) usinng 

“Annotation Pen” during a 

presentation. 

To annotate using th he 

“Annotation Pen”, do th he 

following: 

1. Select Slide Show > 

Slide Show Settings……. 

Slide Show dialog boox 

appears as showwn 
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above. 

2. Select the optiion Mouse 

pointer as pen andd click OK. 

3. Play the presentaation (Press 

F5). Notice the currsor appears 

like a pen; you maay highlight 

by drawing a cirrcle (figure 

adjacent). 

Tip: You can animate thee callout or 

play a background claapping clip 

during this part of thee presentation to attract more presenntation. Try 

experimenting with ways oof annotation and observe the results. 

EXERCISE 

Perform the following actiivities till you are confident: 

S.No. Activities 

1. 
Create a slide to include a chart for displaying scores of tthe previous 

term for at least 33 subjects 

a. Include a rrectangular callout to annotate the top tthree in the 

class. 

b. Present it tto the class and annotate using Annotation n Pen during 

the presenttation. 

ASSESSMENT 

Answer the following 

1. Explain the proceduure to annotate a presentation using callouuts. 

Fill in the blanks 

To use a mouse poiinter as a pen, you should select ___________________ 

in ________ dialog box. 
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SESSION 6: USE A PRESENTER VIEW 

 

 

      

  

           

    

  

           

           

           

    

               

              

          

    

    

    

    

      

    

 

     

   

    

   

  

    

         

  

             

               

  

           

             

     

   

            

       

Learning Objectives: 

At the end of this session, you will be able to: 

• Use presenter view. 

RELEVANT KNOWLEDGE 

When you make electronic presentations, you can use two different monitors; 

one monitor/projector to exhibit the presentation to the audience and your 

own monitor where you can view additional notes/ documents for reference 

during the presentation. 

In this session, you will learn to configure a presentation to run for an audience 

on one display medium, and at the same time, displaying other items such as 

requires two monitors and 

appropriate support using a 

video card. Most laptops 

support this facility (though 

not all desktops do so unless 

they have the requisite 

hardware). 

1. Select Slide Show > 

Slide Show Settings…. 

Slide Show dialog box 

appears as shown 

adjacent. 

2. Select the second 

monitor from Presentation display dropdown list, for example Display 

2. 

Note: Display 1 (primary) refers to the computer which you are using and 

Display 2 refers to an external display unit such as a second monitor or a 

projector. 

3. Play the presentation (Press F5); notice the presentation is displayed 

only on the second monitor. You may now refer to other documents on 

your monitor during this presentation. 

Presenter Screen Extension 

Presenter Screen is an add-on for OpenOffice.org Impress that allows you to: 

a. View slides different than the audience. 

notes/handouts along with the presentation on your monitor. Note: This 
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b. Preview next slide. 

c. View notes of current slide. 

d. View timing. 

e. View navigation menu for entire presentation. 

To download and install the presenter screen, do the following: 

1. Go to http://extensions.openoffice.org/en/node/814/releases. 

2. Select 1.1.0-Win32 (Windows) and click the download button. Save the 

file to the local drive. 

3. Go the saved location and 

double-click oracle-

presenter-screen.oxt. A 

dialog box appears similar to 

the one adjacent. 

4. Click OK. An Extension 

Software Licence 

Agreement appears 

(figure adjacent). 

5. Scroll down till the end 

and Click Accept. Click 

Close. 

To use a presenter’s screen, do 

the following: 

Note: You must have two 

monitors. 

1. Open an existing presentation. 

2. Play the presentation (Press F5). Notice the presenter console on your 

computer (figure below, left) and the presentation played to the 

audience on the second monitor (figure below, right). 
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Observe the current and next slide appears on your computer along with notes; 

only the presentation appears on the second monitor. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Configure the slide show to display presentation on a secondary 

monitor. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to display the presentation only on a second 

monitor or a Projector. 

Fill in the blanks 

1. You should select ________ from presentation display dropdown list to 

display presentation on an external display unit. 
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SESSION 7: AUTOMATICCALLY REPEAT A SLIDE SHOW 

Learning Objectives: 

At the end of this session,, you will be able to: 

• Configure a slide shhow to repeat automatically.  

RELEVANT KNOWLEDGE 

Generally when you run aa slide show, to proceed from one slide tto the next, 

you need to press a key/ click the mouse. It is also however possiblle to deliver 

a presentation without usiing mouse-clicks and even to configure a reepeat of the 

presentation automaticallly. You may have seen a presentation beinng delivered 

without a presenter’s inttervention in a kiosk, trade show, etc. Yoou may have 

noticed slide shows in malls, reception area in an office, eetc. playing 

advertisement-like slide shows. These are all played using the automated 

feature of presentation sooftware. 

To configure a presentatioon to advance slides automatically, you neeed to define 

the display timing for eachh slide.  

To define specific timinng for all slides, do the 

following: 

1. Open an existing prresentation. 

2. Select Slide Show >> Slide Transition….  

3. Under Advance Sllide, select Automatically 

after to set a time.. For example, 3 seconds.  

4. Click Apply to all SSlides. 

5. Play the presentattion (Press F5). Notice the 

slide advancing too next slide automatically 

after 3 seconds. 

To define specific timingg for each slide, do the 

following: 

1. Select Slide Show >> Rehearse Timings. 

2. Slide show starts wwith a timer displayed at 

the left-bottom corrner of the screen. 

3. Click when you wannt to advance to the next 

slide after a speciific duration; repeat the 

process for all slidees.  

4. Save the presentattion. Impress displays the 

recording durationn along with the slides, 

switch to Normal  and observe the timing 
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under Automatically after option in each slide (figure adjacent). 

5. Play the presentation (Press F5). Notice the slide advancing to next slide 

based on the timing set for each slide. 

If you want to repeat the slideshow once again when the presentation is 

complete (loop the 

presentation), do the following: 

1. Select Slide Show > 

Slide Show Settings…. 

Slide Show dialog box 

appears (figure 

adjacent). 

2. Select Auto under Type; 

type in the duration for 

repeating the slide show. 

For example 5 seconds 

(figure below). 

3. Click OK. Play the 

presentation (Press F5). 

4. A window appears similar 

to the one below. 

5. Notice the countdown at 

the right-top corner; also notice 

the slide show repeats from the 

first slide after the count down. 

Using Microsoft PowerPoint 

To set up a slide show to repeat automatically in Microsoft PowerPoint, do the 

following: 

1. Open an existing presentation. 

2. You need to include timing for 

slides to automatically move 

from one slide to another. Select 

Slide Show tab. 

3. Click Rehearse Timings in Set Up 

group (figure adjacent). 
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4. Rehearse toolbar (figure adjacent) appears along with the Slide Show. 

5. Click Next to move to the next slide after a particular duration for 

each slide. For example, click every 5 seconds. 

6. Once you have reached the last slide, click Close in the Rehearsal 

button. A popup appears as shown below displaying the total timing for 

this slide show. 

7. Click Yes. Go to Slide Sorter View. 

8. Notice the timing displayed next to the slides (figure above). 

9. Now play this presentation (F5). Notice the slide advancing every five 

seconds. 

If you want the slide show to repeat once again from the beginning after the 

last slide, do the following: 

1. Select Set Up Slide Show 

in Set Up group. 

2. Check Loop continuously 

until ‘Esc’ under Show 

Options (figure 

adjacent). 

If you want to view the 

presentation manually after 

including rehearses timing, do 

the following: 

1. Select Set Up Slide Show 

in Set Up group. 
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2. Select Manually in Advance Slides section (figure above). 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Apply slides to automatically advance every 10 seconds for the 

presentations created in previous sessions; repeat the slide show after 

3 seconds. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to advance slides automatically after a specific 

duration. 

2. Explain the procedure to advance each slide with a custom timing 

(manual). 

Fill in the blanks 

1. Rehearse timing option is available in ___________ dropdown menu. 
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E-MAIL MESSAGING 

SESSION 1: SEND CALENDAR INFORMATION IN AN E MAIL MESSAGE 

Learning Objectives: 

You have learnt to use e-mail messaging software to send, receive and format 

e-mail messages, insert hyperlinks, and sort and filter messages, etc. You have 

also learnt to use your calendar software to manage events and tasks, change 

work weekdays, manage task requests, etc. 

Now, in this module, you will learn about sending calendar information via e-

mail, send personalized e-mails, organize e-mails, manage data files, delegate 

e-mail and calendar access. 

At the end of this session, you will be able to: 

• Send calendar information in e-mail message. 

RELEVANT KNOWLEDGE 

You have learnt to schedule appointments earlier using calendar software. 

Now, imagine a situation where you are heading a team and want to appoint a 

team member to participate in official meetings in your absence. You can 

create the events and/or tasks in your calendar and send the information to a 

team member to attend the meeting. 

To start learning about send calendar information in e-mail message, first, 

open your calendar software and create 

few appointments in it. 

To send the calendar, do the following: 

1. Right-click Calendar, a popup 

appears as shown adjacent. 

2. Click Export Calendar… (figure 

above). Export dialog box 

appears (figure adjacent). 

3. Select Save as type: dropdown 

menu (figure below). 

You can send the calendar in one of 
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the three following formats: 

a. iCalendar (.ics), a popular format supported by most calendar 

software. 

b. Web Page (.htm or .html), to publish in personal or company 

websites (for example, you can publish training or public events 

through your website). 

c. Outlook Comma Seperated Values (.CSV), a format supported for 

use with Microsoft Outlook. 

4. Select iCalendar (.ics). 

5. Type a name in File name:. (For example, type your name as you are 

sharing your calendar; this will be easy for others to identify). 

6. Click Save and send this calendar as an attachment to your classmate. 

Recipients when they receive this mail will see a window similar to the one 

below: 

You too would have received an e-mail from one of your classmates. Download 

and save the attachment. 

Now to import this into your calendar, 

do the following: 

1. Select File Menu (figure 

adjacent). 

2. Select Open > Calendar 

File….An Open dialog box 

appears (figure adjacent). 

3. Browse and select the 

attachment. Click Open. 

4. Select Events and Tasks > 

Calendar. Notice both the 

calendars are displayed (figure below). 
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You may change the 

color of the other 

calendar to 

differentiate both the 

calendars. To change 

the color, do the 

following: 

1. Right-click the 

second calendar. 

A popup appears 

similar to the 

one below (left). 

      

2. Click Properties. EEdit Calendar dialog box appears (figure abbove right). 

3. Choose a color 

from Color: 

dropdown 

palette and 

click OK. 

Notice both the 

calendars and 

the calendar 

items are displayedd in different colors (figure adjacent).  

Using Microsoft Outlook 

You can also send a calenddar using Microsoft Outlook.  

1. Open Outlook, Sellect Go > 

Calendar.  

2. Right-click Calenddar under 

My Calendars (figure 

adjacent). 
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3. Click Send via E-mail…. A 

Send a Calendar via E-

mail popup appears 

(figure adjacent). 

a. Select the duration 

from Date Range: 

dropdown, for 

example Next 30 

Days. 

b. Select the amount 

of detail from 

Detail: dropdown, 

for example Full 

Details. 

c. Click OK. Notice 

the calendar is 

attached in 

iCalendar format 

(figure adjacent). 

4. Type the recipient’s e-

mail address in To…. Click 

Send. 

5. Recipients receive the e-

mail with the calendar as 

shown adjacent - below. 

6. Select Open this Calendar 

in Open group (figure 

adjacent). You will see a 

popup similar to the one 

below for adding the 

sender’s calendar to your 

software. 
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7. Click Yes. Notice the 

sender’s calendar 

appears side-by-side 

along with your 

calendar (figure 

adjacent). 

a. If you want to 

include items 

from the 

senders’ 

calendar, 

select the 

item from the 

senders’ calendar, drag and drop it in 

your calendar! 

b. To view in overlay mode, right-click 

your calendar under My Calendar and 

select View in Overlay Mode. 

c. Notice the senders’ calendar is displayed in overlay mode (you can 

see their schedule in your calendar as shown below). 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Schedule the following events in your calendar: 

a. Team Outing Discussion, 10 AM – 12 PM (One-time meeting, use 

a date of your choice). 

b. Annual Exam Preparation, 5 PM – 8 PM (Every Wednesday and 
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Friday, recurring until exam schedule). 

Share this calendar with your classmates. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to share a calendar (using .ICS format). 

Fill in the blanks 

1. Formats supported when exporting calendar are: _____________, 

____________ & _____________. 

2. File extension for iCalendar files: _____ . 
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SESSION 2: CUSTOMIZING THE QUICK ACCESS TOOLBAR 

 

 

        

  

           

            

 

  

             

             

             

               

              

               

  

     

    

       

     

     

     

  

  

  

  

   

  

  

 

    

  

 

  

  

   

   

  

  

 

  

Learning Objectives: 

At the end of this session, you will be able to: 

• Customize the quick access toolbar – a feature available in Microsoft 

Outlook. 

RELEVANT KNOWLEDGE 

You have learnt to work with various options in the e-mail messaging software. 

You can add shortcuts (referred to as commands) to items that you frequently 

use to the quick access toolbar for convenience. You can also include shortcuts 

for commands that are not available on any of the default tabs but can be 

accessed through a series of steps. For example, if you frequently use clip arts 

in your e-mails, you can add the shortcut or Clip Art command to the quick 

access toolbar. 

To customize the quick 

toolbar, do the following: 

1. Select File > 

the Quick Access Toolbar). 

2. Right-click on the 

Ribbon (figure 

above), click 

Customize Quick 

Access Toolbar…. 

An Editor Options 

dialog box 

appears (figure 

adjacent). 

3. You can select 

commands from 

Choose 

commands from: 

dropdown menu. 

For example, to 

add clip art, 

select All 

commands from 

Choose 

commands from: 

access 

New > 

Message (this is to access 

Office 
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dropdown menu. Scroll and select Clip Art… from list (figure above). 

4. Click Add button. Notice the Clip Art is added to the Quick Access 

Toolbar list (figure below, right). 

5. Click OK. Notice the Clip Art (icon) command is displayed in the quick 

access toolbar (figure below, left). 

Quick access toolbar is displayed 

at the top by default. However, 

to move its position, for 

example closer to the work area 

(just above the mail message 

area), do the following: 

1. Right-click on the Office Ribbon 

and click the option Show Quick 

Access Toolbar Below the Ribbon 

(figure adjacent). 

2. Notice the Quick Access Toolbar displayed 

near the work area (figure adjacent). 

Now try adding more commands to the Quick 

Access toolbar. 

Adding commands not available in default tabs 

Not all commands are accessible through default tabs (Message, Insert, Options 

or Format Text tabs). To see a list of commands not available in default tab, do 

the following: 

1. Select File > New > Message (this is to access the Quick Access toolbar). 

2. Right-click on the Office Ribbon and click Customize Quick Access 

Toolbar…. An Editor Options 

dialog box appears. 

3. Select Commands not in 

Ribbon from Choose 

commands from dropdown 

menu. Notice the list of commands (figure above). 

4. To add, select a command from this list. For example, select Custom 

Equation and click Add. Click OK. Notice the command Custom 

Equation added to the quick access toolbar. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Customize the toolbar to include the following commands: 

a. Paste Special. 

b. Theme Colors. 

c. Page Color. 

d. Show BCC 

ASSESSMENT 

Answer the following 

1. Explain the procedure to add commands to quick access toolbar with an 

example. 

Fill in the blanks 

1. Customize Quick Access Toolbar option can be accessed through 

__________________________. 
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SESSION 3: USING STATIONERY AND THEMES 

 

 

       

  

           

       

  

           

           

               

            

              

           

           

          

               

    

        

   

   

      

      

     

     

       

           

           

 

        

  

  

  

 

 

        

             

             

Learning Objectives: 

At the end of this session, you will be able to: 

• Personalize e-mails using stationery and themes. 

RELEVANT KNOWLEDGE 

You may have noticed attractive newsletters sent to your e-mail address 

promoting products, clearance sales or promotional offers. If you observe, some 

of them are so attractive that you view the e-mail even though you are not 

really interested. Also, most of them have hyperlinks to websites or e-mail 

addresses! If you too want to send such attractive e-mails to your customers or 

friends, you need to use HTML formatted e-mail messages. E-mail messaging 

software includes support for creating HTML messages through a feature called 

“Stationery”. Stationeries are pre-defined designs which you can replace with 

your own text or images; you can also create your own templates if you are 

comfortable with HTML. 

To work with stationeries, you need the following: 

a. Stationary Add-on. 

b. HTML Templates. 

Downloading and Installing the Stationery Add-on 

1. Open your e-mail messaging software. 

2. Select Tools > Add-Ons. 

3. Search for Stationery 0.7.8. 

4. Click Install and click Restart Now. 

Note: Stationery add-on does not include any templates. However, you can 

either use HTML templates downloaded from websites or your own HTML 

templates. 

Use the following websites to download HTML templates: 

a. http://www.campaignmonitor.com/templates/all/ 

b. http://www.activecampaign.com/templates/ 

c. http://www.eblastmagic.com/free-templates.html 

d. http://www.benchmarkE-mail.com/resources/Free-HTML-E-mail-

Templates 

e. Use Google to find more HTML templates! 

Usually templates contain HTML, CSS & Images compressed as a single .ZIP file; 

once you download a template, unzip them to a folder in your computer. 
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To use this template, do the following: 

1. Select Write dropdown menu. 

2. You need to select the HTML file (template); 

click Other Stationery…. A Select template 

file dialog box appears (figure below). 

3. Browse and select the HTML file; usually 

there is only one HTML file named as 

“index.htm” or 

“default.htm”. You 

can preview the 

template by 

opening in the web 

browser to 

experiment before 

using that as an e-

mail template! In 

this example, the 

file name is 

“full_width.htm”. 

4. Once you select 

the HTML file, 

click Open. 

Observe the 

results displayed 

(figure adjacent). 

5. Templates may 

have placeholders 

and dummy 

content that can 

be replaced with 

your own text. 

Replace the text 

in this template 

and include content as 

required. 

6. Once complete, type the 

e-mail addresses and 

subject. Click Send. 

Recipients will be seeing an e-

mail similar to the one adjacent. 

129 



 

 

             

   

            

     

     

     

    

   

 

   

       

      

 

     

  

     

   

   

   

   

      

    

   

     

   

      

     

     

    

 

 

  

Tip: Since these letters use HTML code, try inserting videos using HTML code! 

Using Microsoft Outlook 

Note: You must have the e-mail message format set to HTML. 

1. Select Tools > Options. 

2. Select Mail Format tab. 

3. Select HTML from Compose 

in this message format: 

dropdown list (figure 

adjacent). 

4. Click OK. 

To use stationary for a single E-mail 

message (one time activity), do the 

following: 

1. Select Actions dropdown menu 

(figure above). 

2. Select New Mail Message 

Using, click More 

Stationary….A Theme or 

Stationary dialog box 

appears (figure adjacent). 

3. Select a theme from this 

list, for example Capsules. 

Notice the preview 

displayed on the right pane 

(figure below right). 

4. To use this theme, click 

OK. Notice a new mail 

message is created based on 

this theme (figure below 

left). 
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To set a theme for all mail 

messages, do the following: 

1. Select Tools > Options. 

2. Select Mail Format tab. 

3. Select Stationery and 

Fonts… (figure 

adjacent). Signatures 

and Stationery dialog 

box appears (figure 

below). 

4. Click Theme Button. A 

Theme or Stationary 

dialog box appears, scroll and select a theme. For example, Compass. 

5. Click OK 

thrice. 

6. Select File > 

New >Mail 

Message. 

Notice the mail 

message 

created based 

on this theme 

(figure below). 

Note: 

1. Stationery or themes cannot be customized. 
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2. Stationery or themes cannot be applied to replies. 

Now use other themes for practice. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Create a newsletter on any of the following topics: 

a. Harmful effects of plastic bags. 

b. Wind energy. 

c. Causes of Uttrakhand disaster. 

d. Disaster management 

Use Microsoft Express Web to create a single page HTML newsletter, 

include hyperlinks, images and relevant videos; send this newsletter 

to your classmates. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of stationeries. 

2. Explain the procedure to send a HTML formatted message. 

Fill in the blanks 

1. List any three websites that offer free HTML e-mail templates. 
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ASESSION 4: CREATING AND MODIFYING SIGNATURES 

Learning Objectives: 

At the end of this session,, you will be able to: 

• Create and modify signatures. 

RELEVANT KNOWLEDGE 

e-mail signatures usually display name, designation, contact informmation, etc. 

and are visible at the eend of e-mails. Once created, e-mail siggnatures are 

automatically included whhen you compose a mail. An e-mail signatuure can be a 

combination of text and immages. 

To create a signature, 

do the following: 

1. Open your email 

messaging 

software. 

2. Select Tools > 

Account Settings. 

An Account 

Settings dialog 

box appears. 

a. To use 

plain text, 

i. Type 

your 

nam 

e andd contact details in Signature 

text: textbox. 

ii. Click OOK. 

iii. Selectt File > New > Message. 

Noticee the signature appearing in 

plain ttext format (figure adjacent). 

b. To use HTMLL text, 

i. Checkk Use HTML (e.g., <b>bold</b>) 

ii. Type tthe following in the Signature text: textboox. 

regaards,<br> 
<b>AArun Kumar.</b><br> 
<i>++91 9000012345</i> 

iii. Click OOK. 
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iv. Select FFile > New > Message. Notice the ssignature 

appearingg in HTML format. 

Attaching a vCard 

You can also attach an electrronic business card to e-mail messages. A vvCard is a 

file format standard widely uused for electronic business cards and is suupported 

most e-mail messaging softwware. Similar to normal business cards, ellectronic 

business cards are usually stoored with the address book of the e-mail mmessaging 

software. 

To attach vCard automaticallly for all outgoing messages, do the followiing: 

1. Select Tools > 

Account Settings. 

Account Settings 

dialog box appears 

(figure adjacent). 

2. Check Attach my 

vCard to 

messages (figure 

above). 

3. Click Edit 

Card….Edit vCard 

dialog box appears 

(figure below). 

a. Type your first nname 

in First: 

b. Type your last nname 

in Last: 

c. Type your eemail 

address in Email: 

d. Type your cell pphone 

number in Mobille: 

e. Click OK. 

4. Compose a new maill message and 

send it to a recipient. 

Recipients will receive the mail similar to 

the one below with the vvCard attached 

(figure below). Recipients can add this 

vCard to their address book by clicking on 

the icon. 

To include vCard for selectivee emails, do the following: 
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1. Select Tools > Account Settings. The Account Settings dialog box 

appears. 

2. Uncheck the option Attach my vCard to messages. 

3. Click OK. 

4. Select File > New > Message. 

5. Select File > Attach > Personal Card 

(vCard). 

Using Microsoft Outlook 

To set up a signature, do the following: 

1. Select Tools > 

Options. 

2. Select Mail Format 

Tab. 

3. Click Signatures. The Signature and 

Stationery dialog box appears. 

a. Click New to create a new 

signature. A New Signature popup 

appears. Enter a name for the 

signature for example, Personal. 

b. Click OK. You can use the Edit signature area to include text, 

hyperlinks and images (refer figure below). 
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4. Click OK twice when done. 

To use this signature, select File > 

New > Mail Message…. Notice the 

signature at the end of the mail 

message (figure adjacent). 

Creating a second signature 

You may use your e-mail software 

to send personal business mails. To 

do so, you can create and use an 

alternate signature for business 

mails. To create another signature, 

1. Select Tools > Options. 

2. Select Mail Format tab. 

3. Click Signature. click New, enter the name as Business and click OK. 

Create a signature similar to the one below. 

4. Click OK twice when done. 

5. Select File > New > Mail Message. Select Insert 

tab, select Signature dropdown arrow (figure 

below). 

6. Notice both the signatures are displayed. Select 

Business from Signature dropdown arrow, notice 

the business signature inserted in the e-mail 

signature area. 

Saving a v-Card 

To save a contact as an electronic business card, do the following: 

1. Open the e-mail messaging software. 

2. Select Go > Contacts. 
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3. Double-click on a contact. Select File 

> Save As…. 

4. Click Export to vCard file. vCard file 

dialog box appears (figure below). 

5. Notice the format displayed in Save as 

type: dropdown, 

type a name in File 

name: and Click 

Save. Now you can 

send this vCard file 

through e-mail 

message as an 

attachment; 

recipient can import 

this vCard that has 

complete 

information 

(depending on how much you have filled) in their e-mail messaging 

software. 

Attaching a v-Card 

You can also attach a business card to an e-mail by 

doing the following: 

1. Select File > New > Message. 

2. Select Insert tab. 

3. Select Business Card dropdown arrow (figure 

above); select the vCard from the list (for example, ODA1 Demo 

Account). To attach 

someone’s contact 

details, select Other 

Business Cards…, 

select the contact and 

click OK. 

4. Notice the vCard 

added as an 

attachment (file 

extension, .VCF). Now 

you can send this mail 

to a recipient. 

Recipients when they open this mail can import this vCard into their e-mail 

messaging software by double-clicking on the attachment and by clicking Save 

& Close. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. 
Include your first name, last name, email address and mobile number 

as a HTML signature. 

2. 
Create a vCard to include your first name, last name, email address 

and mobile number; configure email messaging software to include this 

vCard for all outgoing mails. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to include a signature in plain text format for all 

outgoing mails. 

2. Explain the procedure to include a signature in HTML format for all 

outgoing mails. 

3. Explain the procedure to include vCard for all outgoing messages. 

Fill in the blanks 

1. Signature Text option is available in ________________ dialog box of 

Tools Menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Configure e-mail security settings. 

RELEVANT KNOWLEDGE 

Security refers to protecting your computer from viruses. Some e-mail messages 

may contain malicious code such as a spyware or virus that may harm your 

computer. You can modify certain settings of your e-mail messaging software to 

defend against attacks originating from emails. 

Note: It is highly recommended to have a firewall and anti-virus installed and 

kept up-to-date to ensure maximum protection. 

Messages are displayed in HTML format by default. This can lead to a potential 

security hole as malicious code embedded in HTML can harm your computer. To 

disable HTML formatting, do the following: 

1. Select View menu (figure adjacent). 

2. Select the menu option Message Body 

As. Notice the default setting is HTML; 

select Plain Text. Observe the emails 

in your Inbox displayed in plain text 

format. 

E-mail messaging software includes mail 

filters that can control messages, mark them 

as spam and move them to a special folder called the “Junk Folder” to protect 

your computer. 

To configure security options, do the following: 

1. Select Tools > 

Options. An 

Options dialog 

box appears 

(figure 

adjacent). 

2. Select 

Security. 

a. Select 

Junk 

tab. To 

move 



 

 

            

            

    

     

             

         

       

 

     

 

         

       

         

        

            

   

   

        

  

            

  

           

mails to the Junk folder when they are marked as Junk, check 

When I mark messages as junk: and select Move them to the 

account’s “Junk” folder. 

b. Select E-mail Scams tab. 

c. Check the option Tell me if the message I'm reading is a 

suspected email scam for email messaging software to analyze 

and alert on finding any suspicious mails. 

d. Select Anti-Virus tab. 

e. Check the option Allow anti-virus clients to quarantine 

individual incoming messages for anti-virus software to 

quarantine infected email messages. Quarantine is a feature of 

most anti-virus software that isolates infected email messages 

from rest of the computer keep it safe and secure. 

3. Click OK. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Configure the following in your email messaging software to keep your 

computer secure: 

a. Set the default view of message body to plain text. 
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b. Configure to move email messages to move emails to "Junk" 

folder when they are marked as Junk. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to modify the default message view to plain text. 

2. Explain the procedure to: 

a. Move emails to “Junk” folder when they are marked as Junk. 

b. Allow anti-virus to quarantine infected emails. 

Fill in the blanks 

1. Junk, e-mail scams, anti-virus tabs are available in __________ section 

of Options dialog box. 
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-SESSION 6: ORGANIZING EE MAILS 

Learning Objectives: 

At the end of this session, youu will be able to: 

• Organize your e-mails bby grouping them into appropriate folders.. 

RELEVANT KNOWLEDGE 

It might be difficult to deal wwith e-mails over time. This is especially trrue when 

you send and receive a whoole lot of e-mails. You may end up losing track of 

them! To avoid such confusioon, you can use certain features such as ggrouping, 

conditional formatting, etc. aand organize e-mails. 

Group e-mails 

Grouping helps you to keepp similar e-mails together. For example, you can 

group all the e-mails sent to a particular recipient to track e-mails sennt to that 

recipient thus avoiding scrolliing back and forth to locate the e-mails! 

To group emails by sender’s eemail address, do the following: 

1. Open your email mmessaging 

software. 

2. Select View > Sort by.. 

3. Select the submenuu option 

Recipient. 

4. Select View > Sorrt by > 

Grouped By Sort. 

5. Notice the emails grouped by 

sender’s email addresss (figure 

below). 

To switch to default view, 

1. Select View > Sort by>>Threaded. 
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Using Saved Search Folders 

Saved search folders are virtual folders that have e-mails matching certain 

criteria; they just point to the e-mails located in Inbox or other folders. For 

example you can create a saved search folder to match the criteria “exam” 

that will hold and point all emails matching the keyword “exam”. 

To understand search folders, do the 

following: 

1. Select File > New. 

2. Click Saved Search….A New Saved 

Search Folder dialog box appears 

(figure below). 

a. Type a name for this folder in the textbox Name:, for example 

Sale. 

b. Under the section Configure the search criteria used for this 

saved search folder:, select the option Match any of the 

following. 

c. You can use the dropdown menus for list of values under Configure 

the search criteria used for this saved search folder: section. For 

example, select Subject from 1st dropdown, contains from 2nd 

dropdown and type Sale in the text box. 

d. Click Create. 

e. Notice the saved search folder named Sales displaying emails 

matching the keyword Sale (figure below). 

You can use a variety of combinations such as: 

a. Mails that have attachment(s). 

b. Mails from a particular recipient. 
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c. Mails sent on a particular date and so on. 

Experiment with different dropdown values to learn more. 

Conditional Formatting – MS Outlook 

Microsoft Outlook provides a facility to highlight and organize messages through 

a special feature called “Conditional Formatting”. This helps in attracting 

attention to specific mails. To apply a particular font and colour for mails from 

specific person, do the following: 

1. Select Tools > Organize. 

2. A new Ways to Organize Inbox window will 

appear below the standard toolbar (figure 

adjacent - below). 

3. Select Using Colors, 

you should see a 

window similar to the 

one adjacent - below. 

4. Specify the e-mail 

address of the 

recipient and choose 

a color. 

5. Click Apply Color. 

Click The X command 

button to close. 

6. Now when you 

receive a mail from 

selected contact, you 

should the mail color coded in Inbox. 

Now try changing font, color, etc. by using the Automatic Formatting option 

next to X command button. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Group all the mails by email addresses of your classmates. 

2. Create a saved search folder to display all the emails from one of your 

classmate. 
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ASSESSMENT 

Answer the following 

1. Explain the procedure to group emails by: 
a. Size 
b. Order Received 
c. Read 

2. Explain the purpose of saved search folders with an example. 

Fill in the blanks 

1. Grouped by Sort is available in ________ submenu of _____ menu. 

2. Saved Search option is available in ______ submenu of _____ menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Manage data files. 

RELEVANT KNOWLEDGE 

As you know, it is always recommended to keep backup copies of e-mails in the 

event of a failure. 

Data files refer to e-mail messages, address books and configuration settings 

that are stored in a folder called “Profile”. The first time you start your email 

messaging software, a profile is automatically created and used. 

Note: Profile is NOT deleted when you uninstall email messaging software. 

To view a profile, do the following: 

1. Click Start > Run. 

2. Type %APPDATA% 

and press Enter. A 

window similar to the 

one adjacent 

appears. 

3. Scroll and select the 

folder Thunderbird 

(All settings and date are stored in this folder). Copy this folder for 

backup. 

Additional Information 

1. Double-click 

Thunderbird folder, 

contents of 

Thunderbird folder 

appear (figure 

adjacent). 

Note: Thunderbird uses Profiles.ini to 

locate the data folder. 

2. Double-click profiles folder. A 

folder similar to the one adjacent 

appears. 

3. Double-click this folder. Notice the 

contents of this folder (figure 

below). 
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4. In this case, 

everything is stored in 

pop.googlemail-

4.com (this may vary 

on each computer) 

folder. To view the 

contents, double-click 

the folder. Notice the 

contents of this folder 

(figure adjacent). 

MozBackup 

MozBackup is a free utility that you can 

use to backup Mozilla Firefox and 

Thunderbird. 

1. Go to 

http://mozbackup.jasnapaka.com. 

2. Download MozBackup and install it 

on your computer. 

3. Click Start > Programs 

>MozBackup. A Welcome to 

MozBackup wizard appears 

(figure above). 

4. Click Next. A window similar 

to the one adjacent appears. 
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5. Select Mozilla Thundderbird, 

click Next. A windoww similar 

to the one adjacent apppears. 

6. Click Browse… to select 

another folder on n your 

computer, for exxample: 

D:\Thunderbird and d click 

Save. 

7. Click Next. Questionn popup 

appears as shown below 

(left). 

   

   

    

    

  

  

 

 

   

   

 

    

   

     

     

   

 

 

  

 

 

  

 

  

  

 

    

      

 

       

     

        

   

 

   

 

  

8. Click No. (Password prrotection is optional). A window similar too the one 

above (right) appears. 

9. Click Next. A window ssimilar to the one below (left) appears. 

10.Click Finish. Notice a single file saved in the backup location with the 

file extension .PCV (figgure above right). 
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To restore, do the following: 

1. Click Start > Programs 

>MozBackup. Welcome 

to MozBackup wizard 

appears. 

2. Click Next. A window 

similar to the one 

adjacent appears. 

3. Select Restore a profile 

and Mozilla 

Thunderbird and then 

click Next. 

4. Click Browse to select 

the backup file, click 

Open. 

5. Click Next Twice. A 

popup appears similar 

to the one adjacent. 

6. Click Yes. 

7. Click Finish. 

MS Outlook 2007 

Backup Items 

e-mail messaging software stores all your e-mails, contacts, calendar items, 

etc. in a single file called the Personal Folder File or PST. PST is automatically 

created and managed by the e-mail messaging software. To view the location 

of this file, do the following: 

1. Open the e-mail messaging software. 

2. Select Tools >Account Settings, click Data Files tab. Notice the file 

location under Filename section (figure below). 

3. To view complete path, click Settings… (figure above). 
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4. A Personal Folders popup 

appears (figure adjacent). 

5. Notice the complete path in 

Filename:. By default, PST’s 

are stored in hidden folder 

under Local Settings in 

C:\Documents and 

Settings\USERNAME. 

6. Use Windows Explorer to 

view hidden files, locate the 

PST and create a copy of it 

(select FILENAME.PST, copy 

and paste elsewhere). Also 

note that the e-mail 

messaging software MUST be 

closed or you won’t be able to make copies of it. 

Note: In Windows Vista / 7, PST is stored in C:\USERS\USERNAME. 

Using PST Backup Tool 

The above mentioned procedure may be difficult as it involves too many steps. 

As an alternate, you may download the PST BACKUP Tool from Microsoft’s 

website and take the backup. Download the tool from the following URL: 

• http://www.microsoft.com/en-us/download/details.aspx?id=9003 

To install this tool, do the following: 

1. Double-click pfbackup.exe. A window appears similar to the one below 

(left). 
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2. Click Next. A License 

Agreement appears (above – 

right). 

3. Accept the terms and click Next. 

A Start Installation window 

appears. 

4. Click Next, click Finish. 

To launch the tool, do the following: 

1. Open the e-mail messaging 

software, Select File menu (figure below). 

2. Notice the new entry Backup…. Click 

Backup…, An Outlook Personal Folders Backup 

popup appears (figure below). 

3. Click Options… button (figure above), A 

Backup Options popup appears (figure below). 

a. Specify the reminder value (for example to remind you every 10 

days, specify 10 in 

Remind me to backup 

every __ days). 

b. Specify the location 

where you want to keep 

the backup; choose a 

location that is not the 

same where operating 

system resides. Choose 

another partition, a 

network folder or pen 

drive. Click OK. 

4. Click Save Backup. Backup 

popup appears (figure adjacent) 

indicating the e-mail messaging 

program should be closed. 

5. Click OK. Close e-mail messaging 

software; a backup will be 

created in the location specified 
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earlier.  

6. To view the file, naviggate to the location using Windows Explorerr. Notice 

the backup file (figuree below). 

 

 

Restoring from a backup 

If you want to restore e-maails from the backup (on the same compuuter or a 

different computer), do the ffollowing: 

1. Select File > Open >>Outlook Data 

File (figure adjacent). 

2. Browse and select thee BACKUP.PST. 

Backup data file will  be displayed 

below the default folder (figure 

below). 

3. To restore, select maill(s) from 

Backup, drag and dropp it in Inbox.  

Add data files to a mail profiile 

You can configure multiple e--mail accounts 

in e-mail messaging software which you 

may need if you have multiplle e-mail 

accounts with different providers (such as 

outlook.com, gmail.com, yahhoo.com, etc.). 

You can configure all the accoounts in a 

single e-mail messaging softwware thus saving time and efforts to check eevery 

account manually.  

You can either: 

a. Add multiple accounts to a single profile (useful when you want tto 

configure multiple user accounts in a single shot!) 

b. Add each account to a separate profile (useful when you want too keep 

personal and business EE-mail accounts separate from each other for 

convenience). 

To use another e-mail accounnt using a single profile, do the following: 

1. Open the e-mail messaaging software (as normally you would). 

2. Select Tools > Accounnt Settings. 
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3. Notice the existing mail account is displayed. To add another account, 

click New…, follow the onscreen instructions to complete the steps. 

Notice both the e-mail accounts are displayed (figure below). 

4. When you hit F5 (send/receive), e-mail messaging software will check 

for both the accounts (figure below). 

5. When you send e-mails, you need to specify which e-mail account you 

are sending from as 

it will use the 

default (first) e-mail 

account for all 

messages composed. 

To specify the e-

mail account while 

composing the 

message, do the 

following: 

a. Select File > 

New > Mail 

Message (figure adjacent). 

b. Notice the Account dropdown below the 

Send button. Select the account from 

which you need to send this mail from, 

for example choose the second one in 

the list. 

c. Compose the mail and send it to a recipient. 

6. When you receive e-mails, mails from both the account are displayed 

together in the Inbox (figure below). 
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7. However when you open each 

mail, you may be able to 

differentiate between the two 

accounts (figure adjacent). 

8. Notice the e-mail address in From:. 

Delete a profile 

To remove a profile, go to Control Panel > Mail. Select the profile you want to 

delete, click Remove. 

Important: When you remove a profile, only the settings are removed. Data 

files still remain in respective folder and are NOT deleted. Use Windows 

Explorer to recover data files (.pst) using the procedure outlined in this session. 

Change data file settings 

You can change the data file for an existing account or specify a data file for 

each e-mail account. 

For example, if you have used e-mail messaging software for a very long time 

and have a lot of mails, you can create a new data file for the new mails (from 

now on). You can also create a new data file for each month or year! 

To create a new data file, do the following: 

1. Open the e-mail messaging software. 

2. Select Tools > Account Settings, Select Data Files tab. 

3. Click Add… to add a new data file, A New Outlook Data File dialog box 

appears as shown below. 

4. Select Office Outlook Personal 

Folders File (.pst), click OK. 
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5. Create or Open 

Outlook Data File 

dialog box appears 

(figure adjacent), 

select the location 

where you want to 

store this data file 

and type a name for 

this data file. For 

example, Y2013 and 

then click OK. 

6. Create Microsoft Personal Folders popup appears as shown below. 

7. Type a name in Name: and click OK. 

Notice the second data file created and 

displayed (figure adjacent). 

8. You need to configure the e-mail 

messaging software to deliver new 

messages to this new personal data file 

instead of the old one; to configure, select 

the second data file and click Set as 

Default (refer figure above). A Mail Delivery Location popup appears as 

shown below. 

9. Click OK. Notice the default data file changed to the new data file 

(figure below). 

10.Click Close. 

11.Now exit and re-open the e-mail messaging software. 
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12.Notice the new mails are stored in 

the new data file. 

Note: Older e-mails will be available in 

the old data file and only new items are 

stored in new data file. 

Managing Size 

Personal Data File (PST) can get quite 

large after substantial usage (too many e-

mails everyday and/or used for a very 

long period). In general, PST’s are automatically optimized 

in the background. To manually optimize, do the following: 

1. Select File menu. 

2. Click Data File Management…. 

3. Select the data file you want to 

optimize, for example Personal 

Folders. Click Settings…. A Personal 

Folders dialog box appears (figure 

adjacent). 

4. Click Compact Now. 

Note: Compacting takes time 

depending on the size of the data 

file. 

5. Click OK and then click Close. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Take a backup of your email messaging software (including data) using 

both manually and MozBackup. 
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ASSESSMENT 

Answer the following 

1. List any three scenarios where you need to perform a backup. (Answer: 

Moving data to another computer, formatting and re-installing OS, 

general backup for protection). 

2. Explain the procedure to backup profile folder (Mozilla Thunderbird). 

Fill in the blanks 

1. Profile (Mozilla Thunderbird) is stored in _________ Folder. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Customize the To-Do bar. 

RELEVANT KNOWLEDGE 

In earlier sessions, you learnt about tasks and tasks requests. Tasks and tasks 

requests appear in To-Do bar in Microsoft Outlook. By default, the To Do Bar is 

displayed on the right side of the e-mail messaging/ calendar software window. 

You can configure the To-Do Bar to manage your time effectively. 

When you work with e-mails, it is possible that you may forget to reply to some 

mail or do a particular task. To prevent such errors, you can add the activity as 

a task in your calendar to serve as a reminder for completing the activity. You 

can drag and drop e-mails to the To-Do bar or Calendar to add it as a part of 

your activity. To understand this, do the following: 

1. Open your e-mail messaging software. 

2. Select View > To-Do Bar > Normal 

(figure adjacent). 

3. Notice the To-Do bar displayed on the 

right- most pane on the screen (figure 

below). 

4. Select, drag and drop the mail for 

which you want 

to set a 

reminder, on a 

date in the 

calendar. The 

Appointment 

dialog box 

appears (figure 

below). 
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5. Set up the schedule as you would do for a normal appointment, Click 

Save & Close when done. Now this entry will be added and displayed in 

the To-Do Bar (figure below). 

Using this method only the Subject of the e-mail is displayed in the To Do bar. 

You may want to view the relevant e-mail and/or attachment along with the 

appointment in a calendar (to relate easily). To attach the e-mail and/or 

attachment, do the following: 

1. Right-click the e-mail. Hold, drag and 

drop it on a date on the calendar. A 

popup menu appears (figure adjacent). 
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2. Select Copy Here as 

Appointment with 

Attachment, a window 

similar to the one 

adjacent appears. 

3. Notice the mail itself 

is attached; double-

click on the mail and 

notice the attachment 

included. Click Save & 

Close. 

4. Notice this appointment displayed in the To-Do Bar. 

Adding Documents to Tasks or Appointments 

You can also add attachments or e-mails to new or existing tasks or 

appointments. 

1. Create a new task or appointment, or open an 

existing task or appointment. 

2. Select Insert tab. 

3. To attach documents, select Attach File in 

Include group. 

An Insert File 

dialog box 

appears. 

Browse, select 

the document 

and click 

Insert. 

4. To attach e-

mails, select 

Attach Item in 

Include group. 

Select the e-

mail from Inbox and click OK. 

Note: You can also add items from calendar, Contacts, Journal, etc. 

Now try adding other items to a task or an appointment such as a calendar 

item, contact, etc. 

160 



 

 

   

         

         

        

        

        

   

     

     

    

   

   

  

   

   

   

 

  

    

    

     

    

  

   

   

   

    

   

    

   

   

   

          

           

  

         

Customizing To-Do Bar 

By default To-Do bar displays items in groups and 

only certain items such as Task Subject, Due Date, 

etc. are displayed when available. Also notice that 

items are arranged by Start Date (figure adjacent). 

To sort by Importance, select Importance from this 

context menu. 

Notice - only the Subject 

line is displayed here. To 

display other fields also, 

do the following: 

1. Select Custom… 

(figure adjacent). 

A Customize View: 

To-Do List dialog 

box appears (figure 

below). 

Click Fields… 

button. A Show Fields 

dialog box appears. 

a. Select the fields in 

the order you want 

from Available 

fields: list. These 

are displayed under 

Show these fields 

in this order:. For 

example if you 

want to view Task 

Subject, Start Date 

and Due Date, 

arrange the fields 

(use Move Up and Move Down buttons) as shown adjacent. 

b. Select 3 from Maximum number of lines in compact mode: 

dropdown list. 

c. Click OK. Observe the results displayed (figure below). 
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Now try adding other fields, change the order and observe the results. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Customize the To Do bar to be displayed; create tasks by dragging and 

dropping emails to the to-do bar using the procedure outlined in this 

session. 

ASSESSMENT 

Answer the following 

1. Explain the procedure to customize the To Do bar. 
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SESSION 9: CREATING A FOLDER HOME PAGE USING MS OUTLOOK 

 

 

          

  

           

      

  

           

              

            

       

            

 
 
 

 
  

         
         
         

   
   
    
   
   

 
 
 

 

          

             

Learning Objectives: 

At the end of this session, you will be able to: 

• Create a folder home page. 

RELEVANT KNOWLEDGE 

Email messaging software provides an option to customize folder using an 

ActiveX control called the Outlook View Control. This can be useful when you 

want specific folder and/or calendar items to appear as your home page. 

To understand this concept, do the following: 

1. Open a text editor such as Notepad and type the following: 

<html> 
<head> 
</head> 
<body> 
<OBJECT classid=CLSID:0006F063-0000-0000-C000-000000000046 

id=ViewCtlFolder 
width="100%" 
height="430"> 

<param name="Namespace" value="MAPI"> 
<param name="Folder" value="Tasks"> 
<param name="View" value="By Category"> 
<param name="Restriction" value=""> 
<param name="DeferUpdate" value="0"> 
</OBJECT> 
</body> 
</html> 

2. Save this as an HTM file, for example: "CustomView.htm". 

3. Click Start > Programs > Microsoft Office > Microsoft Outlook 2007. 
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4. Observe the items from Calendar, Tasks 

and emails displayed in the home page 

(figure above). To customize this view, 

right-click the Personal Folder (for 

example, Year 2013 in the image above). 

A popup appears similar to the one 

adjacent. 

5. Select Properties for “Year 2013”. 

Outlook Today – [Year 2013] dialog box 

appears (figure below, left). 

6. Select Home Page tab (figure above - right). 
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7. Click Browse and select the .HTM file (for example, CustomView.htm), 

click Open. Click OK. Observe the results (figure below) displaying items 

from Tasks alone. 

Refer to the following website for additional information: 

• http://support.microsoft.com/default.aspx?scid=KB;en-us;q291407 

You may also specify a webpage or URL from the Internet or Intranet, or even a 

web page from the local hard disk drive. 

1. Right-click the Personal Folder (for example, Year 2013) 
2. Select Properties for “Year 2013”. Outlook Today – [Year 2013] dialog box 

appears. 
3. Select Home Page tab. 
4. For example, type http://www.google.com, Click Apply and OK. 

5. Observe the results (figure below). 
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Mozilla Thunderbird 

> 

include 

another 

site. 

Mozilla Thunderbird 

displays a home page in 

the preview area 

similar to the one 

adjacent by default. 

Instead of displaying 

default page, you may 

customize it to show a 

web page similar to 

outlook (For example, 

Google Home Page). 

For example, to show 

wikipedia’s home page, 

do the following: 

1. Select Tools 

Options. Options 

dialog box appears 

(figure adjacent). 

2. You can 

your own start page 

using HTML code or 

point to 

web page / 

Type 

http://www.wi 

kipedia.org in 

Location:. 

Click OK. 

3. Close and re-

open Mozilla 

Thunderbird. 

4. Observe the 

results 

displayed 

(figure 

adjacent). 

Mozilla Thunderbird 

includes about 
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protocol links, a pre-programmed list of special links that may be used instead 

of a web page. These are used for general information and troubleshooting 

purposes. For example, to view memory utilization, do the following 

1. Select Tools > 
Options. Options 
dialog box 
appears. 

2. Type 
about:memory in 
Location:. Click 
OK. 

3. Close and re-open 
Mozilla 
Thunderbird. 

4. Observe the list 

of add-ons 

displayed (figure 

adjacent). 

Some of the other options are listed below for your reference: 

• about:buildconfig 

• about:cache 

• about:about 

• about:addons 

• about:crashes 

For complete list, refer: http://kb.mozillazine.org/About_protocol_links. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Customize the home page in Microsoft Outlook to display the following 

URL’s: 

a. http://www.linkedin.com 

b. http://kb.mozillazine.org 

c. http://www.about.com 

2. Apply the following about protocol links in Mozilla Thunderbird: 

• about:buildconfig 

• about:cache 

• about:about 

• about:addons 

• about:crashes 
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ASSESSMENT 

Answer the following 

1. Explain the purpose of outlook view control. 

2. Explain the procedure to include an URL as home page in Microsoft 

Outlook. 

3. Explain the procedure to include outlook view control as home page in 

Microsoft Outlook. 

4. Explain the purpose of about protocol links in Mozilla Thunderbird. 

5. Explain the procedure to include an URL as home page in Mozilla 

Thunderbird. 

6. Explain the procedure to include about protocol links in Mozilla 

Thunderbird. 

Fill in the blanks 

1. List any three about protocol links in Mozilla Thunderbird: 

____________, _____________ & ______________. 
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SESSION 10 SETTING PREMISSIONS AND DELEGATING ACCESSS  

Learning Objectives: 

At the end of this session,, you will be able to: 

• Delegate your e-maail and calendar. 

RELEVANT KNOWLEDGE 

You have learnt to use e-mmail messaging software to manage e-maills, tasks and 

appointments. You can alllow other users for example your assistantt to manage 

your e-mails, tasks and/orr appointments. This is referred to as “Delelegation”.  

Note: Using your e-mail mmessaging software for this particular taskk requires a 

special setup hence an aalternate solution is explained here as a rreference to 

help you understand this cconcept.  

To delegate e-mail accesss, do the following: 

1. Go to Gmail.com  

and login with  

your credentials.  

2. Click the Gear  

Icon ( ). Click  

Settings from the  

dropdown (figure 

above). Settings  

page will be displayyed. 

 

 

3. Click Accounts. Scrroll down the web page and click Add anotther 

account (figure bellow). 
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4. Grant Access to your  

Account popup  

appears (figure  

adjacent). 

5. Type the e-mail  

address of another  

user whom you want  

to delegate access.  

For example your classsmates e-mail address, Click Next Step >.. You will 

see a window similar  

to the one adjacent  

(confirmation). 

6. Click Send E-mail to  

grant access. A  

popup appears as  

shown adjacent - 

below. 

7. Now the recipient will receive an e-mail similar to the one beloww: 

 

8. Click on the link givenn in the e-mail (please click the link beelow:) to 

accept the request,. AA popup appears similar to the one below. 
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9. Now click the droppdown arrow next to 

your e-mail adddress. Notice the 

delegated account is displayed (figure 

adjacent). 

10.Click on the delegaated account to work 

with the mailbox.. On doing so, the 

delegated user’s mmailbox is displayed 

in a different winddow. Notice that no 

password was requuired to access the 

delegated account.. 

Note: When you deleggate to a particular user, the delegate can  manage the 

mailbox and perform  activities such as receive, read, or deleete e-mails. 

However the delegate  cannot change password or modify any othher settings.  

Removing a delegation  

To remove a delegation, ddo the following: 

1. Login with your acccount. 

2. Select the Gear icoon and click Settings. 

3. Click Accounts. 

4. Select the option DDelete (figure below). 

 

5. Click OK. The deleggation is removed! 

Delegate Calendar 

You may want to delegatee your calendar too to your secretary who mmanages 

your (the manager’s) scheedule.  

To delegate Calendar, do  the following: 

1. Sign in to Gmail.coom with your 

credentials. 

2. Click Calender hypeerlink at the top (below 

the address bar). 

3. Click Gear icon, cliick Settings (figure 

adjacent). 

4. A Calendar Settinggs dialog box appears 

(figure below). 
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5. Click Calenders 

under Calender 

Settings. A window 

similar to the one 

adjacent appears. 

6. Click Share this 

calendar under 

Sharing. A Share this CCalendar web page appears (figure below)). 

7. You can either share 

this calendar: 

a. With the 

public so 

anyone can 

view your 

calendar.  

b. Share this 

with a 

particular 

person who can  view or manage your calendar. 

8. To share this calendar  with a particular person, type the e-mail aaddress 

of the person under Peerson text box (figure below) and select Maake 

Changes AND manage sharing from Permission Settings dropdowwn 

(figure below). 
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9. Click Add Person. NNotice the e-mail address and permissions displayed 

(figure below). 

 

10.Click Save. 

11.Now the assistant oor friend when they login to their E-mail wiill receive a 

notification similar to the one below. 

 

12.Click the link Viiew your Calendar (figure 

above) to see thee change. Also link to the 

delegated calendarr will be displayed under My 

Calendars (figure aadjacent). 
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13.Now go ahead and crreate 

items in the deleggated 

calendar. Click the 

dropdown arrow nexxt to 

the delegated e--mail 

address (not yours!), click 

Create event on this 

calendar from the ppopup 

menu (figure adjacent)). 

14.Notice the event displlayed 

in different colours.  

15.Also login to your caleendar 

and notice the item 

created by the  

delegate displayed  

(figure adjacent).  

16.Notice the e-mail 

address specified in 

Calendar (Your e-

mail address) and 

Created by (Your 

assistant or friend’s 

e-mail address) 

fields.  

EXERCISE   

Perform the following activitiies till you are confident: 

S.No. Activities 

1. Delegate your emaill and calendar to one of your classmate. 

ASSESSMENT 

Answer the following 

1. Explain the purpose of delegation with an example.  

2. Explain the procedure  to delegate email access. 

3. Explain the procedure  to delegate calendar access. 

Fill in the blanks 

1. ____________ refers too providing access to your emails and caleendar for 

others to manage. 
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PREFACE 

Background 

The National Curriculum Framework, 2005, recommends that children’s life at school 

must be linked to their life outside the school. This principle makes a departure from 

the legacy of bookish learning which continues to shape our system and causes a gap 

between the school, home, community and the workplace. 

The student workbook Volume 3 on “Web Design and Development” is a part of the 

qualification package developed for the implementation of National Vocational 

Education Qualification Framework (NVEQF), an initiative of Ministry of Human 

Resource Development (MHRD), Government of India to set common principles and 

guidelines for a nationally recognized qualification system covering Schools, 

Vocational Education and Training Institutions, Technical Education Institutions, 

Colleges and Universities. It is envisaged that the NVEQF will promote transparency of 

qualifications, cross-sectoral learning, student-centered learning and facilitate 

learner’s mobility between different qualifications, thus encouraging lifelong 

learning. 

This student workbook, which forms a part of vocational qualification package for 

students who have passed Class X or equivalent examination, was created by a group 

of experts. The IT-ITeS Skill Development Council approved by the National Skill 

Development Corporation (NSDC) for the IT/ITES Industry developed the National 

Occupation Standards (NOS). The National Occupation Standards are a set of 

competency standards and guidelines endorsed by the representatives of IT Industry 

for recognizing and assessing skills and knowledge needed to perform effectively in 

the workplace. 

The Pandit Sunderlal Sharma Central Institute of Vocational Education (PSSCIVE), a 

constituent of National Council of Educational Research and Training (NCERT) in 

association with Wadhwani Foundation has developed modular curricula and learning 

materials (Units) for the vocational qualification package in IT/ITES sector for NVEQ 

levels 1 to 4; level 1 is equivalent to Class IX. Based on NOS, occupation related core 

competencies (knowledge, skills, and abilities) were identified for development of 

curricula and learning modules (Units). 

This student workbook attempts to discourage rote learning and to bring about 

necessary flexibility in offering of courses, necessary for breaking the sharp 

boundaries between different subject areas. The workbook attempts to enhance 

these endeavors by giving higher priority and space to opportunities for contemplation 

4 



 

 

         

             

             

              

              

       

            

              

            

             

             

          

 

         

            

            

          

   

 

           

           

          

 

             

 

            

           

     

  

and wondering, discussion in small groups and activities requiring hands-on-

experience. We hope these measures will take us significantly further in the direction 

of a child-centered system of education outlined in the National Policy of Education 

(1986). The success of this effort depends on the steps that school Principals and 

Teachers will take to encourage children to reflect their own learning and to pursue 

imaginative and on-the-job activities and questions. 

Participation of learners in skill development exercises and inculcation of values and 

creativity is possible if we involve children as participants in learning, and not as 

receiver of information. These aims imply considerable change in school routines and 

mode of functioning. Flexibility in the daily time-table would be a necessity to 

maintain the rigor in implementing the activities and the required number of teaching 

days will have to be increased for teaching and training. 
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WEB DESIGN AND DEVELOPMENT 

SESSION 1: INTRODUCTION 

Lesson Objectives: 

At the end of this session, you will be able to: 

• Understand the purpose of web authoring tools. 

• Understand the purpose of Expression Web. 

• Understand Microsoft Expression Web user interface. 

RELEVANT KNOWLEDGE 

You have learnt to use HTML & CSS to create web pages. You know that to design a 

professional looking website, you need to write hundreds of lines of code creating 

several chances for errors. As you can very well imagine it is a very difficult task for 

any developer to write thousands of lines of code to create a website including many 

hyperlinks, images, multimedia content, etc. apart from standard web site content. 

As a solution to this problem, you may use a web authoring tool. 

Web authoring tools simplify your web page development tasks. HTML editors, 

referred to as web authoring tools are applications that write & check HTML code for 

you and help save your time and effort. 

HTML editors are referred to as WYSIWYG (what you see is what you get) editors. This 

is due to the fact that what you see during the design phase is what you get as an 

output viewed in a web browser (or at least very close to it). Usually, websites are 

first designed offline using HTML editors, then tested, and, later uploaded to 

websites. 

Some of the popular HTML editors include Amaya, Adobe Dreamweaver, KompoZer, 

Microsoft Expression Web, etc. Some web hosting provides provide online tools to 

design websites but this usually requires a high-speed Internet connection. 

Advantages provided by HTML editors are: 

• Generate Standard Compliant Code: The developer need not worry whether the 

code written conforms to standards such as HTML 5, CSS3, etc. The editor takes 

care of standards. 

• HTML & CSS Validation: Each and every line of code is checked to ensure it is free 

of errors and/or standard compliant. 
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• Generate Compatibility Reports: The editor generates reports based on 

compatibility with multiple versions of varying browsers. 

• Spell Check: The editor checks for spelling mistakes in content similar to that of 

word processing software. 

• Optimize HTML: The editor “cleans” out unnecessary code resulting in smaller 

web page size enabling a faster download of the web page. 

• Multiple Resolution / Browser Views: The editor automatically checks your web 

page/website across multiple screen resolution/sizes (Smartphone, net-book etc) 

and also across multiple browsers (Mozilla Firefox, Google Chrome, etc.). 

• SEO (Search Engine Optimization): The editor prepares your website in the 

manner that search engines can understand and thereby helps your website to gain 

a better ranking for search results. 

• Support for Add-ons: The editors support 3rd party add-ons which add additional 

capabilities to the HTML editor. 

• Multiple Publishing Methods: Editors have the ability to use different options such 

as FTP, WebDAV, etc. to publish your website on remote computers. 

Microsoft Expression Web 

Microsoft Expression Web is a free HTML editor and web design software product by 

Microsoft. One great advantage of MEW is the ability to create and manage web pages 

using HTML, XML, CSS, ASP.NET, XHTML, PHP and JavaScript. 

Note: This module focuses only on Microsoft Expression Web using HTML. 

Installing Microsoft Expression Web 

To work with MEW, do the following: 

1. Download Microsoft Expression Web 4 (recent and last version) from 

Microsoft.com. 

2. Install by following the on-screen instructions. 

3. Click Start > Programs > Microsoft Expression Web. 

9 

https://Microsoft.com


 

 

   

   

 

    

    

   

   

   

  

   

   

  

    

   

       

         

        

        

            

  

   

        

  

            

        

 

 

    

       

      

    

           

         

The MEW Interface 

MEW User Interface 

explained: 

1. Menu Area, displays 

menu items such as 

File, Edit, etc. 

2. Toolbar Area, 

displays icons to 

Menu Items. 

3. Toolbox, contains 

HTML elements and 

ASP.NET items. 

4. Task Pane, displays 

folders, images, etc. 

in a website in folder list view. 

5. Editing Area, displays the HTML editing area. 

6. Status bar, displays additional document properties. 

7. Style Sheet Area, to manage style sheets. 

8. Attributes & Elements Area, displays HTML attributes & values and CSS property 

and values. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Discuss the benefits of HTML Editor by comparing different HTML editors. 

Use Wikipedia to learn more about HTML Editors. 

ASSESSMENT 

Answer the following questions: 

1. Explain the benefits of HTML Editors. 

2. List any five HTML editors. 

Fill in the blanks: 

1. ________ are software that produces HTML code without writing HTML. 

2. ______________, ______________ & ____________ are free HTML Editors. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create a new site. 

• Create and save a web page. 

RELEVANT KNOWLEDGE 

You can create websites with your own design. When you work with web pages, 

images, style sheets, etc., you need to store all the related files in a single location 

(folder). This helps you to: 

• Stay organized 

• Upload the entire content to the remote server when you want to publish the 

website. 

Note: You will learn about templates later in this module. 

Creating a Website 

To create a new website, 

1. Select Site > New Site… (figure below, left). A New dialog box appears (figure 

below, right). 

a. You can create a website with a single page by selecting One Page Site. 

b. You can create a website from scratch by selecting Empty Site. 

c. If you already have a website created using HTML or any other software, you 

can continue to work with the website using MEW once it is imported. To 

import an existing website, use the Import Site Wizard. 
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2. Select Empty Site and enter a name for the 

website, for example: MyFirstWebsite. Click 

OK. 

3. A website is created and you will notice a 

window similar to the one adjacent: 

Now you can create web pages for this website. 

Navigate to the location (example: My Documents) 

where you stored the website. Notice the folder 

icon. 

Content such as images, flash 

animations, web pages & style 

sheets, etc. will be automatically 

stored in this folder. 

Create a Web page 

Once the website is created, you need to create web pages. To create a webpage, do 

the following: 

1. Select File > New > Page…. A window appears 

similar to the one adjacent. 

2. You can use MEW to create web pages using 

HTML or ASP code, Style Sheets (CSS), etc. 

Select HTML from the list and Click OK. Notice 

that a new page is created (figure below). 

3. Notice the file name 

Untitled_1.html. Being the 

first page of the website, 

this page is may be your 

homepage. Use a standard naming convention such as default.htm, index.htm 

or home.htm and save this page. To save this page, select File > Save. 

4. Type the file name as default and select Save. You need not specify .htm or 

.html extension as it is automatically added to the web page. 

Handling File Extensions 

HTML Editors such as MEW automatically append the required file extension, .html by 

default. You can configure the HTML editor to add the extension .htm by the 

following procedure: 
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1. Select Tools > Page 

Editor Options…. The 

Page Editor Options 

dialog box appears (figure 

adjacent). 

2. Select the Authoring Tab 

(figure below). 

3. Notice the default 

document type selected 

as HTML under Default 

Document: dropdown 

menu and file extension 

selected as .html in 

Default HTML File 

Extension: option. 

You can change the settings, 

and, it is recommended to 

change Document Type 

Declaration to HTML 5. 

You can configure expression web 

to use external programs such as 

notepad to open specific file 

types such as a style sheet. By 

default, style sheets open in 

expression web. To modify, do 

the following: 

1. Select Tools > Application 

Options…. The Application 

Options dialog box appears 

(figure below). 

2. Select the Configure 

Editors Tab (figure below). 

3. Notice the file extensions 

(left pane) and application 

that will handle the 

extension (right pane) 

displayed. 
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Note: Do NOT change any settings here 

for now. 

Working with a Web page 

The biggest advantage of HTML editors 

such as MEW is that the code is written 

for you by the software. 

1. Type the following in the body area 

(figure below): 

a. My Homepage. 

b. This is a website created 

using a HTML Editor. 

When you create content, MEW 

automatically intends them as paragraphs. 

You may notice the paragraph element 

indicated (see figure above) as “p” with a box above around the content. When you 

use carriage return (Enter key), MEW inserts another paragraph similar to that of the 

word processing software. 

2. Now select the text “My Homepage” and do the following: 

a. Select the Style 

dropdown located 

in the toolbar 

(figure adjacent) 

b. Select Heading 1 

<h1> from the list. 

3. Now select the text “This is a website created using a HTML Editor.” Select 

Heading 3 <h3> from the style dropdown list. 

4. Once complete, select View (Menu) > Page 

> Code (or select Code located above the 

status bar). You will see a screen similar to 

the one adjacent. 

5. Notice the text is enclosed using heading 

(h1 and h3) elements. Now save this page 

(CTRL+S). 

Since the editor writes the code for you; you can stay focused on creating the content 

rather than focusing on the code! 
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If you have noticed, there are pre-built standard HTML elements that you can use in a 

webpage by just selecting the element from the style dropdown menu Now to switch 

back to design view, select View > Page > Design. 

The three views available in MEW are: 

1. Design View: This is the default view and displays only the content. 

2. Code View: This is used either when you want to view the source code written 

by the HTML editor or, when you want to insert elements or code that is not 

available within the HTML editor. 

3. Split View: This is used when you want to use both the Design and Code View 

side-by-side. 

Using Multiple Web Browsers 

If you want to test your web page, it is a recommended practice to test using multiple 

web browsers. However you may need to set up the browser list. To specify multiple 

browsers, do the following: 

1. Select File > Preview in Browser > Edit 

Browser List…. The Edit Browser List 

dialog box appears. 

2. You may notice that some web browsers are 

added to the list by default. If you want add 

a web browser (for testing), select Add…, 

and specify the path of the executable file 

of the web browser (for example: C:\Program 

Files\Google\Chrome\Application\chrome.exe). 

3. You can also use set the screen resolution here. This could be useful when 

you want to test your pages for viewing on Smartphones or tablets that use 

different screen resolutions. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Build a website on any of the following topics: 

a. Computer Shop (Sales & Service) 

b. Bakery 

Visit different websites that offer this service and discuss how they are 

designed. Create a new empty website in MEW, create at least 2-3 web 
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pages and use different HTML elements such as Headings, Strong, etc. when 

presenting content. 

2. Add Mozilla Firefox to the Edit Browser list. 

ASSESSMENT 

Fill in the blanks: 

1. New Site is available in _____ menu. 

2. ______, ______ & _______ are type of pages can be created by HTML Editor. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create websites using templates. 

• Import sites. 

RELEVANT KNOWLEDGE 

Templates help in saving time and effort. A template for a website usually consists of 

HTML, CSS and image files that can be readily used for creating similar websites. You 

can use the built-in templates in Microsoft Expression Web to design websites. 

Create a new website using 

templates 

MEW includes many (19) built-in 

templates that can be used for 

creating websites. To create a 

website using the built-in template, 

do the following: 

1. Select Site > New Site… 

2. Select Templates and 

choose a template, for 

example Organization 5 

from the list 

3. Type a new for this website, for 

example: Company01. 

4. Change the location and store 

this website in C:\Documents 

and Settings\Lab\My 

Documents\Company01. Then 

click OK. A website based on the 

template Organization 5 will be 

created (figure adjacent). Notice 

the folders and files in the folder 

list. Now to work with the 

website, you can open any of the 

files listed here. 
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5. To work on the 

homepage, double-

click default.html. You 

can change only certain 

parts of this web page, 

because, when you 

make websites from 

templates, MEW uses 

DWT (Dynamic Web 

Template). You will 

learn more about DWT 

in later sessions. The 

text is editable within 

this page 

6. You can view this website in a browser to see how it will appear to visitors. To 

preview this website in a browser, press F12 on your keyboard. The website 

appears on the default web browser. Use the navigation links on the left side of 

the homepage to view other pages. 

Though it takes some time to get used to an HTML editor, you will soon be creating 

web pages or sites in no time with minimal efforts. 

Importing Sites 

If you have used another HTML editor or created files using a text editor, you can 

import them into your website. This is useful when you want to either use MEW HTML 

editor (ease of use) or to organize different files under one common website. You can 

also import websites that are already hosted (running live) using MEW. For example if 

you have created files manually and saved in C:\HTML and you want to import them, 

do the following: 

1. Create a New Website and give it 

a name, for example: 

IMPORTWEB. 

2. Select Site > Import > Import 

Site Wizard… . 

3. The Import Size Wizard dialog box appears. 

4. Notice the list of values in Connection Type: dropdown menu. 

5. Select the option File System from the Connection Type: dropdown menu. 

6. Click the Browse… button and specify the file path C:\HTML. Click Select. 
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7. Click Next. 

8. The Import Wizard 

creates a copy of the 

original content in 

C:\HTML. This can be 

helpful as your 

original files are left 

as it is. Click Next. 

9. Click Finish. A List of 

files is displayed. For 

importing to your 

new website, you 

can select either 

individual 

files/folders, or the 

entire content of a 

folder. To import 

entire content, select 

all the items on the 

left pane and select 

. Notice the 

results displayed 

(Figure adjacent). 

Now you can use the 

imported files. The original 

files in C:\HTML are left as 

is. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a website using any of the built-in template (choose a topic from 

the list below). Replace the content with your own relevant content. 

a. Household Supplies 

b. Pet Care 

c. Sports Shop 

d. Virtual Museum 
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ASSESSMENT 

Answer the following questions: 

1. Explain the procedure to create a website using templates. 

2. Explain the purpose of importing a website with the procedure. 

Fill in the blanks: 

1. Number of built-in templates ___. 

2. Three categories of templates are ___________, ____________ & ___________. 

3. Templates are available in ____ menu. 

4. __ function key is assigned for previewing web pages or websites. 

5. Import Site Wizard is available in ____ section of Site Menu. 

20 



SESSION 4: LISTS, FORMATING, SPELL CHECK AND FIND & REPLACE 

 

 

          

  

             

    

   

    

     

  

               

            

   

                

          

           

       

                

            

       

         

          

         

  

  

  

   

  

   

           

                 

        

  

Lesson Objectives: 

At the end of this session, using MEW, you will be able to: 

• Work with lists. 

• Format text. 

• Use Spell Check. 

• Use Find and Replace. 

RELEVANT KNOWLEDGE 

In the previous session, you learnt to work with headings and paragraphs. You can also 

work with HTML elements such as lists, images, tables, etc. in MEW. 

Create Unordered lists 

You can create a list using the procedure similar to the one you used in word 

processing software. To create an unordered list, do the following: 

1. Create a new page, save this page as unorderedlists.html. 

2. Type the following text (within quotes): 

“An electronic book or EBook is a book published in digital form. It consists of text, 

images, or both. EBooks are readable on computers, net-books and Smart phones. 

EBooks are available in the following formats:” 

3. Now place the cursor on the next paragraph. 

4. Select Unordered List from the Style dropdown menu. 

5. Type the following (press enter after each entry): 

a. DjVu 

b. EPUB 

c. HTML 

d. iBook (Apple) 

e. KF8 

f. LIT (Microsoft) 

6. Check the results in web browser (use F12 key). 

7. Switch to MEW and select View > Page > Code. Notice the code written by the 

HTML editor for unordered list (Figure above). 
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Handling Text 

You can align or format the text using the options in the common toolbar located 

below the HTML Editor Menu. This is very similar to 

word processing software; however, remember 

that being a web page, special code is needed for formatting and displaying the text. 

You can simply select the items from the toolbar and work as if you work with a 

regular document. HTML Editor writes the code for you! Switch to Code View when 

you use the toolbar items to view the source code. 

Spell Check and Thesaurus 

When you focus on creating content, you may make spelling mistakes. As a solution, 

HTML Editor has an in-built spell check program. To do a spell check on the current 

web page, do the following: 

1. Open a web page with some content. (Create some content with spelling 

mistakes if you don’t have one) 

2. Select Tools > Spelling > Spelling (F7)…. Notice the spell check utility 

checking spelling mistakes just as in a word processing software. 

You can also use the built-in Thesaurus option by selecting Tools > Thesaurus. 

Find and Replace (Text) 

If you want to replace a misspelled author or company name across a website, what 

would you do? You can use the find and replace dialog box to replace text either on a 

single web page or across an 

entire website. The functionality 

is very similar to a word 

processor. To find a particular 

text, do the following: 

1. Select Edit > Find. The 

Find and Replace dialog 

box appears (figure 

adjacent). Notice the tabs 

- one for Find another for 

Replace and a third for 

HTML Tags. 

2. To search for a particular 
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keyword 

across all 

pages in a 

website, 

enter a 

keyword in 

the Find 

What: text 

box and 

select Find All…. See the results. Double-clicking on any item in the listed 

result automatically opens the corresponding web page with the keyword 

highlighted for further action. 

Now explore and the Replace tab to replace an existing text. 

Find and Replace (HTML Tags) 

If you had initially set a table background color as blue and now want to replace it 

with another color, what do you do? Use the HTML tab of the Find and Replace 

feature! Using this, you can replace attributes, values or even a tag across a website. 

To use this feature, do the following: 

1. Select Edit > Replace. 

2. Select the HTML Tags tab. 

3. Select the appropriate option from the Replace action: dropdown menu. Note 

the list of actions that can be performed 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a HTML page utilizing the following HTML Elements: 

a. Ordered List & Definition List 

b. Bold, Italics, Underline & Text Alignment 

2. Use Spell Check to correct spelling errors in the website created 

earlier. 

ASSESSMENT 

Fill in the blanks: 

1. You can view the HTML code in HTML editor by selecting _______. 

2. ____ is the shortcut key to launch Spell Check. 

3. ___ is the shortcut key to launch find tool. 

4. ___ is the shortcut key to launch replace tool. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create tables using MEW. 

• Merge and split cells. 

• Use image background for cells. 

RELEVANT KNOWLEDGE 

MEW simplifies the tough task of creating a table using HTML with many rows and 

columns. 

Creating tables 

To create a complex table, do the following: 

1. Create a new page, save this page as 

tables.html. 

2. Switch to Design View. Place the 

cursor where you want to position 

the table. 

3. Select Table > Insert Table…. A 

dialog box appears similar to the one 

adjacent. 

4. Here you can specify the number of 

rows and columns, border size, 

border color etc. Do the following: 

a. Type 10 in Rows under Size 

section. 

b. Type 10 in Columns under Size 

section. 

c. Type 3 in Size under Borders 

section. 

d. Select Maroon from Color dropdown menu under Borders section. 

e. Click OK. 

5. Imagine how many lines of code you would have typed to have such a result! 

Now to view the HTML code, select View > Page > Code. 

6. Switch to Design View. To create borders for cells, select all the cells in the 

table. 
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7. Select Table > Table Properties > Cell…. The Cell Properties dialog box 

appears (Figure below). 

8. In the Borders section, type 

1 in Size: and select Olive 

from Color: dropdown. 

Click OK. 

9. Save the page and view in 

browser (F12). MEW creates 

style sheet codes and 

placed them within this 

webpage by default. Now 

switch to code view, scroll 

to the top and see the code 

available under <style> and 

</style> element. Now 

scroll down and see the 

style applied to the table 

and cell. So much time and 

effort has been saved! 

Merging and splitting cells 

You have created table structures like the one 

adjacent in word processors. But for a web page, 

you will need to write a lot of code to achieve 

the same! 

Using a HTML editor, it is easy. All you need to do is: 

1. Create a new page, save this page as mergetables.html . 

2. Insert a table (for example, 2 rows and 2 columns). 

3. Select the cells that you want to merge and then select Table > Modify > 

Merge Cells. 

4. Similarly, to split cells, select a single cell. Select 

Table > Modify > Split Cells…. The Split Cells 

dialog box is appears (figure adjacent). 

5. To split this cell into five rows, select Split into 

rows and type 5 in Number of Columns:. Click 

OK. Note, the entire table is auto adjusted to fit 

content. 
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6. Now switch to Code View and see the code under <style> and </style>. Scroll 

to see the style applied to this table. 

Using image background for cells or tables 

You can place images as a background for cells or tables. To include a image 

background for a cell, do the following: 

1. Create a new page, save this page as imagetables.html (You need not type the 

extension). 

2. Insert a table (minimum 2 rows and 2 columns). Place the 

cursor in the cell where you want the background. 

3. Right-click and select Cell Properties. 

4. Under Background, click Browse…. 

5. Locate and select an image, click Open and then click OK. Note the cell 

includes an image background (Figure above). 

6. Save and preview this in a web browser (F12). 

Working with Cell or Table Size 

Usually a table spans the entire screen and that may not be appealing to the eye. 

Also, sometimes you may want to specify a size for a cell or table (for example, to 

display photos). Using MEW, you can specify the size of a cell or the table. To restrict 

the size of a cell, do the following: 

1. Place the cursor in the cell to which you want to set a particular size. Right-

click and select Cell Properties. You can specify the size in pixel units or 

percentage. 

2. Under Layout, select specify width: and type 100 (In pixels). 

3. Select specify height: and type 200 (In pixels) and then click OK. Notice the 

size of the cell. 

Converting Table to Text 

You can also convert the contents of a table to text using the Table to Text option in 

HTML Editor. Explore and convert table to text and observe the changes in code. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a HTML page utilizing the Table HTM

image for a particular cell. Merge the first row 

L Element. Set a background 

and insert appropriate title. 

ASSESSMENT 

Fill in the blanks: 

1. Insert table options is available under _____ menu. 

2. To specify a background for a particular cell, you should use ____ . 

3. Table to Text option is available in ______ under Table menu. 

28 



SESSION 6: IMAGES 

 

 

   

  

           

          

  

                  

              

          

  

         

     

    

  

    

       

            

  

   

 

     

   

             

       

     

   

  

      

    

    

     

    

    

    

     

      

Lesson Objectives: 

At the end of this session, you will be able to: 

• Insert and manipulate images in web pages using MEW. 

RELEVANT KNOWLEDGE 

As you know, it is not an easy task when you have multiple images to be placed in 

varying positions within a web page. HTML editors enable you to easily place images 

with formats such as GIF, JPEG, PNG and BMP. 

Inserting images 

To insert a clipart or image, do the following: 

1. Create a new page, 

save this page as 

images.html. 

2. Select Insert > 

Picture > Picture from file… (figure above). 

3. Browse and select a picture from your computer, Click Insert. The 

Accessibility Properties 

dialog box appears (figure 

adjacent). 

4. Specify the text (ALT 

attribute) in Alternate 

Text:, for example, type Sample Image for Demo. And then click OK. The 

image is inserted in the web page! 

5. Click Save. A Save 

Embedded Files dialog box 

appears. 

MEW saves a copy of the 

image within this website 

folder. Remember this is 

the website that may be 

published to a remote 

computer for visitors. The 

image on your computer 

may not be accessible to 

them if the HTML page and 
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the image are in different locations. So, you need to save the images within 

your website to ensure that the image stays along with the website. 

HTML editor also enable you to save images in different formats. This helps 

when you want to change the image format to one that is suitable for websites. 

Also by optimizing the image size (by optimizing quality), you reduce file size 

resulting in faster downloads of images from your website. 

To change image format and/or optimize quality, click on Picture File Type…. 

The Picture File Type 

dialog box appears. 

a. Select GIF if you 

are inserting an 

image with solid 

colors. 

b. Select JPEG for 

high quality images 

such as 

photographs from a 

digital camera. The 

quality can be 

adjusted only for 

JPEG formats. 

c. Select PNG-24 if 

you are using illustrations or screenshots. 

6. Select JPEG for this exercise. Uncheck Use image as is: and specify a value. For 

example, to retain 75% of the original quality, type 75 in Quality: and click OK 

twice. 

Note: If you are using image editors such as Adobe Photoshop, JPEG images are 

automatically optimized for quality and size. In such cases, leave the image quality as 

it is. Working with image formats requires special expertise, consult an expert if 

required. 

Now this image is saved within this website. Note the image file listed in the folder 

list. Remember, what you have here is a copy of the original image. So even if 

something goes wrong with image quality, size or both, you can rework again! 

Changing Image properties 

If you want to change properties after inserting the image, do the following: 

1. Double-click on the image. You can use the Picture Properties dialog box 

(Figure below, left) to specify or change settings. 
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2. To change size of this image, select Appearance tab (Figure above, right). 

3. To reduce the image to 50% of its original size, select In Percent and type the 

value 50 in both width: and height: fields. Click OK. Notice the adjusted size 

displayed. Preview the change in a web browser (F12). Notice the value in 

alternate text is also displayed. Now switch to MEW and see the code written 

for this image element. 

When you work with images that are relatively huge (covering the whole screen), you 

can make smaller versions of the image (thumbnails) which when clicked, displays the 

image in actual size. This helps make the website with several images look pleasant 

and not crowded. HTML editors have the ability to automatically create thumbnails 

and link them to the actual size images. To create thumbnails, do the following: 

1. Create a new page, save this page as multipleimages.html. 

2. Select Insert > Picture > From File…. 

3. Select multiple pictures by using Ctrl + Click (you need at least 3-4 large size 

pictures for this exercise). 

4. Select Insert. Skip providing alternate text for now, you can add it later. Click 

OK once for each image. Notice the size of the images. 

5. Now select the image, right-click and 

select Auto Thumbnail. Repeat the 

procedure for rest of the images. 

6. The thumbnails are displayed in the 

web page. Click File> Save. HTML 

editor again attempts to save the 

images and the following dialog box appears: 
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7. Note there is a set of 

images with _small 

added to the original 

filenames. These are 

the thumbnail 

versions created by 

the HTML editor. 

Click OK. Now 

preview this web 

page (F12). Notice 

the results. Each 

image is displayed as 

a thumbnail which 

when clicked displays the larger version of the image. 

8. Switch to MEW and view code. 

Modifying thumbnail size 

All the thumbnail images have a 

standard size. This is the default 

setting of the HTML Editor. You may 

need to increase the default thumbnail 

size if it is too small for images such as 

photos or if you are unable to 

differentiate between the small size 

images. To modify the thumbnail size, 

do the following: 

1. Select Tools > Page Editor 

Options…. 

2. Select AutoThumbnail tab 

(Figure below). Note the default 

values. You can change the size 

by altering the values. 

Once changed, thereafter, the modified size is used when you create auto thumbnails 

(older thumbnails will remain the same based on the original thumbnail size). 
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Handling large images 

If large versions of many images are displayed in the same window, visitors may find it 

unpleasant to move back and forth to view images! As a solution, you can make the 

images open up in a new window. To do so: 

3. Right-click a large image and select Picture Properties. 

4. In the Hyperlink section, select the button next to Target Name… The 

Target frame dialog box appears. 

5. Select New Window from the 

Common targets: list and click OK 

twice. Save this web page to 

include the changes and preview this 

in browser (F12).Now click on the 

first thumbnail and observe the 

difference in behavior. 

6. Switch to MEW and view code. 

Aligning Images 

You can also align images along with text 

content (similar to alignments in word 

processing). To align, to the following: 

1. Create a new page, save this page as textwrap.html. 

2. Insert an image and enter some text above or below the image. 

3. Select Image and right click and select Picture Properties. 

4. Select the Appearance tab. Then select a wrapping style to wrap text. 

5. Select a value from the Alignment: dropdown (if required). 

6. Specify a border for the image by entering a value in Border Thickness: field. 

7. Click OK. Save and preview this in your browser (F12). Also, see the source 

code for this activity. 

Editing images 

You can edit images using the built-in image toolbar when you want to crop an image, 

adjusting brightness or contrast of an image, etc. To work with an image using the 

image toolbar, do the following: 

1. Create a new page, save this page as editimage.html 
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2. Insert an image and Select View > Toolbars > Pictures. The Picture Toolbar 

will be displayed (Figure below). 

3. You can use a variety of functions such as: 

a. Flip pictures using different flip options 

b. Increase or decrease brightness or contrast. 

c. Crop (keep only the necessary portion of a picture). 

4. To crop, select the crop tool ( ). Now try and crop the image (same as in any 

other software you have worked with). 

5. Save and preview this in your browser (F12). Also see the source code for this 

activity. 

Working with image formats 

When you insert images, HTML editor is configured to use GIF format for images that 

have 256 colors or lower and JPEG format for images that have more than 256 colors 

(it is intelligent!). At times, you may need to change this default behavior (to use PNG 

when you are creating content with mostly screenshots of products or images with 

focused color). To view or modify this setting, do the following: 

. 

1. Select Tools > Page 

Editor Options…. and 

select the Picture tab. 

2. Notice the values in 

dropdown menus (gif and 

jpg). You can change the 

format by selecting a 

image format from these 

dropdown menus. For example, to force the HTML editor to use PNG as the 

image format when images with 256 color or higher are detected, select PNG 

from Use the following format when converting or pasting images with 

more than 256 colors: dropdown menu. 

3. Click OK. 

To test, do the following: 

1. Create a new page. 

2. Use Ctrl + Print Screen on your keyboard to take a screenshot. 
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3. Save the page. 

4. Notice the image format displayed with the extension of PNG. 

Creating and optimizing images 

If you want to create, edit or optimize images, consider using professional photo 

editing software such as Adobe Photoshop, GIMP (Open Source), Microsoft Expression 

Design (Freeware), Google Picasa or Online editors such as Pixlr (www.pixlr.com). 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a HTML page by inserting images and provide an ALT text for all the 

images. 

2. Create a HTML page with multiple images with thumbnails and configure 

them to open in a separate window. Create custom thumbnail size of 50 * 50 

pixels. 

3. Manipulate the picture’s brightness using the Image toolbar. 

ASSESSMENT 

Fill in the blanks: 

1. To insert a picture, you should use _____ menu. 

2. When inserting multiple pictures, you should the shortcut key ______. 

3. Default thumbnail size can be modified from _____ menu. 

4. Image toolbar should be launched from _____ View Menu. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create hyperlinks to websites 

• Create hyperlinks to email addresses 

• Create hyperlinks to other web pages in a website 

RELEVANT KNOWLEDGE 

Working with hyperlinks 

It is easy to write code when you have a few embedded links. But, when there are 

many links to be included in a web page (image a large organization having 100’s of 

web pages that need to be connected), it will be difficult to code manually. Here, you 

can use HTML editors to simplify the task. 

Hyperlinks to websites 

To work with hyperlinks in HTML editor, do the following: 

1. Create a new page, save this page as links.html. 

2. Type the URL, for example www.google.com. Press Enter. Notice the text is 

automatically formatted and displayed as a hyperlink. 

3. Save and preview this in your browser (F12).View the source code for this 

activity. 

If you want to change the text from URL, do the following: 

4. Switch to MEW and 

place the cursor on 

the text that has 

the hyperlink. 

5. Right-click and 

select Hyperlink 

Properties…. The 

Edit Hyperlink 

dialog box appears. 

6. In the textbox 

Text to display:, 

replace 
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www.google.com with Google. Click OK. Notice the text changed in the 

hyperlink (the link is still available). 

To insert a hyperlink manually to point to Wikipedia, do the following: 

1. Create a new page, save this page as manuallinks.html and place the cursor 

where you place the hyperlink 

2. Select Insert > Hyperlink…. (Or use shortcut CTRL+K). The Insert Hyperlink 

dialog box appears. 

3. Enter Wikipedia in Text to display: textbox (this will be name that will be 

displayed). 

4. To include helpful tips indicating the purpose of links which will be displayed 

when the cursor is placed over the 

hyperlink, select the ScreenTip… button. 

The Set Hyperlink ScreenTip dialog box 

appears. 

5. Type Use Wikipedia to learn more. Click 

OK. 

6. Type http://www.wikipedia.org in Address: and click OK. 

Save and preview this in your browser (F12). Observe the results (Move your 

mouse over the hyperlink). Switch to MEW and view code. 

Hyperlinks to an email address 

1. Create a new page, save this page as emaillink.html and place the cursor 

where you place the 

hyperlink. 

2. Select Insert > 

Hyperlink….. The Insert 

Hyperlink dialog box 

appears. 

3. Select E-mail Addresses. 

a. Type Feedback in 

Text to display: (this 

will be name that will 

be displayed in the browser). 

b. Type an email address in E-Mail address: (for example, 

feedback@example.com). Notice the mailto: attribute is automatically 

added. 
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c. Type a value in Subject: (for example: Feedback for website). This helps 

you trace where the mail came from especially when you are using a 

single email address for multiple purposes. It is recommended that you 

use a separate email address for collecting feedback from visitors. 

d. Click OK. 

4. Save and preview this in your browser (F12). Notice the default email client is 

opened, email address and subject is automatically added leaving the email 

body empty for visitors to send their comments or feedback. 

Link to different sections within a web page 

You can link to different sections within a webpage using HTML editor. To understand 

the procedure, do the following: 

1. Create a new page, save this page as sectionlinks.html. 

2. Create at least two sections in the HTML document (leave adequate space 

between sections, at least 10 lines between them). For example, Section 1 & 

Section 2 (Figure below, left). 

Note: Leave some space at the top of the page. 

3. Select (highlight) the text Section 1. Select Insert > Bookmark…. The 

Bookmark dialog box appears (Figure above, right). 

Notice the name in Bookmark name: list. MEW automatically creates the 

bookmark for you. Click OK. Repeat the procedure to bookmark all sections. 

4. Now scroll to the top where the links will be placed. 
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5. Select Insert > Hyperlink…. Select Place in this document… under Link to:. 

6. Now type Section 1 in Text 

to display:. Select Section_1 

under Bookmarks, Click OK. 

(or use CTRL+G to 

bookmark). 

7. Repeat the procedure to 

include hyperlink for Section 

2. Save and preview this in 

your browser (F12). Check if 

the hyperlink is working by 

clicking on it. Switch to MEW 

and view code. 

Note: If you notice the hyperlinks are not functional though you are following the 

proper procedure, it may be due to insufficient space between the main text that has 

hyperlinks and the sections with the page (too close to scroll up or down). 

Link to another web page within a website 

You can link a web page to other web pages within the site. This helps visitors view 

other sections of your website that may have information on products or service that 

you offer. To link other pages within a website, do the following: 

Note: You will use the HTML files created earlier. 

1. Create a new page, save this page as weblinks.html and place the cursor 

where you want to place the hyperlink. 

2. Select Insert > Hyperlink…. Select Existing File or Web Page under Link To…. 

3. Notice the list of files displayed in your website. You can choose ANY file 

including images. To link to other web pages, you must select only web pages. 

Now select tables.html from this list, type Tables in Text to display: and 

click OK. 

4. Save and preview this in your browser (F12). Check if the hyperlink is working 

by clicking on it. Switch to MEW and view code. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create hyperlinks for at least five websites that offer free tutorials on HTML. 

Include your email address as hyperlinks. 

2. Create hyperlinks for the pages created in earlier sessions. 

ASSESSMENT 

Fill in the blanks: 

1. Hyperlink option is available under ______ . 

2. Shortcut key to insert a hyperlink _______ . 

3. Shortcut key to bookmark a section _______. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create hyperlinks using images. 

• Use Interactive buttons. 

• Use hotspots. 

RELEVANT KNOWLEDGE 

You have learnt to create hyperlinks in text in the previous session. You may have 

noticed websites that have images or buttons that link to other web pages or websites 

to make hyperlinks attractive. You can make use of the built-in facilities of MEW to 

use images for hyperlinks. 

Hyperlink using images 

You can also create links using images enabling you to use attractive buttons or 

images as hyperlinks. 

1. Create a new page, save this page as manuallinks.html. 

2. Insert an image. Select the image, select Insert > Hyperlink…. 

3. Type http://www.download.com. 

4. Generally hyperlinks open within the same window which the visitor is viewing. 

If you do not want the visitor to leave your website, you can set the target 

frame property to open the hyperlink in a new tab or window. To open the 

hyperlink in a new window, select Target Frame…. 

5. Select New Window and then click OK. 

Note: Images with hyperlinks display text such as one below (Use Ctrl + Click if you 

want the destination web page to open in HTML editor). 

This helps you to identify images with hyperlinks when 

you work with HTML editors. 

6. Click OK. Save and preview this in your 

browser (F12).Check if the hyperlink is 

working by clicking on it. Switch to MEW 

and view code. 

Using interactive buttons 
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You may have noticed buttons that are used for highlighting hyperlinks in a web page; 

you can use the “Interactive button” feature of MEW to create such buttons and 

effects instead of dull boring text or heavy images. 

To insert interactive buttons, do the following: 

1. Create a new page, save this page as buttonlinks.html. 

2. Select Insert > Interactive Button…. The Interactive Buttons dialog box 

appears. 

a. You can choose a style from buttons: list. For example, select Glass 

Capsule 1 from list. 

b. Replace Button Text in Text: with a name. For example, Mozilla. 

c. Type the URL in Link:. For example, http://www.mozilla.org. 

3. Click OK. Save and preview this in your browser (F12). Note: You need click OK 

every time you are prompted, to save the images. 

4. Check if the hyperlink is working by clicking on it. Switch to MEW and view 

code. 

Use Hotspots 

Image hotspots refer to using portions of a single image to point to a different web 

page or a link. For example, you can include a world map as a picture and link parts 

of the same image to different web pages that may have separate content for each 

continent or a country. 

Hyperlinks can be used on portions of a single image thereby creating clickable 

hotspots, when you want to link portions of the image to resources such as to a web 

page, website or email address. To create hotspots, do the following: 

1. Create a new page, save this page as hotspots.html. 

2. Insert an image (use an image that can be used for pointing out different 

portions such as world map that has continents). 

3. Select View > Toolbars > Pictures. Picture toolbar appears (Figure below). 

Note: Move your cursor over each icon to understand the purpose of each item. 

4. Select Rectangular Hotspot from Pictures Toolbar. Place the cursor 

(displayed like a pencil), drag over a particular area to draw a square or 

rectangle (this entire area will become a hyperlink). 
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5. Once complete, the Insert Hyperlink dialog box will be displayed. 

6. Type the URL in the Address: and Click OK. 

7. Save and preview this in your browser (F12). Check if the hyperlink is working 

by clicking on it. Switch to MEW and view code. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a html page and insert different images. Create hyperlinks for images 

to launch different websites in new window. 

2. Create a html page with relevant image on any of the following topics: 

a. Anatomy of human brain 

b. Anatomy of human body 

c. Parts of Bulb 

d. Parts of a computer 

e. Anatomy of a flower. 

Use image hotspot to provide hyperlinks to articles on the Internet such as a 

page in Wikipedia about each section. 

3. Create navigation menu for all pages in the website using Interactive 

buttons. Name the buttons accordingly (Hint: For homepage, use HOME). 

ASSESSMENT 

Fill in the blanks: 

1. Interactive buttons can be inserted from _____ Menu. 

2. Image hotspots can be created using ______ toolbar. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Include audio and video content in a web page using MEW. 

• Insert Flash files or movies in a web page. 

• Include Silverlight content in a web page. 

RELEVANT KNOWLEDGE 

You have learnt to include audio & video content in the HTML module. You can also 

use HTML editor to include audio & video content. 

Note: You can also use HTML 5 audio & video elements. Use Code View to insert the 

code. Also keep samples of audio and video clips ready for these exercises. 

Including audio and video content 

To include an audio clip, do the following: 

1. Create a new page, save this page as audio.html. Place the cursor where you 

place the audio player control. 

2. Select Insert > Media > Windows Media Player…. 

Note: MEW by default lists only files that are 

associated with Windows Media file types. Select All 

files from Files of Type: dropdown. 

3. Select the audio clip, for example: sample.mp3. 

Click Insert. 

4. Click Save (Save this audio clip with your website 

when prompted). Notice the result displayed in MEW 

(Figure adjacent). 

5. Save and preview this in your browser (F12). 

Note: Audio clip by default plays automatically when the page is accessed. 

If you want to customize the settings for this audio clip, do the following: 

6. Switch to MEW and double-click the Windows Media Player Control. The 

Windows Media Player Properties dialog box appears. Note the available 

controls (Figure adjacent). 
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7. For the content to play, CODEC (a software component required for playback) 

must be available on the visitor’s computer and if it is not available, you can 

include the source using CODEBASE attribute. Visitor’s browser will download 

the CODEC from the URL specified in CODEBASE: attribute of Object element, 

install and play the content automatically. 

Note: Refer to respective website for correct URL. Some of the common URL’s 

are provided here for your reference: 

Type of Content Download Location 
QuickTime (WAV) http://www.apple.com/qtactivex/qtplugin.cab 

QuickTime (MP4) http://www.apple.com/qtactivex/qtplugin.cab 

Flash (SWF) http://fpdownload.macromedia.com/pub/shockwave/cabs/f 
lash/swflash.cab#version=8,0,0,0 

8. Repeat the procedure for including video clips. Save and preview this in your 

browser (F12). Switch to MEW and view code. 

Inserting a Flash animation 

If you want to include a flash animation, do the following: 

1. Create a new page, save this page as flash.html. 

2. Place the cursor where you place the flash animation. Select Insert > Media > 

Flash Movie…. 

3. Locate and select the flash animation (file with .swf extensions), select Insert. 

4. Save and preview this in your browser (F12). Switch to MEW and view code. 

If you want to include videos, for example, from Youtube.com, do the following: 
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1. Create a new page, save this page as Youtube.html. 

2. Place the cursor where you place the Youtube video. 

Note: You need to follow the procedure before you insert videos from Youtube. 

a. Go to Youtube.com. 

b. Select a video clip. 

c. Right-click on the video and select copy embed html. 

3. Select View > Page > Code. 

4. Paste the code (example: <iframe width="640" height="360" 

src="http://www.youtube.com/embed/ieM93xFIGCc?feature=player_detailpage 

" frameborder="0" allowfullscreen></iframe>) 

5. Save and preview this in your browser (F12). Switch to MEW and view code. 

Note: You need to have an active Internet connection for this exercise. 

Including Silverlight content 

Silverlight is an application framework for writing rich internet applications similar to 

that the ones created using Adobe Flash. Rich internet applications are web 

applications that look and work similar to that of standard desktop applications such 

as accounting software, word processing software, image manipulation software, etc. 

Silverlight content is played using Silverlight plug-in a free download. 

Note: Silverlight content can be played only on Microsoft Windows operating systems, 

MAC OS and Symbian OS. You can use Moonlight, a free plug-in to view content on 

Linux based computers. 

If you want to include Silverlight content 

on your page, do the following: 

1. Create a new page, save this page 

as silverlight.html. 

2. Place the cursor where you place 

the Silverlight content. Select 

Insert > Media > Silverlight. The 

Select a Silverlight XAP file dialog 

box appears. 

3. Silverlight files have the extension 

.XAP. Browse and select the file 

and then select Open. 
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4. Save and preview this in your browser (F12). Notice the Silverlight content 

displayed in the browser (if the plug-in is available). Switch to MEW and view 

code. 

You can use products such as Powerlight Converter, PPTX2SilverLightConverter, etc. 

to convert a presentation to simple Silverlight content. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Insert relevant audio & video clips with a variety of file formats for the 

website created in earlier sessions. 

2. Create a web page and include videos from YouTube. Collect and present 

links related to learning HTML, CSS, Expression Web, XML, XHTML and 

JavaScript. 

ASSESSMENT 

Fill in the blanks: 

1. Media Player control should be inserted from _________ dropdown menu of 

_____ Menu. 

2. Flash content should be inserted using _______ option from _________ 

dropdown menu of _____ Menu. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Use frames, inline frames and layers. 

RELEVANT KNOWLEDGE 

You have learnt to use frames, inline frames in HTML module. Frames are used to 

display one or more pages within a single web page; collections of different frames 

are referred to as a frameset. Frames are used to display different pages as a single 

page in a web browser. You can use the capabilities of MEW to include frames and 

inline frames in a web page. 

Frames 

You have learnt to use frames using HTML code. MEW includes few frame styles that 

you can use right out of the box. 

To create a web page using built-in frames, do the following: 

1. Select File > New > Page…. 

2. Select Frames Pages. A list 

of frames with different 

styles is displayed. 

3. Select Header, Footer and 

Contents from the list and 

Click OK. Notice the results 

displayed. 

4. If you want to use the 

existing HTML files, select 

Set Initial Page…. Select 

any of the HTML pages 

created in earlier activities 

and click OK. 
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5. If you want the HTML 

editor to create a new 

page for rest of the 

frames, select New Page…. 

6. Select File > Save 

(CTRL+S). You will have to 

save each new page that is 

a part of this frame. 

Preview this in your 

browser (F12). Switch to 

MEW and view code. 

If you want to edit or work with 

individual web page in a frame, it 

is recommended to open each file 

separately (open by the file name 

from the folder list). Once 

complete, open the frames.html 

in the HTML editor or web 

browser. 

iframe 

You have learnt to use iframes 

using HTML code. You can also 

create iframes using MEW with 

minimum efforts. To insert an iframe, do the following: 

1. Create a new page, save this page as iframe.html. 

2. Place the cursor where you want the new iframe to 

be placed. Select Insert > HTML > Inline Frame. 

Notice a new frame is inserted within this page. 

3. Select Set Initial Page…. Type 

http://en.wikipedia.org/wiki/Iframe in Address: and click OK. 
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4. Save and preview this in your 

browser (F12). Switch to MEW and 

view code. 

To modify the appearance of an 

iframe, select the iframe and 

double-click on it. The Inline Frame 

Properties dialog box appears 

wherein you can modify the size, 

include margins, align text, disable 

scrollbar or provide alternate text. 

Layers 

Layers are advanced techniques that you 

use to float content on top of other 

content in a web page. You use this 

when you want to include a popup 

registration form or menus when a 

visitor views a web page. Layers can also help in keep 

content such as image or dropdown menus fixed in a 

particular position in a web page. Layers are managed using 

a special element called DIV. To insert layers, do the 

following: 

1. Create a new page, save this page as layers.html. 

2. Select Format > Layers. The Layer Toolbar appears. 

3. From the toolbar, select Insert Layer . A new layer is inserted similar to 

the one below. 

4. You can increase or decrease the size of this layer by 

selecting the layer box and drag around the corner. To 

place this elsewhere, simply drag the entire layer box. 

5. Now insert an image in this layer: 

a. Place the cursor inside the layer. Select Insert > 

Picture > From File… 

b. Locate and Insert the image. Notice the picture is 

within the layer. 

6. Now type some content in the web page. Notice the image present in the layer 

does not move along with the content and stays in the position that you fixed. 
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7. Save and preview this in your browser (F12). Switch to MEW and view code. 

Note: Layers are an advanced concept and require additional practice to understand. 

You can place multiple layers on top of each other (Figure below). 

This is done by inserting and positioning additional layers. Use the 

Layer toolbar to insert additional layers. 

To use the toolbar to position layers, do the following: 

1. Select View > Toolbar > Positioning. 

2. Insert an HTML element in the body, for example: a table 

with 2 rows and 3 columns and select the Table. 

3. Select position: fixed from the dropdown. 

4. Notice the values in positioning toolbar indicated in pixels. 

5. Now try typing content in this web page. Notice the table is 

in a fixed position. 

Note: It will take a while to work with positioning and particularly CSS. Use help file 

and search engines for more examples. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a web page with three frames to represent the following 

designs: 

Link to existing pages created in earlier sessions. 

2. Create a web page with inline frame to point to different websites. 

3. Create at least 3 overlapping layers and include picture in each layer. 
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ASSESSMENT 

Fill in the blanks: 

1. Frame page should be created from _____________ menu. 

2. iframe should be inserted from ______ dropdown of ______ menu. 

3. Layer toolbar can be accessed from _______ menu. 
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SESSION 11: HOVER EFFECT, META ELEMENTS & WATERMARK 

 

 

        

  

           

        

        

       

  

             

               

               

           

     

   

    

  

       

     

     

   

     

   

   

 

   

    

 

         

          

  

   

               

           

    

  

Lesson Objectives: 

At the end of this session, you will be able to: 

• Use meta elements in a web page. 

• Use hover effects in a web page. 

• Use Watermark in a web page. 

RELEVANT KNOWLEDGE 

You have learnt to use HTML elements and attributes such as Title, Description, 

keywords, etc. using HTML code. You can also use the HTML editor to include such 

elements easily. Note that the settings modified here apply only to the current page. 

1. Create a new page, save this page as meta.html. 

2. Right-click on the body, 

select Page Properties. 

The Page Properties dialog 

box appears. 

3. You can specify the Title in 

the Title: text box. Enter 

details about the website in 

Page Description: textbox 

and use keywords for this 

website using the 

Keywords: textbox. Now 

type: 

a. Webpage created 

using HTML editor in 

Title: 

b. We offer great web designs in Page Description: 

c. Type Web Page Development, Web Design, Website Development in 

Keywords: 

d. Click OK. 

4. Save and preview this in your browser (F12). Switch to MEW and view code. 

Notice the HTML elements and content inside elements have been created 

automatically by MEW! 
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Modifying background 

You can also specify a color or image background for a web page. To set a background 

color, do the following: 

1. Select View > Page > Design. 

2. Right-click on the body and 

select Page Properties. 

3. Select the Formatting tab. 

4. In the Colors section, select 

Silver from the Background: 

dropdown menu. 

5. Click OK. 

6. Save and preview this in your 

browser (F12). Switch to MEW 

and view code. 

Modifying appearance of links 

You can also modify how links appear in a web page. To apply hover effects, do the 

following: 

1. Create a new page, save this page as hover.html. Insert at least two or three 

hyperlinks. 

2. Right-click on the body, select Page Properties. Select Formatting tab. 

3. Select the following values in the Colors: section: 

a. Green for Hyperlink:. 

b. Silver for Visited Hyperlink:. 

c. Maroon for Active Hyperlink:. 

d. Teal for Hovered Hyperlink:. 

4. Click OK. Save and preview this in your browser (F12). Switch to MEW and view 

code. 

Inserting a watermark 

You can include a watermark for a web page when you want to inform visitors that 

you are still testing the website or it is under development. To include a watermark, 

do the following: 

1. Create a new page, save this page as watermark.html. 

2. Right-click on the body, select Page Properties. Select the Formatting tab. 
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3. Select Background Picture under Background. Click browse:, select the image 

you want as a watermark and then click OK. 

4. Check Make it a Watermark and click OK. 

5. Type some content in the webpage (at least one or two pages in length). 

6. Save and preview this in your browser (F12). Now scroll down the page and 

notice the background is in fixed position and does not move along with 

content. Switch to MEW and view code. 

Changing the margins 

You can also adjust the margins of a web page while designing the page. Doing so 

leaves some space on either sides of a webpage where you may want to place 

advertisements later on. To adjust the margin, do the following: 

1. Create a new page, save this page as margin.html. 

2. Right-click on the body, select Page Properties. Select Advanced tab. 

3. To specify the margin size (in pixel units), type: 

a. 30 in Top Margin:. 

b. 60 in Left Margin:. 

c. 60 in Right Margin:. 

d. 30 in bottom Margin:. 

4. Type some content. Save and preview this in your browser (F12). Switch to 

MEW and view code. 

Specifying the language 

You can also specify the language the web page is created with. This information is 

used by search engines to index and display language specific results to visitors, by 

screen reader software to understand the language of the content used in a web 

page, by automated translation tools that translate web pages from one language to 

another and so on. To specify a language, do the following: 

1. Create a new page, save this page as lang.html. 

2. Right-click on the body, select Page Properties. Select Language tab. 

3. Select English (India) under Mark current document as: dropdown menu. 

4. Click OK. Save and preview this in your browser (F12). Switch to MEW and view 

code. 

Note: You may not notice any visual difference in web page as this is used only by 

search engines, screen readers or browsers for internal use. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Include meta elements such as title, description and keyword for web pages 

created earlier. 

2. Include a picture as a watermark. 

3. Create hover effect: 

a. Dark Blue for Hyperlink:. 

b. Dark Green for Visited Hyperlink:. 

c. Black for Active Hyperlink:. 

d. Teal for Hovered Hyperlink:. 

4. Set margins: 

a. 10 in Top Margin:. 

b. 10 in Left Margin:. 

c. 10 in Right Margin:. 

d. 10 in bottom Margin:. 

ASSESSMENT 

Fill in the blanks: 

1. Meta elements can be inserted through ____ options. 

2. _________________________ should be checked under background if you want 

to use a picture as a watermark. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create forms. 

RELEVANT KNOWLEDGE 

You have learnt to create forms using HTML code. As you are aware, forms are used 

for collecting information from visitors or for displaying relevant results to visitor. You 

can include forms in a website using the HTML editor. 

Creating forms 

To create a simple HTML form, do the following: 

1. Create a new page, save this page as form.html. 

2. Select Insert > HTML > More HTML Tags…. The HTML 

Toolbox is displayed, scroll down and expand Form 

Controls (Figure adjacent). 

3. To create a form, first you need to add the form control. 

To add the form control, select Form from the 

Form Controls 

4. Click and drag from the toolbox to the web page where you want to 

place the form. 

You need to add elements to make this form functional. There are a variety of 

form controls available with this HTML Editor. For example you can use textbox 

element to collect a visitor’s email address. 

5. Select Input (Text) from Form Control List. Drag and drop it inside the form 

area (Figure below, left). 

list. 
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6. You need to indicate the user the purpose of this field. You can do that by 

double-clicking on an element. Double-click the Input (Text) field that you 

just inserted. Text Box Properties dialog box appears (Figure above, right). 

a. If you have multiple fields in a form, they will be easy to locate and 

understand if you have friendly names assigned to it. To add a name, 

type Email in Name:. 

b. To indicate the purpose of this field, type a value in Initial Value: field. 

This will be displayed initially but can be replaced by visitor’s email 

address. Type Enter your email address in Initial Value: field. 

c. Click OK. 

7. Press Enter to move to the next line. 

8. You need to add a control for this form to be submitted. You 

should use the Input (Submit) control from the Form 

Control List. Select Input (Submit) from the list, drag and 

place it below the Input (Text) field inserted earlier. Now your form will start 

to look like the one 

adjacent. 

9. Now this form needs to be 

configured. To send the 

form details for further 

processing, after the visitor 

enters the email address, 

you need to specify the URL 

where the details should be 

sent. Now right click the 

form, select Form 

Properties. The Form 

Properties dialog box will 

be displayed (Figure 

adjacent). 

a. Select Options…. The Options for Custom Form Handler dialog box 

appears. 

i. You need to specify the 

URL in the text box 

Action: for the details to 

be sent to a script that 

will take care of further 

execution. Type a URL, 

for example: http://www.example.com/submit.asp or 

submit.asp. 
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ii. You need to specify a method. Since we are sending data, select 

POST. 

iii. Click OK. 

10.Give a relevant name to this form that helps track different forms used in a 

website. In this activity, type Newsletter and click OK. 

11.Save and preview this in your browser (F12). Switch to MEW and view code. 

Note: You need to point to the URL that has the script to process this form further. If 

you have provided values just for demo, your form will NOT work. However, you can 

understand the concept behind HTML form. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a form to collect the First name, Last name, Email address, Date of 

birth and Favorite book genre (Science, Science Fiction, Statistics) of visitors 

as single selection. 

ASSESSMENT 

Fill in the blanks: 

1. Form elements are available in ________. 

2. ________ control should be used for password fields in a form. 

3. To create a dropdown list, __________ control should be used. 

4. To provide description inside a form, ________ control should be used. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create Style Sheets (CSS). 

• Apply a style sheet across a website. 

• Apply CSS code to a single page. 

RELEVANT KNOWLEDGE 

If you have noticed HTML code is complimented using CSS. HTML Editor uses CSS for 

presentation to align your website to certain standards as set by W3C. 

Create a style sheet to be used across a website 

You can also create style sheets that could be 

applied across an entire website. You have learnt to 

create style sheets manually in CSS Module. You can 

use MEW to create style sheets using the following 

procedure: 

1. Select File > New > CSS. 

2. You can use the Style toolbox (Figure adjacent) to create styles in the style 

sheet. (If it is not 

visible, select 

Panels > Apply 

Styles….). 

3. Select New Style…. 

The New Style 

dialog box appears 

(Figure adjacent). 

4. You can define 

styles for each 

HTML element 

using the Selector: 

dropdown menu. 

a. For example 

to apply a 

particular 

setting for 

body HTML element, 
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i. Select body from Selector: dropdown 

menu. 

ii. Select Verdana from font-family: 

dropdown menu. 

iii. Select small from font-size: dropdown 

menu. 

iv. Select Gray from Color: dropdown menu. 

v. Click OK. 

vi. Notice the CSS code written automatically (figure above) 

b. To apply a particular setting for Table element, 

select New Style…. 

i. Select Table from Selector: dropdown 

menu. 

ii. Select Courier from font-family: 

dropdown menu. 

iii. Select x-small from font-size: dropdown 

menu. 

iv. Select Gray from Color: dropdown menu. 

v. Click OK. 

vi. Notice the CSS code written automatically (Figure above) 

Note that the code is appended to the existing code. This is helpful when you 

want to modify an existing style sheet. 

5. Save this file with a file name, for example, mystyle.css (You need not type 

the file extension). 

Apply a style sheet across a website 

Now you need to link all the web pages in the website to this style sheet. This is 

usually done by including this style between <style> and </style> elements in each 

page. HTML Editor can add that code for you. 

To apply this style sheet to all the web pages in 

a website, do the following: 

1. Select Attach Style Sheet… under Apply 

Styles. The Attach Style Sheet dialog 

box is displayed (Figure adjacent). 

2. Select All HTML Pages in Attach to: option. You can either include the CSS 

code to all the pages or link all the pages to use the CSS code in this style 
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sheet. It is highly recommended and considered best practice to link style 

sheet as: 

a. You have a better control of the whole site via a single style sheet. 

b. Change of the settings in one style sheet is automatically applied to all 

the web pages linked to the style sheet. 

3. Select Link. 

4. Select browse…. Select the style sheet you created earlier (mystyle.css) and 

click OK. 

Note: Linking all the web pages may take a while depending on the number of web 

pages in the website. Notice the popup message once complete. 

5. To verify if the link is added, open any HTML page in this website. Select View 

> Page > Code. Notice the link to mystyle.css within the <head> and </head> 

elements. 

Removing Style Sheet Links 

To remove style sheet links from a single web page, remove the line that contains 

code for linking to a style sheet. To remove style sheet links for all web pages, open 

any web page that has the link to a style sheet and do 

the following: 

1. Select Panels > Manage Styles…. 

2. Select the Style Sheet listed under CSS Styles:. 

3. Right-click and Select Manage Style Sheet 

Links…. The Link Style Sheet dialog box 

appears (Figure adjacent). 

4. Select All Pages. 

5. Select the Style Sheet from the URL: list. 

6. Select Remove. 

7. Click OK. 

8. Click Continue. 

Now the links will be automatically removed from all the web pages. 

Use CSS code for a single page 

You can also use CSS for a specific web page when you want to use a separate style 

for that particular web page only. To specific CSS for a specific page, do the 

following: 
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1. Create a new page, name it single.html. 

2. Select Format > New Style…. The New Style dialog box appears. 

a. Select Paragraph element from Selector: 

dropdown list. 

b. Select Book Antiqua from font-family: dropdown 

menu. 

c. Select medium from font-size: dropdown menu. 

d. Select Lime from Color: dropdown menu. 

e. Click OK. 

3. Select View > Page > Code. Notice the CSS code included only for this web 

page. 

4. Create some content using paragraph element. Save and preview this in your 

browser (F12). 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a style sheet and define the following elements: 

• Body - background color - light grey 

• Paragraph - left aligned, Times New roman font, size 12pt 

• Table - Border color - Green, thickness 3 pt 

• Heading 1 - Center aligned, Times New roman font, size 20pt 

• Heading 2 - left aligned, Tahoma font, size 16pt 

• Heading 3 - left aligned, Georgia as font, size 14pt 

Apply this to all the web pages in a website. 

2. Create a style sheet and define the following elements: 

• Body background color – Dark Grey 

• Heading 1 – Left Aligned, Century Gothic, size 18 pt 

• Heading 2 – Left Aligned, Century Gothic, size 16 pt 

• Heading 3 – Left Aligned, Century Gothic, size 12 pt 

• Paragraph – Left Aligned, Verdana, Size 10 pt 

Apply this only to the home page. 

ASSESSMENT 

Fill in the blanks: 

1. External style sheets should be created from ______ menu. 

2. Style sheets should be linked using _____ attribute. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Work with behaviors. 

RELEVANT KNOWLEDGE 

Behaviors are pre-defined scripts that add interactivity to a web page. For example, 

you can display a “tip” when a visitor moves the mouse over a particular text. 

You can create behaviors without writing any JavaScript code and get a limited level 

of functionality. You need to use JavaScript for advanced functions; however, you can 

use the built-in Behavior functions to achieve most simple tasks such as: 

• Do something when an object is clicked. 

• Do something when an object is double-clicked. 

• Do something when the cursor is over an object, etc. 

Onclick 

If you want to display a popup message box when a visitor clicks on an image, do the 

following: 

1. Create a new page, save this page as popup.html. 

2. Insert an image, ensure the image is selected. Select 

Format > Behaviors. The Behaviors toolbar is 

displayed. 

3. Select Popup message from the Insert dropdown menu 

(Figure adjacent). 

4. The Popup Message dialog box appears. Type the 

message to be displayed when the visitor clicks on the 

image you inserted earlier (step 2), for example, Image 

Popup using behavior. 

5. Click OK. Save and preview this in your browser (F12). 

Click on the image and notice the popup displayed 

(Figure adjacent). Switch to MEW and view the code. 

Mouseover 

If you want to display a popup when the visitor moves the mouse over an image 

instead of clicking on it, do the following: 
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1. Select View > Page > Design. 

2. Select the image. 

3. From the Behavior toolbar, under Events dropdown, select onmouseover. 

4. Save and preview this in your browser (F12). Move the cursor over the image 

and notice the popup displayed without clicking. 

5. Switch to MEW and view code. 

Redirect 

You can also redirect visitors to another web page or website when they click or move 

their cursor over an image. To redirect a 

visitor, do the following: 

1. Create a new page, save this page as 

redirect.html. 

2. Insert an image, ensure the image is 

selected. 

3. Select Go To URL from the Insert dropdown menu. The Go To URL dialog box 

appears. 

4. Enter an URL. For example, http://www.youtube.com and click OK. 

5. Save and preview this in your browser (F12). Click on the image and notice the 

page is redirected to YouTube. Now try using other behaviors available with 

MEW. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a web page with the following behaviors: 

• Use an image which when double-clicked should take visitors to a 

website. 

• Insert multiple images and display a popup message for each message 

(onmouseover). 
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ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of behaviors with an example. 

Fill in the blanks: 

1. Behavior option is available under ______ Menu. 

2. ______ behavior displays a popup message when a visitor moves their cursor 

over an image. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Check compatibility of a website with different web browsers. 

RELEVANT KNOWLEDGE 

Checking compatibility with other browsers 

Once you complete designing your website, you need to ensure that your website 

works and looks as expected. You can use the compatibility checker to check all pages 

of a website are compatible with different browsers. This helps save time and you 

need not worry about checking each and every web page or item on your website. 

To check for compatibility, do the following: 

1. Open the website that you want to check. 

2. Select Tools > Compatibility Reports…. The Compatibility Checker dialog 

box appears. 

3. A big advantage is that 

compatibility checker can be run 

across the entire website as it 

checks page by page 

automatically. You need to 

specify the HTML and CSS 

standards that need to be 

verified for compatibility. For 

example, 

a. Select HTML 5 from Check HTML/XHTML compatibility with: 

dropdown menu. 

b. Select CSS 2.1 from the Check CSS Compatibility with: dropdown 

menu. Click Check. 

Notice the results displayed. Review each element and correct as required; remember 

to re-run the checker till you have an error free website. 

As you may have some visitors using older browsers (which is most likely on the 

Internet), you need to check for compatibility with older standards too. Now to test 

this website, for older standards such as HTML 4.01 and CSS 1.0, do the following: 

1. Select Tools > Compatibility Reports…. 
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a. Select HTML 4.01 Strict from Check HTML/XHTML compatibility with: 

dropdown menu. 

b. Select CSS 1.0 from the 

Check CSS Compatibility 

with: dropdown menu. 

c. Select Check. 

2. Notice the results displayed (figure 

adjacent). 

Notice the compatibility problems as the 

code in Style sheet is found incompatible 

with CSS 1.0. This indicates that this page may display properly on browsers that 

support only CSS 1.0. 

Note: In such cases where you need to target older browsers or standards, configure 

the HTML editor to use older CSS standards. However, for 

existing code you need to modify the code manually. 

You can also check for issues with CSS code by: 

1. Select Tools > CSS Reports…. The CSS Reports 

dialog box appears. 

2. Click the button Check. Notice the results displayed. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Run compatibility checker, select HTML 5 and CSS 2.1 and validate if the 

website created earlier is standard compliant. 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of compatibility checker with an example. 

2. List the versions available in Check HTML/XHTML compatibility with: dropdown 

menu. 

3. List the versions available Check CSS Compatibility with: dropdown menu. 

Fill in the blanks: 

1. Compatibility Reports is available under _____ menu. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Work with CODE view. 

• Use add-ins. 

• Use snippets. 

• Implement page transitions. 

RELEVANT KNOWLEDGE 

Though most tasks can be completed using GUI, at times you may have to insert code 

manually (for example when you want to integrate with your website, a third party 

web application, provided as code). 

IntelliSense is a feature that automatically provides you a list of codes and attributes 

as a popup when you work in the code view mode. 

Working with CODE View 

To understand how to use it, do the following: 

1. Create a new HTML page. 

2. Select Code View. 

3. Place the cursor after the <body> tag. 

4. Type angle bracket < to open the tag. Notice the list of elements displayed 

(Figure below). 

5. Select a element from the list, for example: h1 . 
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6. Now place the cursor after the element and press spacebar. Notice the list of 

attribute related to this element is displayed. Select align, (notice the 

attribute added), select = on your keyboard. Notice the value corresponding to 

this attribute is selected. Select Center. 

7. Close the tag using >. Notice the end tag is automatically added. 

Though code view can be difficult to use in the beginning, once you have adequate 

practice, you will gain total control of the coding environment! 

To view IntelliSense settings, do the following: 

1. Select Tools > Page Editor 

Options…. 

2. Select the tab IntelliSense 

(Figure adjacent). 

3. Notice the settings. Note that 

you need additional technical 

expertise to work with this 

area. 

Important: Do NOT change 

any setting here. 

Add-ins 

Add-ins extends the capability of the 

main program by adding enhanced 

custom commands and specialized 

features. You can download a variety 

of Add-ins from: 

• http://msdn.microsoft.com/en-us/expression/jj873995.aspx 

• http://www.webassist.com/go/xweb-add-ins 

• http://www.expressionextras.com/products/lightbox.htm 

• http://www.dotnetcurry.com/ShowArticle.aspx?ID=534 

Of Course, you can use Google to find more Add-ins! Once you have downloaded an 

Add-in, use the following procedure to install the Add-in: 

1. Select Tools > Add-ins. The Manage Add-ins dialog box appears. 

2. Select Install…. Browse and select the Add-in and then click Open. 

3. Select Yes. 
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4. Repeat the procedure to include more Add-ins. 

Note: Add-ins may need to be installed through a special procedure. Refer to Add-ins 

help file for detailed instructions. 

Using Snippets 

Snippets are pieces of programs re-used by most developers. Snippets are useful as 

you can keep reusing the code created many times across multiple web pages or web 

sites saving enormous amount of time and effort. To view and insert the available 

snippets, do the following: 

1. Select Panels > Snippets. Notice the list of snippets 

available separated into categories such as CSS, HTML, 

JavaScript, JQuery, etc. 

2. To insert a snippet, do the following: 

a. Create a new page. Place the cursor where you 

want the snippet to be placed. 

b. Select View > Page > Code. (Snippets can be 

inserted only in Split or Code View). 

c. Expand HTML, expand Hyperlink folder. 

d. Double-click on a snippet, for example: Add to 

favorites. Notice the code is added to the web 

page. 

e. Save and preview this page in browser (F12). Switch to MEW to view 

code. 

Note: You may require following additional instructions for some of the snippets listed 

here. Refer to the help file for detailed instructions. 

PSD Templates 

As a web designer, you need to create pages that are attractive and simple. 

Remember that along with showcasing content to a visitor and the design also needs 

to be pleasant, encouraging them to repeat their visit to the website. 

When it comes to Web design, you need to maintain a balance between visual design 

and code. Though it is possible to create simple web designs using standard HTML, it 

is always a good practice to research on good designs. Components of some of the 

attractive websites are usually created using Adobe Photoshop and later integrated 

into the web site for additional functionality such as text content, forms, etc. 
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You can import certain parts (or layers) or entire images into your website using MEW. 

Given here is a list of websites where you can find Photoshop templates (some of 

them are free!): 

• http://www.psdtemplates.com/templates/ 

• http://www.freepik.com/free-psd/web-templates 

You can browse, select, download and use these files. Refer to website terms and 

conditions for license information. 

Link PSD & MEW 

Also there is a special feature that can be used for updating an image whenever the 

original (.PSD) Photoshop image is modified. To understand how to use this feature, 

do the following: 

Import a .PSD (Photoshop files use this extension) file and do the following: 

1. Create a new web page, save the 

file as psd.html. 

2. Select File > Import > Adobe 

Photoshop (.psd)…. 

3. Browse and select the file. Click 

Open. Import Adobe Photoshop 

File dialog box appears (Figure 

adjacent). 

4. You can select the layers you want 

to import using the options in the 

left pane. Select Compatibility Image located at right bottom and click OK. 

5. Click Save when prompted. 

6. Right-click on the image, notice 

the menu item Adobe Photoshop 

(.psd) (Figure adjacent). 

7. You can update this image 

whenever the original image is 

updated by selecting Update from Source…. This is possible because MEW 

maintains a link between the image and the original source. This is one feature 

that is useful for both web developers (who write code) and web designers 

(who design sites)! 
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Page transitions 

You can apply special effects to web pages just as in presentation software. This 

helps present special effects to visitors. To add 

transitions, do the following: 

1. Create a new page, save the file as 

trans.html. 

2. Select Format > Page Transition…. The 

Page Transitions dialog box appears (Figure 

adjacent). 

3. You need to select an event to which the 

effect should be applied. Select Site Enter from Event: dropdown and select 

Circle In from Transition effect: list. 

4. Type 5 in Duration (seconds): box and click OK. 

5. Save and preview this page in browser (F12). Switch to MEW and view code. 

Note: Page Transitions will work only on Internet Explorer 5.5 or above. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Download and use the following Add-ins: 

a. PayPal ecommerce Toolkit 

b. WordPaste Add-in 

c. Insert Bing Map Add-in 

So think DHTML Menu Addon 

2. Include different snippets in web pages created in earlier sessions. 

3. Set the following transition effects for each web page created in earlier 

sessions: 

a. Random dissolve 

b. Blend 

c. Box Out 

d. Split horizontal in 

4. Download and import a .PSD file. 
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ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of Add-ins. 

2. List any three website that offer Add-ins for download (use Google). 

3. Explain the purpose of snippets with an example. 

4. Explain the purpose of Page Transitions with an example. 

Fill in the blanks: 

1. Add-ins is available _____ menu. 

2. Snippets can be accessed from ________ menu. 

3. PSD can be imported from _____ menu. 

Page Transitions is available _____ menu. 

74 



SESSION 17: DYNAMIC WEB TEMPLATES 

 

 

     

  

           

       

  

              

             

                

            

               

            

          

              

   

               

   

                

            

            

      

         

           

            

         

                 

            

             

            

         

    

         

   

Lesson Objectives: 

At the end of this session, you will be able to: 

• Create and edit dynamic web templates. 

RELEVANT KNOWLEDGE 

Templates help you organize the entire website to have a consistent look and feel. 

This is very helpful when you work with large number of web pages. 

On your website, you may have some common items displayed on all pages such as the 

logo, copyright & organization details, navigation menu, etc. but the content may 

vary on each page. Here, you can create a dynamic web template (DWT) with fixed 

positions for common elements and modifiable designated portions on each web page. 

Unlike standard templates, Dynamic Web templates have the following features: 

1. When you update the DWT, all web pages in the website are automatically 

updated to changes. 

2. You can create multiple DWT and keep changing just the template that affects 

the entire website. 

3. You can allow only specific portions of the pages to be edited instead of whole 

web page resulting in better control and reduced chances of mistakes. This 

feature is very useful when multiple developers work on the same website. 

Creating a dynamic web template 

To create a dynamic web template, do the following: 

1. Create a new web page (to be used as template). 

2. Add common elements such as a logo (picture), company name, copyright 

notice at the bottom of the web page, etc. 

3. You need to add editable regions and that will be the only area in which the 

content can be modified. To create an editable region, do the following: 

a. Place the cursor where you need to place content (remember, this will 

be the only area where the content can be placed or changed). Right-

click and select Manage Editable Regions…. The Editable Regions 

dialog box appears (figure below). 

b. Type a name, for example: Content. Click Add. 

c. Click Close. 
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4. Select File > Save. Select Dynamic Web Template from the Save as type: 

dropdown menu (Figure above, right). Type a file name, for example: 

MyTemplate and click Save. 

Using a dynamic web template 

You have created a DWT template. If you want to create web page based on this 

template, do the following: 

1. Select File > New > Create from Dynamic Web 

Template…. (Figure adjacent). 

2. Notice the template displayed in the list. Select 

the template, for example: MyTemplate and click 

Open. A web page based on this template will be created and displayed. 

Template List Web Page 

3. Notice that you are able to type content only in the editable region specified 

earlier and rest of the area are not editable. Now type some content in the 

“Content” area. Save this page as a normal web page. For example, 

Page01.html. 

4. Create at least 2-3 pages based on this DWT. Save the files. 
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Editing a dynamic web template 

When you edit the DWT, it automatically updates the changed layout to all the pages 

created using the DWT (for example, when you want to change to a different layout 

or update the company logo without affecting the content). To edit a DWT, do the 

following: 

1. Locate the Dynamic Web Template you created earlier (it will be displayed 

with the file extension .dwt) and double-click on it. 

2. Now add another editable region by placing the cursor elsewhere in the web 

page. Name the region as “Photos”. 

3. Now save this DWT (CTRL+S). Notice 

the message displayed (figure adjacent). 

4. Select Yes. Automatically all the web 

pages created using this template are 

updated. 

5. Open any of the web pages created using this template and notice the changes. 

6. Insert an image in the “Photo” region. Save the web page. 

Sometimes you may have to use a completely different layout for entire website. In 

such cases you can create a new dynamic web template and associate all the web 

pages to this new DWT. This in turn will (in no time) apply the new structure to all 

the web page eliminating the need for making layout changes to each web page! 

To create a new DWT and associate all web pages (or selected web pages), do the 

following: 

1. Create a new DWT by swapping the “Content” and “Photos” regions: 

a. Create a region for “Photos” (at the top) 

b. Create a region for “Content” (below Photo) 

2. Save this as DWT with a new file name, example: MyTemplate02. 

Note: You need to include the region names as the content has to be retained but 

placed according to the new layout. Use the same region names when you want 

to work with different DWTs. Otherwise content may not swap properly leading 

to issues. 

Now, to use this new DWT, associate the web pages to the new template. 

1. Select all the web pages (Page0x.html) using the folder view (left pane). Use 

CTRL + Click to select multiple pages. 
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2. Select Format > Dynamic Web Template > Attach Dynamic Web Template… 

(Figure below, left). 

3. Attach Dynamic Web Template dialog box appears (Figure above, right). 

4. Select the second template, for example: MyTemplate02 and click Open. 

5. Notice the results displayed. Content from “Photos” and “Content” are 

automatically swapped based on the new template. 

Remove DWT association with selected or all web pages 

When you no longer need to use DWT or are using a HTML editor that may not have 

support for DWT, you can detach the DWT linked with selected or all web pages. 

Note this procedure only removes the relationship and is a one-way process. Content 

and the layout are left undisturbed. However if you want to associate with a DWT you 

need to start all over again! If you decide at some point to remove the relationship of 

DWT and selected or all web pages, do the following: 

1. Select all the web pages (Page0x.html) using the folder view (left pane). 

2. Select Format > Dynamic Web Template > Detach from Dynamic Web 

Template. 

3. Notice the message displayed, select Close. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a dynamic web template using the following guidelines: 

• Use a table to link different pages in a website for navigating to other 

pages. 

• Use a table for the content area. 

• Insert copyright notice at the bottom and a hyperlink to the 

homepage (default.html) 

Link this DWT to the all the web pages in the website created in 

previous sessions. 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of dynamic web template with an example. 

Fill in the blanks: 

1. Acronym for DWT _____________________________. 

2. _________________________ from the Save as type: dropdown menu should be 

used for creating DWT. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Understand the concept of SEO. 

• Use SEO Checker. 

RELEVANT KNOWLEDGE 

Search Engine Optimization or SEO refers to the process that affects the website 

visibility or ranking when displaying search results. Search Engines search contents of 

a web page and create indexes to display results. As a web developer, you need to 

understand how search engines work and how to get better search ranking. SEO 

Checker built-in with the HTML Editor gives detailed reports that help you optimize 

the website for better ranking. 

Anatomy of a Search Engine 

Search engines crawl a website (and hence referred to as Spiders) to create index of 

content. This index helps find a matching web page or link based on keywords entered 

by visitors. 

Search engines index the following components of a web page: 

1. Page Title (only the first 70 characters are displayed in search results!) 

2. Page Description (at least first 156 characters are displayed in search results!) 

3. Page Keywords 

4. Page headers (H1) 

5. Links to other pages 

6. Strong text (bold) 

7. Phrases 

8. ALT Text in images………………..And many 

more. 

Note: You need to learn more about SEO before 

taking decisions on optimizing a website. . You 

need to refer to the SEO process of each search 

engine at their respective websites. However, you 

can use the SEO Checker to understand what needs 

to be optimized for a better ranking. 

1. Select Tools > SEO Reports…. SEO Checker dialog box appears (Figure above). 
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2. Select All Pages, and the select Check .Notice the results (Figure below). 

You can click on each message displayed in the list to find out and fix related issues. 

For example for a message as “The Description is missing”, you can add a description 

using the META tags to correct it. Once errors are identified and fixed, run the SEO 

Checker again to confirm if the website is optimized. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Verify the website created earlier using SEO Checker. 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of SEO. 

2. Explain the purpose of SEO Checker with an example. 

Fill in the blanks: 

1. Acronym for SEO ____________________________________. 

2. SEO reports can accessed from _______ menu. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Create a form to save results in a database. 

RELEVANT KNOWLEDGE 

So far, you have been using HTML and CSS for creating simple web pages. These are 

referred to as Static Web pages. While static web pages are good enough for creating 

basic web sites, you need to learn and use technologies such as ASP, PHP, etc. for 

creating dynamic websites. Dynamic Websites allow visitors to search and locate 

information (such as a search feature of search engines or database listing), submit 

information (such as feedback, rating, voting) etc. 

Advanced Forms 

You can create a fully functional form using MEW. Data filled using a form can be 

stored in a database or sent to a specific email address. But these features require 

proper support from the web hosting provider, primarily the support for FrontPage 

Server Extensions. 

Special Note: 

FrontPage Server Extensions is a technology that provides special functionalities on web 
servers created using Microsoft FrontPage or Microsoft Expression Web. Though this 
technology was used for over a decade, it is considered obsolete due to the evolution of 
other equivalent or better technologies. You may still find a few web hosting providers 
extending their support to this almost obsolete technology. 

Microsoft Expression Web replaced Microsoft FrontPage. Most of the activities in this 
module can also be done using Microsoft FrontPage. However, Microsoft FrontPage has a 
limited support for recent developments in web technologies such as CSS3, HTML5, etc. 
Yet, you can use form functionalities outlined in this module if your web hosting provider 
supports only FrontPage Server Extension. 

If you want to create a form for your Intranet or if your web hosting provider supports 
FrontPage Server Extensions, you can use procedure in this session to create the form, 
configure it to save the data in a database and later publish it to the remote computer. 

Web Server 

You can use the web server in-built with the operating system. Windows includes IIS 

(Internet Information Services) in both client and server operating systems. IIS in-built 

with client operating system such as Windows XP, Vista & 7 is usually sufficient for 
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websites having few visitors. You can install IIS on Windows Vista & 7. Use the help 

file for detailed instructions. 

Note: FrontPage Server Extensions is not available in Vista / Windows 7 & Windows 

2008. You may download an evaluation copy of FrontPage Server Extensions 

(FPSE) from www.iis.net. Some web hosting providers still give support for FPSE 

and you will be able to publish using FPSE. 

Creating forms 

You can create forms and use additional functionalities of MEW. To create a form and 

store the details in a database, do the following: 

1. Select File > New > ASP and save this page as dform.asp. 

2. Insert a form and add the following: 

a. Insert Input (Text), for visitor’s name. 

b. Insert Input (Text), for visitor’s email address. 

c. Insert Drop-Down Box, for collecting visitor’s 

favorite color. 

d. Insert Input (Submit). 

Now your form should look similar to the one adjacent. 

You need to customize this form before it is displayed to the visitor. Now to 

customize the fields, do the following: 

3. Double-click on the first Input (Text) 

field. Type Name in Name:, click OK. 

4. Double-click on the second Input 

(Text) field. Type Email in Name:, 

click OK. 

5. Double-click on the drop-down box. 

Drop-down Box Properties dialog box 

appears. 

6. Since you are collecting details of 

visitor’s favorite color, you need to add 

dropdown values for visitor to select. 

a. Notice there is a default dropdown with null value (no value); you can 

remove that by selecting Remove. 

b. Click Add…, Type Red in Choice:, Click OK. 

c. Click Add…, Type Blue in Choice:, Click OK. 

d. Click Add…, Type Green in Choice:, Click OK. 

e. Now change the Name: (Select1) by replacing the text to Color. 
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7. Click OK. 

Creating a database 

To save the details collected from the form, you 

need to have a database with corresponding 

fields ready. MEW can create a database for you 

and link these fields to the 

automatically. To create and link the database 

automatically, do the following: 

1. Right-click on the form, 

Properties. The Form 

is displayed. 

database 

select Form 

Properties dialog box 

a. Select Send to database 

(Note: Requires 

FrontPage Server 

Extensions). 

b. Select Options…. The 

Options for Saving 

Results to Database dialog box 

appears (figure above). 

c. To create the database, select 

Create Database…. MEW 

automatically creates an Access 

database (only format supported for 

automatic creation). Click OK to 

close the popup. 

d. Select Saved Fields tab. Note the 

fields are mapped from form to 

database automatically. Click OK 

twice. 

Now the form is ready but you need to publish 

the form to a server that supports FrontPage Server Extensions; otherwise this form 

will not work. Once publishing is complete, you can use the published URL to view the 

webpage. 

Publish the form to a website 

Note: Forms are published automatically along with other files in a website. 
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1. Select Site > Publishing Settings…. 

2. Select Add…. 

a. Type a friendly name in Name: 

b. Select FrontPage Server Extensions from Connection Type: dropdown 

menu 

c. Type the remote location, for example: www.example.com 

d. Type the credentials (Username and password) provided by the hosting 

provider. 

e. Click Add. 

3. Click OK. 

4. Select Site > Publish All Files to…NAME (IP address of the server or 

computer that supports FPSE). 

Note: Publishing may take some time. 

Viewing the webpage 

Visitors can now view the website or webpage. When they 

click on the URL that takes them to the form, the form will 

appear. 

Visitors can fill the form by entering the details and when 

they click submit, they will see a confirmation page 

similar to the one below: 

The database is stored in a special folder with the name 

fbdb; this folder is hidden for security purposes and is 

not accessible to visitors. 

You can open this database using your database software to view or modify 

information within this database. This could be useful when you want to collect all 

the email addresses and send a newsletter to visitors. 

Note: Use Windows Explorer to navigate to the folder that contains this website if you 

are using a web server within LAN; Access database is stored in a special folder named 

fpdb. If you are using MEW, then the access database can be retrieved from the fpdb 

folder in folder list view. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 
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1. Create a detailed form for the following fields and configure it to save the 

details in a database. 

a. First Name 

b. Last Name 

c. Age 

d. Email Address 

e. Favorite Car (Include at least three different vendors, allow 

selection through Checkboxes – Single Selection) 

f. City (Create a list and display using a dropdown menu) 

g. State (Create a list and display using a dropdown menu) 

h. Pin Code 

i. Comments 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of FrontPage Server Extensions. 

Fill in the blanks: 

1. ________ is the product was replaced by Microsoft Expression Web. 

2. Acronym for IIS ____________________________. 

3. Create Database option is available in _____________________ dialog box of 

form properties. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Optimize Web pages. 

• Estimating the size of content. 

• Optimize HTML. 

RELEVANT KNOWLEDGE 

You publish a website, only after you completely verify the website’s functionality. 

Hyperlinks (internal & external) should be checked and replaced if necessary. Given 

here is a list of standard procedures to be followed prior to site publishing. 

Examining structure of a website 

Create a visual diagram of 

hyperlinks of a website. This 

helps you understand the 

navigation structure or to trap 

any broken links. To view the 

structure of a website, do the 

following: 

1. Open the website 

2. Select View > Site > 

Hyperlinks. Notice the visual diagram (Figure 

above). 

3. You can further expand and understand the links to 

other pages. Select the plus symbol next to the link 

( ). Notice the results displayed 

(Figure adjacent). 
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Estimating size of a website 

If you know the size occupied by files in a website, 

you can determine if you have sufficient web space 

(as allocated by an ISP) or even determine the time 

taken to download before visitor can view the web page. 

1. Select View > Site > Site Summary (Figure above). 

2. Notice the results displayed (Figure below). Look at the list of items analyzed 

and given below Name, Count, Size and Description. 

Removing slow pages 

You can now decide to remove items that may 

possibly slow down a page. 

1. Select Site > Problems > Slow Pages 

(Figure adjacent) 

2. By default, HTML editor assumes and 

displays only the pages that take more 

than 30 seconds to load. You can 

change the value to 3 seconds to list 

web pages that take more than 3 seconds to download. Select 3 Seconds from 

the dropdown (Figure below). 
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3. Notice the results displayed (Figure below). 

HTML calculates based on two 

parameters; the amount of 

bandwidth and time taken to 

download within the set bandwidth. 

To modify this setting, do the 

following: 

1. Select Tools > Application 

Options…. Application 

Options dialog box will be 

displayed (Figure adjacent). 

2. Select Reports View tab 

(figure adjacent, below). 

3. Notice the values of “Slow 

Pages” take at least and 

Assume connection speed of 

(indicated in kilobits per 

second). 

Note: This is not YOUR connection 

speed. This refers to the 

connection speed available 

at the web hosting end. 

DWT 

If you have used Dynamic Web 

Template to create the website, 

check for updates made to the template. Also you can update all the pages by 

selecting the Format > Dynamic Web Template > Update All Pages option to ensure 

all page layouts are up to date. 
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Code optimization 

Before you publish, you need to cleanup your web page for any unnecessary code that 

can result in reducing page size. This in turn will help in faster downloads. You can 

use the in-built optimizer tool to remove unnecessary code by: 

1. Select Tools > Optimize HTML…. The Optimize HTML dialog box appears. 

2. During development you may have left 

behind some code such as comments. 

These might have to be removed before 

you present the website to an audience. 

To do so, select All HTML Comments in 

Remove Comments section and then 

select OK. All the comments will be 

removed automatically. 

To optimize a web page, do the following: 

1. Open an existing page (at least 5-10 KB in 

size, record the size for comparison). 

2. Select all the items under Remove 

Components list. 

3. Click OK. Notice the difference in file size. 

Fixing errors 

Before you publish the website, you need to verify if there are any pending issues. 

This helps you save time and unnecessary problems that may arise post publishing the 

website. To verify and fix (if there are any errors), do the following: 

1. Open the Website. 

2. Select Tools > Recalculate 

Hyperlinks. The Recalculate 

Hyperlink dialog box is 

displayed (Figure adjacent). 

3. Click Yes. If there are any 

issues, they will be 

automatically fixed. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Create a visual diagram of any of the websites created earlier. Share it with 

your classmates. Optimize the HTML code in your website, remove all 

unnecessary code. 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of Site Summary with an example. 

2. Explain the purpose of Code Optimization with the procedure. 

3. Explain the procedure to fix errors in a web page automatically. 

Fill in the blanks: 

1. Structure of website can be viewed using ____ option in ____ dropdown menu 

of ____ menu. 

2. Site summary is available in ____ dropdown menu of ____ menu. 

3. Optimize HTML is available in _____ menu. 

4. Recalculate Links is available in _____ menu. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Choosing a hosting provider. 

• Work with publishing options. 

• Use Web Packages. 

• Backup websites. 

RELEVANT KNOWLEDGE 

When you want others to see your content designed using HTML, you need to host the 

content in a web server to be viewed by the public. There are several free web 

hosting providers that provide free web space for your content. Though there may be 

restrictions on the total web space or advertisements posted within your website, the 

web space is usually sufficient for hosting small websites or practicing HTML! Use 

Google or other search engines to find a free web hosting provider. 

Web hosting providers usually allow publishing through FTP. Some web hosting 

providers allow other methods such as SFTP, WebDAV, etc. which you can use to 

upload your website. Some of them allow other methods such as SFTP (secure FTP), 

WebDAV, FrontPage Server Extensions, etc. and these are detailed usually in the page 

that displays various plans for comparison. 

For web pages created using HTML, you can use any provider that supports FTP. 

Publishing a website 

Once you have created the website, you need to publish it to computers that will be 

available 24x7 for visitors to view. When you sign up with a hosting provider, 

generally, you will be given multiple options to publish the content such as FTP, 

WebDAV, FrontPage Server Extensions, etc. 

To publish a website using FTP, do the following: 

1. Open the website that you need to publish. 

2. Select Site > Publishing Settings…. The Site Settings dialog box appears. 

3. Prior to publishing, you need to add details such as the destination computer’s 

IP addresses or domain name, settings and credentials. For example if you have 

signed up with a web hosting provider who has given you an IP address 

192.168.1.200 and FTP as the method for publishing, do the following: 

a. Click Add…. The Connection Settings dialog box is displayed. 
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b. Enter the following details: 

i. Type a name in the Name: textbox (usually your domain name or 

destination computer name or IP address of the destination). 

ii. Select FTP from the Connection Type: dropdown menu. 

iii. Hosting providers will provide a path for publishing, for example: 

ftp.domainame.ext. Type the path in Location: textbox. 

iv. Specify the folder where the content will be stored (Usually 

directory is auto-selected for websites, use this only if required). 

v. Enter the username and 

password in Credentials: 

section. This will be used 

when you publish from the 

HTML editor. Generally 

multiple files are 

transferred simultaneously 

between HTML editor and 

destination resulting in 

faster transfers. Leave this 

setting as it is or contact 

hosting provider for this 

detail only if required. 

vi. Click Add. 

c. Notice the change in the Publishing tab (Figure above) indicating the 

remote site is added to the list. 

4. Click OK. 

Now MEW is ready with the remote site settings for publishing content. Whenever you 

want to publish (first time or periodic updates), do the following: 

5. Select Site > Publish All files to [NAME]. Once published, use the web 

browser to view the website. 

Web packages 

Another method to take your website to a remote computer is by using the Web 

package feature. You can use the Web package feature to transfer contents of your 

entire website (preserving the structure) to a remote computer. This is useful when 

you want to send your website (including the complete structure) for being hosted 

from a remote computer or, if the existing structure is to be used for creating another 

website. 
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To export existing website to a web package, do the 

following: 

1. Open the website. 

2. Select Site > Export to Web Package…. 

(Figure adjacent). 

3. Export Web Package dialog box appears. 

4. You can select individual files or folders or, 

package the entire website. To package the 

entire website, 

a. Place the cursor at the root folder (C:\ 

in the image 

adjacent). Click 

Add>>. Notice 

the entire 

website is 

added to the 

right pane. 

b. You can use a 

friendly name 

for this 

package. Select 

Properties…, 

and the Web 

Package 

Properties 

dialog box 

appears. 

c. You can enter company name, 

author, a suitable title for this 

package. External 

dependencies: has a list of 

external resources that this 

website uses. This is helpful 

when you are using any files, 

folder or links that need to be 

verified before sending the 

package to someone. 

i. Enter a title in Title: 

textbox, for example: WEBPACKAGE. 
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ii. Enter a description in Description: textbox, for example: created 

using MEW. 

iii. Enter your name in the Author: textbox 

iv. Click OK. 

5. Click OK. 

6. When 

prompted to 

save this Web 

Package, type 

a filename for 

example: 

MyFirstWebsit 

e_DATE. Click 

Save. Notice 

the result displayed (Figure above). 

7. Click OK. 

Navigate to the folder where you saved this web package and notice the entire 

website packed as a single file (Figure above). 

Note: To easily identify the package, replace the 

date by specifying current date or a version 

number. 

Importing Web Package 

If you want to import this web package on another 

computer, do the following: 

1. Create a New Site (Empty 

Site), name this website for 

example: MySecondWebsite. 

2. Select Site > Import > Import 

from Web Package… (Figure 

above). 

3. Browse and select the Web 

Package, select Open. The 

Import Web Packag dialog 

box appears (Figure 

adjacent). 

4. You can either select 
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individual files or folders, or the entire website. Click Import. 

5. Select Yes to All. Click OK. 

Now you can edit web pages within this website. Also you can keep a copy of the Web 

package as a backup for future use. 

Backup Websites 

It is a highly recommended practice to take periodic (daily, weekly, etc.) backups of 

websites either using special backup tools or publishing it to another internal source. 

Whenever you attempt to perform an update on a website, ensure you take a backup 

of the current site before touching it. 

If you only have HTML content (static web pages), use the following procedure to take 

a backup of the website: 

1. Go the location where your website is stored (default location is My 

Documents). 

2. Select the folder that has the complete website. 

3. Copy and paste it in another location such as a pen drive or to a folder on 

another computer. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Compare different hosting providers using the worksheet below: 

Feature Provider 1 Provider 2 Provider 3 

ISP 
Monthly Price 
Setup Fee 
Disk Space 
Monthly Traffic 
Ads 
Languages 
ASP 
PHP 
Databases 
Access 
MySQL 
Microsoft SQL 
Email 
POP3 / SMTP 
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IMAP 
Web Mail 
Sub-domains 
Templates 
FTP Access 
Static IP address 

2. Backup the website: 

a. Use Web Package to create a single web package file and store 

it elsewhere. 

b. Copy the entire website to another location on your hard disk 

drive. 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of Web packages with an example. 

Fill in the blanks: 

1. Publishing Settings is available in ____ menu. 

2. Web package option should be accessed from _____ menu. 

3. Import from Web Package is available in _______ dropdown menu of ____ 

menu. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Understand the purpose of Authoring Tools. 

• Understand the purpose of KompoZer. 

• Understand the purpose of Macromedia Dreamweaver. 

RELEVANT KNOWLEDGE 

You have learnt to work with Expression Web in earlier sessions. There are a variety 

of other web authoring tools available for use and most of them have similar 

functionality. Some of the popular authoring tools are discussed in this module. 

KompoZer 

KompoZer is an open 

source WYSIWYG HTML 

editor. KompoZer 

complies with the W3C's 

web standards. 

1. Download 

KompoZer from 

www.kompozer.c 

om. 

2. Follow the on-

screen instructions 

and complete installing the software. 

3. Select Start > Programs > 

KompoZer. 

Note: Screen grabs are from 

kompozer-0.8b3.en-US.win32 

(Version). 

Now you have installed, create & 

save pages and view them using 

different web browsers. 

To create a page using KompoZer, 

do the following: 
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1. Select File > New…. The Create a new document or template dialog box is 

displayed (Figure above). 

2. Select A blank template, select Create. 

3. Type some content, select Source to view the source code. 

Use the help file (F1) to learn about using KompoZer. 

Dreamweaver 

Adobe Dreamweaver is another popular 

authoring tool used widely. Adobe 

Dreamweaver supports a variety of 

scripting languages such as JavaScript, 

VBScript, ASP.NET, PHP, etc. apart 

from standard support for HTML & CSS. 

1. Download Trial edition of 

Dreamweaver from adobe.com. 

2. Follow the on-screen instructions 

and complete installing the 

software. 

3. Select Start > Adobe > Dreamweaver. 

Use the help file (F1) to learn about using Adobe Dreamweaver. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Download, install and work with NetObjects Fusion. 

ASSESSMENT 

Answer the following Questions 

1. List any three web authoring tools. 

2. Compare the features of at least two web authoring tools. 
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Learning Objectives: 

At the end of this session, you will be able to: 

• Download and use CSS templates. 

RELEVANT KNOWLEDGE 

Designing a good looking interface can be quite difficult at times as it requires 

creativity. Also you need to learn additional software to create such designs while 

focusing on delivering websites that are standard complaint. 

When you design websites, you don’t have to design a web page from scratch. You 

can use templates that are available for free or a free to save time and efforts. 

Though you have learnt to create templates using HTML editors, you can still find and 

use creative designs for your websites. 

CSS Templates 

Instead of creating dull and boring websites, you can use templates that are available 

on the Internet. Popularly referred to as CSS Templates or XHTML/CSS Templates 

these templates look attractive while meeting certain standards. Following is a list of 

websites that offer such templates for your reference: 

• http://html5up.net 

• http://www.cssportal.com/css-templates/ 

• www.freecsstemplates.org 

• www.free-css.com 

• www.templatemo.com 

• www.oswd.org 

• www.openwebdesign.org 

and many more…. 

To use a CSS template, do the following: 

1. Visit any of the website mentioned above (or use a search engine to locate 

one). 

2. Browse and select a template. 

3. Most website provides an entire site structure consisting of web page(s), style 

sheets and accompanying images as a single compressed package. Download 

the compressed file and unzip them to a folder. Also you may notice a link for 
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live preview that allows you to view the template in action before 

downloading. Always check the design before you download. 

4. Once the download is over, open the homepage. Homepage is usually titled 

with names as index.htm, default.htm or home.htm. 

Note: Some website may require you to sign up and even have certain terms and 

conditions. Check the website for requirements. 

Customizing templates 

You can use a simple text editor to modify the template. However, if you find it 

difficult, you can use an HTML editor such as MEW. Also note that if the template is of 

a recent standard and if the HTML editor does not support that standard, entire 

template will appear distorted. Confirm if the HTML editor support the standard used 

in a template. 

To work with a template using MEW, do 

the following: 

1. Launch MEW. 

2. Create a New Site (always test the 

template in a new website). 

3. Copy all the files from the template 

folder (or use import wizard). 

4. Paste in within the HTML editor 

(You may receive prompt for files to be overwritten, click Yes). 

5. Open the Homepage (index or default.htm) (Figure above). 

6. Customize the website. 

7. To view the source code, select View > Page > Code. 

Following is provided as a courtesy: 

CSS can also be used for developing attractive navigation menus (Figures below). 

You can use CSS Tab designer (http://www.highdots.com/products/css-tab-designer/) 

to create navigation menus such as the ones above. 
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EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Download a CSS template. Use this template as a design for the website 

created in earlier sessions. 

2. Download CSS Tab designer, create a navigation menu for a website. 

ASSESSMENT 

Answer the following Questions 

1. Explain the purpose of using CSS templates. 

Fill in the blanks 

1. List any three websites that offer free CSS templates (write complete URL). 

a. __________________. 

b. __________________. 

c. __________________. 
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SESSION 24:OVERVIEW OFF WEB APPLICATIONS 

Learning Objectives: 

At the end of this session, youu will be able to: 

• Setup common web appplications. 

RELEVANT KNOWLEDGE 

You have learnt about web designing using HTML, CSS & Microsoft Exxpression Web. 

These are sufficient for creatting basic web pages or websites.   

You may have noticed severral websites such as blogs, forums, newws, etc showing 

dynamic content. Most websiites integrate blogs or forums to cater to ttheir additional 

customer needs (for examplee: handle customer queries or provide assiistance in using 

their products). This is in adddition to providing information about theeir products or 

services through static pages..  

Such websites require a sppecial setup such as database server annd web server 

supporting a server-side scriipting language. Server-side scripting lannguage helps in 

processing code at the web  server; for example, a web server needds to have PHP 

interpreter installed for proccessing PHP code as illustrated below: 

 

a. Client computer sends login request to web server. 

b. Web server validates loogin details in the database server throughh PHP code. 

c. Web Server responds inn plain HTML to the client computer. 

 
Whether it is a blog applicaation or a forum web application, most wwebsites today 

operate by making use of: 

• A server-side scripting lannguage to store and/or retrieve items from a database  

• A client-side scripting langguage to display results to visitors. 

 
Combining both the power off client-side scripting and server-side scrippting languages, 

you can create a website thatt provides best, rich-in-class experience foor visitors.  
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Every dynamic website requires a database for storing data, commonly referred to as 

a “back-end”. Depending on the complexity of a business requirement, a database 

engine is selected. You can use different databases such as Microsoft Access, SQL 

Server, Oracle Database Server, OpenOffice.org Base, etc. In general, you can use 

ANY back-end (database) with a front-end (server-side scripting language). Most 

popular combinations include: 

• Microsoft ASP & Microsoft SQL Server 

• PHP & MySQL 

• JSP (Java Server Pages) & Oracle Database Server 

Developing web applications requires additional learning, practice and references. 

However, there are several Open Source applications available ready-made ranging 

from simple scripts (stock tickers, news tickers) to complex applications (forums, 

blogs, learning management systems, content management systems, etc). 

Since the applications dealt in this session are open source, you may download the 

source code to learn about how the application works behind the scenes! 

Note: Though there are open source applications available, web applications dealt in 

this session make use of PHP & MySQL, one of the most common and popular 

combination. You may download other web applications post this session. 

Content management systems 

Content management systems are web applications designed to manage text, graphics 

and multimedia content. You have already learnt to create blogs, one of the most 

common web application used by millions of users across the globe. You can use any 

of the popular ready-made content management systems to setup a blog or a news 

website. Some of them include: 

• Joomla • DotNetNuke 

• WordPress • mojoPortal 

• Moodle • Umbraco 

• MediaWiki • Mambo 

• Atutor • PHP-Nuke 

Internet forum 

Internet forum refers to the online discussion websites where people exchange 

conversations in the form of messages. Forums usually have: 

• Users, who post questions or comments 
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• Moderators, who regulate (post or remove threads) 

• Administrator, who manage the forum. 

Users submit their message to forums referred to as a “Post”. Users can also modify 

their posts or reply to other posts, thus creating an interactive experience on the 

Web. Some of the most popular forum systems include: 

• phpBB • Phorum 

• vBulletin • vBulletin 

• PHPWind • ASPNetForum 

Note: You may also find complete packages with integrated blogs and/or forums. Do 

some research on the features to learn more. 

PHP 

PHP or Hypertext Preprocessor is a widely used open source scripting language. PHP is 

popular more as a server-side (web based) scripting language though it falls in to the 

general purpose programming language category. 

Web pages with PHP code are processed by a web server before it is sent to a web 

browser (as it is a server-side scripting language). 

Using PHP, you can write code to: 

• Create dynamic web content 

• Collect data (form) 

• Send and receive cookies 

• Add, delete or modify data in a database 

• And many more…. 

MySQL 

MySQL is an Open Source RDBMS and is the most popular choice for databases in web 

applications. Features of MySQL include: 

• Cross Platform (available for Windows, Linux, etc.) 

• Multiple Languages 

• Many built-in functions right out-of-the-box 

• ACID compliance and many more. 

Note: You have learnt work with databases software earlier using statements such as 

Select, Create, etc.; most RDBMS software support similar statements including 
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Microsoft SQL Server, MySQLL, etc. If you are familiar working with SQSQL statements 

with any RDBMS, you will findd that working with MySQL is almost the samme. 

Installing PHP & MySQL 

To work with these web appliications, you need to have the following innstalled: 

a. A web server such as AApache or Internet Information Service webb server. 

b. PHP 5.4 (or above) 

c. A database server succh as MySQL, Microsoft SQL Server, etc. ((if you want to 

design database-drivenn web applications). 

Since installing and configurinng the above mentioned components can bbe tedious, you 

may download a software staack such as WAMP to simply the process. 

WAMP 

WAMP or “Windows Apache MySQL PHP” refers to 

software stack that consist oof Apache, MySQL & PHP 

as a single package and runs hassle free on Microsoft 

Windows. Generally installingg individual components 

may take time and requirees additional technical 

skills. WAMP makes it easy by installing the whole 

package in a single shot. 

Note: Though these applicatiions can be installed without WAMP, instrucctions provided 

in this session are WAMP baseed as it is much simpler and easier to makke it functional. 

LAMP (Linux Apache MySQL PHHP) may be used on Linux based computerss. 
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Downloading and Installing WAMP 

1. Download WAMP (Wampserver2.4-x86.exe) from the following address: 

http://sourceforge.net/projects/wampserver/files/WampServer%202/Wampser 

ver%202.4/. 

2. Go the downloaded folder and double-click Wampserver2.4-x86.exe. 

Welcome to the WampServer 2 Setup Wizard appears (Figure above). 

3. Click Next. Licence Agreements section appears (Figure above). 

4. Select I Accept the agreement and click Next. 
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5. Leave the default installation location as it is, click Next. 

6. To add shortcuts, check both Create a Quick Launch icon and Create a 

Desktop Icon. Click Next. 
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7. Click Install. You may receive Windows Security alert similar to the one 

below: 

8. Click Allow access. PHP mail parameters appears as shown below: 
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9. You may skip this section, Click Next. 

10.Click Finish. 

Testing WAMP 

It is recommended to check if the web server is running properly. To check, do the 

following: 

Note: If the icon is NOT available in the system tray, click Start > Programs > start 

wampserver shortcut. 
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1. Click the WAMP icon in the system tray (Figure below, left). A popup 

appears (Figure below, right). 

2. Click Localhost. A webpage appears similar to the one below: 

If you see this webpage, this means the web server is working fine. 

Alternatively you can also open the browser and type http://localhost to verify web 

server functionality. 
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Publishing files 

You have learnt to publish HTML files earlier; similarly, web pages containing PHP 

code must be published to the web server. This in turn will be served to the web 

browsers by the web server. 

1. Click WAMP icon in the 

system tray; select www 

directory. 

2. This is the default location 

for this website. Files saved 

in this location are used by 

the web server to be 

processed and sent to the 

web browser. 

Tip: There are other stacks such 

as LAMP, EasyPHP, etc. You can also download Apache, PHP, MySQL separately and 

install them by referring to the instructions on their respective websites. 

Lab: Install and work with WordPress 

1. Download WordPress package (Open Source & Windows) from 

http://wordpress.org/. Save the file to a folder in your computer. 

2. Extract the compressed file to a folder C:\WAMP\WWW\WORDPRESS. 

Important: During the extraction process, files may be unzipped to a folder under the 

WordPress folder causing redundant names. For example, the folder structure may 

look like C:\WAMP\WWW\WORDPRESS\WORDPRESS instead of 

C:\WAMP\WWW\WORDPRESS\. However, there is no harm in using such file system 

structure as it results only in a lengthier path for accessing the website. 

3. You need to set up a separate database for WORDPRESS. 

a. Click the WAMP icon and click PHPMYADMIN. 

b. Click Databases. 

c. Type a name in Create Database textbox. For example, WORDPRESSDB. 

d. Click Create. 

4. Open the web browser and type http://localhost/wordpress/wordpress/ and 

press Enter. A web page appears (Figure below). 
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5. Click Create a configuration file button. A web page appears (Figure below). 

6. Scroll down to the end of this page and click Let’s Go button. A web page 

appears (Figure below). 
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a. Type “WORDPRESSDB” in Database Name 

b. Type “root” in User Name 

c. Type the password in Password (replace password to blank if there is no 

password). 

d. Scroll down to the end of the page and click Submit. A web page 

appears (figure below). 

e. Click Run the Install button. A web page appears (figure below). 
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f. Type a name for this blog in Site Title, for example YOURNAME_BLOG 

g. Type your name in Username 

h. Type password in Password, twice text boxes 

115 



 

 

        

         

  

 

 

 

    

  

   

 

    

 

   

         

        

 

           

i. Type your email address in Your E-mail 

j. Uncheck Allow search engines to index this site 

k. Click 

Install 

WordPress 

Button. 

7. A web page 

appears similar 

to the one 

adjacent. 

8. Now close this 

window. 

Accessing the blog 

1. Open the web browser and type http://localhost/wordpress/wordpress and 

press Enter. Your blog is setup (Figure below). 

2. Now login and work with this blog to learn more. 
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Lab: Install and work with PHPBB 

1. Download PHPBB package (Open Source) from https://www.phpbb.com/. Save 

the file to a folder in your computer. 

2. Extract the compressed file to a folder C:\WAMP\WWW\PHPBB. 

3. You need to set up a separate database for PHPBB. 

a. Click the WAMP icon and click PHPMYADMIN. 

b. Click Databases. 

c. Type a name in Create Database textbox. For example, PHPBBDB. 

d. Click Create. 

4. Open the web browser and type http://localhost/phpBB/phpBB3/install and 

press Enter. A web page appears (Figure below). 

5. Select Install Tab. 

6. Click Proceed to Next step button located at the bottom of the web page. 

7. Installation Compatibility web page appears, scroll down to the bottom of the 

web page and click Start Install button. A web page appears (Figure below). 
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a. Type PHPBBDB in Database name: 

b. Type “root” in Database username: 

c. Click Proceed to next step button at the bottom of the web page. 

Database connection web page appears (figure below). 
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d. Click Proceed to next step button. Administrator configuration web 

page appears (Figure below). 

e. Type your name in Administrator username: 

f. Type a password in Administrator password: and confirm administrator 

password: fields. 

g. Type your email address in Contact e-mail address: and Confirm 

contact e-mail: fields. 

h. Click Proceed to next step button. 

i. Administrator details web page appears, Click Proceed to next step 

button. 

j. A confirmation web page appears, Click Proceed to next step button. 

k. E-mail settings and Server URL Settings web page appears (do not alter 

any settings). Click Proceed to next step button. 

Note: Installation may take a while. 

l. A confirmation web page appears, Click Proceed to next step button. 

m. Final Stage web page appears (Figure below). 
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8. Now the forum is ready for use. Close this window. 

Important: You need to remove the “Install” folder. Go to 

C:\wamp\www\phpBB\phpBB3 and delete the “Install” folder post installation. 

Accessing the forum 

1. Open the web browser and type http://localhost/phpbb/phpbb3 and press 

Enter. Notice the forum appears! (figure below). 
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2. You can now login or rregister as a new user, etc. Use the help file to work with 

the forum.  

Though you have learnt to innstall WordPress and PHPBB using WAMP, yyou can also try 

installing with other softwarre environment or through a web hosting provider since 

the procedure is more or lesss the same. Most web hosting providers proovide a detailed 

step-by-step instruction on ssetting up blogs or forums; refer to their knowledgebase 

for details if hosting on the reeal-time environments.  

Accessing the website from other computers 

So far you have been workinng on the local computer using http://loocalhost as the 

URL. If you attempt to accesss the 

website using the computerr’s IP 

address in the address bar orr from 

another computer, you may nnotice 

the adjacent message. 

You need to modify the seccurity 

settings to remove this restriiction 

on the web server. You havee been 

using Apache web server;  settings of Apache web server are stored in the 

configuration file named “httpd.conf” loccated in 

C:\wamp\bin\apache\Apache22.4.4\conf folder. 

You can access this file by, 

1. Click on the WAMP icoon (System tray), a popup appears (figure bbelow) 
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2. Select Apache > httpdd.conf (figure above). The configuration file httpd.conf 

opens in a text editor ((notepad) as shown below: 

 

3. Scroll down to the <Diirectory "c:/wamp/www"> section (figure bbelow, left), at 

the end notice the setttings (figure below, right). 

 

4. If you observe, the vaalue is set as “Deny from all”. To allow acccess, it should 

be changed to “Allow ffrom all” (figure below). 

 

5. You need to restart thhe web server to apply changes. Click on the WAMP icon, 

a popup appears.  
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Select Apache > Service > Restart Service. Now try accessing this computer from c 

other computers in your netwwork using the IP address or computer namme to view the 

websites. 

You have learnt to setup a bb rlog and a forum in this session; you can try downloading 

and installing blogs / forumss or web applications from the Internet. AAlways refer to 

the detailed instructions on respective website for downloading, instaalling and using 

them.  

If you sign-up with web hostinng providers, usually the steps are much siimpler and may 

be very similar to set it up inn the real-time. Instructions for the same iis also available 

in the website; contact the teechnical support if you need assistance. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Understand the concept of Web Page Development. 

• Understand the concept of Web Application Development. 

• Understand the basics of .NET platform. 

RELEVANT KNOWLEDGE 

Web page development 

Web page development refers to web pages that use client-side technologies such as 

HTML, CSS, JavaScript, etc. Web Pages served by a web server are processed by a web 

browser such as Mozilla Firefox, Microsoft Internet Explorer, etc at the client end. 

As you already know, HTML is used to format data on a page and serves to lay out 

contents in a Web page. When the client browser receives a HTML document it 

converts the document to a screen display. CSS is used to separate the text that is 

displayed from the manner (style) in which it is displayed. CSS is used to improve 

flexibility and control over the manner in which the content is presented. It provides 

an efficient way to ensure that multiple pages share the same type of formatting. It 

also allows for creation of dynamic content. JavaScript is used for adding 

functionality and enabling user interactivity. 

Web application development 

To develop web applications, you need IDE’s such as Microsoft Visual Studio or 

Microsoft Visual Web Developer 2010 Express (Free). Although you can use simple 

text editors such as Notepad, it is recommended to use an IDE for faster development 

with fewer errors. 

Web application development refers to web pages generated by a web server using 

server-side technologies such as ASP, ASP.NET, PHP, etc. Web pages are processed by 

the web server and results are sent to the web browser for further rendering 

(rendering refers to a process by which a web browser executes the code sent by the 

web server and just display it in the web browser). 

Tip: Web Development – Client Side & Web Application – Server Side. 
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Client-Server Model 

Client-Server model refeers to a 

distributed architecture where 

workload is shared to produuce desired 

results. For example, loook at the 

adjacent illustration. In thiis scenario 

when a user books a train tickket, a sequence of operations take place: 

1. User opens web browserr and specifies the URL www.irctc.co.inn; the browser 

(client) sends a request too the web server. 

2. Server receives the requesst and it processes any server-side scripts. 

3. Server sends the results too the web browser. 

4. Web browser handles furthher processing and displays results on the wweb browser. 

Client-side / Server-side scriipting 

In a web application, the sccript used may be a client side script oor a server-side 

script. A client-side script is ddownloaded by the browser and is executeed on the client 

computer (user’s computer) wwhen the page is loaded. As you already knnow, JavaScript 

is a client-side scripting languuage that helps make Web pages interactivve. 

Client-side scripting represennts all code that is executed in the browwser, after the 

server sends the page back tto the user while server-side scripting reffers to all code 

that is executed by the weeb server before the web page is sent to the user’s 

computer. It is to be noted thhat client-side scripting is completely indeependent of the 

server and server-side technoologies used to process the request. 

Checking the data that a useer has entered into a form on a web pagge is a common 

usage of client-side scriptingg. While inserting data in a form, if you misspelled the 

email address or forgot to kkey in an important field or entered text into a number 

field, the script will warn thhe user about these errors. Of course, thhis may also be 

done at the server end, but that would make your application slower aas it requires a 

round trip. Client-side scriptts are more responsive and faster becausse they do not 

depend on the server and thee Internet traffic between the client and thhe server. 

Creating visual page effects (e.g. dynamically swap images on mouse over), showing 

more effects in the browser window, disabling the right mouse-click,, scrolling text, 

creating online browser gamees, etc requires client side scripting. 

On the other hand, for seleecting data from a database, securing tthe login page, 

creating an online questionnaaire, server side scripting needs to be used.. 
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Hypertext Transfer Protocol (HTTP) 

HTTP is an application protocol which allows a client to talk to a server. When a 

client computer wants to communicate with the Web server, it uses its Web browser 

to send a HTTP request to the Web server. The contents of the HTTP request specify 

what action the client requires the server to take. When requesting for a Web page, 

the browser uses the GET method and while sending data to be processed to the 

server, it uses the POST method. 

An event is a notification which occurs in response to an action, such as a change in 

state, a user clicking the mouse or pressing a key while viewing the document, or user 

moving the mouse over a tab and causes a mouseover to occur. An event handler is 

the code, written in a scripting language, which receives control when the 

corresponding event occurs. 

An event model in a Web application is a software architecture that determines how 

to create and describe events and trigger them on the event source side. It 

determines how to react to events or subscribe to event sources on the event listener 

side. It is to be noted that an event is raised on the client side and handled on the 

Server Side. 

Cookies and Sessions 

Cookies are information (data) stored in your web browser. When you visit websites 

such as ebay.com, you may have noticed items under “Items you viewed” section 

even when you return to the website after a few hours or days (or even when you 

shutdown and restart a computer); how does a website like EBAY record such 

information while having thousands of visitors viewing it every day? Simple, all items 

that you view are recorded and stored in a text file referred to as “Cookies”. 

When you visit the same website after sometime, the web server sends specific 

information to the web browser through HTTP headers. Web browsers in turn return 

the information stored in the text file; based on which specific items that you viewed 

are retrieved and displayed. 

Cookies can also have expiry date and/or time; this is useful in situations when you 

don’t want the web browser to “remember” certain details after a specific period. 

Cookies are mostly used for personalization like remembering the web pages that you 

have visited, items that you viewed, values that you have filled in a form, etc. 

Cookies can also help in manage sessions effectively by minimizing network traffic 

between web servers and web browsers; for example, imagine a visitor viewing first 
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50 items of records from a daatabase. In this case, the web server can usse cookies to 

track and send the next 50 iteems or previous 50 items depending on thee value stored 

in the cookie instead of startiing all over each time. 

Note that cookies can also bee stored for a specific period or removed frrom your 

computer depending on how yyou have configured your web browser. Foro example if 

you have set the web browserr to clear cookies when it is closed, cookiees are 

automatically deleted from yyour computer. 

Sessions are similar to cookiees that store information. Sessions are files stored on the 

web server for an extremely llimited time span and expire when the webb browser is 

closed. 

Sessions are files stored on thhe web server that carry unique informatioon for each 

visitor; however, the informaation is valid only for that particular visit. FFor example, 

you may visit a website to puurchase products from an online shopping wwebsite. 

However, you may add or remmove items from the shopping cart for a whhile before 

making a purchase. In such caases, sessions are used for storing the inforrmation on the 

server and used when requireed (for example, when you proceed to checckout). Session 

details are removed from thee web server once you leave the website orr close the 

browser. 

Imagine the number of sessioons a web server managing an online shoppiing site like 

flipkart.com or ebay.com thaat may have thousands of visitors shopping 

simultaneously. Sessions are aassigned through a unique string so that it does not 

affect sessions from other vissitors. 

THE .NET Strategy 

The main strategy of the .NEET is to enable software as a service. It also responds to 

the latest trends in the softwware industry namely: 

• Distributed computingg to simplify the development of client/seerver and n-tier 

applications 

• Componentization to 

simplify the integratioon of 

software componnents 

developed by diffeerent 

vendors 

• Enterprise services to 

allow the developmennt of 

scalable enterpprise 

applications without wwriting code to manage transactions, securiity or pooling 
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• Web paradigm shifts such as sharing of functionality across thhe Web among 

different platforms, deevices and programming languages. 

• Support for interooperability, scalability, availability, security and 

manageability of commmercial web applications. 

 

The .NET Platform 

The Microsoft .NET Platform  consists of five main components as shownn in the figure. 

At the lowest layer, you havve the Operating system which could incluude a variety of 

Windows platforms.  

On top of the OS, we have aa collection of specialized server productss that shortens 

the time required to develoop large scale business systems such as BBiz Talk Server, 

Commerce Server, Applicatioon Centre, SQL Server etc. Since Web servvices are highly 

reusable, a number of buildinng-block services are provided which deveelopers can use 

for a fee. These services incluude the .NET Passport and the .NET Alert sservices. 

The top layer consists of a ddevelopment tool called the Visual Studioo.NET (VS.NET) 

which helps in rapid deployyment of web services and applications.. VS.NET is an 

Integrated Development Envirronment (IDE) which supports four differennt languages. 

The .NET framework is a deevelopment infrastructure which includes the CLR and a 

common framework of classees that may be used by all .NET languages. 

Components of the .NET frammework 

Remember, this framework sits on 

top of the operating systemm. That 

is, the .NET framework is esseentially 

a system application which rruns on 

Windows. 

1. The Common Language RRuntime 

(CLR) is the most immportant 

component of the framewwork. It 

activates objects, peerforms 

security checks, lays the objects 

in memory, executes them, 

helps in debugging, handdling exception and has a Just In Time Compiler (JIT) 

which uses metadata to ccompile Intermediate Language code. Thee CLR supports 

any language that can bbe represented in its Common Intermeddiate Language 

(CIL). 
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2. The framework Base classes support basic input and output functionalities, string 

manipulation, security management, network communication as well as other 

functions. 

3. The DATA and XML Class support data management and XML manipulation. It also 

allows you to manipulate XML data and perform XML searching and XML 

transactions. 

4. Web Services, Web Forms and the Windows Forms are three different technologies 

which extend the DATA and XML classes. Web services include classes which 

support the development of distributed components. Web Forms is the key 

technology behind ASP.NET and allows you to rapidly develop Web GUI 

applications. Windows Forms help you to develop native Windows GUI applications. 

ASP.NET 

ASP.NET is a Web development framework which helps you build Web applications 

with very little coding. It is a server side scripting technology which is used for 

generating Web pages by request. The pages render real time data which is created 

just before being sent to the client browser. So you can build online shops, auction 

sites, bulletin boards etc using ASP.NET. 

ASP.NET simplifies web page development with form-based programming. These 

forms are called Web Forms. While programming these forms, you can access classes 

of the .NET Framework and you can code your applications in any language which is 

compatible with the common language runtime (CLR) such as Visual Basic and C#. 

The Web pages created using ASP.NET are completely object-oriented. These pages 

are compiled into an intermediate language by a .NET CLR compliant compiler. Then 

a Just In Time (JIT) compiler turns the intermediate code to native machine code 

which is eventually run on the processor. 

The ASP.NET page framework presents a unified model for responding to client events 

that run on the server. The framework also maintains the State of the page and the 

controls on the page during the Page Processing Life Cycle. State management refers 

to the process by which a server maintains page information over multiple requests 

for the same or different pages. 

Life cycle of a web page 

While using simple ASP programming, the Web page starts its life when a client 

requests a particular page. The IIS parses this, does all initialization and runs the 

scripts on the ASP page to render HTML content to the client. Once rendering is 

complete, the page’s life ends. If you have forms that pass some more data (from the 
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client) back to the ASP page ((on the server) to be processed, a New reqquest is run and 

the same process repeats. PPassing data back to the original page foor processing is 

known as Postback. 

Web page created with ASP..NET 

While using ASP.NET a slighht modification takes place which has a hhuge impact on 

speeding up the application.. Here also, the Web page starts its life wwhen the client 

requests a particular page. TThe life cycle of the ASP.NET page includees initialization, 

instantiating controls, restorring and maintaining state, running eventt handler code, 

and rendering. 

1. Initialization: The first eevent that happens in the life of a Web FForm is the Init 

event. This is raised so thhat we can have initialization code ready foor the page. At 

this time a master page aand themes may be applied. Every page haas an IsPostBack 

property which indicates if the page request is an original requestt or a postback 

request from the user. If PPostBack is true, page initialization is not ddone. 

This is the place where aa major difference occurs between ASP proogramming and 

ASP.NET programming. Immagine that you sent in a form from your client machine 

with 25 fields filled in to tthe server. Assume that 2 of the fields havve to be resent. 

With ASP.NET programmiing and the IsPostBack property, you willl resend only 2 

fields to the server. Wheereas, with ASP programming, the browseer will have to 

send all 25 fields again. 

2. Instantiating controls: Thhe next event is the Load event in which alll child controls 

of the Web Form are loadeed and accessible. Thus, you will be able tto retrieve data 

and populate the controlls so that they may render themselves oon a Web page 

when they are sent back tto the client. 

3. Restoring and Maintaininng State: During load, if the current requestt is a postback, 

control properties are looaded with information recovered from vview state and 

control state 

4. Running Event Handlerr code: User interactions with the paage such as a 

ButtonClick are handled tthrough postbacks. If the request is a postbback, and there 

are user initiated events, event handlers are called. 

5. Rendering: Before renderring, the view state is saved for the page aand all controls. 

The page calls a Render mmethod for each control. 

Now, take a deeper look at SState Management which forms a very impoortant aspect of 

ASP.NET technology. 
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State management in ASP.NET 

State management refers to a number of client-side and server-side options which 

help to preserve data on a per-page as well as an application wide basis. 

On the client-side are the view state, control state, hidden fields and cookies options 

for managing the state of data. 

On the server side are the application state, session state, profile properties and 

database support options for managing the state. 

Client side state management options: 

a. View state: The view state property gives us a structure for saving values between 

multiple requests for the same page. This property is used when storing small 

amounts of information for a page which will post back to itself. When the page is 

processed, the state of the page and the controls is hashed into a string and saved 

inside the page as a hidden field. When this page is posted back to the server, the 

view-state string is parsed at page Initialization and restores property information 

in the page. 

b. Control state: This is used when storing small amounts of state information about 

a control. The Control state property allows you to save the property information 

of a specific control. 

Server Side State Management 

a. Application State: Application State is used for storing global information which is 

not changed frequently and which is used by many users where security is not an 

issue. ASP.NET provides the application state through the HttpApplicationState 

class as a method to store global application specific information which is visible 

to the entire application. 

b. Session State: This is used when storing information which is specific to a session 

where security is of importance. ASP.NET uses the HttpSessionState class to store 

session specific information which is visible only inside the session. 

Both application state information and session state information are managed by the 

server. 

EXERCISE 

Perform the following activities till you understand the basics of Web Applications 

S.No. Activities 

1. Discuss the process involved while you try to book an Air ticket using 

MakeMyTrip, online shopping using ebay & flipkart. 
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ASSESSMENT 

Answer the following questions: 

1. Explain the concept of a client server Model. 

2. Give a few examples of where you will use Client –Side Scripting. 

3. Explain what you understand by the term Event Handler. Specify a few events 

that may be occur while you fill in a form for IRCTC. 

4. What is an Event Model? 

5. Explain how the page life cycle differs in ASP and ASP.NET 

6. Specify three .NET enterprise servers and specify what their main purpose is 

7. Explain what you understand by “Postback”. 

8. What do you understand by the term State Management in ASP.NET? 

Fill In The Blanks: 

1. The ___________ has a computer program which runs continuously listening for 

connections from _______. 

2. When requesting for a Web page, the browser will use the _______ method and 

while sending data to be processed to the server, it uses the ____________ 

method. 

3. Client-side scripting represents all code that is executed in the browser 

_________ the server sends the page back to the user. 

4. Server-side scripting refers to all code that is executed by the web server 

________ the web page is sent to the user’s computer. 

5. Checking the data that a user has entered into a form on a Web Page is a 

common usage of ______________ scripting. 

6. ____________refers to the process by which a server maintains page 

information over multiple requests for the same or different pages. 

7. ASP.NET uses the ____________ class to store session specific information 

which is visible only inside the session. 

8. The HttpApplicationState class _____________ information which is visible to 

the entire application. 

9. _________, ______ and ________ are three different technologies which extend 

the DATA and XML classes in the .NET framework. 

10.The life cycle of the ASP.NET page includes ____________, 

___________,____________, and ________________. 

11.Acronym for JIT: _________________. 
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Lesson Objectives: 

At the end of this session, you will be able to 

• Create a Web page using Visual Web Developer Express. 

• Create a Web Application using Visual Web Developer Express. 

RELEVANT KNOWLEDGE 

You have learnt to use HTML, CSS and Expression Web previously; it is recommended 

that you recap these modules before proceeding further. 

Note: Download and Install Microsoft Visual Web Developer 2010 Express before 

proceeding further. 

Important: This module focuses on fundamental concepts of web development and 

web application. Only a high-level overview is provided here; use product help files 

and/or online resources to learn more. 

Launching Visual Web Developer 2010 Express Edition 

Once the installation is complete, launch the program by following the procedure: 

1. Click Start > Programs > Microsoft Web Developer 2010 Express. 

Note: It may take a while to load for the first time. 
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Creating Websites (Static) 

You can create web pages using Visual web developer express; procedure is very 

similar to that of Microsoft Expression Web. 

1. Select File > New Website…. New Web Site dialog box appears (figure below). 

a. You need to choose a programming language (not required for normal 

websites that will make use of HTML and CSS). Leave the default 

selection. 

b. You can create database-driven websites; however, this requires 

programming. Select ASP.NET Empty Web Site from the list available. 

c. You can either choose to use HTTP (directly to a web server), FTP 

(directly to a web server using FTP) or File System (local computer). 

Select File System as you can work with the website on the local 

computer and publish it later to a web server. 

d. Choose a location on your local hard disk drive, for example 

C:\Websites\Web1. Click OK. Notice an empty website created (figure 

below). 
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2. Now you may add HTML, CSS, JavaScript, etc. files to the website. To add a 

HTML file, select File > New File…. Add New Item dialog box appears (Figure 

below). 

a. Scroll and select HTML page. 

b. Type a file name in Name:, for example default.htm. Click Add. 

3. Observe an HTML file added to this website (figure below). 
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a. List of files (HTML, CSS, JavaScript, Images, etc.) for this website. 

b. Coding Area for inserting code manually. 

c. Switch between Design, Code and Split views (looks familiar to 

expression web, isn’t it?). 

d. Properties window for setting properties (similar to MEW). 

4. Now switch to Design View and insert some text (similar to MEW). 

5. Save the file. 

Microsoft Visual Web Developer Express includes a “mini” web server (referred to as 

“development server”) that can be used for testing web pages; this is useful in 

situations when you want to test a website before uploading to a remote web server. 

6. To view this website in a web browser, Press CTRL+F5. Observe the results 

displayed in the web browser (Sample below). 

7. When you run a website by pressing CTRL+F5, Development Server runs in the 

background and appears in the system tray (figure below, left). Double-click 
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the ASP.NET Development Server icon in the system tray; a window appears 

similar to the one below (figure below, right). 

8. Notice the port number in Port: and the URL in Root URL:; isn’t it the same 

that is displayed in the address bar of the web browser? 

9. Click Stop to stop the development web server. 

The Development Server built-in with Visual Web Developer Express is designed for 

processing server-side scripting code before the results are sent to a web browser, 

especially, pages with ASP.NET code needs to be processed before it is sent to a web 

browser. 

Creating Web Applications 

You can create web applications using Visual Web Developer. 

1. Select File > New Website…. New Web Site dialog box appears (figure below). 
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a. Select Visual C# under Installed Templates. You can use a language of 

your choice, either Visual Basic or Visual C#. Since you have been 

learning Visual C#, select Visual C#. 

b. Select ASP.NET Empty Web Site. You can select from different types of 

ASP.NET web applications; to create an empty site as a starting point, 

select ASP.NET Empty Web Site. 

c. Select File System from Web location: dropdown list. You can either 

choose to use HTTP (directly to a web server), FTP (directly to a web 

server using FTP) or File System (local computer). Choose File System as 

you can work with the website on the local computer and publish it later 

to a web server. 

d. Save this website in a different location, for example: 

C:\Websites\Web2. 

2. Click OK. Notice a website is created and displayed (figure below). 

Since this is a ASP.NET website, you may notice an additional file “web.config” 

included automatically. Web.config is the main configuration file for ASP.NET 

applications; it contains information that controls module loading, security 

configuration, session state configuration, database connection strings, application 

language and compilation settings. 

3. You can add HTML, Style Sheets, ASP.NET pages, etc. to this website. If you 

want to create a web application, you must use the ASPX format which 

configures the web page to a dynamic web page. To add a dynamic web page, 

select File > New File…. A Add New Item dialog box appears (figure below). 
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Notice the different items in this list. To create a web page that needs to be 

processed by the web server, select Web Form and click Add. Notice a web form 

added to this website (Figure below). 

Note: ASP.NET web pages have the file extension .ASPX. 

a. Solution Explorer refers to files and resources within this website. 

b. ASP related code embedded in web page. 

c. Toolbox contains controls that can be used in a website. 
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d. Database Exploorer refers to database related resourcces used in a 

website. 

e. Properties winddow. 

A Simple Program 

1. Open Default.aspx.. 

2. Switch to Design Viiew. 

3. Move the mouse cuursor over toolbox. 

4. Drag and drop Labeel control into the web page. 

5. Switch to Code Vieew. Observe the code included (figure beloww). 

 

6. Now type the folloowing code anywhere within the page (Reemember, web 

server will look for ASP code anywhere within this page to exxecute) (Sample 

below. 

<% Labeel1.Text = "Hello World!"; %> 

 

7. Now press CTRL+FF5. Observe the results displayed in thee web browser 

(figure below). 
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Adding Images into the Project 

You can include images from your local computer using the IMG SRC element. To add 

an image, copy the image to the project folder within Visual Web Developer Express. 

Drag and drop the image to a web page that is already open. Switch to Code View and 

observe the code included. Press CTRL+F5 and observe the results displayed in the 

web browser. 

You can create really professional Web applications with very little code by using the 

various controls in the Toolbox. For details, visit the following websites: 

• http://msdn.microsoft.com/en-US/library/w9ss7h1a%28v=vs.80%29.aspx 

• http://msdn.microsoft.com/en-us/library/x8k61whf%28v=vs.80%29.aspx 

EXERCISE 

Perform the following activities till you understand the basics of creating Web Pages 

and Web applications 

S.No. Activities 

1. Assume that you are a Computer Products Dealer and you wish to create a 

Web Application to showcase your products. Discuss what controls you will 

use to create the content of your Web Page & how you will make it look good 

and appealing to the user. Create a Web page to showcase the same. 
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Lesson Objectives: 

At the end of this session, you will be able to: 

• Understand the concept of Web hosting. 

• Understand the concept of Web Services. 

RELEVANT KNOWLEDGE 

You have learnt about web hosting, ISP’s, etc. in the previous sessions. Given below is 

a recap: 

• A Web Hosting Service allows individuals and organizations to make their website 

accessible to the public. Organizations that provide resources such as disk space, 

bandwidth, etc. are referred to as “Web Hosts” or “Web Hosting Providers”. Web 

hosts usually keep their infrastructure in a placed commonly referred to as a “Data 

Center”. Most web hosting providers also allow you to keep your server in their 

premises (referred to as Co-location) usually for high-availability and bandwidth. 

• An Internet Service Provider (ISP) is a company that offers you access to the 

Internet using data transmission technology such as dial-up, DSL, cable modem or 

dedicated high-speed interconnects. It generally provides space on a server, email 

service, maintenance and support & security. 

Most basic type of Web Hosting Service involves the Web Page and small-scale file 

hosting. In file hosting, files are uploaded to the Web on an ‘as is’ basis with minimal 

processing, using the File Transfer Protocol (FTP) or a Web Interface. Single page 

hosting is usually sufficient for Personal web pages and Personal Web Site hosting is 

typically free. A large number of Internet Service Providers (ISP) offers this as a free 

service to their subscribers. 

A business site may be more complex and may need a comprehensive package which 

gives database support and application development platforms such as Java, PHP, 

ASP.NET, ColdFusion etc. Using these, the customer will be able to write or install 

scripts for applications such as Forums and Content Management. 

E-Commerce makes use of Secure Socket Layers (SSL). So we see that the Business 

web site hosting often has a higher expense depending upon the size and type of the 

website. 

• Internet Information Services (IIS) is a suite of product that has HTTP, FTP, 

etc. servers included as a part of the Microsoft Operating System. Organizations 
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that prefer to keep thheir hosting private can use IIS; you can creeate web sites, 

virtual directories, etcc. and manage everything from within your own premises. 

o A Site or Weeb Site refers to a separate domain (for example, 

www.example.oorg) hosted on single or multiple computerr. Multiple web 

sites may also be possible on a single computer deppending on the 

hardware & neetwork resources and the ability of a wweb server. For 

example, you caan host only a single website on client opeerating systems 

such as Microsooft Windows XP; but you can host unlimiited number of 

websites on servver operating systems such as Windows 20003 or Windows 

2008. 

o A Virtual Direcctory is a folder that may point to a diffeerent folder on 

the same compuuter or to a folder another computer. Virttual directories 

are used in largee complex web sites where each part of a website should 

be managed by a different person or team. For example, yyou may have a 

website called www.example.org; in this case, an admministrator can 

create a virttual directory under this domain, for example 

www.example.oorg/help and the help content can be published and 

managed on a ddifferent computer. However, this URL appeears a part of a 

website for the end user. This can help in improving perfoormance as the 

content is actuaally isolated from the main web server. 

• A Web Service is a wway of communication between two elecctronic devices 

across the World Widde Web. Usually applications are locally installed on a 

computer and accesseed; this requires the application to be avvailable on the 

local computer and iif in case, the application or computer on which the 

application is installedd is not working or not 

available, it has a neegative impact on the 

business. Recent trrend includes using 

applications over the IInternet (referred to as 

“Software as a Servicee or SaaS”) where users 

can use the applicattion using any device 

such as mobile phonnes, smart phones or 

netbooks from virtuallyy anywhere around the 

globe. Also charges aare comparatively less 

making it affordable ffor anyone to use the 

application. These colllectively are referred 

to as the “Web Servicee”. 
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A Web Service consists of distributed software components available over the 

web/cloud and accessible through Web protocols. It has an interface described in a 

machine-readable format called WDSL. 

Web Services Description Language (WSDL) is an interface description language 

based on XML which describes the functionality offered by a Web Service. The WSDL 

specifies how the service is to be called, the parameters that are expected and the 

type of data structure that will be returned. WSDL uses the SOAP protocol to pass 

messages between clients and servers. 

Simple Object Access Protocol (SOAP) provides a basic messaging framework using 

XML upon which web services can be built. It is a specification for exchanging 

structured information in the implementation of Web Services using XML Information 

Set for its message format and HTTP and SMTP for message negotiation and 

transmission. 

SOAP protocol provides a basic Messaging framework consists of three parts: 

1. an envelope, which specifies what is in the message and how to process it. 

2. a set of encoding rules for expressing instances of application-defined 

datatypes. 

3. a convention for representing procedure calls and responses. 

SOAP has three major characteristics: 

1. Extensibility (security and WS-routing), 

2. Neutrality (across any transport protocol such as HTTP, SMTP, TCP, etc.). 

3. Independence (allowing for any programming model). 

There are a large number of SOAP services available. Bing (searches), stock quotes, 

traffic conditions and weather are a few of them. 

EXERCISE 

Perform the following activities till you understand the concept of Web Services 

S. No. Activities 

1. Assume that you want to create a simple Web Site to showcase your talents 

on the Web. Discuss and specify the steps that you need to take to make this 

a possibility. 

2. Use the following articles for additional reading: 

• https://en.wikipedia.org/wiki/Virtual_directory 

• http://support.microsoft.com/kb/172138 

• http://technet.microsoft.com/en-
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us/library/cc772350%28v=ws.10%29.aspx 

• http://support.microsoft.com/kb/323972 

• http://www.microsoft.com/technet/prodtechnol/WindowsServer2003 

/Library/IIS/b77cf015-017f-489c-9b5b-65ca4a679392.mspx?mfr=true 

• http://www.youtube.com/watch?v=8SGL5BoMvmM 

ASSESSMENT 

Answer the following questions: 

1. Explain the purpose of web hosting. 

2. Explain Virtual Directory (IIS). 

3. Explain what you understand by a Web Service. 

4. Explain what you understand by SOAP. 

Fill in the blanks: 

1. Companies that provide space on a server to be owned or leased to clients as 

well as Internet connectivity in a data center are called ________. 

2. The three major characteristics of SOAP are _____________, ________ and 

_____________________________. 
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If you want to learn more about developing Windows or Web applications, you may 

use “Starter Kits”. “Starter Kits” are complete applications, available free for 

download. To use starter kits, do the following: 

1. Go to http://www.asp.net/web-forms/open-source. 

2. Browse, select and download a starter kit. 

3. Refer to instructions for each starter kit on the website. 

Using a starter kit (WINDOWS APPLICATION) 

1. Download Teacher Starter kit from http://msdn.microsoft.com/en-

us/beginner/aa700775.aspx. 

2. Go to the downloaded location and double-click TeacherStarterKit(Csharp).vsi. 

Follow the on-screen instructions and complete the installation (ideally they are 

extracted into C:\Users\USERNAME\Documents\Visual Studio 

2010\Templates\ProjectTemplates\Visual C# folder). 

3. Open Microsoft Visual C# 2010 Express. 

4. Select File > Open Project…. Browse and locate the project file. 

5. Press CTRL+F5 to run the project! 

Using a starter kit (WEB APPLICATION) 

1. Download Employee Info Starter Kit from 

http://code.msdn.microsoft.com/Employee-Info-Starter-Kit-2d386ba7. 

2. Most of them are compressed files, extract them into a folder. 

3. Open Microsoft Visual Web Developer Express. 

4. Select File > Open Project…. Browse and locate the project file. 

5. Press CTRL+F5 to run the project! 

Note: 

a. Some of the samples may be developed using earlier or recent versions of express 

editions. For example, if you download a Starter kit designed for 2008 express 

edition, it may be converted to 2010 edition when you open the project. Some 

code may need to updated manually for functionality. 

b. Starter kits are usually available in two programming languages, C# and/or VB. 

Download appropriate versions before experimenting with it. 

c. Visit websites such as www.sourceforge.net for open source applications. 

d. Always read the instructions before you work with a starter kit; these may have 

specific instructions, last minute updates, etc. 
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e. If necessary, download the previous versions of the express editions (Google for 

link) if you want to run older samples. 

f. Once you are comfortable with a particular edition (like 2010 express), you can 

download recent version of the express editions (currently 2012) for practice. 

Additional Links 

• http://www.microsoft.com/web/gallery/ 

• http://msdn.microsoft.com/en-us/library/vstudio/dfcw7sd5%28v=vs.100%29.aspx 

• http://www.codeplex.com/ 

• http://msdn.microsoft.com/en-us/beginner/aa700775.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308740.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308743.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308747.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308749.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308770.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308786.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308809.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308817.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308818.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308825.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308861.aspx 

• http://msdn.microsoft.com/en-us/beginner/bb308891.aspx 

• http://msdn.microsoft.com/en-us/beginner/ff715351.aspx 

• http://msdn.microsoft.com/en-us/library/32dbftby.aspx 

• http://msdn.microsoft.com/en-us/library/5b13a7k4.aspx 

• http://msdn.microsoft.com/en-us/library/8y82wx12.aspx 

• http://msdn.microsoft.com/en-us/library/aa288453.aspx 

• http://msdn.microsoft.com/en-us/library/aa480728.aspx 

• http://msdn.microsoft.com/en-us/library/aa984771%28VS.71%29.aspx 

• http://msdn.microsoft.com/en-us/library/asz1fz8b.aspx 

• http://msdn.microsoft.com/en-us/library/bb330916.aspx 

• http://msdn.microsoft.com/en-us/library/bb330932.aspx 

• http://msdn.microsoft.com/en-us/library/d56de412.aspx 

• http://msdn.microsoft.com/en-us/library/dd409393%28VS.100%29.aspx 

• http://msdn.microsoft.com/en-us/library/fda2bad5%28VS.100%29.aspx 

• http://msdn.microsoft.com/en-us/library/ms173104.aspx 

• http://msdn.microsoft.com/en-us/library/ms173109.aspx 

• http://msdn.microsoft.com/en-us/library/ms173121.aspx 
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• http://msdn.microsoft.com/en-us/library/ms173149.aspx 

• http://msdn.microsoft.com/en-us/library/ms173150.aspx 

• http://msdn.microsoft.com/en-us/library/ms173152.aspx 

• http://msdn.microsoft.com/en-us/library/ms173153.aspx 

• http://msdn.microsoft.com/en-us/library/ms173160.aspx 

• http://msdn.microsoft.com/en-us/library/ms379570.aspx 

• http://msdn.microsoft.com/en-us/library/ms950421.aspx 

• http://msdn.microsoft.com/en-us/library/x9afc042.aspx 

• http://msdn.microsoft.com/en-us/library/x9fsa0sw.aspx 

• http://msdn.microsoft.com/en-us/library/zt39148a.aspx 

• http://msdn.microsoft.com/en-us/vcsharp/aa336800.aspx 

• http://www.asp.net/sql-server/videos/designing-relational-database-tables 

• http://www.w3schools.com/ado/default.asp 

• http://www.w3schools.com/sql/default.asp 

• http://www.iis.net 

• http://msdn.microsoft.com/en-us/library/hh147278%28v=vs.88%29.aspx 
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Download and Install Visual Studio 2010 Express Edition. 

1. Download Visual Studio 2010 Express Edition from download.microsoft.com. 

Note: When you download, 

select the Offline Installer 

version to save bandwidth when 

installing on multiple computers 

and for future installations. 

2. Burn it to DVD and 

insert the DVD on the 

computer where you 

want to install (if you 

are using Windows 8, 

just double-click the 

ISO file. It will 

automatically mount 

as a DVD). 

3. Double-click 

X:\Setup.exe (Replace X: 

with drive letter assigned to 

DVD). Visual Studio 2010 

Express Setup dialog box 

appears (Figure above). 

4. Click Visual C# 2010 

Express. Welcome to Setup 

dialog box appears (Figure 

adjacent). 

5. Click Next. License Terms 

section appears (Figure 

below). 
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6. Select I have read and accept the license terms and click Next. 

Installation options section appears (Figure below). 

7. Check Microsoft SQL Server 2008 Express Edition (x86) and click Next. 

Destination Folder section appears (Figure below). Click Next. 
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8. Click Install >. Setup Complete section appears (Figure below). 

9. Click Exit. 
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Downloading and Installing Microsoft Visual Web Developer 2010 Express 

1. Download Microsoft Visual Web Developer 2010 Express from 

download.microsoft.com or Use the Visual Studio 2010 Express Edition offline 

installer downloaded earlier. 

2. Insert the DVD and double-click Setup.exe. A dialog box appears similar to the 

one below. 

3. Click Visual Web Developer 2010 Express. Welcome to Setup dialog box 

appears (Figure below). 

4. Click Next. License Terms section appears (Figure below). 
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5. Select I have read and accept the license terms and click Next. Destination 

Folder section appears (Figure below). 

Click Install and click Exit once installation is complete. 
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